Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 345331 - app-text/calibre fails to build with dev-python/PyQt4 due to segfault in sip.so from dev-python/sip (at addTypeSlots in siplib.c)
Summary: app-text/calibre fails to build with dev-python/PyQt4 due to segfault in sip....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Zac Medico
URL: http://wiki.gentoo.org/wiki/Sub-slots...
Whiteboard:
Keywords:
: 353259 404251 432832 (view as bug list)
Depends on: force-rebuild
Blocks:
  Show dependency tree
 
Reported: 2010-11-13 23:49 UTC by Ed Tomlinson
Modified: 2013-08-29 16:58 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Failing ebuild log (build.log,22.37 KB, text/plain)
2010-11-14 00:17 UTC, Ed Tomlinson
Details
ebuild environment file (environment,201.29 KB, text/plain)
2010-11-14 00:18 UTC, Ed Tomlinson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Tomlinson 2010-11-13 23:49:30 UTC
Calibre-0.7.28 fails to build with PyQt4-4.8.1.  It works with PyQt4-4.7.7-r1.
As request I've opened a new bug (see 342751).

Reproducible: Always

Steps to Reproduce:
1. emerge =PyQt4-4.8.1 calibre
2. fails
3. emerge =PyQt4-4.7.7-r1 calibre 
4. works





emerge --info
Portage 2.2.0_alpha2-r1 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.1-r3, 2.6.36-crc+ x86_64)
=================================================================
System uname: Linux-2.6.36-crc+-x86_64-AMD_Phenom-tm-_II_X4_940_Processor-with-gentoo-2.0.1
Timestamp of tree: Sat, 13 Nov 2010 17:15:02 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r3::ohnobinki_overlay
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.5, 4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
Repositories: gentoo sunrise x11 ruby multilib ohnobinki_overlay local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://adelie.polymtl.ca/ ftp://cs.ubishops.ca/pub/gentoo ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo ftp://mirror.iawnet.sandia.gov/pub/gentoo/ "
LC_ALL="en_CA.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/x11 /usr/local/portage/layman/ruby /usr/local/portage/layman/multilib /usr/local/portage/layman/ohnobinki /usr/local/portage"
SYNC="rsync://rsync.ca.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl alsa amd64 arts artswrappersuid asf berkdb bluetooth bzip2 cdr cli cracklib crypt cups cxx divx4linux doc dri dts dvd dvdread enable-jingle fam fat ffmpeg firefox gdbm gnome gpm gstreamer gtk iconv ipv6 jpeg kde lcms mad matroska mmx mmxext modules mudflap multilib multilib_abi_amd64 ncurses nls nptl nptlonly ntfs ogg opengl openmp pam pcre pdf perl png pppd python qt qt-copy quicktime readline reiser4 reiserfs ruby samba sdl session smb sse sse2 ssl sysfs tcpd theora threads truetype unicode vorbis wavpack webkit wma xcb xcomposite xfs xinerama xorg xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" MULTILIB_ABIS="amd64 x86" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa fbdev vmware gallium" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ed Tomlinson 2010-11-14 00:17:23 UTC
Created attachment 254251 [details]
Failing ebuild log
Comment 2 Ed Tomlinson 2010-11-14 00:18:39 UTC
Created attachment 254255 [details]
ebuild environment file
Comment 3 Zac Medico gentoo-dev 2010-11-14 04:58:39 UTC
The log shows that python was killed due to a segmentation fault. If you check dmesg then it might mention a particular library that the segmentation fault occurred in.
Comment 4 Ed Tomlinson 2010-11-14 13:58:37 UTC
Yes.  did not think to check dmesg.  When I did I found:

[164417.984243] python2.6-amd64[21033]: segfault at 1a ip 00007f44b9a0af80 sp 00007fff2ff89178 error 4 in sip.so[7f44b9a06000+17000]

equery b sip.so
 * Searching for sip.so ... 
dev-python/sip-4.11.2 (/usr/lib64/python3.1/site-packages/sip.so)
dev-python/sip-4.11.2 (/usr/lib64/python2.6/site-packages/sip.so)

eselect python show
python2.6

eix dev-lang/python
[I] dev-lang/python
     Available versions:  
        (2.4)   2.4.6
        (2.5)   2.5.4-r4
        (2.6)   2.6.5-r3 (~)2.6.6-r1
        (2.7)   [M](~)2.7
        (3.1)   3.1.2-r4
        {-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml}
     Installed versions:  2.6.6-r1(2.6)(10:02:06 PM 16/10/10)(berkdb doc gdbm ipv6 multilib_abi_amd64 multilib_abi_x86 ncurses readline sqlite ssl threads tk wide-unicode xml -build -elibc_uclibc -examples -wininst) 3.1.2-r4(3.1)(02:22:46 PM 17/07/10)(doc gdbm ipv6 multilib_abi_amd64 multilib_abi_x86 ncurses readline sqlite ssl threads tk wide-unicode xml -build -elibc_uclibc -examples -wininst)                                                                                                 
     Homepage:            http://www.python.org/
     Description:         Python is an interpreted, interactive, object-oriented programming language.

Thanks
Comment 5 Zac Medico gentoo-dev 2010-11-14 14:01:53 UTC
It's working here with dev-python/sip-4.11.2. You might try rebuilding that package.
Comment 6 Ed Tomlinson 2010-11-14 14:33:20 UTC
rebuild dev-python/sip-4.11.2 and retried with PyQt4-4.8.1 with the same results.  

Ideas?
Comment 7 Zac Medico gentoo-dev 2010-11-14 14:58:56 UTC
You could build dev-python/sip with debugging info and get a backtrace:

  http://www.gentoo.org/proj/en/qa/backtraces.xml

For debugging packages, it's useful to create /etc/portage/env/debug.conf containing these settings:

FEATURES="${FEATURES} installsources splitdebug"
CFLAGS="${CFLAGS} -ggdb"
CXXFLAGS="${CXXFLAGS} -ggdb"

Then you can enable those debug settings for specific packages in /etc/portage/package.env, like this:

dev-python/sip debug.conf
Comment 8 Ed Tomlinson 2010-11-14 16:58:27 UTC
Done and I do see the -ggdb flag when sip builds - I just do not see any backtrace.  Where should it be?  Do I have to do anything special to get it to appear?
TIA
Comment 9 Zac Medico gentoo-dev 2010-11-14 17:03:18 UTC
You have to enable core dumps and use gdb on the core file like it explains here:

  http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 10 Ed Tomlinson 2010-11-14 17:15:31 UTC
I'm pretty sure this is not what we need to see.  What else needs to be done?

gdb /usr/lib64/python3.1/site-packages/sip.so --core /var/tmp/portage/app-text/calibre-0.7.28/work/calibre/core
GNU gdb (Gentoo 7.2 p1) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/lib64/python3.1/site-packages/sip.so...Reading symbols from /usr/lib64/debug/usr/lib64/python3.1/site-packages/sip.so.debug...done.
done.

warning: core file may not match specified executable file.
[New Thread 4749]
Core was generated by `/usr/bin/python2.6-amd64 setup.py install --root=/var/tmp/portage/app-text/cali'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007f6b715eef80 in ?? ()
(gdb) bt
#0  0x00007f6b715eef80 in ?? ()
#1  0x00007f6b715ef8fe in ?? ()
#2  0x00007f6b71801c40 in ?? ()
#3  0x00000000030f67d0 in ?? ()
#4  0x00000000030927d0 in ?? ()
#5  0x00007f6b80505a2b in ?? ()
#6  0x00007fff2b0ac740 in ?? ()
#7  0x00007f6b807d2720 in ?? ()
#8  0x00007fff2b0ac738 in ?? ()
#9  0x00007f6b807db110 in ?? ()
#10 0x0000000000000001 in ?? ()
#11 0x00000000030f5df0 in ?? ()
#12 0x0000000000000000 in ?? ()
Comment 11 Ed Tomlinson 2010-11-14 17:58:40 UTC
Think this is more like what is needed (added python2.6 to package.env)

(gdb) bt
#0  addTypeSlots (heap_to=0x3940bb0, slots=0x1a) at siplib.c:9489
#1  0x00007fa17baf68fe in sipEnumType_alloc (self=<value optimized out>, nitems=<value optimized out>) at siplib.c:10631
#2  0x00007fa18aa0cacb in type_new (metatype=<value optimized out>, args=<value optimized out>, kwds=<value optimized out>) at Objects/typeobject.c:2290
#3  0x00007fa18aa03c05 in type_call (type=0x3940bb0, args=0x421c7d0, kwds=0x0) at Objects/typeobject.c:726
#4  0x00007fa18a9b31c4 in PyObject_Call (func=0x7fa17bd08c40, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#5  0x00007fa17bafd642 in createContainerType (cod=<value optimized out>, td=0x7fa16cba06e0, bases=<value optimized out>, metatype=0x7fa17bd08c40, 
    mod_dict=<value optimized out>, client=<value optimized out>) at siplib.c:5264
#6  0x00007fa17bafd367 in createClassType (client=0x7fa16cb91540, ctd=0x7fa16cba06e0, mod_dict=<value optimized out>) at siplib.c:5386
#7  0x00007fa17bafe232 in sip_api_init_module (client=0x7fa16cb91540, mod_dict=0x43097d0) at siplib.c:1388
#8  0x00007fa16c858d1d in initkdecore () from /usr/lib64/python2.6/site-packages/PyKDE4/kdecore.so
#9  0x00007fa18aa58d3d in _PyImport_LoadDynamicModule (name=0x7ffff7a2cf90 "PyKDE4.kdecore", 
    pathname=0x7ffff7a2bec0 "/usr/lib64/python2.6/site-packages/PyKDE4/kdecore.so", fp=<value optimized out>) at ./Python/importdl.c:53
#10 0x00007fa18aa56e5e in import_submodule (mod=0x4223b08, subname=0x7ffff7a2cf97 "kdecore", fullname=0x7ffff7a2cf90 "PyKDE4.kdecore") at Python/import.c:2592
#11 0x00007fa18aa570df in load_next (mod=0x4223b08, altmod=<value optimized out>, p_name=<value optimized out>, buf=0x7ffff7a2cf90 "PyKDE4.kdecore", 
    p_buflen=<value optimized out>) at Python/import.c:2412
#12 0x00007fa18aa576f8 in import_module_level (name=0x0, globals=<value optimized out>, locals=<value optimized out>, fromlist=0x7fa18b0eed88, 
    level=<value optimized out>) at Python/import.c:2141
#13 0x00007fa18aa58441 in PyImport_ImportModuleLevel (name=<value optimized out>, globals=<value optimized out>, locals=<value optimized out>, 
    fromlist=<value optimized out>, level=<value optimized out>) at Python/import.c:2185
#14 0x00007fa18aa3e6cf in builtin___import__ (self=<value optimized out>, args=<value optimized out>, kwds=<value optimized out>) at Python/bltinmodule.c:48
#15 0x00007fa18a9b31c4 in PyObject_Call (func=0x7fa18b0e30e0, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#16 0x00007fa18a9b32a1 in call_function_tail (callable=0x7fa18b0e30e0, args=0x398d050) at Objects/abstract.c:2524
#17 0x00007fa18a9b3e82 in PyObject_CallFunction (callable=0x7fa18b0e30e0, format=<value optimized out>) at Objects/abstract.c:2548
#18 0x00007fa18aa585b8 in PyImport_Import (module_name=0x4226180) at Python/import.c:2770
#19 0x00007fa18aa586fc in PyImport_ImportModule (name=<value optimized out>) at Python/import.c:2044
#20 0x00007fa17bb01982 in sip_api_export_module (client=0x7fa16e8d89a0, api_major=<value optimized out>, api_minor=<value optimized out>, 
    unused=<value optimized out>) at siplib.c:1210
#21 0x00007fa16e24c0f8 in initkdeui () from /usr/lib64/python2.6/site-packages/PyKDE4/kdeui.so
#22 0x00007fa18aa58d3d in _PyImport_LoadDynamicModule (name=0x7ffff7a2f3e0 "PyKDE4.kdeui", 
    pathname=0x7ffff7a2e310 "/usr/lib64/python2.6/site-packages/PyKDE4/kdeui.so", fp=<value optimized out>) at ./Python/importdl.c:53
#23 0x00007fa18aa56e5e in import_submodule (mod=0x4223b08, subname=0x7ffff7a2f3e7 "kdeui", fullname=0x7ffff7a2f3e0 "PyKDE4.kdeui") at Python/import.c:2592
#24 0x00007fa18aa570df in load_next (mod=0x4223b08, altmod=<value optimized out>, p_name=<value optimized out>, buf=0x7ffff7a2f3e0 "PyKDE4.kdeui", 
    p_buflen=<value optimized out>) at Python/import.c:2412
#25 0x00007fa18aa576f8 in import_module_level (name=0x0, globals=<value optimized out>, locals=<value optimized out>, fromlist=0x7fa18acda610, 
    level=<value optimized out>) at Python/import.c:2141
#26 0x00007fa18aa58441 in PyImport_ImportModuleLevel (name=<value optimized out>, globals=<value optimized out>, locals=<value optimized out>, 
    fromlist=<value optimized out>, level=<value optimized out>) at Python/import.c:2185
#27 0x00007fa18aa3e6cf in builtin___import__ (self=<value optimized out>, args=<value optimized out>, kwds=<value optimized out>) at Python/bltinmodule.c:48
#28 0x00007fa18a9b31c4 in PyObject_Call (func=0x7fa18b0e30e0, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#29 0x00007fa18aa3ec82 in PyEval_CallObjectWithKeywords (func=0x7fa18b0e30e0, arg=0x2f5c3c0, kw=0x7fa16cba06e0) at Python/ceval.c:3619
#30 0x00007fa18aa41c89 in PyEval_EvalFrameEx (f=0x42a3620, throwflag=<value optimized out>) at Python/ceval.c:2159
#31 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x4213738, globals=<value optimized out>, locals=<value optimized out>, args=0x42f5290, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#32 0x00007fa18aa44aa7 in fast_function (f=0x42f50b0, throwflag=<value optimized out>) at Python/ceval.c:3846
#33 call_function (f=0x42f50b0, throwflag=<value optimized out>) at Python/ceval.c:3771
#34 PyEval_EvalFrameEx (f=0x42f50b0, throwflag=<value optimized out>) at Python/ceval.c:2412
#35 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x4207cd8, globals=<value optimized out>, locals=<value optimized out>, args=0x2, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#36 0x00007fa18a9da5f9 in function_call (func=0x420c2a8, arg=0x2a5b7e8, kw=0x0) at Objects/funcobject.c:524
#37 0x00007fa18a9b31c4 in PyObject_Call (func=0x420c2a8, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#38 0x00007fa18a9c55ed in instancemethod_call (func=0x420c2a8, arg=0x2a5b7e8, kw=0x0) at Objects/classobject.c:2579
#39 0x00007fa18a9b31c4 in PyObject_Call (func=0x421c230, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#40 0x00007fa18aa04f3e in slot_tp_init (self=<value optimized out>, args=0x2f5d110, kwds=0x0) at Objects/typeobject.c:5632
#41 0x00007fa18aa03c4a in type_call (type=<value optimized out>, args=0x2f5d110, kwds=0x0) at Objects/typeobject.c:742
#42 0x00007fa18a9b31c4 in PyObject_Call (func=0x42f6600, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#43 0x00007fa18aa44174 in do_call (f=0x42d2da0, throwflag=<value optimized out>) at Python/ceval.c:3968
#44 call_function (f=0x42d2da0, throwflag=<value optimized out>) at Python/ceval.c:3773
#45 PyEval_EvalFrameEx (f=0x42d2da0, throwflag=<value optimized out>) at Python/ceval.c:2412
#46 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x4204a80, globals=<value optimized out>, locals=<value optimized out>, args=0x4, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#47 0x00007fa18a9da5f9 in function_call (func=0x420c758, arg=0x7fa18afffb50, kw=0x0) at Objects/funcobject.c:524
#48 0x00007fa18a9b31c4 in PyObject_Call (func=0x420c758, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#49 0x00007fa18a9c55ed in instancemethod_call (func=0x420c758, arg=0x7fa18afffb50, kw=0x0) at Objects/classobject.c:2579
#50 0x00007fa18a9b31c4 in PyObject_Call (func=0x421c4b0, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#51 0x00007fa18aa44174 in do_call (f=0x42f2190, throwflag=<value optimized out>) at Python/ceval.c:3968
#52 call_function (f=0x42f2190, throwflag=<value optimized out>) at Python/ceval.c:3773
#53 PyEval_EvalFrameEx (f=0x42f2190, throwflag=<value optimized out>) at Python/ceval.c:2412
#54 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x2aa0828, globals=<value optimized out>, locals=<value optimized out>, args=0x1, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#55 0x00007fa18a9da5f9 in function_call (func=0x420de60, arg=0x2f5d0d0, kw=0x0) at Objects/funcobject.c:524
#56 0x00007fa18a9b31c4 in PyObject_Call (func=0x420de60, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#57 0x00007fa18a9c55ed in instancemethod_call (func=0x420de60, arg=0x2f5d0d0, kw=0x0) at Objects/classobject.c:2579
#58 0x00007fa18a9b31c4 in PyObject_Call (func=0x421c370, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#59 0x00007fa18aa04f3e in slot_tp_init (self=<value optimized out>, args=0x7fa18b0ba050, kwds=0x0) at Objects/typeobject.c:5632
#60 0x00007fa18aa03c4a in type_call (type=<value optimized out>, args=0x7fa18b0ba050, kwds=0x0) at Objects/typeobject.c:742
---Type <return> to continue, or q <return> to quit--- 
#61 0x00007fa18a9b31c4 in PyObject_Call (func=0x42c0000, arg=0x1a, kw=0x7fa16cba06e0) at Objects/abstract.c:2492
#62 0x00007fa18aa44174 in do_call (f=0x2955a70, throwflag=<value optimized out>) at Python/ceval.c:3968
#63 call_function (f=0x2955a70, throwflag=<value optimized out>) at Python/ceval.c:3773
#64 PyEval_EvalFrameEx (f=0x2955a70, throwflag=<value optimized out>) at Python/ceval.c:2412
#65 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x2a9c3f0, globals=<value optimized out>, locals=<value optimized out>, args=0x6, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x23ca9b0, defcount=4, closure=0x0) at Python/ceval.c:3000
#66 0x00007fa18aa44aa7 in fast_function (f=0x2b50790, throwflag=<value optimized out>) at Python/ceval.c:3846
#67 call_function (f=0x2b50790, throwflag=<value optimized out>) at Python/ceval.c:3771
#68 PyEval_EvalFrameEx (f=0x2b50790, throwflag=<value optimized out>) at Python/ceval.c:2412
#69 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x2aa0c60, globals=<value optimized out>, locals=<value optimized out>, args=0x2, argcount=24, 
    kws=<value optimized out>, kwcount=1, defs=0x3075d28, defcount=1, closure=0x0) at Python/ceval.c:3000
#70 0x00007fa18aa44aa7 in fast_function (f=0x24d0450, throwflag=<value optimized out>) at Python/ceval.c:3846
#71 call_function (f=0x24d0450, throwflag=<value optimized out>) at Python/ceval.c:3771
#72 PyEval_EvalFrameEx (f=0x24d0450, throwflag=<value optimized out>) at Python/ceval.c:2412
#73 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x23086c0, globals=<value optimized out>, locals=<value optimized out>, args=0x1, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#74 0x00007fa18aa44aa7 in fast_function (f=0x24d0290, throwflag=<value optimized out>) at Python/ceval.c:3846
#75 call_function (f=0x24d0290, throwflag=<value optimized out>) at Python/ceval.c:3771
#76 PyEval_EvalFrameEx (f=0x24d0290, throwflag=<value optimized out>) at Python/ceval.c:2412
#77 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x2308468, globals=<value optimized out>, locals=<value optimized out>, args=0x2, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#78 0x00007fa18aa44aa7 in fast_function (f=0x24cf590, throwflag=<value optimized out>) at Python/ceval.c:3846
#79 call_function (f=0x24cf590, throwflag=<value optimized out>) at Python/ceval.c:3771
#80 PyEval_EvalFrameEx (f=0x24cf590, throwflag=<value optimized out>) at Python/ceval.c:2412
#81 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x7fa18b01e918, globals=<value optimized out>, locals=<value optimized out>, args=0x3, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#82 0x00007fa18aa44aa7 in fast_function (f=0x24cf1d0, throwflag=<value optimized out>) at Python/ceval.c:3846
#83 call_function (f=0x24cf1d0, throwflag=<value optimized out>) at Python/ceval.c:3771
#84 PyEval_EvalFrameEx (f=0x24cf1d0, throwflag=<value optimized out>) at Python/ceval.c:2412
#85 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x7fa18b01e918, globals=<value optimized out>, locals=<value optimized out>, args=0x3, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#86 0x00007fa18aa44aa7 in fast_function (f=0x24cf000, throwflag=<value optimized out>) at Python/ceval.c:3846
#87 call_function (f=0x24cf000, throwflag=<value optimized out>) at Python/ceval.c:3771
#88 PyEval_EvalFrameEx (f=0x24cf000, throwflag=<value optimized out>) at Python/ceval.c:2412
#89 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x7fa18b01ad50, globals=<value optimized out>, locals=<value optimized out>, args=0x2, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#90 0x00007fa18aa44aa7 in fast_function (f=0x245ac00, throwflag=<value optimized out>) at Python/ceval.c:3846
#91 call_function (f=0x245ac00, throwflag=<value optimized out>) at Python/ceval.c:3771
#92 PyEval_EvalFrameEx (f=0x245ac00, throwflag=<value optimized out>) at Python/ceval.c:2412
#93 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x7fa18aff8210, globals=<value optimized out>, locals=<value optimized out>, args=0x1, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x7fa18b008fa8, defcount=1, closure=0x0) at Python/ceval.c:3000
#94 0x00007fa18aa44aa7 in fast_function (f=0x206dcb0, throwflag=<value optimized out>) at Python/ceval.c:3846
#95 call_function (f=0x206dcb0, throwflag=<value optimized out>) at Python/ceval.c:3771
#96 PyEval_EvalFrameEx (f=0x206dcb0, throwflag=<value optimized out>) at Python/ceval.c:2412
#97 0x00007fa18aa464e7 in PyEval_EvalCodeEx (co=0x7fa18aff8828, globals=<value optimized out>, locals=<value optimized out>, args=0x0, argcount=24, 
    kws=<value optimized out>, kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:3000
#98 0x00007fa18aa465d2 in PyEval_EvalCode (co=0x3940bb0, globals=0x1a, locals=0x7fa16cba06e0) at Python/ceval.c:541
#99 0x00007fa18aa602d1 in run_mod (mod=<value optimized out>, filename=<value optimized out>, globals=0x2018000, locals=0x2018000, flags=<value optimized out>, 
    arena=<value optimized out>) at Python/pythonrun.c:1351
#100 0x00007fa18aa6039c in PyRun_FileExFlags (fp=0x206d1c0, filename=0x7ffff7a341a3 "setup.py", start=<value optimized out>, globals=<value optimized out>, 
    locals=0x2018000, closeit=1, flags=0x7ffff7a32be0) at Python/pythonrun.c:1337
#101 0x00007fa18aa61807 in PyRun_SimpleFileExFlags (fp=0x206d1c0, filename=0x7ffff7a341a3 "setup.py", closeit=1, flags=0x7ffff7a32be0) at Python/pythonrun.c:941
#102 0x00007fa18aa6d8ab in Py_Main (argc=-1962430320, argv=<value optimized out>) at Modules/main.c:584
#103 0x00007fa18a408d2d in __libc_start_main () from /lib/libc.so.6
#104 0x00000000004008c9 in _start ()
Comment 12 Zac Medico gentoo-dev 2010-11-15 04:39:40 UTC
(In reply to comment #11)
> (gdb) bt
> #0  addTypeSlots (heap_to=0x3940bb0, slots=0x1a) at siplib.c:9489

A google search for sip and addTypeSlots turns up this report:

  http://www.mail-archive.com/pyqt@riverbankcomputing.com/msg21726.html

Later in the thread, he reports the rebuilding PyQt4 solved the problem:

  http://www.mail-archive.com/pyqt@riverbankcomputing.com/msg21925.html

Can you rebuild PyQt4 and see if that helps?
Comment 13 Ed Tomlinson 2010-11-15 12:38:17 UTC
I also found refs suggesting to rebuild PyQt4 after change sip.  I've been doing this for each test.  Its not helping here.
Comment 14 Zac Medico gentoo-dev 2010-11-15 16:27:22 UTC
Adding python and qt herds to CC since the problem seems related to the combination of dev-python/sip-4.11.2 and dev-python/PyQt4-4.8.1.
Comment 15 Guy 2010-11-21 16:35:46 UTC
I've been having the same issue with calibre. Based on the discussion here, I executed the following:


emerge sip && emerge PyQt4 && emerge calibre. 


The emerge of calibre failed. This is the pertinent snip from the build.log>:


>>> Source compiled.
>>> Test phase [not enabled]: app-text/calibre-0.7.28

>>> Install calibre-0.7.28 into /var/tmp/portage/app-text/calibre-0.7.28/image/ category app-text
python2.6 setup.py install --root=/var/tmp/portage/app-text/calibre-0.7.28/image/ --no-compile --bindir=/var/tmp/portage/app-text/calibre-0.7.28/image/usr/bin --sharedir=/var/tmp/portage/app-text/calibre-0.7.28/image/usr/share

*
* Running build
*

--no-compile specified, skipping compilation

*
* Running gui
*

        Compiling form /var/tmp/portage/app-text/calibre-0.7.28/work/calibre/src/calibre/gui2/shortcuts.ui
/var/tmp/portage/app-text/calibre-0.7.28/temp/environment: line 1401:  6477 Segmentation fault      "$(PYTHON)" "${setup_file}" "${DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@"


This is the snip from dmesg:


[76562.977244] python2.6[26995]: segfault at 1a ip 00007f34aa712f10 sp 00007fff7ea2a118 error 4 in sip.so[7f34aa70e000+17000]
[78755.151763] python2.6[6477]: segfault at 1a ip 00007fd058870f10 sp 00007fff94fb4248 error 4 in sip.so[7fd05886c000+17000]


The previous version of calibre installed with the following environment:


Portage 2.2.0_alpha4 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.1-r3, 2.6.35.8 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.35.8-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.0.1
Timestamp of tree: Sat, 20 Nov 2010 17:30:19 +0000
ccache version 3.1.1 [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.5.4-r4, 2.6.6-r1, 3.1.2-r4
dev-util/ccache:     3.1.1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.4
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.5
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
Repositories: gentoo zugaina x11 sping local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL AdobeFlash-10 AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=opteron -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=opteron -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/local/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/x11 /var/lib/layman/sping /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib accessibility acl acpi aften aio alsa amd64 amr ao apache2 audiofile automount avahi bash-completion bdf berkdb blender-game bonjour boost bzip2 cairo cdda cddb cdio cdparanoia cdr cgi chm cjk cleartype cli consolekit cracklib crypt css cups curl curlwrappers cxx dbase dbus dga dia directfb djvu dri dts dv dvb dvd dvdr dynamic eds emovix encode exif expat fam fat fbcon ffmpeg fftw filter flac flash fontconfig foomaticdb fortran fpx ftp fuse gcj gd gdbm ggi gif gimp glib glibc-omitfp gmp gnutls gpac gphoto2 gpm graphviz gs gstreamer gtk guile hal hddtemp hdri html iconv icu id3tag idea imagemagick imap imlib inkjar inotify insecure-savers ipfilter ipv6 irc jabber java javascript jbig jpeg jpeg2k kde kerberos kipi lame latex lcms libcaca libnotify libsamplerate libvisual live lm_sensors lzo mad matroska midi mikmod mjpeg mmap mmx mmxext mng modplug modules mono mp3 mp4 mpeg mpi mplayer msn msql mudflap multilib multiuser musepack mysql mysqli nas ncurses network nfs nls nntp nptl nptlonly nsplugin ntfs odbc offensive ogg ogm openal openexr opengl openmp oscar pam pango pcre pda pdf perl php plotutils plugins png policykit posix postscript ppds pppd private-headers ps pulseaudio python q32 qt3support qt4 quicktime rar raster raw rdesktop readline recode reflection regex reiser4 reiserfs restrict-javascript rle rss rtc ruby samba sasl scanner schroedinger sdk sdl sensord session sftp sharedmem sift simplexml slang sndfile snmp soap sockets sox speex spell spl sql sqlite sse sse2 ssl subversion svg swat sysfs syslog t1lib taglib tcl tcpd tga theora threads tidy tiff timidity tk tokenizer toolbar tools transcode truetype udev unicode usb utils v4l v4l2 vcd vdr vorbis wav wavpack webkit winbind wmf x264 xanim xcomposite xfs xft xine xinerama xml xmlrpc xorg xosd xpm xscreensaver xv xvid xvmc yaepg yahoo zeroconf zip zlib zoran" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon minolta konica" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-text/calibre-0.7.26 was built with the following:
USE="bash-completion (multilib)"
Comment 16 Guy 2010-11-21 16:44:11 UTC
I'm not a programmer so I have no idea if this question means anything or merely demonstrates my ignorance, but ...

I don't recall calibre ever installing "shortcuts". What are the shortcuts involved here? I'm wondering if they're anything like the "shortcuts" I would understand as a user like keyboard or desktop shortcuts and if so, do they include python code and is that code syntactically correct?

I really don't know anything. Just wondering.
Comment 17 Guy 2010-11-21 16:45:42 UTC
Sorry - I meant to include this excerpt from my initial message:

*
* Running gui
*

        Compiling form
/var/tmp/portage/app-text/calibre-0.7.28/work/calibre/src/calibre/gui2/shortcuts.ui
/var/tmp/portage/app-text/calibre-0.7.28/temp/environment: line 1401:  6477
Segmentation fault      "$(PYTHON)" "${setup_file}"
"${DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@"
Comment 18 Zac Medico gentoo-dev 2010-11-21 17:02:05 UTC
(In reply to comment #16)
> I don't recall calibre ever installing "shortcuts". What are the shortcuts
> involved here? I'm wondering if they're anything like the "shortcuts" I would
> understand as a user like keyboard or desktop shortcuts and if so, do they
> include python code and is that code syntactically correct?

The shortcuts.ui file that triggered the error on your system is probably fine. As mentioned in bug #342751, comment #6, it works fine for me (plain x86 though, not amd64). Note that the log attached in comment #1 shows it failing while compiling filename_pattern.ui rather than shortcuts.ui. Since these ui files compile fine for me, it seems to indicate that PyQt4 (which is used to compile those ui files) is broken somehow on your system.

Since it doesn't seem to help when you rebuild just sip and PyQt4, you might try rebuilding the qt-* packages and then rebuild PyQt4 again.
Comment 19 Guy 2010-11-21 17:21:39 UTC
(In reply to comment #18)
> 
> Since it doesn't seem to help when you rebuild just sip and PyQt4, you might
> try rebuilding the qt-* packages and then rebuild PyQt4 again.
> 

Thank you for the reply. I recently rebuilt all the qt-* packages are part of my latest 'emerge --sync && emerge -uND @world' as of yesterday. FWIW, 'scribus' and all other 'qt' based packages had no problem updating or re-emerging after the updates to the 'qt' packages. There were a number of such packages.

I note that the reporter {Ed Tomlinson} is also configured as 'AMD64'. This may have more to do with the issue than anything else. My 'i686' based system is not currently up to date so I can't check this.

Also, I haven't downgraded PyQt4 to check that either. I'm thinking of doing so but the system I'm currently on is also my binary packages server. I'll need to think about doing this test first.

ie: 
Comment 20 Guy 2010-11-21 17:59:53 UTC
The reporter {Ed Tomlinson} is correct in that calibre emerges to completion with PyQt4-4.7.7-r1.

Executing:

emerge =PyQt-4.7.7-r1 && emerge calibre && emerge PyQt4

works. This appears to be a combined issue of 'amd64' and PyQt4 version.

Hope this helps.
Comment 21 Davide Pesavento gentoo-dev 2010-11-21 22:35:56 UTC
Have you tried rebuilding kde-base/pykde4 ?
Comment 22 Guy 2010-11-22 21:04:16 UTC
(In reply to comment #21)
> Have you tried rebuilding kde-base/pykde4 ?
> 

Per your question, I tested by executing the following:

1) I confirmed current levels of PyQt4, pykde4 and calibre --

# emerge -s pykde4 calibre PyQt4
Searching...    
[ Results for search key : pykde4 ]
[ Applications found : 1 ]

*  kde-base/pykde4
      Latest version available: 4.5.3
      Latest version installed: 4.5.3
      Size of files: 6,174 kB
      Homepage:      http://www.kde.org/
      Description:   Python bindings for KDE4
      License:       GPL-2

Searching...    
[ Results for search key : calibre ]
[ Applications found : 1 ]

*  app-text/calibre
      Latest version available: 0.7.28
      Latest version installed: 0.7.28
      Size of files: 17,961 kB
      Homepage:      http://calibre-ebook.com/
      Description:   Ebook management application.
      License:       GPL-2

Searching...    
[ Results for search key : PyQt4 ]
[ Applications found : 1 ]

*  dev-python/PyQt4
      Latest version available: 4.8.1
      Latest version installed: 4.8.1
      Size of files: 9,188 kB
      Homepage:      http://www.riverbankcomputing.co.uk/software/pyqt/intro/ http://pypi.python.org/pypi/PyQt
      Description:   Python bindings for the Qt toolkit
      License:       || ( GPL-2 GPL-3 )

2) Executed 'emerge calibre' to confirm that calibre would fail --

*
* Running gui
*

        Compiling form /var/tmp/portage/app-text/calibre-0.7.28/work/calibre/src/calibre/gui2/shortcuts.ui
/var/tmp/portage/app-text/calibre-0.7.28/temp/environment: line 1401: 14308 Segmentation fault      "$(PYTHON)" "${setup_file}" "${DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@"
 * ERROR: app-text/calibre-0.7.28 failed:

[183642.084498] python2.6[14308]: segfault at 1a ip 00007f2cb9dedf10 sp 00007fffa15d2358 error 4 in sip.so[7f2cb9de9000+17000]

3) executed 'emerge pykde4 && emerge calibre' to check if calibre would now succeed --

>>> Completed installing calibre-0.7.28 into /var/tmp/portage/app-text/calibre-0.7.28/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/calibre-mount-helper
   usr/lib64/calibre/calibre/plugins/pictureflow.so
   usr/lib64/calibre/calibre/plugins/lzx.so
   usr/lib64/calibre/calibre/plugins/chmlib.so
   usr/lib64/calibre/calibre/plugins/podofo.so
   usr/lib64/calibre/calibre/plugins/progress_indicator.so
   usr/lib64/calibre/calibre/plugins/magick.so
   usr/lib64/calibre/calibre/plugins/chm_extra.so
   usr/lib64/calibre/calibre/plugins/pdfreflow.so
   usr/lib64/calibre/calibre/plugins/cPalmdoc.so
   usr/lib64/calibre/calibre/plugins/msdes.so
   usr/lib64/calibre/calibre/plugins/fontconfig.so
ecompressdir: bzip2 -9 /usr/share/calibre/man
>>> Done.

Calibre successfully compiled with current version of PyQt4 after re-install of 'pykde4'

I don't know what this all means in terms of any possible ebuild changes or anything like that. Perhaps a message from 'PyQt4' recommending a forced 'revep-rebuild' on packages depending on 'PyQt4' libraries or similar might be in order. I do note that 'pykde4' is directly dependent on 'PyQt4'

Thanks for your suggestion about 'pykde4' It's appreciated. :)
Comment 23 Guy 2010-11-22 21:09:49 UTC
A further question - in line with whatever the issue is here, these are the packages I have installed with are dependent on 'PyQt4' --

# equery d PyQt4
 * These packages depend on PyQt4:
app-text/calibre-0.7.28 (>=dev-python/PyQt4-4.7[X,svg,webkit])
dev-python/matplotlib-1.0.0 (qt4 ? dev-python/PyQt4[X])
dev-python/qscintilla-python-2.4.5 (>=dev-python/PyQt4-4.7[X])
dev-util/eric-5.0.3 (>=dev-python/PyQt4-4.7[assistant,svg,webkit,X])
kde-base/marble-4.5.3 (python ? >=dev-python/PyQt4-4.4.4-r1)
kde-base/plasma-workspace-4.5.3 (python ? >=dev-python/PyQt4-4.4.0[X])
kde-base/pykde4-4.5.3 (>=dev-python/PyQt4-4.7.7-r1)
                      (aqua ? >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,aqua])
                      (!aqua ? >=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,X])
net-print/hplip-3.10.9 (qt4 ? dev-python/PyQt4[dbus,X])

Is a 'revdep-rebuild' advisable? And if so, which 'PyQt4' libraries should I do it against? I don't know how to determine that myself.

Thank you again for your help.
Comment 24 Zac Medico gentoo-dev 2010-11-22 22:27:46 UTC
(In reply to comment #22)
> I don't know what this all means in terms of any possible ebuild changes or
> anything like that. Perhaps a message from 'PyQt4' recommending a forced
> 'revep-rebuild' on packages depending on 'PyQt4' libraries or similar might be
> in order. I do note that 'pykde4' is directly dependent on 'PyQt4'

When we implement abi-slot deps (bug #192319), we'll be able to trigger automatic rebuilds. The sip ebuild already has a message in postinst, advising users to rebuild reverse dependencies, but obviously an automated solution would help to avoid bug reports like this one.
Comment 25 Guy 2010-11-22 23:50:49 UTC
(In reply to comment #24)
> 
> When we implement abi-slot deps (bug #192319), we'll be able to trigger
> automatic rebuilds. The sip ebuild already has a message in postinst, advising
> users to rebuild reverse dependencies, but obviously an automated solution
> would help to avoid bug reports like this one.
> 

From practical experience and especially from the fact I am now running a binary packages server, I am beginning to understand this on a more than cursory level.

I really do try to follow the post instructions because I have too many PCs on my network which depend on my binary packages server to be right at all times.

Having said that, and having gone back and re-read the post install instructions for sip, I realize now that I had done the instructions for PyQt4 but not for sip itself. {sigh} I sometimes read too fast.

Thanks for the reply and I'll keep my eyes open for the abi-slot enhancement.
Comment 26 Ed Tomlinson 2010-11-23 00:27:53 UTC
Just to confirm, using:

emerge PyQt4 && emerge pykde4 && emerge calibre

works with 4.8.1 here too.

Thanks
Comment 27 Dolores 2010-12-25 05:38:43 UTC
breaks on dev-python/PyQt4-4.8.2 again, and this time kde-base/pykde4 doesn't compile either
Comment 28 Zac Medico gentoo-dev 2010-12-25 06:39:58 UTC
(In reply to comment #27)
> breaks on dev-python/PyQt4-4.8.2 again, and this time kde-base/pykde4 doesn't
> compile either

If dmesg doesn't show a segfault in sip.so, then it's not the same issue.

I've tried the PyQt4-4.8.2 upgrade here and when I try to rebuild pykde4-4.5.4, I get an error that seems equivalent to bug 349668. When I searched for bugs involving pykde4, I also found bug 349497, which I haven't experienced myself.
Comment 29 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2011-01-31 13:36:54 UTC
*** Bug 353259 has been marked as a duplicate of this bug. ***
Comment 30 Davide Pesavento gentoo-dev 2012-02-20 22:51:26 UTC
Is this still reproducible with more recent sip/PyQt4 versions?
Comment 31 Zac Medico gentoo-dev 2012-02-20 22:56:12 UTC
(In reply to comment #30)
> Is this still reproducible with more recent sip/PyQt4 versions?

Maybe, since bug 404251 may be a duplicate, and was apparently triggered by a recent version bump.
Comment 32 Marc Schiffbauer gentoo-dev 2012-03-11 11:24:19 UTC
(In reply to comment #31)
> (In reply to comment #30)
> > Is this still reproducible with more recent sip/PyQt4 versions?
> 
> Maybe, since bug 404251 may be a duplicate, and was apparently triggered by
> a recent version bump.

I had that issue here too with pykde4-4.8.49.9999 / dev-python/PyQt4-4.9.1 / app-text/calibre-0.8.41

Solution: emerge -1 PyQt4 pykde4 calibre
Comment 33 Davide Pesavento gentoo-dev 2012-03-11 11:27:48 UTC
So... this is fixed just by rebuilding PyQt4 and pykde4 after each sip update? (as suggested by an ewarn in recent sip/PyQt4 ebuilds btw).
Comment 34 Zac Medico gentoo-dev 2012-03-11 15:01:09 UTC
(In reply to comment #33)
> So... this is fixed just by rebuilding PyQt4 and pykde4 after each sip
> update? (as suggested by an ewarn in recent sip/PyQt4 ebuilds btw).

Yeah, but we're condemned to have duplicates like bug 404251 filed after each sip update, so that's why I made this bug depend on bug 192319 which is about automating the rebuilds.
Comment 35 Zac Medico gentoo-dev 2012-03-11 15:02:07 UTC
*** Bug 404251 has been marked as a duplicate of this bug. ***
Comment 36 Davide Pesavento gentoo-dev 2012-04-19 23:18:34 UTC
Removing qt from CC, nothing to do for us (this is not a package bug after all).
Comment 37 Zac Medico gentoo-dev 2012-08-30 03:35:44 UTC
*** Bug 432832 has been marked as a duplicate of this bug. ***
Comment 38 jannis 2012-12-18 11:40:01 UTC
Is this bug still current/valid? If so, can the version numbers mentioned in the title be updated or removed? None of the mentioned versions can be found in the current portage tree.
Comment 39 Zac Medico gentoo-dev 2012-12-18 17:28:29 UTC
(In reply to comment #38)
It looks like dev-python/sip-4.14* is now using EAPI 5 sub-slots, which is the first step. The dependent packages (like dev-python/PyQt4 and kde-base/pykde4) will also need to be updated to use the SLOT operator, so that they will automatically be rebuilt when the dev-python/sip sub-slot changes:

  http://wiki.gentoo.org/wiki/Sub-slots_and_Slot-Operators
Comment 40 Michael Palimaka (kensington) gentoo-dev 2013-08-29 11:25:11 UTC
(In reply to Zac Medico from comment #39)
> (In reply to comment #38)
> It looks like dev-python/sip-4.14* is now using EAPI 5 sub-slots, which is
> the first step. The dependent packages (like dev-python/PyQt4 and
> kde-base/pykde4) will also need to be updated to use the SLOT operator, so
> that they will automatically be rebuilt when the dev-python/sip sub-slot
> changes

All versions in the tree of both PyQt4 an pykde4 make use of the SLOT operator for sip.
Comment 41 Zac Medico gentoo-dev 2013-08-29 16:58:23 UTC
(In reply to Michael Palimaka (kensington) from comment #40)
Okay, I guess we can close this then.