Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404251 - app-text/calibre-0.8.39 - /var/tmp/portage/app-text/calibre-0.8.39/temp/environment: line 1373: 7882 Errore di segmentazione "$(PYTHON)" "${setup_file#*|}"
Summary: app-text/calibre-0.8.39 - /var/tmp/portage/app-text/calibre-0.8.39/temp/envir...
Status: RESOLVED DUPLICATE of bug 345331
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-17 13:47 UTC by Fabio Coatti
Modified: 2012-03-11 15:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Coatti 2012-02-17 13:47:48 UTC
I'm trying to install calibre: all compilation goes fine, but during install phase I get the following messages:


>>> Install calibre-0.8.39 into /var/tmp/portage/app-text/calibre-0.8.39/image/ category app-text
python2.7 setup.py install --root=/var/tmp/portage/app-text/calibre-0.8.39/image/ --no-compile --prefix=/usr --libdir=/usr/lib64 --staging-root=/var/tmp/portage/app-text/calibre-0.8.39/image/usr --staging-libdir=/var/tmp/portage/app-text/calibre-0.8.39/image/usr/lib64

*
* Running build
*

--no-compile specified, skipping compilation

*
* Running gui
*

        Compiling form /var/tmp/portage/app-text/calibre-0.8.39/work/calibre/src/calibre/gui2/filename_pattern.ui
/var/tmp/portage/app-text/calibre-0.8.39/temp/environment: line 1373:  7882 Errore di segmentazione "$(PYTHON)" "${setup_file#*|}" "${_DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@"
 * ERROR: app-text/calibre-0.8.39 failed (install phase):
 *   Installation failed
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_install
 *   environment, line 5200:  Called distutils_src_install '--prefix=/usr' '--libdir=/usr/lib64' '--staging-root=/var/tmp/portage/app-text/calibre-0.8.39/image/usr' '--staging-libdir=/var/tmp/portage/app-text/calibre-0.8.39/image/usr/lib64'
 *   environment, line 1377:  Called die
 * The specific snippet of code:
 *               "$(PYTHON)" "${setup_file#*|}" "${_DISTUTILS_GLOBAL_OPTIONS[@]}" install --root="${D}" --no-compile "$@" || die "Installation failed";
 * 
 * If you need support, post the output of 'emerge --info =app-text/calibre-0.8.39',
 * the complete build log and the output of 'emerge -pqv =app-text/calibre-0.8.39'.
 * The complete build log is located at '/var/tmp/portage/app-text/calibre-0.8.39/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/calibre-0.8.39/temp/environment'.
 * S: '/var/tmp/portage/app-text/calibre-0.8.39/work/calibre'

>>> Failed to emerge app-text/calibre-0.8.39, Log file:

>>>  '/var/tmp/portage/app-text/calibre-0.8.39/temp/build.log'



Reproducible: Always




# emerge --info
Portage 2.2.0_alpha86 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r2, 3.2.6 x86_64)
=================================================================
System uname: Linux-3.2.6-x86_64-Intel-R-_Core-TM-_i5_CPU_M_520_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Fri, 17 Feb 2012 09:00:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.1.4-r3, 3.2.2
dev-util/cmake:           2.8.7-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo overlay
Installed sets: @kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ "
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3dnowprefetch X \ a52 aac aalib acl acpi aim alsa amd64 apng ares asf ati audio audiofile avahi bash-completion berkdb bidi bl bluetooth branding bri bzip2 caps ccdda cdr cjk cli consolekit cracklib crypt cups curl cxx dba dbus declarative device-mapper dga divx divx4linux dparanoia dri dts dv dvb dvd dvdr dvdread eap-sim edl embedded encode ethereal exif expat faad fam fame fbcon ffmpeg fftw flac force-cgi-redirect fortran ftp gallium garmin gd gdbm gimp gmedia gmp gnutls gphoto2 gpm gps gsm gtk h264 h323 iconv icq icu idn ifp ilbc imagemagick imap innodb ipod iproute2 ipv6 ithreads jabber jack java javascript joystick jpeg kde kontact kvm lastfm lcms libcaca libnotify libvirtd live lm_sensors lua lvm lxc lzma lzo maildir matroska mbox mdnsresponder-compat mhash mime mjpeg mmap mmx mmxext mng modules mozdevelop mozilla mp3 mp4 msn mtp mudflap multilib mysql ncurses nepomuk network networkmanager new-hpcups nfsv4 njb nls nptl nptlonly nsplugin offensive ofx ogg oggvorbis ogm openal openexr opengl openmp oscar pam parted pcap pcre pdf phonon php plasma plotutils png policykit ppds pppd qemu qt3support qt4 readline rtc ruby samba sasl sdl semantic-desktop session sha512 sip slang slp sndfile snmp sox speex spell srt sse sse2 ssh ssl ssse3 startup-notification svg symlink sysfs tcltk tcpd theora threads tiff tk tremor udev unicode usb utempter v4l v4l2 vcd vde vdpau vhosts video videos vim-syntax virt-network virtualbox vorbis wav webkit wifi wimax wmf wmp wps wxwindows x264 xanim xattr xen xface xft xine xinerama xorg xosd xpm xscreensaver xsl xulrunner xv xvid xvmc yahoo zlib zpm" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2012-02-17 15:15:22 UTC
Please attach the environment file to this bug report.
Comment 2 Jean-Francois Ostiguy 2012-02-17 15:18:42 UTC
I have exactly the same issue.
Comment 3 Anthony Boynes 2012-02-18 00:11:22 UTC
I'm also experiencing this problem.
Comment 4 Zac Medico gentoo-dev 2012-02-18 00:15:40 UTC
Just after it happens, check the output of `dmesg | tail` for a segfault fault message and post it here.
Comment 5 Jean-Francois Ostiguy 2012-02-18 02:26:16 UTC
(In reply to comment #4)
> Just after it happens, check the output of `dmesg | tail` for a segfault fault
> message and post it here.

python2.7[24755]: segfault at 0 ip b6cc2b69 sp bfe480d0 error 6 in sip.so[b6cb7000+12000]
Comment 6 Zac Medico gentoo-dev 2012-02-18 02:38:02 UTC
(In reply to comment #5)
> python2.7[24755]: segfault at 0 ip b6cc2b69 sp bfe480d0 error 6 in
> sip.so[b6cb7000+12000]

It looks like bug 345331, which you can solve by rebuilding PyQt4 and emerge pykde4.
Comment 7 Fabio Coatti 2012-02-18 10:32:43 UTC
indeed. emerge PyQt4 && emerge pykde4 && emerge calibre works just fine. 
Thanks!
Comment 8 jannis 2012-02-18 12:17:22 UTC
(In reply to comment #6)
> It looks like bug 345331, which you can solve by rebuilding PyQt4 and emerge
> pykde4.

Helped me here, too. Would be worth an einfo or something IMHO
Comment 9 Anthony Boynes 2012-02-18 14:21:45 UTC
The steps in bug 345331 didn't work for me.  I still get errors when trying to emerge the gentoo package.  For now I am using their binary for 0.8.40, which works.
Comment 10 Jean-Francois Ostiguy 2012-02-18 14:35:31 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > python2.7[24755]: segfault at 0 ip b6cc2b69 sp bfe480d0 error 6 in
> > sip.so[b6cb7000+12000]
> 
> It looks like bug 345331, which you can solve by rebuilding PyQt4 and emerge
> pykde4.

Yep. Works for me.
Comment 11 Guy 2012-02-18 14:53:42 UTC
emerge PyQt4 && emerge pykde4 && emerge calibre

Worked for me as well.
Comment 12 Anthony Boynes 2012-02-18 17:26:28 UTC
Should I submit a separate bug report, since my issue seems unrelated, or give information about my situation in this one?
Comment 13 Zac Medico gentoo-dev 2012-02-18 19:19:29 UTC
(In reply to comment #12)
> Should I submit a separate bug report, since my issue seems unrelated, or give
> information about my situation in this one?

Yes, please file a new bug.

(In reply to comment #8)
> (In reply to comment #6)
> > It looks like bug 345331, which you can solve by rebuilding PyQt4 and emerge
> > pykde4.
> 
> Helped me here, too. Would be worth an einfo or something IMHO

A message like that is meaningless unless the person is experiencing this particular issue. I suppose we could have it search dmesg output for a message like the one in comment #5, and if that's found then suggest to rebuild PyQt4 and pykde4.
Comment 14 filip 2012-02-21 08:37:23 UTC
Had the same problem with both versions 0.8.39 and .40, which went away after remerging pykde4 (had already remerged PyQt4 after updating sip).

Funny thing is that I thought I'd already remerged pykde4 too (am pretty sure about that actually). So for the someone who still has this problem: Check dmesg|tail for a message complaining about sip.so after you have failed to emerge calibre - and if it's there, try to remerge PyQt4 and pykde4 again. Do it in two different statements, don't put them on the same line - that's what I believe didn't work for me. (Does that even make sense?)
Comment 15 Zac Medico gentoo-dev 2012-03-11 15:02:07 UTC

*** This bug has been marked as a duplicate of bug 345331 ***