Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 432832 - app-text/calibre-0.8.65 - .../temp/environment: línea 4769: 795 Violación de segmento [...] python setup.py install [...]
Summary: app-text/calibre-0.8.65 - .../temp/environment: línea 4769: 795 Violación d...
Status: RESOLVED DUPLICATE of bug 345331
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Zac Medico
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-26 10:55 UTC by juantxorena@gmail.com
Modified: 2012-09-01 14:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,29.32 KB, text/plain)
2012-08-28 15:33 UTC, juantxorena@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description juantxorena@gmail.com 2012-08-26 10:55:53 UTC
app-text/calibre-0.8.65 doesn't compiles. I'm using the lastest stable packages of every dependency when possible, if not, the minimum version needed.

Here's the error:

        Compiling form /var/tmp/portage/app-text/calibre-0.8.65/work/calibre/src/calibre/gui2/shortcuts.ui
/var/tmp/portage/app-text/calibre-0.8.65/temp/environment: línea 4769: 30021 Violación de segmento  PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} python setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}"
 * ERROR: app-text/calibre-0.8.65 failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  85:  Called src_install
 *   environment, line 4788:  Called die
 * The specific snippet of code:
 *       PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} python setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}" || die;


Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2012-08-27 22:50:02 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 juantxorena@gmail.com 2012-08-28 15:33:19 UTC
Created attachment 322450 [details]
build.log

emerge --info:

Portage 2.1.11.9 (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r2, 3.4.9-gentoo x86_64)
=================================================================
System uname: Linux-3.4.9-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7200_@_2.53GHz-with-gentoo-2.1
Timestamp of tree: Mon, 27 Aug 2012 18:00:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.4.7, 4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo proaudio science sunrise local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ftree-vectorize"
DISTDIR="/var/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --keep-going --jobs=2 --load-average=6"
FCFLAGS="-march=native -O2 -pipe -ftree-vectorize"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch usersync"
FFLAGS="-march=native -O2 -pipe -ftree-vectorize"
GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo-euetib.upc.es/mirror/gentoo/ http://gentoo.wheel.sk/ http://gentoo.mirror.dkm.cz/pub/gentoo/"
LANG="s_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--sort-common"
LINGUAS="es en es_ES"
MAKEOPTS="-j3 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="pbzip2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/pro-audio /usr/portage/local/layman/science /usr/portage/local/layman/sunrise /usr/portage/local/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 amr asf audiofile bash-completion blas bluetooth bzip2 cairo cdaudio cdda cdparanoia cdr cjk cleartype cli consolekit cracklib crypt css cuda cups curl cxx dbus djvu dri dssi dts dvd dvdr eigen emboss enca encode exif expat fam ffmpeg fftw flac fontconfig fortran gdbm geoip gif glibc-omitfp glut gmp gnuplot gphoto2 gpm hdf5 iconv icu idn imagemagick jack javascript jpeg jpeg2k kde kdehiddenvisibility kpathsea ladspa lame lapack lash latex lcms libsamplerate lm_sensors lua lv2 lzma mad mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz ncurses network nls nptl nsplugin ntp ogg openal opencl opencore-amr openexr opengl openmp pam pango pch pcre pcsc-lite pdf plotutils png policykit postproc postscript ppds pppd qt3support qt4 qthelp readline samba sdl semantic-desktop session smp sndfile speex spell sse sse2 sse3 sse4.1 ssl ssse3 startup-notification svg taglib tcpd theora threads threadsafe tiff truetype udev udisks unicode upower usb v4l v4l2 vaapi vcd vdpau vim-syntax vorbis vpx wavpack wmf wxwidgets x264 xcb xcomposite xml xv xvid xvmc zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="es en es_ES" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 3 Jeroen Roovers gentoo-dev 2012-08-28 20:22:16 UTC
/var/tmp/portage/app-text/calibre-0.8.65/temp/environment: línea 4769:   795 Violación de segmento  PATH=${T}:${PATH} PYTHONPATH=${S}/src${PYTHONPATH:+:}${PYTHONPATH} python setup.py install --root="${D}" --prefix="${EPREFIX}/usr" --libdir="${EPREFIX}/usr/${libdir}" --staging-root="${ED}usr" --staging-libdir="${ED}usr/${libdir}"
Comment 4 Zac Medico gentoo-dev 2012-08-28 20:48:04 UTC
This looks similar to bug 315345. If you check the output of `dmesg | tail` after the segfault, it should tell you what library it occurred in.
Comment 5 Richard Freeman gentoo-dev 2012-08-30 03:09:15 UTC
(In reply to comment #4)
> This looks similar to bug 315345. If you check the output of `dmesg | tail`
> after the segfault, it should tell you what library it occurred in.

For me this gives:
[542430.289905] python2.7[9324]: segfault at 0 ip 00007f945f6f0465 sp 00007fffecb9d6e0 error 6 in sip.so[7f945f6e2000+17000]
Comment 6 Zac Medico gentoo-dev 2012-08-30 03:35:44 UTC
If it's sip.so then it's probably a duplicate of bug #345331. See bug #345331, comment #32 for the solution.

*** This bug has been marked as a duplicate of bug 345331 ***
Comment 7 Richard Freeman gentoo-dev 2012-08-30 21:29:56 UTC
(In reply to comment #6)
> If it's sip.so then it's probably a duplicate of bug #345331. See bug
> #345331, comment #32 for the solution.
> 
> *** This bug has been marked as a duplicate of bug 345331 ***

Interesting - I had built all those packages at one time, but the fix still worked the next time around.  Wonder if it is some kind of bootstrapping issue (need to build them twice)...