Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 254704 - app-text/gscan2pdf - GUI to produce PDF or DjVu files from scanned documents
Summary: app-text/gscan2pdf - GUI to produce PDF or DjVu files from scanned documents
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 5 votes (vote)
Assignee: Default Assignee for New Packages
: 157887 (view as bug list)
Depends on: 254716 272308 288177 288179 288189
  Show dependency tree
Reported: 2009-01-12 22:13 UTC by Jimmy.Jazz
Modified: 2017-02-09 22:57 UTC (History)
20 users (show)

See Also:
Package list:
Runtime testing required: ---

gscan2pdf-0.9.27.ebuild (gscan2pdf-0.9.27.ebuild,1.10 KB, text/plain)
2009-01-12 22:14 UTC, Jimmy.Jazz
gtk2-imageview-0.04.ebuild (gtk2-imageview-0.04.ebuild,876 bytes, text/plain)
2009-01-12 22:16 UTC, Jimmy.Jazz
gtkimageview-1.6.3.ebuild (gtkimageview-1.6.3.ebuild,943 bytes, text/plain)
2009-01-12 22:18 UTC, Jimmy.Jazz
media-gfx/gscan2pdf-0.9.27.ebuild (gscan2pdf-0.9.27.ebuild,1.15 KB, text/plain)
2009-06-02 18:38 UTC, MT
media-gfx/gscan2pdf-0.9.29.ebuild (gscan2pdf-0.9.29.ebuild,1.21 KB, text/plain)
2009-10-09 08:48 UTC, MT
metadata.xml (metadata.xml,1.14 KB, text/plain)
2009-10-09 09:24 UTC, MT
media-gfx/gscan2pdf-0.9.29.ebuild (gscan2pdf-0.9.29.ebuild,1.23 KB, text/plain)
2009-10-12 08:04 UTC, MT
media-gfx/gscan2pdf-0.9.31.ebuild (gscan2pdf-0.9.31.ebuild,1.40 KB, text/plain)
2010-07-20 11:01 UTC, Günther Hutzl
media-gfx/gscan2pdf-0.9.31-r1 (gscan2pdf-0.9.31-r1.ebuild,1.41 KB, text/plain)
2010-11-19 13:41 UTC, Oisin O Malley
Replace forks with threads (gscan2pdf-0.9.31-threads.patch,221 bytes, patch)
2010-12-19 20:27 UTC, Chris Mayo
Details | Diff
Can use either forks or threads, add ithread use flag (gscan2pdf-0.9.31-r2.ebuild,1.60 KB, text/plain)
2011-01-29 14:31 UTC, Konstantin Lysenko
ebuild update to 0.9.32 (gscan2pdf-0.9.32.ebuild,1.46 KB, text/plain)
2011-04-04 19:16 UTC, Ronald van der Meer
gscan2pdf-0.9.32.ebuild requiring perl[ithreads] (gscan2pdf-0.9.32.ebuild-ithreads.diff,564 bytes, patch)
2011-06-04 12:12 UTC, Petr Pisar
Details | Diff
updated ebuild version 1.0 (gscan2pdf-1.0.0.ebuild,1.28 KB, text/plain)
2011-10-11 03:31 UTC, jamatik
gscan2pdf-1.0.0.ebuild (gscan2pdf-1.0.0.ebuild,1.46 KB, text/plain)
2011-10-11 03:59 UTC, jamatik
gscan2pdf-1.0.0.ebuild fiexed (gscan2pdf-1.0.0.ebuild,1.49 KB, text/plain)
2011-10-11 04:05 UTC, jamatik
gscan2pdf-1.0.0-r1.ebuild (gscan2pdf-1.0.0-r1.ebuild,1.48 KB, text/plain)
2011-11-23 00:23 UTC, Clemmitt M. Sigler
gscan2pdf-1.0.4.ebuild (gscan2pdf-1.0.4.ebuild,1.50 KB, text/plain)
2012-05-12 15:40 UTC, David
gscan2pdf-1.0.6.ebuild (gscan2pdf-1.0.6.ebuild,1.52 KB, text/plain)
2012-10-23 15:35 UTC, Sławomir Nizio
gscan2pdf-1.0.6.ebuild, variant 2 (gscan2pdf-1.0.6.ebuild,1.41 KB, text/plain)
2012-10-23 15:56 UTC, Sławomir Nizio
app-office/gscan2pdf-1.2.7.ebuild (gscan2pdf-1.2.7.ebuild,2.00 KB, text/plain)
2015-01-19 20:34 UTC, rajas
media-gfx/gscan2pdf-1.2.7 with corrected dependencied (gscan2pdf-1.2.7.ebuild,1.99 KB, text/plain)
2015-05-23 16:02 UTC, Petr Pisar
media-gfx/gscan2pdf-1.3.9 ebuild (gscan2pdf-1.3.9.ebuild,2.06 KB, text/plain)
2016-03-26 16:36 UTC, Petr Pisar

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy.Jazz 2009-01-12 22:13:46 UTC
new scanner ebuild

Reproducible: Always
Comment 1 Jimmy.Jazz 2009-01-12 22:14:29 UTC
Created attachment 178272 [details]
Comment 2 Jimmy.Jazz 2009-01-12 22:16:27 UTC
Created attachment 178274 [details]
Comment 3 Jimmy.Jazz 2009-01-12 22:18:52 UTC
Created attachment 178276 [details]
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-01-12 22:22:21 UTC
I'm going to take a look to this, I wanted to prepare an ebuild for this a long time ago already...
Comment 5 Lars 2009-03-03 17:59:21 UTC
I get this error when emerging media-gfx/gtkimageview-1.6.3:

checking whether the i686-pc-linux-gnu-gfortran linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux
(cached) (cached) checking how to hardcode library paths into programs... immediate
./configure: line 20113: GNOME_COMMON_INIT: command not found
./configure: line 20114: syntax error near unexpected token `error'
./configure: line 20114: `GNOME_COMPILE_WARNINGS(error)'

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-gfx/gtkimageview-1.6.3/work/gtkimageview-1.6.3/config.log
 * ERROR: media-gfx/gtkimageview-1.6.3 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 2943:  Called econf
 *     , line  529:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed

I hope I don't have to install gnome libs.
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-03-03 18:00:35 UTC
That's a missing dependency over gnome-common
Comment 7 Lars 2009-03-03 18:09:49 UTC
(In reply to comment #6)
> That's a missing dependency over gnome-common

Yes, installing gnome-common solved this issue.
Comment 8 Lars 2009-03-03 18:23:47 UTC
Next error:

>>> Compiling source in /var/tmp/portage/dev-perl/Gtk2-Ex-PodViewer-0.17/work/Gtk2-Ex-PodViewer-0.17 ...
 * Using ExtUtils::MakeMaker
MakeMaker FATAL: prerequisites not found (Locale::gettext not installed)

               Please install these modules first and rerun 'perl Makefile.PL'.
 * ERROR: dev-perl/Gtk2-Ex-PodViewer-0.17 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 2800:  Called perl-module_src_compile
 *             environment, line 2227:  Called perl-module_src_prep
 *             environment, line 2280:  Called die
 * The specific snippet of code:
 *               echo "$pm_echovar" | perl Makefile.PL ${myconf} INSTALLMAN3DIR='none' PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D} || die "Unable to build! (are you using USE="build"?)";
 *  The die message:
 *   Unable to build! (are you using USE="build"?)

# emerge --search gettext
*  dev-perl/Locale-gettext
      Latest version available: 1.05
      Latest version installed: 1.05

Comment 9 Lars 2009-03-03 18:28:13 UTC
Could emerge dev-perl/Gtk2-Ex-PodViewer-0.18

But when I try to start gscan2pdf:

 $ gscan2pdf 
Can't locate Locale/ in @INC (@INC contains: /etc/perl /usr/lib/perl5/vendor_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/local/lib/site_perl .) at /usr/bin/gscan2pdf line 117.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 117.
Comment 10 Torsten Veller (RETIRED) gentoo-dev 2009-03-03 20:31:00 UTC
(In reply to comment #8)
> # emerge --search gettext
> *  dev-perl/Locale-gettext
>       Latest version available: 1.05
>       Latest version installed: 1.05

(In reply to comment #9)
> Can't locate Locale/ in @INC (@INC contains: /etc/perl

Where did dev-perl/Locale-gettext install Locale/
( grep /var/db/pkg/dev-perl/Locale-gettext-1.05/CONTENTS )

Did you change USE=ithreads recently?
Comment 11 Lars 2009-03-03 21:08:35 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Can't locate Locale/ in @INC (@INC contains: /etc/perl
> Where did dev-perl/Locale-gettext install Locale/
> ( grep /var/db/pkg/dev-perl/Locale-gettext-1.05/CONTENTS )
# grep /var/db/pkg/dev-perl/Locale-gettext-1.05/CONTENTS
obj /usr/lib/perl5/vendor_perl/5.8.8/i686-linux/Locale/ cfb8f18915662ab571bc228d0507967c 1230260128

> Did you change USE=ithreads recently?
Yes indeed, I had to for emerging mod_perl a few days ago:

ERROR: www-apache/mod_perl-2.0.3-r2 failed.
 The die message:
  Need missing USE flag 'ithreads' in dev-lang/perl
Comment 12 Torsten Veller (RETIRED) gentoo-dev 2009-03-03 22:21:38 UTC
If you change the ithreads useflag (you have to do it for dev-lang/perl and sys-devel/libperl), you have to reinstall the modules. 
Run `perl-cleaner --reallyall` to fix your system.
Comment 13 Lars 2009-03-05 14:51:22 UTC
(In reply to comment #12)
> Run `perl-cleaner --reallyall` to fix your system.

This didn't hep. I know this is not the right place for support questions, but do you know any other way to get perl fixed again.
Comment 14 Lars 2009-03-05 14:55:47 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > Run `perl-cleaner --reallyall` to fix your system.

To be more precise `perl-cleaner --reallyall` does nothing.
Comment 15 Torsten Veller (RETIRED) gentoo-dev 2009-03-05 15:11:27 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > Run `perl-cleaner --reallyall` to fix your system.
> This didn't hep. I know this is not the right place for support questions,

So if reinstalling dev-perl/Locale-gettext doesn't solve your problems, please file a new bug and assign it to
Comment 16 Lars 2009-03-06 00:11:07 UTC
(In reply to comment #15)
> (In reply to comment #13)
> > (In reply to comment #12)
> > > Run `perl-cleaner --reallyall` to fix your system.

The correct command `perl-cleaner reallyall` worked and now gscan2pdf works too. Thanks.
Comment 17 MT 2009-06-02 17:08:31 UTC
Comment on attachment 178276 [details]

a new and improved ebuild can be found at #192239
Comment 18 MT 2009-06-02 18:38:29 UTC
Created attachment 193316 [details]

- fixed ebuild headers;
- added missing checks and EAPI 2;
- added missing dependencies (see blockers);
- updated ebuilds of some dependencies (see blockers);
Comment 19 MT 2009-06-02 19:27:54 UTC
Comment on attachment 178274 [details]

deprecated see bug 192239 and bug 272303
Comment 20 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-06-02 19:39:03 UTC
*** Bug 157887 has been marked as a duplicate of this bug. ***
Comment 21 Marco Schinkel 2009-07-14 10:40:20 UTC
0.9.29 is available on I used the gscan2pdf-0.9.27.ebuild and just renamed it. Intalls without problems, but gscan2pdf does not start, because and Set::IntSpan are needed. After installing these two via CPAN it works fine.
Comment 22 Lars 2009-07-15 21:24:32 UTC
After installing 0.9.27 gscan2pdf did not start due to dependency issues. After installing virtual/perl-Archive-Tar gscan2pdf started. Please add this perl module as dependency to the ebuild. 
Comment 23 Petr Pisar 2009-07-28 19:13:31 UTC
media-gfx/gscan2pdf-0.9.27.ebuild depends on media-gfx/unpaper which is not in tree (bug #172958). Please add bug #172958 as dependency into bugzilla.
Comment 24 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-09-24 23:39:57 UTC
Ooookay this should be updated to 0.9.29 I guess, any volunteer? ;)
Comment 25 MT 2009-10-09 08:48:40 UTC
Created attachment 206509 [details]

Updated the ebuild to the last package version, added new dependencies and fixed declaration of 'media-gfx/unpaper' dependency.
Comment 26 MT 2009-10-09 09:24:44 UTC
Created attachment 206511 [details]

the metadata.xml with the use flag descriptions.
Comment 27 MT 2009-10-12 08:04:12 UTC
Created attachment 206834 [details]

added missing virtual/perl-Archive-Tar as reported by @Lars in comment #22.
Comment 28 Jeremy Johnson 2009-11-20 03:38:21 UTC
After emerging gscan2pdf on x86 system, 
I ran into some missing runtime perl modules:        at /usr/bin/gscan2pdf line 106.
Image/ at /usr/bin/gscan2pdf line 121.

which weren't in portage, 
so I installed them using g-cpan:
g-cpan -i forks Image::Magick 
which pulled in:
 * perl-gcpan/forks
 * perl-gcpan/IO-CaptureOutput
 * perl-gcpan/Sys-SigAction
 * perl-gcpan/Acme-Damn

There were a few other runtime perl modules 
which also needed to be installed from portage:

Gtk2/      at/usr/bin/gscan2pdf line 111.
Gtk2/Ex/Simple/ at /usr/bin/gscan2pdf line 112.

So I emerged:
Comment 29 sean dreilinger 2010-02-20 08:59:24 UTC
to build gscan2pdf-0.9.30, i had to add these to the RDEPEND variable in the ebuild file:


and had to add this via CPAN since i couldn't find an ebuild for it:


Comment 30 Günther Hutzl 2010-07-20 11:01:21 UTC
Created attachment 239539 [details]

gscan2pdf-0.9.31 version bump. I had to add some more runtime dependencies:


I have also added cuneiform and ocropus use flags which pull in these:

cuneiform? ( app-text/cuneiform )
ocropus? ( app-text/ocropus )
Comment 31 Oisin O Malley 2010-11-07 23:40:59 UTC
gscan2pdf-0.9.31 appears to build and install fine but hangs on start. No window appears and there is no output in the terminal.

Running "gscan2pdf --debug":

gscan2pdf 0.9.31
Using en_IE@euro locale
Running init
Running sane_init
Gtk2-Perl version 1.222
Built for 2.20.1
Running with 2.20.1
Using GtkImageView version 1.6.4
Using Gtk2::ImageView version 0.05
Using PDF::API2 version 0.57
$VAR1 = {
          'frontend' => 'libsane-perl',
          'Paper' => {
                       'US Legal' => {
                                     'l' => 0,
                                     'y' => 356,
                                     'x' => 216,
                                     't' => 0
                       'US Letter' => {
                                      'l' => 0,
                                      'y' => 279,
                                      'x' => 216,
                                      't' => 0
                       'A4' => {
                               'l' => 0,
                               'y' => 297,
                               'x' => 210,
                               't' => 0
          'unsharp radius' => 0,
          'window_maximize' => 1,
          'ocr engine' => 'ocropus',
          'layout' => 'single',
          'unsharp amount' => 1,
          'OCR output' => 'replace',
          'OCR on scan' => 1,
          'Page range' => 'all',
          'window_height' => 600,
          'user_defined_tools' => [
                                    'gimp %i'
          'default filename' => '%a %y-%m-%d',
          'rotate reverse' => 0,
          'startup warning' => '',
          'Dark threshold' => '0.12',
          'pages to scan' => 1,
          'Blank threshold' => '0.005',
          'unpaper on scan' => 1,
          'rotate facing' => 0,
          'libsane-perl version' => '0.03',
          'cache options' => 1,
          'downsample dpi' => 150,
          'window_width' => 800,
          'threshold tool' => 80,
          'quality' => 75,
          'unsharp sigma' => 1,
          'date offset' => 0,
          'thumb panel' => 100,
          'unsharp threshold' => '0.05',
          'scan prefix' => '',
          'SANE version' => '1.0.19',
          'downsample' => '',
          'restore window' => 1,
          'pdf compression' => 'auto'
Comment 32 Petr Pisar 2010-11-12 13:23:09 UTC
media-gfx/gscan2pdf-0.9.29 that worked perfectly hangs on start-up now too. I guess it's because of perl upgrade to 5.12 or some of its dependecies.

Actually, it's not indefinit hang. It just forks, creates TCP connection on localhost between the two processes and after some time it times out and main window appears.
Comment 33 Oisin O Malley 2010-11-19 13:41:03 UTC
Created attachment 254825 [details]

gscan2pdf requires >=dev-perl/fork-0.34 to run correctly. This should fix the bug described above.
Comment 34 Petr Pisar 2010-11-27 14:50:02 UTC
Thanks. gscan2pdf-0.9.31-r1 with fork-0.34 starts fast now.
Comment 35 Marco Schinkel 2010-11-29 19:05:52 UTC
(In reply to comment #33)
> Created an attachment (id=254825) [details]
> media-gfx/gscan2pdf-0.9.31-r1
> gscan2pdf requires >=dev-perl/fork-0.34 to run correctly. This should fix the
> bug described above.

Ebuild works without problems now. Would be nice to see the ebuild in portage tree soon.
Comment 36 Chris Mayo 2010-12-19 20:27:26 UTC
Created attachment 257574 [details, diff]
Replace forks with threads

Alternative to using forks is to back-port the attached change from current upstream development (combination of the links below).

This does require perl with USE="ithreads", so
Comment 37 Konstantin Lysenko 2011-01-29 14:31:44 UTC
Created attachment 260993 [details]
Can use either forks or threads, add ithread use flag

This is ebuild that includes patch from

In this ebuild added ithreads use flag, if you use ithreads use flag then patch used and forks excludes from dependencies.
Comment 38 Ronald van der Meer 2011-04-04 19:16:02 UTC
Created attachment 268503 [details]
ebuild update to 0.9.32

ebuild update to 0.9.32

Just removed the ithreads patch and useflag, and added dev-perl/Log-Log4perl as a dependency.

Really powerful and useful app by the way. It would be nice to have it in portage.
Comment 39 Dennis Birkholz 2011-05-14 21:49:32 UTC
(In reply to comment #38)
> Created attachment 268503 [details]
> ebuild update to 0.9.32
> ebuild update to 0.9.32
> Just removed the ithreads patch and useflag, and added dev-perl/Log-Log4perl as
> a dependency.
> Really powerful and useful app by the way. It would be nice to have it in
> portage.

Version 0.9.32 requires dependency dev-lang/perl[ithreads] so ebuild should be fixed.
Comment 40 Petr Pisar 2011-06-04 12:12:11 UTC
Created attachment 275783 [details, diff]
gscan2pdf-0.9.32.ebuild requiring perl[ithreads]
Comment 41 jamatik 2011-10-11 03:31:15 UTC
Created attachment 289497 [details]
updated ebuild version 1.0


Comment 42 jamatik 2011-10-11 03:59:04 UTC
Created attachment 289499 [details]

updated ebuild using gscan2pdf-0.9.32.ebuild
Comment 43 jamatik 2011-10-11 04:05:40 UTC
Created attachment 289501 [details]
gscan2pdf-1.0.0.ebuild fiexed
Comment 44 Petr Pisar 2011-10-22 13:47:22 UTC
(In reply to comment #43)
> Created attachment 289501 [details]
> gscan2pdf-1.0.0.ebuild fiexed

Any reason why to depend on dev-perl/forks or dev-perl/prefork?
Also you mix tabs and spaces in indentation.
Comment 45 Petr Pisar 2011-10-22 14:21:14 UTC
(In reply to comment #43)
> Created attachment 289501 [details]
> gscan2pdf-1.0.0.ebuild fiexed

1.0.0 should RDEPEND dev-perl/HTML-Parser (lib/Gscan2pdf/
Comment 46 Clemmitt M. Sigler 2011-11-23 00:23:26 UTC
Created attachment 293461 [details]

I updated the ebuild provided by jamatik in Comment 43, making the changes suggested by Petr Pisar in Comment 44 and Comment 45.

Comment 47 Jeremy Johnson 2011-11-23 14:43:42 UTC
also need RDEPEND on dev-perl/HTML-TokeParser-Simple

$ cd gscan2pdf-1.0.0/lib/Gscan2pdf
$ grep "^use " *.pm | grep "HTML::TokeParser" HTML::TokeParser;
Comment 48 Torsten Veller (RETIRED) gentoo-dev 2011-11-23 15:00:35 UTC
HTML::TokeParser is a module from HTML-Parser, not from HTML-TokeParser-Simple. HTML-Parser is already in RDEPEND.
Comment 49 David 2012-05-12 15:40:52 UTC
Created attachment 311519 [details]

version bump
Comment 50 Kristian Niemi 2012-05-23 18:51:19 UTC
At least version 1.0.4 depends on bug 414705 (dev-perl/Sane-0.50).
Comment 51 Marco Schinkel 2012-06-27 07:41:22 UTC
The 1.0.4 ebuuild works for me without adding any additional dependencies into my overlay. THank you!
Comment 52 nikarul 2012-08-02 03:08:04 UTC
The 1.0.4 ebuild worked for me as well.  Additionally, copying the build to *-1.0.6 successfully built the latest version for me.
Comment 53 Olivier Mehani 2012-08-04 08:56:58 UTC
There's a dependence missing on dev-perl/HTML-Parser which provides HTML/ needed by, at least, Gscan2pdf/

It also needs dev-perl/Locale-gettext.
Comment 54 Sławomir Nizio 2012-10-23 15:35:59 UTC
Created attachment 327236 [details]

Same with small changes, mainly updated license and corrected dependencies.
By the way, this bug should no longer depend on bug 288177 and bug 288181.
Comment 55 Sławomir Nizio 2012-10-23 15:56:55 UTC
Created attachment 327238 [details]
gscan2pdf-1.0.6.ebuild, variant 2

More binary package friendly ebuild. Better suited for my needs; everyone is free to choose his.
Also the message about Thunderbird is removed - related bug is fixed upstream:
(if I had noticed it before, I would have removed the notice from the previous ebuild too).
Comment 56 Jason Lamb 2012-12-02 17:53:54 UTC
After emerging the most recent media-gfx/gscan2pdf-1.1.0 from the sabayon overlay, gscan2pdf fails on my system with the following error message;

open3: exec of unpaper --version failed at /usr/lib64/perl5/vendor_perl/5.16.1/Gscan2pdf/ line 1126.
Perl exited with active threads:
	2 running and unjoined
	0 finished and unjoined
	0 running and detached

Emerging unpaper, fixed this. Perhaps unpaper may not be an optional dependency anymore.
Comment 57 Sławomir Nizio 2012-12-02 20:55:53 UTC
Unpaper is still optional.
I have dev-lang/perl 5.12.4-r1 and it works for me. (Actually, it turns out that version detection is broken also here when unpaper is not installed, but at least it doesn't fail.)
Reason of this bug: IPC::Open3::open3 in your Perl version raises an exception as documented; it's not handled and the application aborts. In my older Perl's IPC::Open3 (1.05) it doesn't raise an exception. Gscan2pdf doesn't handle the correct behaviour from more recent Perls, and therefore needs to be fixed.
Comment 58 Marco Schinkel 2013-06-18 07:26:43 UTC
Version 1.1.3 is available on
Comment 59 rajas 2015-01-19 20:34:27 UTC
Created attachment 394354 [details]

Bump to version 1.2.7. Works for me without any problems. Added use flags to easier depend on the optional packages. This may or may not be a good idea. Comments welcome.
Comment 60 Petr Pisar 2015-05-23 16:02:17 UTC
Created attachment 403818 [details]
media-gfx/gscan2pdf-1.2.7 with corrected dependencied

This corrects previous ebuild which had misspelled dependencies or dependencies with unnecessary too high versions.
Comment 61 Thomas Capricelli 2015-10-22 20:01:54 UTC
This is the only way to get pdf from scanners in a friendly manner (gui).
Comment 62 Petr Pisar 2016-03-26 16:36:41 UTC
Created attachment 429050 [details]
media-gfx/gscan2pdf-1.3.9 ebuild

Ebuild for latest upstream version 1.3.9.
Comment 63 James Broadhead 2016-11-16 14:12:47 UTC
Just a quick note to say that the sabayon overlay has an ebuild as 
Comment 64 Amy Liffey gentoo-dev 2016-12-12 10:00:51 UTC
Hello guys,
Is there anyone who would be willing to maintain this ebuild through Proxy Maintainers project?
Comment 65 Chris Mayo 2016-12-30 17:48:08 UTC
I offer to Proxy it, bug 604162. PR for ebuild here:

Thanks to everyone on this bug it has been a source of news of new versions and pointers to changes to dependencies for a long time (plus the 2 years on bug 157887).
Comment 66 Göktürk Yüksek archtester gentoo-dev 2017-02-09 22:57:37 UTC
commit 82f3aa4407ad16afde14d2f382dabdc4c4c65f53
Author:     Chris Mayo <>
AuthorDate: Thu Feb 9 19:38:11 2017 +0000
Commit:     Göktürk Yüksek <>
CommitDate: Thu Feb 9 17:55:26 2017 -0500

    media-gfx/gscan2pdf: New package