Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 192239 - New ebuild for gtkimageview library
Summary: New ebuild for gtkimageview library
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
: 52445 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-11 21:36 UTC by Bruce Guenter
Modified: 2009-06-02 17:37 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New ebuild for GtkImageView-1.5.0 (gtkimageview-1.5.0.ebuild,643 bytes, text/plain)
2007-09-11 21:36 UTC, Bruce Guenter
Details
License is LGPL-3 (gtkimageview-lgpl3.patch,373 bytes, patch)
2007-12-27 12:20 UTC, Wolfgang Goetz
Details | Diff
LGPL-3 and ~amd64 (gtkimageview-lgpl3-amd64.patch,422 bytes, patch)
2007-12-27 12:40 UTC, Wolfgang Goetz
Details | Diff
New Ebuild for gtkimageview-1.6.1 (gtkimageview-1.6.1.ebuild,851 bytes, text/plain)
2008-03-29 16:00 UTC, Andreas Volz
Details
new ebuild for gtkimageview (gtkimageview-1.6.3.ebuild,685 bytes, text/plain)
2009-03-09 23:23 UTC, Ian Stakenvicius
Details
x11-libs/gtkimageview-1.6.3.ebuild (gtkimageview-1.6.3.ebuild,813 bytes, text/plain)
2009-06-02 16:34 UTC, Toffanin
Details
x11-libs/gtkimageview-1.6.4.ebuild (gtkimageview-1.6.4.ebuild,802 bytes, text/plain)
2009-06-02 16:39 UTC, Toffanin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Guenter 2007-09-11 21:36:02 UTC
GtkImageView is a simple image viewer widget for GTK. Similar to the image viewer panes in gThumb or Eye of Gnome. It makes writing image viewing and editing applications easy.

Its home page is http://trac.bjourne.webfactional.com/

Reproducible: Always
Comment 1 Bruce Guenter 2007-09-11 21:36:46 UTC
Created attachment 130639 [details]
New ebuild for GtkImageView-1.5.0
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-09-11 21:40:31 UTC
*** Bug 52445 has been marked as a duplicate of this bug. ***
Comment 3 Wolfgang Goetz 2007-12-27 12:20:18 UTC
Created attachment 139394 [details, diff]
License is LGPL-3 

http://trac.bjourne.webfactional.com/chrome/common/gtkimageview-docs/overview.html
links to http://www.gnu.org/licenses/lgpl.html which is V3 of the LGPL
Comment 4 Wolfgang Goetz 2007-12-27 12:25:47 UTC
is ist possible to tell ebuild that SRC_URI with '?format=raw'
should place the tar.gz solely?

now it's: /usr/portage/distfiles/gtkimageview-1.5.0.tar.gz?format=raw

Comment 5 Wolfgang Goetz 2007-12-27 12:27:15 UTC
to see it working: emerge ufraw 
Comment 6 Wolfgang Goetz 2007-12-27 12:40:44 UTC
Created attachment 139396 [details, diff]
LGPL-3 and ~amd64
Comment 7 Andreas Volz 2008-03-29 16:00:19 UTC
Created attachment 147633 [details]
New Ebuild for gtkimageview-1.6.1

Updated to 1.6.1

I think renaming the file after download and then using the ebuild way to unpack is better than tar direct.
Comment 8 Dmitry Ivankov 2009-01-18 22:20:57 UTC
> I think renaming the file after download and then using the ebuild way to
> unpack is better than tar direct.
No, this way file will be fetched again each time.
Filename issue ticket http://trac.bjourne.webfactional.com/ticket/27

Comment 9 Ian Stakenvicius gentoo-dev 2009-03-09 23:23:34 UTC
Created attachment 184513 [details]
new ebuild for gtkimageview

I version-bumped this ebuild to current upstream, and converted it to EAPI="2", which cleans up the ebuild substantially and addresses the pesky ?format=raw filename issue.

Tried submitting it to sunrise, but they want the docs to be strippable via USE="-doc", a patch to configure.in/Makefile.am and eautoreconf, before they will accept.
Comment 10 Toffanin 2009-06-02 16:34:57 UTC
Created attachment 193307 [details]
x11-libs/gtkimageview-1.6.3.ebuild

- fixed ebuild headers;
- fixed USE="doc" as required by sunrise project;
- added missing eauto* calls;
- improved ebuild to make usage of the gnome2 eclass;

p.s.: unfortunately compilation with USE="doc" fails due a parsing error (just reported upstream as bugreport: http://trac.bjourne.webfactional.com/ticket/36 ), so i suggest to temporarely mask the use 'doc' within the profile of the sunrise overlay until the bug is fixed.
Comment 11 Toffanin 2009-06-02 16:39:43 UTC
Created attachment 193309 [details]
x11-libs/gtkimageview-1.6.4.ebuild

version bump for v1.6.4

p.s.: this version do not compile at all, see my upstrem report: http://trac.bjourne.webfactional.com/ticket/35
Comment 12 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-06-02 17:37:10 UTC
It looks like maekke added a gtkimageview ebuild to the tree yesterday.