Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240958 - x11-misc/xscreensaver + dev-util/intltool-0.40.5 - config.status: error: po/Makefile.in.in was not created by intltoolize.
Summary: x11-misc/xscreensaver + dev-util/intltool-0.40.5 - config.status: error: po/M...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Samuli Suominen (RETIRED)
URL:
Whiteboard:
Keywords:
: 242448 245671 (view as bug list)
Depends on:
Blocks: 242660
  Show dependency tree
 
Reported: 2008-10-10 03:04 UTC by Ivan
Modified: 2021-07-23 15:18 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Hack :) (no_intltool.patch,2.22 KB, patch)
2008-10-16 01:26 UTC, dnw.ftw
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2008-10-10 03:04:41 UTC
xscreensaver fails its configuring stage when using intltool-0.40.5.

Reproducible: Always

Steps to Reproduce:
1. Install intltool-0.40.5
2. Try to install xscreensaver (tested with 5.06 and 5.07)

Actual Results:  
...
configure: creating ./config.status
config.status: creating Makefile
config.status: creating utils/Makefile
config.status: creating driver/Makefile
config.status: creating hacks/Makefile
config.status: creating hacks/glx/Makefile
config.status: creating po/Makefile.in
config.status: creating driver/XScreenSaver.ad
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing po/stamp-it commands
config.status: error: po/Makefile.in.in was not created by intltoolize.
...

(install fails).


Expected Results:  
Install succeeds.

Masking dev-util/intltool-0.40.5 (and thus using version 0.40.4) fixes this problem (i.e. xscreensaver installs).

This is on a freshly installed ~x86 install.

# emerge --info
Portage 2.2_rc11 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.23.1-42.fc8 i686)
=================================================================
System uname: Linux-2.6.23.1-42.fc8-i686-Intel-R-_Core-TM-2_Duo_CPU_T7250_@_2.00GHz-with-glibc2.0
Timestamp of tree: Thu, 09 Oct 2008 11:15:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/gentoo//distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=""
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_AU en_GB en uk"
MAKEOPTS="-j3"
PKGDIR="/gentoo//packages"
PORTAGE_COMPRESS=""
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/gentoo//gentoo-tree"
PORTDIR_OVERLAY="/gentoo/emacs /gentoo/haskell /gentoo/local /gentoo/science /gentoo/sunrise"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X Xaw3d aac acpi alsa bash-completion bluetooth bzip2 cairo cddb cdparanoia cdr clamav clucene cracklib crypt css cups dbus directfp doc dri dv dvd dvdr dvdread emacs encode fam fbcon ffmpeg firefox flac fontconfig fortran gd gif gimp gnuplot gphoto2 gpm graphviz gstreamer hal hddtemp htmlhandbook iconv imagemagick imlib imp ipv6 jpeg kde libnotify lm_sensors matroska mime mmx mp3 mpeg mplayer msn ncurses nls nptl offensive ogg openal opengl pam pdf plotutils png qt4 quicktime readline real samba session speex spell sse sse2 ssl startup-notification svg svga theora threads tiff truetype unicode usb vcd videos vorbis wifi win32codecs wmf x264 x86 xcb xcomposite xinerama xorg xpm xscreensaver xulrunner xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_AU en_GB en uk" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Oschtan 2008-10-10 14:02:04 UTC
And amd64
==========
Portage 2.2_rc11 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-glibc2.2.5
Timestamp of tree: Thu, 09 Oct 2008 12:47:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache collision-protect distlocks metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://local.weirdwire.ru/distr/mirror/gentoo http://mirror.yandex.ru/gentoo-distfiles http://trumpetti.atm.tut.fi/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror ftp://gentoo.chem.wisc.edu/gentoo/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="3dnow 3dnowext 7zip X a52 aac aalib acl acpi additions alsa amd64 amr amrnb amrwb ao apm applet arts audacious audiofile bdf berkdb bindist bzip2 cairo cdparanoia cdr cgi cjk clamav cli color-console cracklib crypt dbus divx djvu dri drm dts dvd dvdr dvdread enca encode exif fbcondecor ffmpeg fftw fortran ftp fuse gd gdbm gecko gif gimp glitz gmedia gphoto2 gpm graphviz gtk gtkhtml hal hddtemp hdri htmlhandbook icons iconv icq imagemagick imlib isdnlog java java5 java6 javascript jbig jpeg jpeg2k kde lame lcms lm_sensors lzma mad midi mikmod mime mjpeg mmx mmxext mng motif mp2 mp3 mp4 mpeg mplayer mudflap multilib multitarget ncurses nls nptl nptlonly nsplugin oav objc objc++ objc-gc ogg openexr opengl openmp pam pcre pdf perl pertty plotutils png povray pppd python qt3 qt3support qt4 quicktime rar rcc readline realmedia reflection rtc samba sdl sensord session sndfile sound source spell spl sqlite3 srt sse sse2 ssl startup-notification svg symlink sysfs syslog szip tcpd theora tidy tiff truetype type1 unicode unsupported usb userlocales utempter vcd visualization vorbis wma wmf wmp x264 x264-svn-encoder xattr xcomposite xml xorg xpm xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="intel8x0"
Comment 2 Oschtan 2008-10-10 14:17:06 UTC
Compiled successful: downgrade dev-util/intltool-0.40.5 >> dev-util/intltool-0.40.4
Comment 3 Leung Ki Chi 2008-10-11 23:42:25 UTC
Same here, masking intltool 0.40.5 fixes the problem.
Comment 4 M. Edward Borasky 2008-10-14 04:03:33 UTC
(In reply to comment #2)
> Compiled successful: downgrade dev-util/intltool-0.40.5 >>
> dev-util/intltool-0.40.4
> 
Thanks for the workaround!
Comment 5 Ivan 2008-10-14 04:11:17 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Compiled successful: downgrade dev-util/intltool-0.40.5 >>
> > dev-util/intltool-0.40.4
> > 
> Thanks for the workaround!
> 

Note that this workaround was listed in my original bug report (in the middle though):

> Masking dev-util/intltool-0.40.5 (and thus using version 0.40.4) fixes this
> problem (i.e. xscreensaver installs).
Comment 6 Ivan 2008-10-15 08:06:13 UTC
It now seems that leio has removed intltool-0.40.4 because it's "old"...
Comment 7 Mart Raudsepp gentoo-dev 2008-10-15 16:07:49 UTC
Yes it's old, and the change in 0.40.5 is precisely to not allow broken intltoolized stuff. Now it errors, before it was plain out broken in translation handling (in principle, I don't know what the effects were on the system when installed).
Comment 8 Mart Raudsepp gentoo-dev 2008-10-15 16:14:46 UTC
The problem is that it uses both gettext and intltool - there are both AC_PROG_INTLTOOL and AM_GLIB_GNU_GETTEXT calls in configure.in. It should use one or the other for the translations, not both. If intltool isn't intended to be used (it before wasn't used, but maybe accidentally because intltool didn't warn about it) then AC_PROG_INTLTOOL call could be removed and it should work.
Comment 9 dnw.ftw 2008-10-16 01:26:43 UTC
Created attachment 168632 [details, diff]
Hack :)

The quick-patch I made, that made it merge fine on my machine.
Comment 10 Bob Raitz 2008-10-16 05:56:53 UTC
Thanks for this. Moving to intltool-0.40.4 not only allowed xscreensaver to compile, but xfce-netload as well. Nice.

Blessed be!
Pappy
Comment 11 Ian Abbott 2008-10-16 10:10:44 UTC
(In reply to comment #9)
> Created an attachment (id=168632) [edit]
> Hack :)
> 
> The quick-patch I made, that made it merge fine on my machine.

It works for me.  To apply it, save it to "${local_portage}/x11-misc/xscreensaver/files/5.07/02_all_no_intltool.patch" (where "$(local_portage}" is your local portage overlay) and run "ebuild ${local_portage}/x11-misc/xscreensaver/xscreensaver-5.07 manifest".
Comment 12 Jeremy Murphy 2008-10-17 09:08:45 UTC
(In reply to comment #11)
> 
> It works for me.  To apply it, save it to
> "${local_portage}/x11-misc/xscreensaver/files/5.07/02_all_no_intltool.patch"
> (where "$(local_portage}" is your local portage overlay) and run "ebuild
> ${local_portage}/x11-misc/xscreensaver/xscreensaver-5.07 manifest".
> 

Did you mean "ebuild ${local_portage}/x11-misc/xscreensaver/xscreensaver-5.07.ebuild manifest"?
That's what I had to run anyway.  Thank you to both of you for the patch and explanation!
Comment 13 Mike Auty (RETIRED) gentoo-dev 2008-10-18 09:50:26 UTC
*** Bug 242448 has been marked as a duplicate of this bug. ***
Comment 14 Francisco José Cañizares Santofimia 2008-11-02 16:00:45 UTC
(In reply to comment #9)
> Created an attachment (id=168632) [edit]
> Hack :)
> 
> The quick-patch I made, that made it merge fine on my machine.
> 

It does the trick for me too.
Comment 15 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2008-11-05 19:17:42 UTC
*** Bug 245671 has been marked as a duplicate of this bug. ***
Comment 16 Ben de Groot (RETIRED) gentoo-dev 2008-11-05 20:33:17 UTC
Patch committed.
Comment 17 Jamie Zawinski 2008-12-08 04:29:43 UTC
I don't understand what's going on here.

Surely that patch isn't the right way to fix this?

Is there some change I should make upstream?  If so, what, and why?
Comment 18 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 06:59:04 UTC
Reopening. The patch committed is invalid.
Comment 19 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 07:05:11 UTC
Comment on attachment 168632 [details, diff]
Hack :)

This "patch" breaks translations of .desktop file entirely.
Comment 20 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 07:17:49 UTC
(In reply to comment #17)
> I don't understand what's going on here.
> 
> Surely that patch isn't the right way to fix this?
> 
> Is there some change I should make upstream?  If so, what, and why?
> 

Quoting from, http://bugs.gentoo.org/show_bug.cgi?id=242530#c3

"The problem is that it uses both gettext and intltool - there are both
AC_PROG_INTLTOOL and AM_GLIB_GNU_GETTEXT calls in configure.in. It should use
one or the other for the translations, not both. If intltool isn't intended to
be used (it before wasn't used, but maybe accidentally because intltool didn't
warn about it) then AC_PROG_INTLTOOL call could be removed and it should work."

Quoting from, http://bugs.gentoo.org/show_bug.cgi?id=240958#c8

"The problem must be that compiz asks both gettext and intltool to create
po/Makefile.in.in - that is safeguarded with intltool-0.40.5 because that's
probably not what was intended. You use either gettext or intltool to take care
of po/, not both. There is a bug against xscreensaver with the same problem
that has a longer explanation from me as a comment"

That said, I don't know the real solution to xscreensaver yet. It breaks when you autoreconf with combination of autoconf-2.63, automake-1.10.2 and intltool-0.40.5.
Comment 21 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 07:28:22 UTC
(In reply to comment #17)
> I don't understand what's going on here.

We need to run autoreconf to xscreensaver before ./configure because of bug
155049. That is no problem for us, until intltool-0.40.5.
Comment 22 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 07:30:11 UTC
(In reply to comment #21)
> (In reply to comment #17)
> > I don't understand what's going on here.
> 
> We need to run autoreconf to xscreensaver before ./configure because of bug
> 155049. That is no problem for us, until intltool-0.40.5.
> 

Arg, I meant bug 113681. Sorry.
Comment 23 Gilles Dartiguelongue gentoo-dev 2009-04-23 22:50:59 UTC
simply needs to call:
intltoolize --force --copy --automake || die "intltoolize failed"
before calling eautoreconf.
Comment 24 Samuli Suominen (RETIRED) gentoo-dev 2009-04-30 14:20:45 UTC
(In reply to comment #23)
> simply needs to call:
> intltoolize --force --copy --automake || die "intltoolize failed"
> before calling eautoreconf.
> 

That doesn't work for xscreensaver, it seems the generated files has been edited by hand..

I found that Fedora is applying this, 

http://cvs.fedoraproject.org/viewvc/rpms/xscreensaver/devel/xscreensaver-5.08-po-recreate.patch?revision=1.3&view=markup

But it doesn't work after we autoreconf for bug 113681.
Comment 25 Samuli Suominen (RETIRED) gentoo-dev 2009-04-30 14:42:29 UTC
I give up.. I'll simply "unset LINGUAS" to avoid the catalog failure with LINGUAS="zh".. and realize this package can't be autoreconfigured anymore.