Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242530 - x11-wm/compiz-* fails to configure with dev-util/intltool-0.40.5
Summary: x11-wm/compiz-* fails to configure with dev-util/intltool-0.40.5
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 242660
  Show dependency tree
 
Reported: 2008-10-18 04:33 UTC by Scott Moreau
Modified: 2009-01-21 04:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Moreau 2008-10-18 04:33:52 UTC
x11-wm/compiz-* fails to compile (when configuring) when dev-util/intltool-0.40.5 is installed, but using dev-util/intltool-0.40.4 compiz configures and compiles fine.

Reproducible: Always

Steps to Reproduce:
1.Emerge dev-util/intltool-0.40.5
2.Install the desktop-effects overlay
3.Try to emerge compiz

Actual Results:  
compiz will fail to configure with "config.status: error: po/Makefile.in.in was not created by intltoolize."

Expected Results:  
compiz should pass configure and compile as it does when dev-util/intltool-0.40.4 is installed

I suspect this is a bug with intltool, but asking around and googling I can not find any information about which component is faulty, yet many other users are having this same problem
Comment 1 Mike Auty gentoo-dev 2008-10-18 09:10:00 UTC
Probably a compiz issue, but CCing Gnome as they may have run into this before...
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-10-18 19:11:35 UTC
tried stuffing intlootlize --force and eautoreconf in the ebuild ?
Comment 3 Mart Raudsepp gentoo-dev 2008-10-18 19:36:39 UTC
The problem must be that compiz asks both gettext and intltool to create po/Makefile.in.in - that is safeguarded with intltool-0.40.5 because that's probably not what was intended. You use either gettext or intltool to take care of po/, not both. There is a bug against xscreensaver with the same problem that has a longer explanation from me as a comment
Comment 4 Scott Moreau 2008-10-18 20:34:48 UTC
>The problem must be that compiz asks both gettext and intltool to create
>po/Makefile.in.in - that is safeguarded with intltool-0.40.5 because that's
>probably not what was intended. You use either gettext or intltool to take care
>of po/, not both. There is a bug against xscreensaver with the same problem
>that has a longer explanation from me as a comment

I have found that omitting the glib-gettextize line in src_prepare() from the ebuild fixes this problem. Thank you much for your time and information.
Comment 5 Mart Raudsepp gentoo-dev 2008-10-18 21:41:04 UTC
That doesn't mean it works for others if the ebuild in portage tree isn't fixed and committed by a developer. This is obvious, so please don't close the bug in that case. Reopening
Comment 6 Scott Moreau 2008-10-19 05:07:10 UTC
Yes, I have found that this effects not only x11-wm/compiz, but x11-libs/libcompizconfig, x11-plugins/compiz-fusion-plugins-main, x11-plugins/compiz-fusion-plugins-extra and x11-plugins/compiz-fusion-plugins-unsupported in the same way as well. I have contacted the desktop-effects overlay maintainer, and will notify when this is resolved and been pushed.
Comment 7 Scott Moreau 2008-10-21 08:32:08 UTC
Components from the desktop-effects overlay now compile thanks to jim. I have not and will not be testing the portage compiz ebuilds so I'll leave this open for now.
Comment 8 Scott Moreau 2008-10-28 20:47:03 UTC
compiz 0.7.8 components have made their way into portage, and the ebuilds are working now.
Comment 9 Mart Raudsepp gentoo-dev 2008-10-31 00:19:54 UTC
I doubt that's enough, unless compiz-0.7.8 in portage is planning to go stable within the upcoming week, as that's when I'm hoping to stabilize intltool-0.40.x. There's a backup plan though, but I'd hope to not need it.