Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204128 - x11-base/xorg-server- broken cz_qwerty layout on 'rtyuiop' keys
Summary: x11-base/xorg-server- broken cz_qwerty layout on 'rtyuiop' keys
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
Depends on:
Blocks: 210710
  Show dependency tree
Reported: 2008-01-02 23:06 UTC by Martin Mokrejš
Modified: 2008-02-19 15:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

X.txt (X.txt,7.14 KB, text/plain)
2008-01-11 11:40 UTC, Martin Mokrejš
Xorg.0.log (Xorg.0.log,53.41 KB, text/plain)
2008-01-11 11:44 UTC, Martin Mokrejš
X.txt (X__without_hal_is_still_broken.txt,5.51 KB, text/plain)
2008-01-11 13:27 UTC, Martin Mokrejš
Xorg.0.log (Xorg.0.log-without-hal-is-still-broken,43.62 KB, text/plain)
2008-01-11 13:27 UTC, Martin Mokrejš
xorg.conf (working) (xorg.conf,14.75 KB, text/plain)
2008-02-06 13:38 UTC, Martin Mokrejš

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2008-01-02 23:06:13 UTC
  in the 1.4 series there is broken the layout when user enables a different layout using alt+shift, a czech-one in my case.

When I am in 'en_US' mode, I get 'qwertyuiop[]' keys. When I switch to 'cz_qwerty' mode, I should get exactly same keys, because these keys are not altered in czech layout. But, the 1.4 series has this screwed somehow. Compare the following PAIRS of lines. First two lines on US layout, the latter on czech layout.

$ qwertyuiop[]
$ `1234567890-=\
$ qwe¶ŧ←↓→øþú)
$ ;+ěščřžýáíé='"

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "CoreKeyboard"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "en_US,cz_qwerty"
    Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-03 02:53:51 UTC
Which x11-misc/xkeyboard-config version? Also, you have HAL enabled or not?
Comment 2 Martin Mokrejš 2008-01-03 13:27:12 UTC
# emerge -s xkeyboard-config
[ Results for search key : xkeyboard-config ]
[ Applications found : 1 ]
*  x11-misc/xkeyboard-config
      Latest version available: 1.1
      Latest version installed: 1.1
*  app-misc/hal-info
      Latest version available: 20070618
      Latest version installed: 20070618
*  sys-apps/hal
      Latest version available:
      Latest version installed:
# emerge --info
Portage 2.1.4_rc14 (default-linux/x86/2007.0/desktop, gcc-4.2.2, glibc-2.7-r1, i686)
System uname: i686 Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
Timestamp of tree: Wed, 02 Jan 2008 11:00:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.3
dev-lang/python:     2.3.6-r3, 2.4.4-r6, 2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /var/bind /var/qmail/alias /var/qmail/control /var/spool/torque /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -mmmx -msse -msse2 -fomit-frame-pointer -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en cs cz"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="7zip R X Xaw3d a52 aac aalib ace acl acpi alsa amr amrnb amrwb apache2 audacious audiofile bash-completion bcmath berkdb bitmap-fonts blas boost bzip2 cairo cblas cddb cdparanoia cdr clamav cli colordiff compress cpio cracklib crypt cscope css ctype cups curl curlwrappers cxx dbus dga dia directfb djbfft dri dts dv dvb dvd dvdr dvdread eds emacs emboss emf enblend encode enscript exif expat fam fame fat fbcon ffmpeg fftw firefox flac flash foomaticdb fortran fpx ftp gcj gd gdbm ggi gif gimp gimpprint glibc-compat20 glibc-omitfp glitz glut gmp gnuplot gnutls gpgme gphoto2 gpm graphviz gs gsl gstreamer gtk gtkhtml hal hdf hdf5 i8x0 icc iconv icu id3 ieee1394 ifc imagemagick imlib inifile innodb isdnlog ithreads jack java javascript jbig jikes jpeg jpeg2k kdtree kerberos lame lapack lcms leim libcaca libedit libwww live lzo lzw mad maildir matroska mhash midi mikmod mime ming mjpeg mmap mmx mng mod_python modperl modplug motif mozilla moznoirc mp2 mp3 mp4 mpeg mpi mpi_njtree mplayer mudflap mule musepack mxdatetime mysql mysqli ncurses netcdf netpbm network nls nntp nptl nptlonly nsplugin ntfs numeric ogg opengl openmp oss pam pango pcmcia pcntl pcre pdf perl plotutils plugin png pnm postproc postscript ppds pppd procmail pymol python qt3 qt3support qt4 quicktime rar raw readline real recode reflection reiserfs rpm rtc samba sasl scanner scp seamonkey server session sftp sift slp smime sndfile soap sockets spell spl sqlite srt sse sse2 ssl subtitles subversion svg svgz sysfs sysvipc t1lib tcl tcpd tetex theora threads tidy tiff tk transcode truetype truetype-fonts type1-fonts unicode urandom usb userlocales uuencode v4l v4l2 vcd vim-syntax vim-with-x vorbis wifi win32codecs wmf wxwindows x264 x86 xanim xcb xcf xfs xft xinetd xml xorg xpm xprint xsl xslt xv xvid xvmc yv12 zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config mem_cache mime mime_magic rewrite setenvif speling status unique_id userdir usertrack vhost_alias negotiation" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs cz" USERLAND="GNU" VIDEO_CARDS="radeon"

# ps -ef | grep hal
109       4255     1  0 Jan02 ?        00:00:02 /usr/sbin/hald --use-syslog --verbose=no
root      4256  4255  0 Jan02 ?        00:00:00 hald-runner
109       4262  4256  0 Jan02 ?        00:00:01 hald-addon-keyboard: listening on /dev/input/event3
root      4264  4256  0 Jan02 ?        00:00:00 /usr/libexec/hald-addon-cpufreq
109       4265  4256  0 Jan02 ?        00:00:01 /usr/libexec/hald-addon-acpi
109       4269  4256  0 Jan02 ?        00:00:00 hald-addon-keyboard: listening on /dev/input/event0
109       4270  4256  0 Jan02 ?        00:00:00 hald-addon-keyboard: listening on /dev/input/event1
109       4272  4256  0 Jan02 ?        00:00:00 hald-addon-keyboard: listening on /dev/input/event2
109       4273  4256  0 Jan02 ?        00:00:00 hald-addon-keyboard: listening on /dev/input/event7
Comment 3 Martin Mokrejš 2008-01-03 13:39:55 UTC
The problem can be "fixed" by the following downgrades and subsequent recompilation of mesa (see bug #204188) and few x11-drivers. 

[ebuild     UD] x11-proto/renderproto-0.9.2 [0.9.3] 
[ebuild     UD] x11-libs/libXrender-0.9.2 [0.9.4] 
[ebuild     UD] x11-base/xorg-server- [] USE="nptl*" 
[ebuild     UD] x11-drivers/xf86-input-keyboard-1.1.1-r1 [1.2.2] 
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-01-03 19:33:22 UTC
Well, that's obviously not any fix. What I meant is whether it works for you when you compile xorg-server w/ USE="-hal"
Comment 5 Saleem Abdulrasool (RETIRED) gentoo-dev 2008-01-04 03:00:45 UTC
@jakub: not the issue, using <hal-0.5.10.
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2008-01-11 08:14:36 UTC
What's the output of `setxkbmap -print`? Please reopen when you reply.
Comment 7 Martin Mokrejš 2008-01-11 10:09:31 UTC
OK, under working instalation I have the following at the moment. I will upgrade to the 1.4 series to repeat the problem and reopen afterwards.

# setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete+ledscroll(group_lock)"        };
        xkb_symbols   { include "pc+latin+cz(qwerty):2+group(switch)+group(alt_shift_toggle)"   };
        xkb_geometry  { include "pc(pc105)"     };
# emerge -uNp world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild     U ] x11-base/xorg-server- [] USE="hal%*" VIDEO_CARDS="-amd% -vermilion% -xgi%" 
[ebuild     U ] x11-drivers/xf86-input-keyboard-1.2.2 [1.1.1-r1] 
[ebuild     U ] x11-drivers/xf86-input-evdev-1.2.0 [1.1.5-r2] 
Comment 8 Martin Mokrejš 2008-01-11 11:40:16 UTC
# emerge x11-misc/xkeyboard-config x11-drivers/xf86-video-fbdev x11-drivers/xf86-input-mouse x11-drm libdrm mesa mesa-progs xf86-video-ati

I think I found something in the STDERR when starting up X after the upgrade to I do not see such message sin /var/log/Xorg.0.log. Will attach both.

# X > X.txt 2>&1
Comment 9 Martin Mokrejš 2008-01-11 11:40:33 UTC
Created attachment 140677 [details]
Comment 10 Martin Mokrejš 2008-01-11 11:44:11 UTC
Created attachment 140678 [details]

So, for some reason I cannot reproduce now the problem, because my czech layout is not picked up from the xorg.conf file.

# setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete+ledscroll(group_lock)"        };
        xkb_symbols   { include "pc+us+inet(evdev)+group(switch)+group(alt_shift_toggle)"       };
        xkb_geometry  { include "pc(pc104)"     };
Comment 11 Martin Mokrejš 2008-01-11 13:23:58 UTC
I could reproduce the problem again, even without HAL (5.0.10 having now), per comment #4:

# USE=-hal emerge xorg-server
# qwe¶ŧ←↓→øþú)
# setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete+ledscroll(group_lock)"        };
        xkb_symbols   { include "pc+latin+cz(qwerty):2+group(switch)+group(alt_shift_toggle)"   };
        xkb_geometry  { include "pc(pc105)"     };
Comment 12 Martin Mokrejš 2008-01-11 13:27:19 UTC
Created attachment 140686 [details]

# USE=-hal emerge xorg-server
# X > X.txt 2>&1
Comment 13 Martin Mokrejš 2008-01-11 13:27:56 UTC
Created attachment 140687 [details]

And the corresponding logfile generated by /etc/init.d/xdm
Comment 14 Martin Mokrejš 2008-01-11 13:52:31 UTC
As per comments #4 and #5: this is not same as bug #200061. I inserted 

# prevent hal 0.5.10 messing with my keyboard as per bug #200061
    Option "AutoAddDevices" "False" 

into ServerLayout section of my xorg.conf ( and I still have wrong qwerty keys. Downgrading back to anyway.
Comment 15 Donnie Berkholz (RETIRED) gentoo-dev 2008-01-11 18:02:04 UTC
With hal 0.5.10 and evdev driver installed, it takes over and ignores whatever you may have configured in xorg.conf.  Take a look at -- tweak it for your needs and stick it into /etc/hal/fdi/policy/
Comment 16 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-15 09:15:26 UTC
I also have several regression bugs with X-1.4: bug 204401 and bug 194515 . Qlso visit bug 205041 that also tell about input+HAL problems.

This morning I an having 2 more problems: layout broken (I have FR board and X defaulted me in US) and broken evdev/mouse so that the Y axis is inverted.

(In reply to comment #10)
> my czech layout
> is not picked up from the xorg.conf file.
> # setxkbmap -print
> xkb_keymap {
>         xkb_keycodes  { include "evdev+aliases(qwerty)" };

same here:
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
when it should be French azerty
Comment 17 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-15 09:32:28 UTC
Before trying to mask sys-apps/hal-0.5.10 try to add
Option  "AutoAddDevices"        "False"
to your ServerLayout. It fixed my layout, but not my mouse. See
Comment 18 Donnie Berkholz (RETIRED) gentoo-dev 2008-01-19 09:25:12 UTC
If you have confirmed that using the FDI file as I suggested does not resolve your layout issues or mouse configurations (on 1.4.x xorg-server with USE=hal), please file a bug upstream at in the xorg product and post the URL here.
Comment 19 Martin Mokrejš 2008-01-22 20:37:25 UTC
Sorry, I have given this up. I could not make it to work. After having the following xorg.conf setup not even my ctrl+alt+F1 worked and after killing x from remote computer several times I have just given up, sorry. I am not even gouing to report upstream, a number of lists and forums are full of reports of problems.

The theoretically best I have got in terms of configuration (still not functional!) was this:

Section "InputDevice"

    Identifier  "Keyboard1"

    # for xorg-server-1.4 series and hal-0.5.10
    #Driver "evdev"
    #Option "XkbModel" "evdev"
    # for >=evdev-1.2.0 otherwise use 1.1.5 instead
    # some people claim the eventX changes on every reboot, and
    # there were some solutions, but don't ask me details
    # Option    "Device"    "/dev/input/event3"
    # egrep "Name|Handler" /proc/bus/input/devices

    # for <xorg-server-1.4 series and <hal-0.5.10
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules"   "xorg"
    Option "CoreKeyboard"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "en_US,cz_qwerty"
    Option "XkbOptions" "grp:alt_shift_toggle,grp:switch,grp_led:scroll"


The following should have helped to at least have a us layout and but evdev was not being loaded:
(EE) Keyboard0: cannot open input pEvdev

Then I did 
# cp /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi /etc/hal/fdi/policy/
to get at least a us keyboard fine again with ctrl+alt+F1 working again, but there was some other error leading me to downgrade xf86-input-evdev to 1.1.5 version. I think the very "last" error was that evdev was seeing my keybaoard and mouse but it complained that it does not know how to talk to the hardware, I do not remeber exactly the error message. So I gave up. 

If Jakub or someone else provides me with a working setup (xorg.conf + *.fdi) for cz_qwerty then maybe I try once again, otherwise ... sorry.

After summing up all of this, I think now I maybe understand what was mentioned somewhere and what I did not undertand before. Probably we need to set INPUT_DEVICES="evdev" in make.conf or somewhere else, it was somewhere along a note about "hotplug" which has to be turned on ...

maybe I should have played more with the stuff in and with the stuff in
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2008-01-22 20:45:45 UTC
(In reply to comment #19)
> If Jakub or someone else provides me with a working setup (xorg.conf + *.fdi)
> for cz_qwerty then maybe I try once again, otherwise ... sorry.

Well, the working setup (for me :P) is this:

- NO "InputDevice" section in xorg.conf at all - IMPORTANT!!!

Section "ServerFlags"
    Option "AllowEmptyInput" "yes"

$ cat /etc/hal/fdi/policy/use-multiple-layouts.fdi 
<?xml version="1.0" encoding="utf-8"?>
    Identifier "Logitech Internet Keyboard"
    Option     "XkbLayout"     "us,cz"
    Option     "XkbVariant"    ",qwerty"
    Option     "XkbOptions"    "grp:alt_shift_toggle,grp_led:scroll,caps:shift_nocancel"
<deviceinfo version="0.2">
   <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us,cz</merge>
      <merge key="input.xkb.variant" type="string">,qwerty</merge>
      <merge key="input.xkb.options" type="strlist">grp:alt_shift_toggle</merge>
      <append key="input.xkb.options" type="strlist">grp_led:scroll</append>
      <append key="input.xkb.options" type="strlist">caps:shift_nocancel</append>

Good luck. :)
Comment 21 Martin Mokrejš 2008-02-06 13:38:09 UTC
Created attachment 142823 [details]
xorg.conf (working)

Thanks to Jakub, this works here in conjuction with /etc/hal/fdi/policy/use-multiple-layouts.fdi from and xorg-server-, app-misc/hal-info-20071030, sys-apps/hal-0.5.10.
Comment 22 Martin Mokrejš 2008-02-06 13:40:49 UTC
And while things work I have:

$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete+caps(shift_nocancel)" };
        xkb_compat    { include "complete+ledscroll(group_lock)"        };
        xkb_symbols   { include "pc+us+inet(evdev)+cz(qwerty):2+group(alt_shift_toggle)"        };
        xkb_geometry  { include "pc(pc104)"     };
$ ;+ěščřžýáíé=
$ qwertyuiopú)
$ `1234567890-=\
$ qwertyuiop[]