Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194515 - x11-base/xorg-server-1.4-r2 crashes without explicit error.
Summary: x11-base/xorg-server-1.4-r2 crashes without explicit error.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 210710
  Show dependency tree
 
Reported: 2007-10-02 14:56 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2009-05-06 22:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/emerge--info (emerge--info,8.85 KB, text/plain)
2007-10-02 14:56 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.1.log (Xorg.1.log,19.48 KB, text/plain)
2007-10-02 14:57 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/etc/X11/xorg.conf (xorg.conf,33.95 KB, text/plain)
2007-10-02 15:10 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.0.log (Xorg.0.log,86.16 KB, text/plain)
2007-10-02 15:15 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.1.log (Xorg.1.log,19.52 KB, text/plain)
2007-10-02 15:22 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/etc/X11/xorg.conf (xorg.conf,34.85 KB, text/plain)
2008-01-04 20:09 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.1.log (Xorg.1.log,64.29 KB, text/plain)
2008-01-04 20:11 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.0.log (Xorg.0.log,68.99 KB, text/plain)
2008-01-04 20:14 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
xorg.conf to make it crash easily (xorg.conf_noEE,26.28 KB, text/plain)
2008-01-05 04:54 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.0.log_noEE_crash (Xorg.0.log_noEE_crash,19.05 KB, text/plain)
2008-01-05 04:55 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/Xorg.0.log_noEE_works (Xorg.0.log_noEE_works,63.06 KB, text/plain)
2008-01-05 04:56 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 14:56:06 UTC
I report here an error I already described briefle in bug 192254 . This may be linked with bug 194503 and bug 194506

Fact is: X crashes, and prints this very simplist message:

Fatal server error:
Requested Entity already in use!

*** *** *** console

root@moon_gen_2:~# xinit -- :1


X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.22-gentoo-r8-Gentoo-moon_20 i686
Current Operating System: Linux moon_gen_2 2.6.22-gentoo-r8-Gentoo-moon_20 #1 PREEMPT Fri Sep 28 03:54:45 CEST 2007 i686
Build Date: 02 October 2007  02:32:43PM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Oct  2 16:44:00 2007
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ddc" already built-in

Fatal server error:
Requested Entity already in use!

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.

*** *** ***

I consider this as a big problem for the following reason: error message is not explicit at all. Worse:

root@moon_gen_2:~# cat /var/log/Xorg.1.log |grep EE
Current Operating System: Linux moon_gen_2 2.6.22-gentoo-r8-Gentoo-moon_20 #1 PREEMPT Fri Sep 28 03:54:45 CEST 2007 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
root@moon_gen_2:~#

=> X crashes without finding any problem. I can understand X crashes; but it's the first time in 8 years it crashes and log does not contain any line starting with "(EE)"*

I could understand X has troubles; but I can not accept it bugs, and does not properly explain whats the problem.

Due to bug 194506 I can not recompile all modules yet. Still, just after upgrading to 1.4, X bugged, and complained about evdev driver; so, if there is any problem with LinuxWacom, I would expect X to report about it the same way.

So, any way: I can not rebuild all modules (LinuxWacom fails), X does not start. I ask for hard mask again. Please mask x11-base/xorg-server-1.4-r2 ASAP, because it does not let me have a consistent/working system.

(more tests & logs coming soon).
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 14:56:28 UTC
Created attachment 132394 [details]
/tmp/emerge--info
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 14:57:56 UTC
Created attachment 132395 [details]
/var/log/Xorg.1.log

xinit -- :1
usually works fine; last time it did not work, killing current X and run just "xinit" did not help any way (and I did not have any X left until I recompile it all, what took a few hours; so, I am not to kill my actual X ATM)
Comment 3 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 15:00:37 UTC
Please note that ... linuxwacom came out because it's mentionned as a dep of my world; actually, it is not used/called in /etc/X11/xorg.conf . So, fact driver "may" be broken (or not) should NOT prevent X to start, since my conf does NOT ask to load this driver.

=> X just bugs, and this is not related to bug 194506
Comment 4 Marijn Schouten (RETIRED) gentoo-dev 2007-10-02 15:02:14 UTC
(In reply to comment #0)
> Fatal server error:
> Requested Entity already in use!

Are you using dual head? Where is your xorg.conf?
Comment 5 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 15:10:24 UTC
Created attachment 132397 [details]
/etc/X11/xorg.conf

Sorry, I did not really thought it was important, but it *is*. Not dual-head like some people do; it's true xinerama, 5 screens (1 dual AGP, and 3 PCI cards). X-1.3 works very fine. If bug is not fiexed tonight, I will have to keep machine on over night. If it's not fixed tomorrow, I will downgrade so that I can shutdown, and start X next day, as I did for x11-base/xorg-server-1.4-r1 .
Comment 6 Marijn Schouten (RETIRED) gentoo-dev 2007-10-02 15:13:36 UTC
Please try adding to your xorg.conf:

Section "Extensions"
        Option "Composite" "false"
EndSection
Comment 7 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 15:15:14 UTC
Created attachment 132399 [details]
/var/log/Xorg.0.log

Just for fun, I give you X.0 log, so that you can see how it looks like when it works, and compare. I sware that with X 1.3 I can run two X at a time using xinit -- :1 . And I am 100% sure that closing actual X:0 would not help (it would just kill a working cession, and block me access to this BTS).
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 15:22:11 UTC
Created attachment 132400 [details]
/var/log/Xorg.1.log

(In reply to comment #6)
> Please try adding to your xorg.conf:

actually, this section already exists; just had to uncomment it ... and turn true into false.

Result is ... identical

*** *** *** *** *** ***

root@moon_gen_2:~# xinit -- :1

X.Org X Server 1.4.0
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.22-gentoo-r8-Gentoo-moon_20 i686
Current Operating System: Linux moon_gen_2 2.6.22-gentoo-r8-Gentoo-moon_20 #1 PREEMPT Fri Sep 28 03:54:45 CEST 2007 i686
Build Date: 02 October 2007  02:32:43PM

        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Oct  2 17:20:24 2007
(==) Using config file: "/etc/X11/xorg.conf"

(II) Module "ddc" already built-in

Fatal server error:
Requested Entity already in use!

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
root@moon_gen_2:~#
Comment 9 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-15 16:05:47 UTC
still true with 1.4.0.90
Comment 10 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-20 19:42:31 UTC
(In reply to comment #6)
> Please try adding to your xorg.conf:
> 
> Section "Extensions"
>         Option "Composite" "false"
> EndSection
> 

Tried again; same problem.
Comment 11 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-25 15:15:30 UTC
http://wiki.debian.org/XStrikeForce/HowToRandR12

Maygbe the problem is about my multi-head system ... maybe X-1.4 is more senble to Randr bugs than 1.3 ...

But I am really too lazy to perform all required tests about this. It would take 1h to remove my cards, set up a system that I could use for a few days on single head, then, spend 6 to 8 hours recompiling everything tor X-1.4 ...  maybe for no result at all ...
Comment 12 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-04 20:08:32 UTC
Works now.

I mean ... X does not behave AT ALL like it should; I have several heavy brekages, but, since I can run X, and X keeps "up and running", this bug claming for crash is not "solved".

*** *** ***

Let'me tell you the story, for posterity:

Because of initial bug, I had to mask all these:

## all thos are problems vs xorg-server-1.4-r1
=x11-base/xorg-server-1.4-r1
=x11-base/xorg-server-1.4-r2
=x11-drivers/xf86-video-mga-1.4.7
=x11-proto/renderproto-0.9.3
=x11-libs/libXrender-0.9.4
=x11-drivers/xf86-input-keyboard-1.2.2
=x11-drivers/xf86-input-keyboard-1.2.0-r1
=x11-drivers/xf86-input-keyboard-1.2.0
=x11-base/xorg-server-1.4.0.90

So, this morning, I unmasked them.

Here are not my actual versions installed, list given with command
qlist -ICv x11-base/* x11-drivers/* x11-proto/* x11-libs/*

x11-base/xorg-server-1.4.0.90
x11-base/xorg-x11-7.3

x11-drivers/linuxwacom-0.7.8_p3
x11-drivers/synaptics-0.14.6
x11-drivers/xf86-input-evdev-1.1.5-r2
x11-drivers/xf86-input-keyboard-1.2.2
x11-drivers/xf86-input-mouse-1.2.3
x11-drivers/xf86-input-mutouch-1.1.0
x11-drivers/xf86-input-penmount-1.2.1
x11-drivers/xf86-video-fbdev-0.3.1
x11-drivers/xf86-video-mga-1.4.7
x11-drivers/xf86-video-nv-2.1.6
x11-drivers/xf86-video-s3-0.5.0
x11-drivers/xf86-video-s3virge-1.9.1
x11-drivers/xf86-video-sis-0.9.4
x11-drivers/xf86-video-tdfx-1.3.0
x11-drivers/xf86-video-tga-1.1.0
x11-drivers/xf86-video-trident-1.2.3
x11-drivers/xf86-video-v4l-0.1.1
x11-drivers/xf86-video-vesa-1.3.0
x11-drivers/xf86-video-vga-4.1.0
x11-drivers/xf86-video-via-0.2.2

x11-proto/bigreqsproto-1.0.2
x11-proto/compositeproto-0.4
x11-proto/damageproto-1.1.0
x11-proto/dmxproto-2.2.2
x11-proto/evieext-1.0.2
x11-proto/fixesproto-4.0
x11-proto/fontcacheproto-0.1.2
x11-proto/fontsproto-2.0.2
x11-proto/glproto-1.4.9
x11-proto/inputproto-1.4.2.1
x11-proto/kbproto-1.0.3
x11-proto/printproto-1.0.3
x11-proto/randrproto-1.2.1
x11-proto/recordproto-1.13.2
x11-proto/renderproto-0.9.3
x11-proto/resourceproto-1.0.2
x11-proto/scrnsaverproto-1.1.0
x11-proto/trapproto-3.4.3
x11-proto/videoproto-2.2.2
x11-proto/xcmiscproto-1.1.2
x11-proto/xextproto-7.0.2
x11-proto/xf86bigfontproto-1.1.2
x11-proto/xf86dgaproto-2.0.3
x11-proto/xf86driproto-2.0.3
x11-proto/xf86miscproto-0.9.2
x11-proto/xf86rushproto-1.1.2
x11-proto/xf86vidmodeproto-2.2.2
x11-proto/xineramaproto-1.1.2
x11-proto/xproto-7.0.10

*** *** ***

To be 100% sure everything would work fine, here is what I did, after unmasking, to fix definitively *THIS* bug:

qlist -IC x11-base/* | xargs emerge -v1 && qlist -IC x11-drivers/* | xargs emerge -v1 && qlist -IC x11-proto/* | xargs emerge -v1 && qlist -IC x11-base/* | xargs emerge -v1 && qlist -IC x11-drivers/* | xargs emerge -v1 && qlist -IC x11-proto/* | xargs emerge -v1

So, somehow, to explain the concept briefly:
for i in 1 2
  for j in x11-base x11-drivers x11-proto
    emerge -v1 $j/*
  loop
loop

It's a double compleet merge ... just in case revdep-rebuild would have miss sime things, and, to force being sure everything is compiled for the lastest everything.

*** *** ***

I now close this bug WORKSFORME.

X starts with my actual xorg.conf. But, still have several heavy breakages: the layout of xinerama is compleetely broken; second head of the MGA400 is not a replication of the first one, instead of being independent TV, and, the layout is broken (the upper screen are now virtualy at the right of screen #0 .
Comment 13 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-04 20:09:18 UTC
Created attachment 140120 [details]
/etc/X11/xorg.conf

conf of the day
Comment 14 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-04 20:11:41 UTC
Created attachment 140121 [details]
/var/log/Xorg.1.log

log when it worked as described 2mn ago. Root ran
xinit -- :1
and had E16 working, with a few mis-placed heads, for 10s (quiet enough to close this bug), and killed with shurtcuts.
Comment 15 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-04 20:14:42 UTC
Created attachment 140122 [details]
/var/log/Xorg.0.log

for referecen, I give the log of the server I am running since this morning, with the old packages (X-1.3, compiled with many things masked, as mentioned 3 or 4 comments above), still running ATM, and that produce my "normal" environment", with the same conf, and the heads where I need them.
Comment 16 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-05 04:54:34 UTC
Created attachment 140151 [details]
xorg.conf to make it crash easily

I can reproduce :)

Here is a clean configuration.

If you just uncomment Screen 3, then, you reproduce the bug explained previously. I will leave it closed. Here is lspci.

dhp@moon_gen_2:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:09.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo Banshee (rev 03)
00:0b.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2064W [Millennium] (rev 01)
00:0d.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2064W [Millennium] (rev 01)
00:0f.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 82)
Comment 17 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-05 04:55:33 UTC
Created attachment 140153 [details]
/var/log/Xorg.0.log_noEE_crash

crash as described, but for latest xorg.conf
Comment 18 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-05 04:56:19 UTC
Created attachment 140155 [details]
/var/log/Xorg.0.log_noEE_works

Log when it works fine, with latest conf.
Comment 19 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-05 05:21:29 UTC
"similar" bug open: bug #204401
Comment 20 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-05 16:15:55 UTC
Sorry I need to re-open. I Commented too fast yesterday. 

This is a REGRESSION bug.

*THIS* bug occurs when X-1.4 is asked to access two identical cards (here, two Matrox Me 2064W ). The bug does not happen when I ask X to access two elements of a G450x4 (the G450 quad is a PCI brige to a bus with four (4) ordinary G450 cards).

It is a regression because using the same xorg.conf, X-1.3 was working fine, and, keeping the conf untouched breaks usability of the machine. Worse, there is a feature regression: using two 2064W was ok before, and is now impossible.

I still ask for an urgent hard mask of all the X-1.4 bunch. I have been forced to migrate to X-1.4 because, when I was masking it, I could not emerge -DaNuv world any more, due to xorg-x11 depending on 1.4.

There are in fact two problems closely related to this report:
- X crashing without explicit message
- X crashing because I need to use two 2064W

In fact, bug #204401 explains a case where X mis-behaves, without explicit message, without crash.

Al this is due to X-1.4, broken drivers, broken X, regressions, and the impossibility to mask 1.4 and keep 1.3
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2008-01-11 10:19:36 UTC
(In reply to comment #20)
> impossibility to mask 1.4 and keep 1.3

You can mask 1.4.x perfectly fine, just stick the following to package.mask 

=x11-base/xorg-server-1.4*
>=x11-base/xorg-x11-7.3
>=x11-proto/renderproto-0.9.3
>=x11-libs/libXrender-0.9.4
>=x11-drivers/xf86-input-joystick-1.3.0
>=x11-drivers/xf86-input-evdev-1.2.0

(You might need more entires there if you have more stuff in INPUT_DEVICES and VIDEO_CARDS)
Comment 22 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 14:21:43 UTC
After bug 204401 , now come bug 210704 , that also have X feature problems without explicit message.

For history, the fatal crash that made me open this bug was linked to 2 facts:
- as reported in bug 204401 , broken second head of G400 was somehow fatal
- using two Matrox ME was always fatal with x11-base/xorg-server-1.4.0.90 and x11-drivers/xf86-video-mga-1.4.7

Bug 210704 confirms this present one in the way that ... X still does not say that it will not respect the conf file:
- head broken
- video layout sometimes not respected according to conf
- keyboard layout is wrong (defaulting to US)
- missing many keys (multimedia, Home, End ...)
- Y mouse axis broken (functions 6 and 7 are inverted, whatever I put in the conf)
and all this get broken without any real message, warning, or error (except for USB mouse that have a nice error section). Once I got 
Comment 23 Rémi Cardona gentoo-dev 2009-05-06 09:40:40 UTC
Xorg-server 1.5.3-r5 is now the latest stable version of the X server.

I have no idea if upstream still cares about the mga driver but there's been a bugfix release a few days ago.

In any case, please upgrade to 1.5.3 and don't hesitate to reopen this bug if you can still reproduce the issue.

Thanks
Comment 24 DEMAINE Benoît-Pierre, aka DoubleHP 2009-05-06 22:00:28 UTC
1.5 is even worse: Bug 267080