Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 194503 - x11-base/xorg-server-1.4-r2 ewarn message should give handy command ...
Summary: x11-base/xorg-server-1.4-r2 ewarn message should give handy command ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: Inclusion
Depends on: 194506
Blocks:
  Show dependency tree
 
Reported: 2007-10-02 13:39 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2007-12-16 09:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 13:39:43 UTC
enotice reports:

Package: xorg-server-1.4-r2
 * Users of reduced blanking now need:
 *    Option "ReducedBlanking"
 * In the relevant Monitor section(s).
 * Make sure your reduced blanking modelines are safe!
 * You must rebuild all drivers if upgrading from xorg-server 1.3
 * or earlier, because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.

It would help VERY MUCH if we were given a handy command to run; example for principle:

emerge -ep world | cut foo | grep -v bar | xargs emerge

I will try to work one and give feedback.

Without this, many users will be in big trouble doing what's proposed. Do not expect users to known how to list such thing; please provide a ready-to-use solution.

PS: cant we remove this message about reduced blanking ? I read this since months, I am bored of it ...
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 13:52:38 UTC
emerge -ep world |grep x11-drivers | cut -d "]" -f2 | cut -d " " -f2 |sed 's/x11-drivers/ =x11-drivers/' | xargs emerge -v1p 

looks nice to me

Shouldn't we add some x11-libs and x11-proto such as x11-proto/renderproto or x11-libs/libXrender ?

Dont forget to remove the "-p" thing if you like this :)

I tell you in 20mn if this is "enough" to fix whats said in the ewarn, and if X starts correctly.
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-02 14:08:54 UTC
bug 194506 blocks this because as long as I cant upgrade drivers, proposed command can not be "checked": as long as test fails, I conclude the command does not let X work again, thus, does not perform the advice given in ewarn ...

ATM, I consider my machine a unfunctionnal: X is broken.
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2007-10-14 11:16:04 UTC
I added a little bit to xorg-server-1.4-r2 to try printing the drivers. Let me know how you like it.
Comment 4 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-15 15:05:57 UTC
No, that's not <<handy>> for newbs:

root@moon_gen_2:~# ebuild x11-base/xorg-server-1.4-r2 postinst
'/root/x11-base/xorg-server-1.4-r2' does not exist.
root@moon_gen_2:~# ebuild /usr/portage/x11-base/xorg-server/xorg-server-1.4-r2.ebuild postinst

!!! Error: Invalid usage of set action.
/usr/portage/x11-base/xorg-server/xorg-server-1.4-r2.ebuild: line 526: 25608 Killed                  eselect opengl set ${OLD_IMPLEM}
 * Users of reduced blanking now need:
 *    Option "ReducedBlanking"
 * In the relevant Monitor section(s).
 * Make sure your reduced blanking modelines are safe!

 * You must rebuild all drivers if upgrading from xorg-server 1.3
 * or earlier, because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.
 * x11-drivers/linuxwacom-0.7.4_p3
 * x11-drivers/synaptics-0.14.6
 * x11-drivers/xf86-input-evdev-1.1.5-r2
 * x11-drivers/xf86-input-keyboard-1.1.1-r1
 * x11-drivers/xf86-input-mouse-1.2.2-r1
 * x11-drivers/xf86-input-mutouch-1.1.0
 * x11-drivers/xf86-input-penmount-1.2.0
 * x11-drivers/xf86-video-fbdev-0.3.1
 * x11-drivers/xf86-video-mga-1.4.6.1
 * x11-drivers/xf86-video-nv-2.1.5
 * x11-drivers/xf86-video-s3-0.5.0
 * x11-drivers/xf86-video-s3virge-1.9.1
 * x11-drivers/xf86-video-sis-0.9.3
 * x11-drivers/xf86-video-tdfx-1.3.0
 * x11-drivers/xf86-video-tga-1.1.0
 * x11-drivers/xf86-video-trident-1.2.3
 * x11-drivers/xf86-video-v4l-0.1.1
 * x11-drivers/xf86-video-vesa-1.3.0
 * x11-drivers/xf86-video-vga-4.1.0
 * x11-drivers/xf86-video-via-0.2.2
Interrupted.


As I said, read ewarns of GCC or OpenSSL, they explicitely give the command to run. Having to copy/paste a dozen of things is neither handy, nor user-friendly; it should be something as simple as
$ revdep-rebuild --library libcrypto.so.0.9.7
or
$ fix_libtool_files.sh

I proposed
emerge -ep world |grep x11-drivers | cut -d "]" -f2 | cut -d " " -f2 |sed
's/x11-drivers/ =x11-drivers/' | xargs emerge -v1p 

I understand that print_installed is safer; thus, we may end-up with something like
ewarn "To rebuild required things, run:"
ewarn "emerge -va1 " `print_installed x11-drivers/ |sed 's/\* / =/ |xargs echo -ne'` " ."
( command not tested)

if you see what I mean ...

(REOPENing)

You did not answer me about if we should also adivse to rebuild some x11-proto/ , x11-libs/ or things like media-libs/svgalib , DRM ... that may also be affected ...
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2007-10-15 19:05:45 UTC
You can't run emerge from inside emerge, that's why I put together an alternate command. But I'll see whether I can get the actual output in there -- it might get interrupted by a bunch of stars '*' though, so it's reduced to copy and paste anyhow. As for other packages, just the driver ABI was broken.
Comment 6 DEMAINE Benoît-Pierre, aka DoubleHP 2007-10-15 19:15:53 UTC
You got me wrong:

ewarn "to fix stuff run this:"
ewarn "emerge -ep world |grep x11-drivers | cut -d "]" -f2 | cut -d " " -f2 |sed
's/x11-drivers/ =x11-drivers/' | xargs emerge -v1p "

does NOT run emerge inside emerge ... 

(but actually, what I propose in #4 is bad, since I rely on sed inside an ebuild, what *IS* bad). I think you misunderstood at least one of my comms.
Comment 7 Donnie Berkholz (RETIRED) gentoo-dev 2007-10-15 20:17:03 UTC
Oh, I see. I must not have seen the ewarn in front when you mentioned emerge before. I do prefer the current way of getting packages though, as it's much faster and easier to tweak for people using pkgcore etc, and it also sticks the package names into the log. I'll change it up a bit to print without the versions so it's easier to paste into an emerge command.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-11-24 19:02:10 UTC
Why do you need versions there? Plus users completely ignore the messages anyway, so it's just mostly ebuild bloat. Stick a simple command there for the unlikely possibility that someone actually read it and be done with it.

emerge portage-utils; emerge -1 $(qlist -CI x11-drivers)

Comment 9 Donnie Berkholz (RETIRED) gentoo-dev 2007-12-14 07:59:58 UTC
Should be fixed in 1.4.0.90, please reopen if it's not.
Comment 10 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-15 15:15:56 UTC
Still not. What _I_ would have consider handy would have been:

 * You can generate a similar list at any point using this command:
 * emerge portage-utils ; qlist -I -C x11-drivers/ | xargs emerge

instead of
 * You can generate a similar list at any point using this command:
 * emerge portage-utils; qlist -I -C x11-drivers/
in xorg-server-1.4.0.90

I will explain my point one more time: the thing is that the user should have to recopy only one command line; the actual message requires the user to copy/paste all lines, that are 20 drivers on my system (should be around 6 for common usrs).

The problem is not getting a list of drivers to recompile, but, to list and recompile them in the same command. Were my previous explanations ambiguous ? Having to copy/paste more than 2 lines is NOT newbe-friendly.

The emssage should not even list installed drivers, but, only say:

 * You must rebuild all drivers if upgrading from xorg-server 1.3
 * or earlier, because the ABI changed. If you cannot start X because
 * of module version mismatch errors, this is your problem.
 * You can list and recompile them by running:
 * emerge portage-utils ; qlist -I -C x11-drivers/ | xargs emerge -v
Comment 11 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-15 15:34:56 UTC
I am sorry for typo; emerge command should in fact be:

xargs emerge -v1
Comment 12 Donnie Berkholz (RETIRED) gentoo-dev 2007-12-16 06:49:41 UTC
(In reply to comment #10)
> The problem is not getting a list of drivers to recompile, but, to list and
> recompile them in the same command. Were my previous explanations ambiguous ?
> Having to copy/paste more than 2 lines is NOT newbe-friendly.

This is Gentoo, which isn't a newbie-friendly distribution. Are we trying to be so "friendly" that we assume people don't know how to use pipes and xargs?
Comment 13 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-16 09:07:32 UTC
I am trying to automise things, so that other users wont have to "think". Nothing bores me more than having to copy/pasted dozen lines, so, if I can avoid this for friend, I will.

But since nobody else joined this bug by the mean times, it means I am the only Gentoo user thinking this way. So, let's close.

It's not a matter of helping dumb people, but a matter of not making every single user having to trick this, when the tip help could be usefull for every one.