Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 210710 - [tracker] x11-base/xorg-server-1.4 breaks behaviours without explicit message.
Summary: [tracker] x11-base/xorg-server-1.4 breaks behaviours without explicit message.
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords: Tracker
Depends on: 194515 200061 204128 204401 205041 210704
Blocks:
  Show dependency tree
 
Reported: 2008-02-19 15:22 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2010-01-21 21:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:22:44 UTC
This tracker will list bugs that are related to the fact X-1.4 does not always behave as asked in xorg.conf, and will not report problem, message, warnings properly on the log (improperly, or not at all).
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:23:17 UTC
204401 x11-base/xorg-server-1.4.0.90 does not use second G400 head and does not say why
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:23:46 UTC
210704 x11-base/xorg-server-1.4.0.90 does not use second/third/fourth G45x4 heads and does not say why
Comment 3 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:24:19 UTC
194515 x11-base/xorg-server-1.4-r2 crashes without explicit error.
Comment 4 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:26:39 UTC
200061 sys-apps/hal-0.5.10 breaks layout switching in X server via Xkb

because whatever the reason is, this is a regression problem compared to X-1.3, and X does not use asked layout !
Comment 5 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-19 15:29:32 UTC
bug 204128 x11-base/xorg-server-1.4.0.90: broken cz_qwerty layout on 'rtyuiop' keys for same reason (but here its about kbd layout)
Comment 6 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-20 17:22:21 UTC
bug 205041 : x11-drivers/xf86-input-evdev-1.2.0 breaks multi-head /multi-foot xorg layouts

Please, do not detach closed bugs from this bug; this bug is a list of reports, to help maitainers, developers, and users to get a list of problems and solutions that are linked to X not reporting problems, or lack of documentation. It should be stay open until ALL bugs are solved. Not solved in the BTS way, but fixed technically with a solution merged to portage. "upstream" is not what I call a solution nor a fix: when marked UPSTRAEM, the bug seems closed from BTS point of view, but is still alive from user point of view.
Comment 7 Rémi Cardona gentoo-dev 2009-02-27 19:09:31 UTC
Benoît,

I took a quick look at all the linked bugs and here are my suggestions :

1) Could you please update to xorg-server 1.5.3 if you haven't done so already and close bugs which have already been fixed?

2) Could you open bugs in FreeDesktop's bugzilla for all hardware-related breakage? There's only so much we can do here and filing bugs in FreeDesktop is probably your best bet to see issues fixed for good.

Thanks
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2010-01-21 21:50:07 UTC
(In reply to comment #7)
> 1) Could you please update to xorg-server 1.5.3 if you haven't done so already
> and close bugs which have already been fixed?
> 
> 2) Could you open bugs in FreeDesktop's bugzilla for all hardware-related
> breakage? There's only so much we can do here and filing bugs in FreeDesktop is
> probably your best bet to see issues fixed for good.

Details in bug #267080

X 1.7 does not help. The issues are known upstream, but nobody can point me to any proper tutorial.

https://bugs.freedesktop.org/show_bug.cgi?id=18472

I will give up with all this. And, either accept to have only one monitor working with a garbaging mouse, or maybe downgrade again to X 1.4, or stop using Linux because it just can't handle dual card conf like before. I am tired of regression bugs.