Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200061 - sys-apps/hal-0.5.10 breaks layout switching in X server via Xkb
Summary: sys-apps/hal-0.5.10 breaks layout switching in X server via Xkb
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major with 1 vote (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
: 200157 204857 205077 206625 212597 (view as bug list)
Depends on:
Blocks: 210710
  Show dependency tree
 
Reported: 2007-11-23 09:57 UTC by Andrey Melentyev
Modified: 2009-07-29 07:52 UTC (History)
27 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
use-multiple-layouts.fdi (use-multiple-layouts.fdi,4.70 KB, text/plain)
2009-03-04 12:31 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Melentyev 2007-11-23 09:57:35 UTC
I've just synced with the latest portage tree for 23.11.2007, emerge -upvD world suggested to update hal to 0.5.10. And to install two new dependencies: policykit and pm-utils which I don't really need (IMHO). But thats not the only trouble - as a Russian speaking Linux user I have to configure X for two language layouts: us and ru. Here's a part of my xorg.conf which used to work well until upgrading hal:

Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"keyboard"

    Option	"XkbModel"	"pc101"
    Option	"XkbLayout"	"us,ru"
    Option	"XkbVariant"	",winkeys"
    Option	"XkbOptions"	"grp:alt_shift_toggle,grp_led:scroll"

EndSection

After upgrading hal I cannot switch between English and Russian input anymore. Alt+shift just do nothing. If I mask the new hal and downgrade, after restarting X, layout switching works again.

Reproducible: Always

Steps to Reproduce:
1. configure X for multiple layouts
2. update hal to 0.5.10 version
3. restart X, try to switch layout

Actual Results:  
Key combo to switch input languages is not working, I'm stuck with English layoyt.

Expected Results:  
Layout should be switched successfully

# emerge --info
Portage 2.1.4_rc1 (default-linux/x86/2007.0/desktop, gcc-4.2.2, glibc-2.7-r0, 2.6.23-gentoo-r2 i686)
=================================================================
System uname: 2.6.23-gentoo-r2 i686 Intel(R) Pentium(R) M processor 1500MHz
Timestamp of tree: Fri, 23 Nov 2007 07:46:02 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86 ~x86"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant-core"
ARCH="x86"
AUTOCLEAN="yes"
CAMERAS="canon"
CBUILD="i686-pc-linux-gnu"
CCACHE_SIZE="2G"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="-v"
EMERGE_WARNING_DELAY="10"
FEATURES="autoaddcvs collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -c -t 1 -T 5 --passive-ftp ${URI} -P ${DISTDIR}"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="ftp://kos.local/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.2.2/info"
INPUT_DEVICES="mouse keyboard synaptics evdev"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
KDE_IS_PRELINKED="1"
KERNEL="linux"
LANG="ru_RU.UTF-8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LDFLAGS="-Wl,--hash-style=gnu"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LINGUAS="ru en"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j2"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.2.2/man:/etc/java-config/system-vm/man/:/usr/kde/3.5/share/man:/usr/qt/3/doc/man:/opt/opera/share/man"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.2.2:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_JABBERFROM="portage@jabber.ru:portage"
PORTAGE_ELOG_JABBERSUBJECT="Fresh elog info from portage@laptop"
PORTAGE_ELOG_JABBERTO="rikz@jabber.ru"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save jabber"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_NICENESS="19"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_TMPFS="/dev/shm"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/portage/local/layman/sunrise /usr/portage/local/layman/x11 /usr/portage/local/openchrome /usr/portage/local/overlay"
PORT_LOGDIR="/var/log/portage"
PWD="/home/rikz"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 1 -T 5 --passive-ftp ${URI} -P ${DISTDIR}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.2.2:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SANE_CONFIG_DIR="/etc/sane.d"
SBCL_HOME="/usr/lib/sbcl"
SBCL_SOURCE_ROOT="/usr/lib/sbcl/src"
SHELL="/bin/bash"
SHLVL="1"
STAGE1_USE="nptl nptlonly unicode"
SUDO_COMMAND="/bin/su"
SUDO_GID="100"
SUDO_UID="1000"
SUDO_USER="rikz"
SYNC="rsync://mirror.yandex.ru/gentoo-portage"
TERM="xterm"
USB_DEVFS_PATH="/dev/bus/usb"
USE="X a52 aac acpi alsa bash-completion beagle berkdb bitmap-fonts bluetooth bzip2 cairo cdr chardet cli cracklib crypt cscope cups dbus dga djvu dri dvd dvdr emboss encode exif exiv2 fam ffmpeg flac ftp fuse galago gdbm gif gimp glut gnome gphoto2 gpm gsf gstreamer gtk gtkhtml hal hashstyle icc iconv imagemagick inotify isdnlog javascript jpeg kdeenablefinal lcms libnotify logrotate mad midi mikmod mmap mmx mmxext mono mp3 mpeg mudflap musicbrainz ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcmcia pcre pdf png pppd python qt3 qt3support qt4 quicktime readline real reflection samba sasl scanner sdl session slang speex spell spl sqlite sqlite3 sse sse2 ssl startup-notification svg t1lib taglib tetex tiff truetype truetype-fonts type1-fonts unicode usb videos vim vim-syntax vnc vorbis wifi win32codecs x264 x86 xattr xcomposite xine xml xorg xosd xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="mouse keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="openchrome vesa via"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="openchrome vesa via"
XARGS="xargs -r"
XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share"
_="/usr/bin/emerge"
Comment 1 Dennis Schridde 2007-11-24 00:29:26 UTC
Coming from bug#200087 I can confirm this.
hal-0.5.10 / evdev-1.2.0 ignores XkbLayout completely. (Xorg.log says it is using Option "xkb_layout" "us".)
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2007-11-24 00:40:31 UTC
I believe this to be an instantiation of https://bugs.freedesktop.org/show_bug.cgi?id=13217: xserver 1.4 ignoring keyboards configured via xorg.conf
Comment 3 Doug Goldstein gentoo-dev 2007-11-24 01:56:02 UTC
Yep. You need a custom FDI file to be written for this configuration. Documentation on how to write the file has yet to be written. Please see http://blog.cardoe.com/archives/2007/11/23/hal-0510-and-things-todo-before-hitting-the-tree/ for details.
Comment 4 Andrey Melentyev 2007-11-24 11:31:47 UTC
(In reply to comment #3)
> Yep. You need a custom FDI file to be written for this configuration.
> Documentation on how to write the file has yet to be written. Please see
> http://blog.cardoe.com/archives/2007/11/23/hal-0510-and-things-todo-before-hitting-the-tree/
> for details.
> 

Hmm. Layout switching configuration with xorg.conf used to work for ages. Why can't HAL use existing preferences?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-11-24 17:51:05 UTC
(In reply to comment #3)
> Yep. You need a custom FDI file to be written for this configuration.

Pardon me, but that's supposedly a bad joke? You tell people to write some cryptic custom XML configs for their xorg.conf to be honored? May I ask WTH is this 'feature' about? How about entirely removing this major regression? 

Ugh.
Comment 6 Doug Goldstein gentoo-dev 2007-11-24 20:18:59 UTC
(In reply to comment #5)
> (In reply to comment #3)
> > Yep. You need a custom FDI file to be written for this configuration.
> 
> Pardon me, but that's supposedly a bad joke? You tell people to write some
> cryptic custom XML configs for their xorg.conf to be honored? May I ask WTH is
> this 'feature' about? How about entirely removing this major regression? 
> 
> Ugh.
> 

Your comments are neither constructive nor helpful. This is the path that the xorg-server maintainers have decided to take. They have decided to deprecate xorg.conf in favor of a HAL configuration. As they have not populated hal-info with all the data to autodetect settings for everyone, people are left with writing their own HAL FDI files currently.
Comment 7 Andrey Melentyev 2007-11-24 23:30:57 UTC
Hmm. I don't understand how my bug is related to xorg-server and its maintainers. I see only the fact that new HAL ignores my existing X.org configuration and rewrites it with its own default unusable settings. 

So here's some kind of FDI which works-for-me and allows me to switch between english and russian layouts with Alt+Shift:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<match key="info.capabilities" contains="input.keyboard">
	<merge key="input.x11_driver" type="string">keyboard</merge>
	<merge key="input.xkb.layout" type="string">us,ru</merge>
	<merge key="input.xkb.model" type="string">pc101</merge>
	<merge key="input.xkb.rules" type="string">xorg</merge>
	<merge key="input.xkb.variant" type="string">,winkeys</merge>
	<merge key="input.xkb.options" type="string">grp:alt_shift_toggle,grp_led:scroll</merge>
</match>

of course it is not universal solution, someone needs another driver or layout, but maybe someone will find it helpful. This text should be placed in some file in /etc/hal/fdi/policy/
Comment 8 Doug Goldstein gentoo-dev 2007-11-28 01:02:08 UTC
If xorg-server is going to rely on keyboard configuration to be stored in HAL and require that people write the files themselves, xorg-server should be like every other package out there (example, libgphoto2) and provide documentation on how to write configuration files since xorg.conf is not the place to configure your keyboard. Or provide some sample files.
Comment 9 Doug Goldstein gentoo-dev 2007-11-28 01:07:11 UTC
(In reply to comment #7)
> Hmm. I don't understand how my bug is related to xorg-server and its
> maintainers. I see only the fact that new HAL ignores my existing X.org
> configuration and rewrites it with its own default unusable settings. 

Incorrect. xorg-server now ignores it's own xorg.conf and expects HAL to provide it with keyboard configuration data. However, if xorg-server is going to do that, they should provide some documentation how to write these configuration files. The HAL specification merely documents a list of valid keys, but the data those keys contain is up to the xorg-server guys.
Comment 10 Petteri Räty (RETIRED) gentoo-dev 2008-01-07 02:14:19 UTC
Could you please add some elog comments about this the ebuilds so that users know the the breakage is known and can at least find the information provided here easily.
Comment 11 Petteri Räty (RETIRED) gentoo-dev 2008-01-07 02:17:30 UTC
As an alternative to fdi files I guess putting setxkbmap <layout> to ~/.xinitrc could work too. At least here setxkbmap fi works.
Comment 12 Søren Dalby Larsen 2008-01-07 07:50:16 UTC
It also makes Xorg server 1.4.0.90 ignore the specified keyboard layout (it adds my usb keyboard with evdev driver and applies us keyboard layout).
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2008-01-07 08:02:42 UTC
(In reply to comment #12)
> It also makes Xorg server 1.4.0.90 ignore the specified keyboard layout (it
> adds my usb keyboard with evdev driver and applies us keyboard layout).

Yes, as noted above, xorg-server chooses to *ignore* the configuration in xorg.conf if you enable hal. If you have no use for this kind of behind-the-scenes magic that clearly is not ready for prime time here, you can recompile xorg-server with USE="-hal" and move on. 

Also noting that unmasking this again when none of the issues at hand wrt xorg-server breakage have been addressed is a rather bad idea. :/
Comment 14 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-01-07 18:45:45 UTC
(In reply to comment #13)
> Also noting that unmasking this again when none of the issues at hand wrt
> xorg-server breakage have been addressed is a rather bad idea. :/

Even funnier when evdev keyboard works like for me - cursor up works as printscreen, page up/down etc does nothing... great!
Comment 15 Petteri Räty (RETIRED) gentoo-dev 2008-01-07 18:56:10 UTC
(In reply to comment #14)
> 
> Even funnier when evdev keyboard works like for me - cursor up works as
> printscreen, page up/down etc does nothing... great!
> 

Do you have the model set for something else than evdev? This caused similar effects for me when I accidentally switched at some point.
Comment 16 Davide Pesavento gentoo-dev 2008-01-07 19:02:48 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Also noting that unmasking this again when none of the issues at hand wrt
> > xorg-server breakage have been addressed is a rather bad idea. :/
> 
> Even funnier when evdev keyboard works like for me - cursor up works as
> printscreen, page up/down etc does nothing... great!
> 

Maybe you are experiencing bug #200060 ? Or maybe that bug and this one are just the same issue that pops up in different (funny) ways?
Anyway, I also think that unmasking hal-0.5.10 without fixing these issues was a very bad idea...
Comment 17 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-01-07 19:14:03 UTC
(In reply to comment #15)
> Do you have the model set for something else than evdev? This caused similar
> effects for me when I accidentally switched at some point.

Hm according to log it sets evdev, but it could be my KDE setting changing it (since I noticed the cursors work on kdb but not after login).

> Maybe you are experiencing bug #200060 ? Or maybe that bug and this one are
> just the same issue that pops up in different (funny) ways?

I'd say a bit different issue, but same cause.

> Anyway, I also think that unmasking hal-0.5.10 without fixing these issues was
> a very bad idea...

Me too. Well at least I hope it won't get stable before this is sorted out... 

Comment 18 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-01-07 19:31:31 UTC
(In reply to comment #17)
> Hm according to log it sets evdev, but it could be my KDE setting changing it
> (since I noticed the cursors work on kdb but not after login).

Right so it was KDE... changed layout to evdev there, and it works, layout switching via KDE also works, good. And no fdi file needed. Too bad this is per-user setting so the ebuild can't do anything except big fat warning which users will ignore anyway :)
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2008-01-07 21:34:31 UTC
*** Bug 200157 has been marked as a duplicate of this bug. ***
Comment 20 Bruno Laturner Lemes 2008-01-11 01:00:50 UTC
My keyboard config in xorg.conf is only

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

I keep it configured via KDE Control Panel, but with hal-0.5.10 that didn't work. Downgrading to hal-0.5.9-r3 works beautifully.

Please mask HAL 0.5.10 until this is fixed!
Comment 21 Bruno Laturner Lemes 2008-01-11 01:02:52 UTC
(In reply to comment #20)
> 
> I keep it configured via KDE Control Panel
>

I forgot to add: my default layout is Brazilian ABNT 2 (br, abnt2 variant)
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2008-01-11 06:47:27 UTC
(In reply to comment #20)
> Please mask HAL 0.5.10 until this is fixed!

Just stick
  
Option "AutoAddDevices" "False" 

in ServerLayout section of xorg.conf and HAL will stop messing with your keyboard.
Comment 23 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-15 09:32:25 UTC
Jakub do you have similar peaces of advices to fix mice and video card detection problems ? is your AutoAddDevices thing specific to keyboards ?
Comment 24 Andrey Melentyev 2008-01-15 10:09:29 UTC
I'm not sure, but if the only fix that we are waiting for is proper documentation for new HAL features, then maybe we should somehow merge this bug with bug #200060 ?
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2008-01-15 11:13:36 UTC
(In reply to comment #23)
> Jakub do you have similar peaces of advices to fix mice and video card
> detection problems ? is your AutoAddDevices thing specific to keyboards ?

See http://dev.gentoo.org/~compnerd/temp/hal-config-examples/; as for video card, I have no idea whether it could be even remotely related to HAL...
Comment 26 Bruno Laturner Lemes 2008-01-16 02:23:45 UTC
(In reply to comment #22)
> (...)

Thank you!



Comment 27 Jakub Moc (RETIRED) gentoo-dev 2008-01-19 11:26:20 UTC
*** Bug 206625 has been marked as a duplicate of this bug. ***
Comment 28 Thomas Bettler 2008-01-22 10:48:41 UTC
To fix this behavior, just set your KDE-keyboard-layout in KControl to "evdev managed Keyboard"

HTH for you too.
Comment 29 DEMAINE Benoît-Pierre, aka DoubleHP 2008-01-22 13:20:50 UTC
(In reply to comment #28)
> To fix this behavior, just set your KDE-keyboard-layout in KControl to "evdev
> managed Keyboard"

re-read comments 2 and 4. I had this problem too (by the time I tried to use X-1.4 ... I now reverted to 1.3 because 1.4 has too many bugs), and I wonder how you can propose us a KDE fix:
- I dont use KDE at all
- the X bug should not have a WM fix: what about non-KDE wm ? what about people who do not want wm at all ? from times to times, I need to just run X and Eterm, nothing more !

X regression bug should not have WM fix. And this is at least the 4th regression bug I found in X-1.4
Comment 30 Martin Mokrejš 2008-01-22 20:07:19 UTC
Myself have given up both hal-0.5.10 and xorg-server-1.4 series. As I have read on some debian and archlinux lists and forums, one has to use the evdev instead of kbd driver in xorg.conf and also use evdev in those .fdi files, otherwise things do not work perfectly as before (somebody posted somewhere a nice list of what exactly works and does not work in each combination). Unfortunately, I was still having problems so I gave up. For details see bug #204128.
Comment 31 Rafał Mużyło 2008-01-25 12:21:48 UTC
Please, take  a look at my comment to bug 200060, this may be the answer to comment #29.
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2008-02-21 19:54:32 UTC
*** Bug 205077 has been marked as a duplicate of this bug. ***
Comment 33 Jakub Moc (RETIRED) gentoo-dev 2008-02-21 19:56:36 UTC
*** Bug 204857 has been marked as a duplicate of this bug. ***
Comment 34 Nick Andrade 2008-02-23 20:25:50 UTC
(In reply to comment #23)
> Jakub do you have similar peaces of advices to fix mice and video card
> detection problems ? is your AutoAddDevices thing specific to keyboards ?
> 

The entry resolved my mouse issue, no clue on vid cards.  You do need a working xorg.conf as it disables ALL auto detected stuff.  Basically if your xorg.conf worked for Xorg 1.3 or prior you'll be fine, but there's a chance if you've only used Xorg 1.4, then you'll break something (easy to fix though, the system will still boot to a cli).
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2008-03-07 18:02:01 UTC
*** Bug 212597 has been marked as a duplicate of this bug. ***
Comment 36 Martin Mokrejš 2009-03-04 12:31:04 UTC
Created attachment 183879 [details]
use-multiple-layouts.fdi

Working definition under xorg-server-1.5.3. I can switch using alt+shift from us to czech keyboard layout. More info at http://lists.freedesktop.org/mailman/listinfo/xorg under thread name "[Bug 19947] xkbcomp-1.0.5: Group width mismatch between key	and type" around Feb23 2009.


From: Peter Hutterer

this is what actually is loaded in the server. You see how all your options
are missing? This is because of a wrong setup (fdi file below).

when I run setxkbmap with the settings you're presumably trying to get:
$> setxkbmap -layout "us,cz" -variant ",qwerty" -option "grp:alt_shift_toggle"\
 -option "grp_led:scroll" -option "caps:shift_nocancel" -print 
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete+caps(shift_nocancel)" };
        xkb_compat    { include "complete+ledscroll(group_lock)"        };
        xkb_symbols   { include "pc+us+cz(qwerty):2+inet(evdev)+group(alt_shift_toggle)"        };
        xkb_geometry  { include "pc(pc104)"     };
};

this command should work for you. (remove the -print option to set it and check the server log)
Comment 37 Gilles Dartiguelongue gentoo-dev 2009-07-28 22:55:18 UTC
what's the status on this bug ?
Comment 38 Rémi Cardona gentoo-dev 2009-07-29 07:52:15 UTC
Layout switching works correctly with xorg-server 1.5.3 with evdev (probably even keyboard as well).

If this is not the case, please don't hesitate to reopen this bug with updated information.

Thanks