Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 173467 (tcltk-8.5) - [Tracker] dev-lang/{tcl,tk}-8.5 incompatible packages
Summary: [Tracker] dev-lang/{tcl,tk}-8.5 incompatible packages
Status: RESOLVED FIXED
Alias: tcltk-8.5
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: TCL/TK Project
URL: http://www.tcl.tk/software/tcltk/8.5....
Whiteboard:
Keywords: Tracker
: 206811 (view as bug list)
Depends on: 173542 177912 181524 181526 195451 200477 201021 203523 204524 210765 212676 212678 212682 212700 212705 212711 212936 213028 213504 213852 232945 246774 246950 247197 247210 247330 249468 249479 250029 250354 250368 250400 271307 281148
Blocks: 280845
  Show dependency tree
 
Reported: 2007-04-05 14:28 UTC by David Girault
Modified: 2009-08-10 15:55 UTC (History)
49 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Tcl 8.5a5 ebuild (tcl-8.5_pre5.ebuild,3.29 KB, text/plain)
2007-04-05 14:28 UTC, David Girault
Details
Tk 8.5a5 ebuild (tk-8.5_pre5.ebuild,2.88 KB, text/plain)
2007-04-05 14:31 UTC, David Girault
Details
list of apps w/ tcl and/or tk deps for testing (tcltk-list.txt,6.03 KB, text/plain)
2008-03-08 18:30 UTC, Jakub Moc (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Girault 2007-04-05 14:28:03 UTC
New development release of Tcl/Tk add support for nice features.
It should be added to portage to allow testing it and to use aMsn with anti-aliased fonts. ;-)

Reproducible: Always
Comment 1 David Girault 2007-04-05 14:28:59 UTC
Created attachment 115507 [details]
Tcl 8.5a5 ebuild
Comment 2 David Girault 2007-04-05 14:31:04 UTC
Created attachment 115508 [details]
Tk 8.5a5 ebuild
Comment 3 David Girault 2007-04-05 14:34:59 UTC
Save attached ebuild in 
- dev-lang/tcl/tcl-8.5_pre5.ebuild
- dev-lang/tk/tk-8.5_pre5.ebuild

To add anti-aliased font support, add "xft" use flag in /etc/portage/package.use for the "dev-lang/tk" package.
Comment 4 David Girault 2007-04-06 09:02:29 UTC
Using this version for aMsn work very well but dev-tcltk/tls need to be patched to be detected by aMsn. Look at bug #173542.
Comment 5 Pacho Ramos gentoo-dev 2007-04-22 18:58:58 UTC
I also think that it should be added and marked as HardMasked for testing ;-)

Thanks a lot :-)
Comment 6 Evan 2007-05-24 03:53:36 UTC
is it supported on amd64 system?

I saw "KEYWORDS="x86"" in ebuild.

Thanks a lot.
Evan
Comment 7 MATSUU Takuto (RETIRED) gentoo-dev 2007-07-20 18:41:13 UTC
8.5a6 in cvs.
Comment 8 MATSUU Takuto (RETIRED) gentoo-dev 2007-07-20 18:45:17 UTC
with package.mask
Comment 9 Pacho Ramos gentoo-dev 2007-07-24 09:13:37 UTC
Why "xft" has been dropped from tk?

Thanks for information :-)
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 11:59:40 UTC
Reopening this bug as there's loads of packages that fail with Tcl/Tk 8.5; unmasking this thing hasn't been one of the best ideas around...
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 12:48:32 UTC
*** Bug 206811 has been marked as a duplicate of this bug. ***
Comment 12 MATSUU Takuto (RETIRED) gentoo-dev 2008-03-08 16:14:41 UTC
sorry. MATSUU IS TOO STUPID.

remasked now.
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 17:24:39 UTC
Sooo, to prevent more kabooms like this... The following apps have dependency on dev-lang/tcl - maintainers please verify and fix/file separate bugs blocking this one in case they don't compile/work with dev-lang/tcl-8.5.x or note that they do work here:

app-accessibility/brltty - williamh/accessibility
app-admin/moodss - tcltk
app-cdr/tkdvd - tcltk
app-crypt/mit-krb5 - kerberos
app-dicts/wordnet - app-dicts
app-emulation/frodo - maintainer-needed
app-emulation/systemsim-cell - corsair/ppc64
app-misc/tkpasman - maintainer-needed
app-mobilephone/obexftp - mrness/mobile-phone
app-office/ical - maintainer-needed (Bug 212705)
app-pda/pilot-link - pda
app-text/tkman - maintainer-needed
dev-ada/tash - ada
dev-db/metakit - maintainer-needed
dev-db/pgaccess - pgsql-bugs
dev-db/postgresql  - pgsql-bugs
dev-db/sqlite - betelgeuse
dev-java/jacl - java
dev-lang/mercury-extras - keri
dev-lang/mozart - keri
dev-lang/R - sci
dev-lang/swig - hkbst/scheme
dev-libs/liboop - maintainer-needed
dev-libs/newt - xmerlin (Bug 212676)
dev-libs/redland-bindings - sound
dev-libs/xapian-bindings - python
dev-libs/yaz - robbat2
dev-ml/lablgl - ml (Bug 212678)
dev-tcltk/bwidget - tcltk
dev-tcltk/expect - tcltk (Bug 200477)
dev-tcltk/mysqltcl - mysql-bugs
dev-tcltk/otcl - tcltk
dev-tcltk/snack - tcltk
dev-tcltk/snack - tcltk
dev-tcltk/tclcl - tcltk 
dev-tcltk/tcl-debug - tcltk
dev-tcltk/tcldom - tcltk
dev-tcltk/tclgpgme - tcltk (Bug 201021)
dev-tcltk/tcl-gtk - tcltk
dev-tcltk/tcllib - tcltk
dev-tcltk/tcl-mccp - tcltk
dev-tcltk/tclperl - tcltk
dev-tcltk/tclpython - tcltk
dev-tcltk/tclreadline - tcltk
dev-tcltk/tcl-sql - tcltk
dev-tcltk/tclx - jokey/tcltk
dev-tcltk/tclxml-expat - tcltk
dev-tcltk/tclxml - tcltk
dev-tcltk/tdom - tcltk
dev-tcltk/thread - tcltk
dev-tcltk/tkTheme - tcltk (Bug 177912)
dev-tcltk/Tk_Theme - tcltk (Bug 177912)
dev-tcltk/tkXwin - tcltk
media-sound/rat - sound
kuba@notorcomp /tmp $ cat foo1 
app-accessibility/brltty - williamh/accessibility
app-admin/moodss - tcltk
app-cdr/tkdvd - tcltk
app-crypt/mit-krb5 - kerberos
app-dicts/wordnet - app-dicts
app-emulation/frodo - maintainer-needed
app-emulation/systemsim-cell - corsair/ppc64
app-misc/tkpasman - maintainer-needed
app-mobilephone/obexftp - mrness/mobile-phone
app-office/ical - maintainer-needed (Bug 212705)
app-pda/pilot-link - pda
app-text/tkman - maintainer-needed
dev-ada/tash - ada
dev-db/metakit - maintainer-needed
dev-db/pgaccess - pgsql-bugs
dev-db/postgresql  - pgsql-bugs
dev-db/sqlite - betelgeuse
dev-java/jacl - java
dev-lang/mercury-extras - keri
dev-lang/mozart - keri
dev-lang/R - sci
dev-lang/swig - hkbst/scheme
dev-libs/liboop - maintainer-needed
dev-libs/newt - xmerlin (Bug 212676)
dev-libs/redland-bindings - sound
dev-libs/xapian-bindings - python
dev-libs/yaz - robbat2
dev-ml/lablgl - ml (Bug 212678)
dev-tcltk/bwidget - tcltk
dev-tcltk/expect - tcltk (Bug 200477)
dev-tcltk/mysqltcl - mysql-bugs
dev-tcltk/otcl - tcltk
dev-tcltk/snack - tcltk
dev-tcltk/snack - tcltk
dev-tcltk/tclcl - tcltk 
dev-tcltk/tcl-debug - tcltk
dev-tcltk/tcldom - tcltk
dev-tcltk/tclgpgme - tcltk (Bug 201021)
dev-tcltk/tcl-gtk - tcltk
dev-tcltk/tcllib - tcltk
dev-tcltk/tcl-mccp - tcltk
dev-tcltk/tclperl - tcltk
dev-tcltk/tclpython - tcltk
dev-tcltk/tclreadline - tcltk
dev-tcltk/tcl-sql - tcltk
dev-tcltk/tclx - jokey/tcltk
dev-tcltk/tclxml-expat - tcltk
dev-tcltk/tclxml - tcltk
dev-tcltk/tdom - tcltk
dev-tcltk/thread - tcltk
dev-tcltk/tkTheme - tcltk (Bug 177912)
dev-tcltk/Tk_Theme - tcltk (Bug 177912)
dev-tcltk/tkXwin - tcltk
dev-tcltk/tls - tcltk
dev-util/dejagnu - toolchain
dev-util/dirdiff - tgall
dev-util/redet - jmglov
dev-util/visual-regexp - maintainer-needed
games-action/extreme-tuxracer - games
games-arcade/jumpnbump - games
games-arcade/koules - games
games-arcade/ppracer - games
games-emulation/openmsx - games
games-emulation/openmsx - games
games-mud/gMOO - games
games-mud/tkmoo - games
games-mud/trebuchet - games
games-roguelike/zangband - games
games-simulation/planets - games
games-sports/gracer - games
games-strategy/xbattleai - games
games-strategy/xconq - games
mail-client/exmh - net-mail
media-gfx/graphviz - graphics (Bug 181526)
media-libs/hamlib - maintainer-needed
media-libs/pdflib - php
media-radio/svxlink - pylon
media-sound/rat - sound
media-sound/tk707 - sound
media-sound/waif - sound
media-tv/nxtvepg - pylon,dev-zero/media-tv (Bug 212682_
net-analyzer/barnyard netmon
net-analyzer/hping - netmon
net-analyzer/nam anant/netmon
net-analyzer/ns - anant/netmon
net-analyzer/rrdtool - netmon
net-analyzer/sguil-client - strerror/netmon
net-analyzer/sguil-sensor - strerror/netmon
net-analyzer/ttt - netmon
net-dialup/isdn4k-utils - sbriesen/net-dialup
net-dialup/vbox3 - net-dialup
net-im/amsn - net-im
net-im/ccmsn - net-im
net-im/climm jokey/net-im
net-im/kadu - cla/net-im
net-im/pidgin - net-im
net-im/tkabber - net-im
net-irc/eggdrop - net-irc
net-irc/epic5 - net-irc
net-irc/quirc - net-irc
net-irc/savirc - net-irc
net-irc/xchat-gnome - net-irc
net-irc/xchat - net-irc
net-misc/suite3270 - robbat2
net-misc/tkusr - maintainer-needed
net-nntp/brag - maintainer-needed
sci-chemistry/ccp4 - sci-chemistry
sci-chemistry/gopenmol  - sci-chemistry
sci-chemistry/namd  - sci-chemistry
sci-chemistry/nmrpipe  - sci-chemistry
sci-chemistry/vmd  - sci-chemistry
sci-electronics/lard - sci-electronics
sci-electronics/magic - sci-electronics
sci-electronics/magic - sci-electronics
sci-geosciences/grass - nerdboy/sci-geosciences
sci-geosciences/mapserver - sci-geosciences
sci-libs/vtk - markusle/java,sci (Bug 212700 
sci-mathematics/scilab - sci-mathematics
sci-visualization/paraview - markusle/sci
sys-cluster/xpvm tantive/hp-cluster
sys-fs/hfsutils - ppc
sys-fs/owfs - wschlich
sys-libs/db - caleb/pauldv
sys-libs/openipmi - robbat2
www-apache/mod_tcl - apache
x11-drivers/linuxwacom - ikelos,rbu
x11-misc/lavaps - desktop-misc
Comment 14 Ferris McCormick (RETIRED) gentoo-dev 2008-03-08 18:07:55 UTC
It does not seem to be able to build otcl?
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 18:17:33 UTC
Additionally, the following needs testing with dev-lang/tk-8.5.x.

app-admin/setools - hardened
app-dicts/bookview - cjk
app-laptop/i8kutils - tester
app-text/catdoc - tex 
app-text/ding - tove
app-text/gocr - tex 
app-text/namazu - hattya/cjk
app-text/tkinfo - maintainer-needed
app-text/tkman - maintainer-needed
app-text/txt2tags - sgml 
app-text/uudeview  - maintainer-needed 
dev-lang/caml-light - ml
dev-lang/entity - maintainer-needed
dev-lang/erlang - opfer/lang-misc
dev-lang/gnu-smalltalk - araujo
dev-lang/ocaml - ml
dev-lang/python - python
dev-lang/ruby - ruby
dev-lang/yap - prolog
dev-lisp/cl-lisp2wish - common-lisp
dev-lisp/cl-ltk - common-lisp
dev-lisp/gcl - common-lisp
dev-lisp/gcl-cvs - common-lisp
dev-python/editobj - python
dev-python/imaging - python
dev-python/pylint - python
dev-python/pythong - python
dev-tcltk/blt - tcltk
dev-tcltk/ck - tcltk
dev-tcltk/itk - tcltk
dev-tcltk/otcl - tcltk
dev-tcltk/snack - tcltk
dev-tcltk/tix - tcltk
dev-tcltk/tkdiff - tcltk
dev-tcltk/tkpiechart - tcltk
dev-tcltk/tktable - tcltk
dev-tcltk/tkzinc - tcltk
dev-tcltk/vtcl - tcltk
dev-util/aegis - maintainer-needed
dev-util/git - ferdy/robbat2
dev-util/tkcvs - tcltk
games-board/chessdb - games
games-board/pysol - games
games-board/scid - games
games-mud/mmucl - games
games-puzzle/penguzzle - games
games-strategy/xbattleai - games
media-gfx/skencil - hanno
media-sound/timidity++ - sound
media-sound/vkeybd - sound
net-analyzer/cnet - netmon
net-analyzer/netwag - netmon
net-analyzer/nsat - netmon 
net-dialup/globespan-adsl - nerdboy/net-dialup
net-dialup/rp-pppoe - net-dialup
net-dialup/tkvoice - net-dialup
net-im/ccmsn - net-im
net-im/coccinella - bass
net-misc/secpanel - maintainer-needed 
sci-chemistry/pymol - sci-chemistry
sci-chemistry/sparky - sci-chemistry
sci-electronics/gnetman - sci-electronics
sci-electronics/pcb  - sci-electronics
sci-electronics/xcircuit - sci-electronics
sci-libs/plplot - cryos/sci
sci-mathematics/maxima  - sci-mathematics
sci-misc/gato - sci-mathematics
sys-cluster/torque - hp-cluster
sys-cluster/xpvm - tantive/hp-cluster
x11-misc/accessx - desktop-misc
x11-misc/remind - tove/desktop-misc
x11-misc/tkhylafax - nerdboy
x11-misc/xbindkeys - desktop-misc
x11-wm/fvwm - desktop-wm
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 18:30:41 UTC
Created attachment 145588 [details]
list of apps w/ tcl and/or tk deps for testing

Looks like the list got somehow partially duplicated when pasting on the above comments, so here's one as attachment instead.
Comment 17 Alexis Ballier gentoo-dev 2008-03-09 12:08:25 UTC
dev-lang/ocaml fixed (didnt fail but didnt build tk support)
dev-ml/lablgl fixed
dev-lang/caml-light deserves a last rite due to bug #206138
Comment 18 Draco Levanah 2008-03-09 14:32:36 UTC
Hello, good day, i have recompiled successfully the following packages that use tcl and/or tk:
=app-mobilephone/obexftp-0.22_rc9
=app-crypt/mit-krb5-1.5.3-r1
=dev-db/postgresql-8.2.6
=dev-db/sqlite-3.5.6
=dev-db/sqlite-2.8.16-r4
=net-irc/xchat-2.8.4-r3
=media-libs/pdflib-7.0.2_p8
=sys-libs/db-4.3.29-r2
=sys-libs/db-4.2.52_p4-r2
=sys-libs/db-4.5.20_p2
=net-im/pidgin-2.4.0
=dev-java/bsf-2.4.0-r1
=dev-lang/swig-1.3.34
=sys-fs/hfsutils-3.2.6-r5
=net-analyzer/rrdtool-1.2.27
=dev-tcltk/tls-1.5.0-r1
=app-text/gocr-0.45
=media-gfx/graphviz-2.16.1-r3
=net-im/pidgin-2.4.0
=dev-lang/python-2.5.1-r5
=dev-lang/ruby-1.8.6_p114
=dev-lang/erlang-12.2.1
=dev-lang/swig-1.3.34
=dev-lisp/gcl-2.6.7-r3
=dev-util/git-1.5.4.3
=dev-python/pyopengl-3.0.0_beta1
=dev-python/imaging-1.1.6
=sys-fs/hfsutils-3.2.6-r5
=media-sound/timidity++-2.13.2-r6

The package =media-gfx/graphviz-2.16.1-r3 send me an error about that autoconf could not be run, so i don't know if it actually can be compiled without errors with tcl/tk, but the other ones compiled.
Comment 19 Alexis Ballier gentoo-dev 2008-03-09 14:59:29 UTC
(In reply to comment #15)
> app-text/catdoc - tex 
> app-text/gocr - tex 

both fine
Comment 20 Markus Dittrich (RETIRED) gentoo-dev 2008-03-09 15:29:41 UTC
> sci-libs/vtk - markusle/java,sci (Bug 212700)

patched and should work now.

> sci-mathematics/scilab - sci-mathematics

builds fine as is.

Thanks,
Markus
Comment 21 William Hubbs gentoo-dev 2008-03-09 19:09:49 UTC
app-accessibility/brltty builds as is.

Thanks,

William

Comment 22 Dawid Węgliński (RETIRED) gentoo-dev 2008-03-10 09:23:00 UTC
net-im/kadu-0.4.3 will be removed from the tree as soon as i bump it to 0.6.0

Cheers,
Dawid
Comment 23 Markus Dittrich (RETIRED) gentoo-dev 2008-03-10 13:19:20 UTC
> sci-visualization/paraview
> sci-chemistry/namd

These seem to be fine!

Best,
Markus
Comment 24 Luis Araujo (RETIRED) gentoo-dev 2008-03-10 18:10:15 UTC
dev-lang/gnu-smalltalk works perfectly fine.

So, feel free to remove it from the list.
Comment 25 Sébastien Fabbro (RETIRED) gentoo-dev 2008-03-10 19:50:31 UTC
dev-lang/R
sci-mathematics/maxima

build fine as is.
Comment 26 Anant Narayanan (RETIRED) gentoo-dev 2008-03-11 11:53:15 UTC
(In reply to comment #14)
> It does not seem to be able to build otcl?

Can't fix ns/nam without otcl, hence I'll wait for bug #213028

Comment 27 Keri Harris gentoo-dev 2008-03-12 06:39:16 UTC
The following are ok:

dev-lang/mercury-extras
dev-lang/mozart
dev-lang/yap
Comment 28 Denis Dupeyron gentoo-dev 2008-03-15 17:26:06 UTC
(In reply to comment #13)
> sci-electronics/lard - sci-electronics

Masked for removal in 30 days. See bug #172356.

Denis.
Comment 29 Markus Ullmann (RETIRED) gentoo-dev 2008-03-17 16:42:32 UTC
dev-tcltk/tclx works fine
Comment 30 Denis Dupeyron gentoo-dev 2008-03-18 18:53:17 UTC
sci-electronics/gnetman OK

sci-electronics/pcb OK

sci-electronics/xcircuit not OK, see bug #213852

sci-electronics/magic not OK, same symptoms as xcircuit (same author) and blocked by bug #212711.

Denis.
Comment 31 Benedikt Böhm (RETIRED) gentoo-dev 2008-03-22 17:03:51 UTC
www-apache/mod_tcl is fine
Comment 32 Chris PeBenito (RETIRED) gentoo-dev 2008-03-31 23:27:52 UTC
setools all set.
Comment 33 George Shapovalov (RETIRED) gentoo-dev 2008-04-03 15:28:14 UTC
Actually dev-ada/tash has =dev-lang/tcl-8.4* (same for tk) in DEPEND, this should not have even be mentioned here. Also, this is a low profile package, so I'd rather do proper bumping/testing when new version of tash is released.
Comment 34 Markus Rothe (RETIRED) gentoo-dev 2008-04-03 16:39:47 UTC
app-emulation/systemsim-cell now depends on =tcl/tk-8.4*. I've asked upstrem if they could release a version for 8.5, but they did not yet respond.
Comment 35 Alin Năstac (RETIRED) gentoo-dev 2008-06-08 00:22:22 UTC
app-mobile/obexftp should be ok.
Comment 36 Michael Hammer (RETIRED) gentoo-dev 2008-09-11 12:25:37 UTC
kerberos do no longer depend on tcl.
Comment 37 sargun dhillon 2008-09-22 23:05:14 UTC
ClusterSSH does not work with 8.5!
Comment 38 Akinori Hattori gentoo-dev 2008-09-23 07:03:11 UTC
app-text/namazu should be ok.
Comment 39 Markos Chandras (RETIRED) gentoo-dev 2008-11-09 11:00:09 UTC
Do we have any updates on that? Are these packages going to be marked as ~arch soon ?
Comment 40 Santiago M. Mola (RETIRED) gentoo-dev 2008-11-15 16:14:11 UTC
This bug being more than one year old, I'd be inclined to unmask {tcl,tk}-8.5 so it can get wider testing and eventually stabilized.

@Matsuu, mescalinum, what do you think?
Comment 41 Mark Loeser (RETIRED) gentoo-dev 2008-11-15 20:24:54 UTC
dejagnu seems fine
Comment 42 jannis 2008-12-07 10:41:52 UTC
dev-tcltk/mysqltcl-3.02 compiles fines and gets loaded on "package require". No function test made, though
Comment 43 Peter Volkov (RETIRED) gentoo-dev 2008-12-11 11:18:16 UTC
I've checked all packages mentioned here and opened new bugs for those that are broken with blocker on this bug. So I don't see any need for herds to be CC'ed here anymore. But, please, unCC yourself since I don't know why you are here.

Below is summary of my semi-manual tests:

Packages that force 8.4:
dev-libs/newt
media-sound/rat
sci-chemistry/gopenmol
sci-chemistry/sparky

Removed or pending remove (package.mased):
dev-lang/entity in package.mask: # Abandonware. Masked for removal.
dev-tcltk/Tk_Theme Macked for removal, bug 177912
media-sound/waif Treecleaner bug filed: bug 249244
dev-tcltk/tclgpgme Masked for removal (31 Aug 2008)
net-im/ccmsn - already removed
dev-lisp/gcl-cvs - already removed

Don't depend on tcl/tk now:
app-pda/pilot-link comment inside ebuild: # tcl/tk support is disabled as per upstream request.
net-dialup/isdn4k-utils Doesn't use tcl? bug 249311
dev-libs/redland-bindings-1.0.8.1 does now have tcl binding any more...
dev-libs/xapian-bindings Build pass but bindings are not installed bug 247228


Success - installs and pass some basic manual tests:
sys-cluster/xpvm : has unrelated to tcl/tk problems: bug 250261 , but builds with 8.5
app-cdr/tkdvd
app-dicts/wordnet
app-emulation/frodo
app-misc/tkpasman
app-text/tkman
dev-db/metakit
dev-java/jacl
dev-libs/liboop
dev-libs/yaz
dev-tcltk/bwidget
dev-tcltk/expect
dev-tcltk/mysqltcl
dev-tcltk/snack
dev-tcltk/tcldom
dev-tcltk/tcl-gtk
dev-tcltk/tcllib
dev-tcltk/tcl-mccp
dev-tcltk/tclperl
dev-tcltk/tclxml-expat
dev-tcltk/tclxml
dev-tcltk/tdom
dev-tcltk/tkTheme
dev-tcltk/tkXwin
dev-util/dejagnu
dev-util/dirdiff
dev-util/visual-regexp
games-action/extreme-tuxracer
games-arcade/jumpnbump
games-arcade/koules
games-arcade/ppracer
games-emulation/openmsx
games-mud/gMOO
games-mud/tkmoo
games-mud/trebuchet
games-roguelike/zangband
games-simulation/planets
games-sports/gracer
games-strategy/xbattleai
games-strategy/xconq
mail-client/exmh
media-libs/hamlib
media-radio/svxlink
media-sound/tk707
media-tv/nxtvepg
net-analyzer/barnyard
net-analyzer/sguil-sensor
net-dialup/vbox3
net-im/amsn
net-im/climm
net-im/tkabber
net-irc/eggdrop
net-irc/savirc
net-irc/xchat-gnome
net-misc/tkusr
net-nntp/brag
sci-chemistry/vmd
sci-geosciences/grass
sys-fs/owfs
sys-libs/openipmi
x11-drivers/linuxwacom
x11-misc/lavaps
app-dicts/bookview
app-laptop/i8kutils
app-text/ding
app-text/tkinfo
app-text/txt2tags
app-text/uudeview
dev-lisp/cl-lisp2wish
dev-lisp/cl-ltk
dev-python/editobj
dev-python/pylint
dev-tcltk/blt
dev-tcltk/ck
dev-tcltk/tkdiff
dev-tcltk/tkpiechart
dev-tcltk/tktable
dev-tcltk/tkzinc
dev-util/aegis
dev-util/tkcvs
games-board/chessdb
games-board/pysol
games-board/scid
games-puzzle/penguzzle
games-strategy/xbattleai
media-gfx/skencil
media-sound/vkeybd
net-analyzer/cnet
net-analyzer/netwag
net-analyzer/nsat
net-dialup/globespan-adsl
net-dialup/rp-pppoe
/usr/bin/tkvoice
net-misc/secpanel
sci-chemistry/pymol
sci-misc/gato
sys-cluster/torque
x11-misc/accessx
x11-misc/remind
x11-misc/tkhylafax
x11-misc/xbindkeys
x11-wm/fvwm

Failed to work with tcl/tk 8.5:
app-admin/moodss bug 247197
app-office/ical bug 212705
dev-tcltk/otcl bug 213028
dev-tcltk/thread bug 247586
dev-tcltk/itcl bug 210765
net-irc/quirc bug 249468
net-misc/suite3270 bug 249479
dev-tcltk/vtcl failed to start bug 250368
net-im/coccinella builds fine but possible does not work somebody needs to confirm

Unknown because of related or not so related problems:
dev-tcltk/tclcl depends on dev-tcltk/otcl which fails
dev-util/redet unknown depends on dev-tcltk/itcl which fails
dev-tcltk/itcl unknown depends on dev-tcltk/itcl which fails
sci-libs/plplot unknown depends on dev-tcltk/itcl which fails
dev-tcltk/itk unknown depends on dev-tcltk/itcl which fails

sci-chemistry/ccp4 Failed to check because of bug 246255
dev-python/pythong Unable to test - does not install anything bug 249379
dev-tcltk/tclpython bug 247190 (But it's not related to tcl/tk 8.5)
sci-chemistry/nmrpipe : Fetch restricted package... Unable to test.


tcltk herd, now it's up to you how to proceed from this point. Obviously blockers should be resolved somehow and itcl seems to be most important since other packages depend on it. And now you have clear plan, what to do further :)
Comment 44 Joe Jezak (RETIRED) gentoo-dev 2009-02-09 03:02:56 UTC
sys-fs/hfsutils - ppc

Works great with 8.5, add us back on the list if you need ppc for anything else.
Comment 45 Justin Lecher gentoo-dev 2009-04-28 18:39:51 UTC
(In reply to comment #43)
> sci-chemistry/ccp4 Failed to check because of bug 246255
Can be overcome with ebuilds from sci overlay. I will test, build already succeed 
> sci-chemistry/nmrpipe : Fetch restricted package... Unable to test.
Using that package, build succeed, will test the runtime next days.
Comment 46 Justin Lecher gentoo-dev 2009-04-29 15:26:48 UTC
(In reply to comment #45)
> (In reply to comment #43)
> > sci-chemistry/ccp4 Failed to check because of bug 246255
> Can be overcome with ebuilds from sci overlay. I will test, build already
> succeed 
> > sci-chemistry/nmrpipe : Fetch restricted package... Unable to test.
> Using that package, build succeed, will test the runtime next days.
> 

Did it and both compile and work as expected. At least in all things I have done today.
Comment 47 Christian Hoffmann (RETIRED) gentoo-dev 2009-05-26 14:42:58 UTC
php herd was only CC'ed because of pdflib, which works according to comment #c18. Un'CC'ing.
Comment 48 Samuli Suominen gentoo-dev 2009-05-29 07:18:23 UTC
media-sound/rat - sound (removed from tree because of open open CVE)
media-sound/tk707 - sound (works)
media-sound/waif - sound (removed from tree by treecleaners)
media-sound/vkeybd - sound (works)
media-sound/timidity++ - sound (works, I've just been tounching the pkg, it's up to -r10 now)

So I don't see whatelse sound@ has to do here, removing CC, please readd us back if we missed something.
Comment 49 Federico Ferri (RETIRED) gentoo-dev 2009-08-09 03:34:03 UTC
everything's fixed

bug referenced in this page (as today) which are still open, probably have nothing to do with tcl-8.5

seems time to go for stabilization!