Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 168799 - app-office/lyx-1.5.1 bump request
Summary: app-office/lyx-1.5.1 bump request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: CJK Team
Depends on:
Blocks: 91667 170762
  Show dependency tree
Reported: 2007-02-28 22:18 UTC by Andrés Becerra Sandoval
Modified: 2007-10-14 08:10 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

ebuild attempt (lyx-1.5.0_beta1.ebuild,4.30 KB, text/plain)
2007-02-28 22:42 UTC, Andrés Becerra Sandoval
lyx-1.5.0_beta1.ebuild (lyx-1.5.0_beta1.ebuild,2.68 KB, text/plain)
2007-03-01 15:16 UTC, MATSUU Takuto (RETIRED)
files/lyx-1.5.0_beta1-gentoo.patch (lyx-1.5.0_beta1-gentoo.patch,1.29 KB, patch)
2007-03-01 15:17 UTC, MATSUU Takuto (RETIRED)
Details | Diff
Matsuu's ebuild with added useflag tetex (lyx-1.5.0_beta1.ebuild,2.78 KB, text/plain)
2007-04-09 12:12 UTC, tralalas

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Becerra Sandoval 2007-02-28 22:18:55 UTC
app-office/lyx-1.5.0_beta1 is out. The most important change is UTF-8 support in lyx documents and in the GUI.

Reproducible: Always
Comment 1 Andrés Becerra Sandoval 2007-02-28 22:42:06 UTC
Created attachment 111636 [details]
ebuild attempt

This bumped ebuild fails in the compilation phase when make begins to execute uic. For example:
/usr/qt/3/bin/uic -tr lyx::qt_ FontUi.ui -o FontUi.h
uic: File generated with too recent version of Qt Designer (4.0 vs. 3.3.6)

The problem is that lyx-1.5.0* depends on qt4, but I don't know how to tell in the ebuild that uic from qt4 is the one that should be executed, no /usr/qt/3/bin/uic.

In qt4 uic and moc are located in /usr/bin, no in /usr/qt/4/bin
Comment 2 MATSUU Takuto (RETIRED) gentoo-dev 2007-03-01 15:16:49 UTC
Created attachment 111708 [details]
Comment 3 MATSUU Takuto (RETIRED) gentoo-dev 2007-03-01 15:17:07 UTC
Created attachment 111710 [details, diff]
Comment 4 Andrés Becerra Sandoval 2007-03-01 20:30:05 UTC
Thanks MATSUU, I tested the ebuild on x86, and it's working correctly generating dvi, ps and pdf output for article, book, and beamer documents.
Comment 5 Trent Apted 2007-03-25 08:18:35 UTC
(In reply to comment #4)
> Thanks MATSUU, I tested the ebuild on x86, and it's working correctly
> generating dvi, ps and pdf output for article, book, and beamer documents.

Yup no problems for me on x86.. except some redraw issues that are probably upstream bugs.

But on my amd64 I got the following until I re-emerged app-text/aiksaurus (-1.2.1):

g++ -march=athlon64 -O3 -pipe -fomit-frame-pointer -fno-stack-protector -o lyx-qt4 main.o Bidi.o BufferView.o Bullet.o BranchList.o Chktex.o Color.o ConverterCache.o CutAndPaste.o DepTable.o FloatList.o Floating.o FontIterator.o FuncStatus.o InsetList.o LColor.o LaTeX.o LaTeXFeatures.o LyXAction.o MenuBackend.o ParagraphParameters.o PrinterParams.o Spacing.o Thesaurus.o ToolbarBackend.o author.o boost.o box.o buffer.o buffer_funcs.o bufferlist.o bufferparams.o bufferview_funcs.o changes.o chset.o converter.o counters.o coordcache.o cursor.o cursor_slice.o debug.o dimension.o dociterator.o encoding.o errorlist.o exporter.o gettext.o factory.o format.o funcrequest.o graph.o importer.o intl.o insetiterator.o kbmap.o kbsequence.o language.o session.o lengthcommon.o lyx_cb.o lyx_main.o lyx_sty.o lyxfont.o lyxfind.o lyxfunc.o lyxgluelength.o lyxlayout.o lyxlength.o lyxlex.o lyxlex_pimpl.o lyxrc.o lyxrow.o lyxserver.o lyxsocket.o lyxtextclass.o lyxtextclasslist.o lyxvc.o messages.o metricsinfo.o mover.o output.o outputparams.o output_docbook.o output_latex.o output_plaintext.o paragraph.o ParagraphMetrics.o paragraph_funcs.o paragraph_pimpl.o pariterator.o aspell.o ispell.o SpellBase.o rowpainter.o sgml.o tabular.o tex-accent.o tex-strings.o texrow.o text.o text2.o text3.o TextMetrics.o TocBackend.o toc.o trans.o trans_mgr.o undo.o vc-backend.o version.o vspace.o  mathed/.libs/libmathed.a insets/.libs/libinsets.a frontends/.libs/libfrontends.a frontends/qt4/.libs/libqt4.a -L/usr/lib64/qt4 -L/usr/lib64/mysql -L/usr/lib /usr/lib64/qt4/ -L/usr/lib64 /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ /usr/lib64/ frontends/controllers/.libs/libcontrollers.a graphics/.libs/libgraphics.a support/.libs/libsupport.a /usr/lib64/qt4/ -lpthread ../boost/libs/regex/src/.libs/libboost_regex.a ../boost/libs/signals/src/.libs/libboost_signals.a ../boost/libs/filesystem/src/.libs/libboost_filesystem.a ../boost/libs/iostreams/src/.libs/libboost_iostreams.a /usr/lib64/ /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/ -L/usr/x86_64-pc-linux-gnu/bin -L/usr/x86_64-pc-linux-gnu/lib /usr/lib64/ -lgpm /usr/lib64/ /usr/lib64/ -lc -lm /usr/lib64/ /usr/lib64/ /usr/lib64/ -ldl -lz
session.o: In function `lyx::LastFilePosSection::read(std::basic_istream<char, std::char_traits<char> >&)':
session.C:(.text+0x335b): undefined reference to `std::basic_istream<char, std::char_traits<char> >::ignore(long)'
session.C:(.text+0x337c): undefined reference to `std::basic_istream<char, std::char_traits<char> >::ignore(long)'
session.o: In function `lyx::BookmarksSection::read(std::basic_istream<char, std::char_traits<char> >&)':
session.C:(.text+0x46ba): undefined reference to `std::basic_istream<char, std::char_traits<char> >::ignore(long)'
session.C:(.text+0x46d7): undefined reference to `std::basic_istream<char, std::char_traits<char> >::ignore(long)'
collect2: ld returned 1 exit status
make[3]: *** [lyx-qt4] Error 1

The .la file for /usr/lib64/ was pulling in /usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/ and causing conflicts. Recompiling with gcc-4.1.1 fixed the problem.

it *can* also be fixed by the following

-                       itmp.ignore(2);  // ignore ", "
+                       //itmp.ignore(2);  // ignore ", "
+                       itmp.get(c) && itmp.get(c);

but that's kinda dodgy.
Comment 6 tralalas 2007-04-09 12:09:58 UTC

I took the ebuild from Matsuu Takuto and extended it with the USE-Flag tetex to change the MUST-dependency into a CAN-dependency.

This is maybe in conflict with bug #155446 but it is neseccary: I am not using tetex anymore for several reasons, but I still need lyx. But if I would install lyx with tetex dependency it will break my system. 

Ciao, P.
Comment 7 tralalas 2007-04-09 12:12:28 UTC
Created attachment 115801 [details]
Matsuu's ebuild with added useflag tetex
Comment 8 pavel sanda 2007-04-22 17:37:05 UTC
beta 2 is out.
Comment 9 Trent Apted 2007-05-22 13:28:16 UTC
beta 3 is out -- oodles of bug fixes

Just renaming the ebuild and patches works a treat
Comment 10 M. Edward Borasky 2007-06-03 09:10:34 UTC
I'm testing with the upstream subversion source. It looks to me like it requires qt4. Is that also the case for the ebuild?
Comment 11 M. Edward Borasky 2007-06-03 18:23:09 UTC
They just put up a Release Candidate 1 tarball -- I'm testing it now on my Athlon T-Bird. So far, the build I did from SVN on my AMD64 looks good. A word of warning -- it will upgrade your docs to the latest LyX format and can't downgrade them, so if you need to fall back, keep the old ones around.
Comment 12 pavel sanda 2007-06-03 18:29:42 UTC
falling back would be possible with 1.4.5, which will be released shortly after
1.5.0 is out , ie in a few weeks.
Comment 13 M. Edward Borasky 2007-06-03 21:04:07 UTC
So is LyX going to be slotted? Can 1.4.x and 1.5.x co-exist? I'm planning to switch to 1.5 -- the only problem I've had with it so far is that the fonts in the menu are waaaay too small.
Comment 14 pavel sanda 2007-06-03 21:15:15 UTC
i dont think they are going to be slotted (what i have written was true also
between 1.3.7 and 1.4.x series.)

afaik configuration files in ~/.lyx for 1.4. and 1.5 are different.
but you can build other version of lyx for some special user manually in his 
Comment 15 pavel sanda 2007-06-03 21:20:39 UTC
... and as far as font-size is concerned - does qtconfig settings help you ?
Comment 16 M. Edward Borasky 2007-06-03 21:34:56 UTC
it worked on one box but not the other ... I'm still tracking that down
Comment 17 M. Edward Borasky 2007-07-05 13:54:42 UTC
Release Candidate 2 is out. It's working on both my Athlon T-Bird and Athlon 64 X2. I don't know if I missed this the first time out or it's a new feature, but it now can save files in older LyX formats as well as the current one. So no need to wait for 1.4.5 here.

For bonus points, it builds fine on Gentoo but I haven't been able to get it to work on CentOS 5. ;)
Comment 18 Carlos Cordoba 2007-07-11 10:22:52 UTC
Success here too!! I've compiled and installed correctly Lyx 1.5 RC2 with the MATSUU ebuild.
Even more, I took my master thesis written in Lyx 1.4.4 and imported to Lyx 1.5 and everything worked fine :-)

I just want to ask how it will be taken advantage of the new UTF8 capabilities of Lyx in Gentoo, since, as far as I know, tetex 3.0 doesn't have support for it.
Comment 19 pavel sanda 2007-07-11 10:35:45 UTC
it seems to work for me.
when using utf encoding of document, in exported tex is
and tetex translated few chosen chars correctly.
Comment 20 Carlos Cordoba 2007-07-24 00:20:35 UTC
Thanks for the tip pavel! I was confused about it

However, I've tried your advice and it worked only partially. For example, I took some text of and imported it into Lyx. The good news is that Lyx renders correctly the text in the screen. The bad news is that it can't generate any output with any driver (pdflatex, etc). The error I'm getting is this

Package inputenc Error: Unicode char \u8:中 not setup for use with Latex.

Obviously this is not a Lyx error but a Latex configuration problem. Do you know, or somebody else in this bug, how to fix or change the configuration? Latex config problems could be tricky....
Comment 21 Lars Weiler (RETIRED) gentoo-dev 2007-07-24 08:14:02 UTC
Instead of \usepackage[utf8]{inputenc} I installed dev-tex/latex-unicode and put
into the header.

The utf8-inputenc-package which is delivered with LaTeX seems to be for european languages only.
Comment 22 pavel sanda 2007-07-24 12:56:25 UTC
(In reply to comment #20)
> However, I've tried your advice and it worked only partially. For example, I
> took some text of and imported it into Lyx. The good news is that
> Lyx renders correctly the text in the screen. The bad news is that it can't
> generate any output with any driver (pdflatex, etc). The error I'm getting is
> this

hello carlos :)
this is known problem. it was already resolved for many utf characters,
but many others are supposed to appear :)
> Package inputenc Error: Unicode char \u8:中 not setup for use with Latex.

it seems from your message, that you use CJK chars, you can try utf8x and UTF8
(case sensitive) encodings, which are there to support CJK.

if this and even dev-tex/latex-unicode advice does not help,
can you send that file privately please ?
Comment 23 pavel sanda 2007-07-26 21:17:56 UTC
lyx 1.5.0 is out, please bump it.

cjk is now integrated and no additional patches are needed to wait for.
Comment 24 MATSUU Takuto (RETIRED) gentoo-dev 2007-07-27 00:27:03 UTC
1.5.0 in cvs.
ppc, ppc64, and sparc archs: please mark ~ARCH to dev-tex/ivritex and =app-office/lyx-1.5.0.
Comment 25 Pinky 2007-07-27 11:17:00 UTC
app-office/lyx-1.5.0_beta2 is out

just rename beta1 ebuild and beta1 patch file.
Comment 26 Ferris McCormick (RETIRED) gentoo-dev 2007-07-27 12:56:52 UTC
(In reply to comment #24)
> 1.5.0 in cvs.
> ppc, ppc64, and sparc archs: please mark ~ARCH to dev-tex/ivritex and
> =app-office/lyx-1.5.0.

sparc done for both.
Comment 27 M. Edward Borasky 2007-07-27 14:05:00 UTC
1. I have 1.5.0 running from upstream source on both x86 and x86_64. As far as I'm concerned it's ready for prime time. :)
2. They also released a maintenance release to the 1.4 series, Is there any reason to slot lyx and have both in Portage??
3. When you configure lyx, there are a couple of things it can't seem to find having to do with document converters. I don't remember which ones were missing other than "w2l" ... does anyone know which, if any, ebuild "w2l" lives in?
Comment 28 pavel sanda 2007-07-27 16:45:28 UTC
ad 2)
i dont see many reasons why slot it. but it maybe good to have ebuild in
portage simultaneously. for users who can afford file format changes...

ad 3)
there is a bunch of supported progs by lyx. general overview can be done by
grep checkProg lib/
in lyx sources.
w2l particularly lives in bug #181283.
Comment 29 Markus Rothe (RETIRED) gentoo-dev 2007-07-30 10:37:05 UTC
qt4 does not work on ppc64. I'll add ~ppc64 once qt4 is ~ppc64.
Comment 30 Jakub Moc (RETIRED) gentoo-dev 2007-08-05 17:03:43 UTC
*lyx-1.5.0 (27 Jul 2007)

  27 Jul 2007; MATSUU Takuto <>
  +files/lyx-1.5.0-gentoo.patch, +lyx-1.5.0.ebuild:
  Version bumped, bug #168799.

Anyway, this version is seriously buggy:
Comment 31 MATSUU Takuto (RETIRED) gentoo-dev 2007-08-06 16:35:29 UTC
1.5.1 in cvs.
Comment 32 Mirko Briemle 2007-09-19 17:05:54 UTC
Version 1.5.1 seems pretty stable for ppc.
Comment 33 pavel sanda 2007-09-19 17:07:28 UTC
the same here on ~x86
Comment 34 nixnut (RETIRED) gentoo-dev 2007-09-22 17:34:48 UTC
Comment 35 pavel sanda 2007-10-08 07:56:29 UTC
bugfix release of lyx (1.5.2) is out. please bump.
Comment 36 Jakub Moc (RETIRED) gentoo-dev 2007-10-14 08:10:19 UTC
*lyx-1.5.1 (06 Aug 2007)

  06 Aug 2007; MATSUU Takuto <> +lyx-1.5.1.ebuild:
  Version bumped, bug #168799.
  Fixed dependency, bug #186991.

FIXED. Anything else -> new bug, please.