Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 147537 - x11-drivers/linuxwacom-0.7.9_p4 devel (version bump)
Summary: x11-drivers/linuxwacom-0.7.9_p4 devel (version bump)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://linuxwacom.sourceforge.net/
Whiteboard:
Keywords: EBUILD
: 151802 158154 194506 197699 200876 201972 207745 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-14 01:02 UTC by Federico Fissore
Modified: 2008-02-24 20:52 UTC (History)
25 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
linuxwacom-0.7.5_p2.ebuild (linuxwacom-0.7.5_p2.ebuild,1.40 KB, text/plain)
2006-09-14 01:02 UTC, Federico Fissore
Details
linuxwacom-0.7.5-2.xorg71.diff (linuxwacom-0.7.5-2.xorg71.diff,288 bytes, patch)
2006-09-14 01:03 UTC, Federico Fissore
Details | Diff
linuxwacom-0.7.5_p3.ebuild (linuxwacom-0.7.5_p3.ebuild,1.40 KB, text/plain)
2006-09-15 13:37 UTC, Federico Fissore
Details
hackish ebuil with wacom flag to build module (linuxwacom-0.7.5_p3.ebuild,1.69 KB, text/plain)
2006-09-22 16:28 UTC, Matteo Azzali (RETIRED)
Details
linuxwacom-0.7.5_p3.ebuild (linuxwacom-0.7.5_p3-r1.ebuild,2.54 KB, text/plain)
2006-09-25 10:19 UTC, Matteo Azzali (RETIRED)
Details
linuxwacom-0.7.5_p4.ebuild (linuxwacom-0.7.5_p4.ebuild,2.54 KB, text/plain)
2006-10-02 07:42 UTC, Matteo Azzali (RETIRED)
Details
linuxwacom-0.7.6_p1.ebuild (linuxwacom-0.7.6_p1.ebuild,2.49 KB, text/plain)
2006-10-18 01:07 UTC, Federico Fissore
Details
linuxwacom-0.7.6_p2.ebuild (linuxwacom-0.7.6_p2.ebuild,2.49 KB, text/plain)
2006-11-01 12:19 UTC, Federico Fissore
Details
60-wacom.rules (60-wacom.rules,139 bytes, text/plain)
2007-02-07 03:55 UTC, Sudrien
Details
linuxwacom-0.7.6_p4-r1.ebuild (linuxwacom-0.7.6_p4.ebuild,2.61 KB, text/plain)
2007-02-07 04:23 UTC, Sudrien
Details
Aforementioned Udev rules nicked from Debian Etch (60-wacom.rules,5.58 KB, text/plain)
2007-03-07 01:14 UTC, Stuart Longland (RETIRED)
Details
ebuild for 0.7.8-2 tested on linux 2.6.22 (linuxwacom-0.7.8_p2.ebuild,3.11 KB, text/plain)
2007-08-01 10:59 UTC, Denys Duchier
Details
diff from linuxwacom-0.7.8_p2.ebuild to linuxwacom-0.7.8_p3.ebuild (linuxwacom-0.7.8_p2-p3.ebuild.patch,1.14 KB, patch)
2007-09-16 21:19 UTC, Honza Macháček
Details | Diff
linuxwacom-0.7.8-pDev.patch for linuxwacom-0.7.8_p3.ebuild (linuxwacom-0.7.8-pDev.patch,483 bytes, patch)
2007-09-16 21:20 UTC, Honza Macháček
Details | Diff
linuxwacom-0.7.8_p2-p3.ebuild.patch (linuxwacom-0.7.8_p2-p3.ebuild.patch,1.21 KB, patch)
2007-10-07 12:00 UTC, Honza Macháček
Details | Diff
alternative 0.7.8-3 ebuild (linuxwacom-0.7.8_p3.ebuild,3.25 KB, text/plain)
2007-11-01 07:33 UTC, antonmx
Details
patch which removes the multitouch feature (linuxwacom-0.7.8-untouch.patch,4.91 KB, patch)
2007-11-01 07:35 UTC, antonmx
Details | Diff
linuxwacom-0.7.9_p4.ebuild (linuxwacom-0.7.9_p4.ebuild,3.13 KB, text/plain)
2007-12-30 15:10 UTC, Mike Auty
Details
emerge --info (emergeinfo,3.88 KB, text/plain)
2008-02-24 16:22 UTC, Federico Fissore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Fissore 2006-09-14 01:02:24 UTC
linuxwacom project just released the beta 0.7.5-2 of linuxwacom drivers

attached you find a preliminary ebuild. the main difference is in the patch, as sources structure has changed

tests are welcome
Comment 1 Federico Fissore 2006-09-14 01:02:58 UTC
Created attachment 96937 [details]
linuxwacom-0.7.5_p2.ebuild
Comment 2 Federico Fissore 2006-09-14 01:03:22 UTC
Created attachment 96938 [details, diff]
linuxwacom-0.7.5-2.xorg71.diff
Comment 3 Federico Fissore 2006-09-15 13:37:39 UTC
Created attachment 97078 [details]
linuxwacom-0.7.5_p3.ebuild

new version
Comment 4 Matteo Azzali (RETIRED) gentoo-dev 2006-09-22 10:53:48 UTC
Not working here, same behaviour of 7.4 : all seems good but 
evtest /dev/input/eventx shows there's nothing coming from the tablet.

I have tested it and is working on older systems, also I have wacom as module 
and evdev,ehci,ohci,hid as builtin.... am I missing something or I should not
compile wacom module from the kernel?
Comment 5 Federico Fissore 2006-09-22 12:59:44 UTC
I've not tested all the combination but on my 2.6.16 kernel, I've enabled wacom as a module in the kernel, then I've emerge linuxwacom, then I've took the archive of linuxwacom, compiled it on my own and overwritten the file wacom.ko. finally rebooted
I don't know another way to make it work
Comment 6 Matteo Azzali (RETIRED) gentoo-dev 2006-09-22 16:28:56 UTC
Created attachment 97803 [details]
hackish ebuil with wacom flag to build module

worked like a charm! I created an hackish ebuild to use with 2.6.18 kernel
while waiting for a proper ebuild (one using versionator and linux-mod
eclasses). Tested only on x86 + gentoo-sources-2.6.18 , use at your risk.
Comment 7 Federico Fissore 2006-09-25 00:34:53 UTC
I confirm! thx!
Comment 8 Matteo Azzali (RETIRED) gentoo-dev 2006-09-25 10:19:58 UTC
Created attachment 98041 [details]
linuxwacom-0.7.5_p3.ebuild

That one was too hackish to substitute your previous ebuild, this one
at least uses linux-mod to get kernel version and check if wacom was
compiled as module. This should be much better.
Comment 9 Matteo Azzali (RETIRED) gentoo-dev 2006-10-02 07:42:19 UTC
Created attachment 98606 [details]
linuxwacom-0.7.5_p4.ebuild

Updated for the new beta release
Comment 10 Matteo Azzali (RETIRED) gentoo-dev 2006-10-02 15:47:47 UTC
Care! I added _p4 release that seems to install the correct files,
however my tablet (volito 1 ) ceased working with that release and kernel
2.6.18.... I rollbacked to _p3 release.
Comment 11 Federico Fissore 2006-10-18 01:07:55 UTC
Created attachment 99920 [details]
linuxwacom-0.7.6_p1.ebuild

ebuild for latest STABLE release of linuxwacom driver
upstream finally made it xorg7.1 compatible. the patch is no more needed.
the ebuild is ok apart some "dodoc" warnings at the end
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-10-18 02:18:41 UTC
*** Bug 151802 has been marked as a duplicate of this bug. ***
Comment 13 Federico Fissore 2006-11-01 12:19:51 UTC
Created attachment 100992 [details]
linuxwacom-0.7.6_p2.ebuild

version bump
Comment 14 crusaderky 2006-11-12 16:39:57 UTC
I've got a Volito 2, linux 2.6.18-gentoo and X.org 7.1.

linuxwacom-0.7.4_p3 and vanilla kernel module: doesn't work
linuxwacom-0.7.4_p3 and kernel module from the linuxwacom package: works

linuxwacom-0.7.6_p2 and vanilla kernel module: doesn't work
linuxwacom-0.7.6_p2 and kernel module from the linuxwacom package using USE=wacom: works like a charm :-]

So yeah, leaving the kernel module support to the version that will go in portage is quite critical.
Comment 15 Federico Fissore 2006-11-13 12:12:31 UTC
afaik, enabling wacom module support (and therefor compiling the bundled module, even if not properly working) is mandatory as linuxwacom, during compile, checks if you have enabled that. if not, even you have asked it to, it will not compile its own module

sad, but true (afaik)
Comment 16 Matteo Azzali (RETIRED) gentoo-dev 2006-11-22 06:38:43 UTC
Just a note.... it seems to have issue if you emerge with wacom flag
while you're still using the old release of the kernel (while the newer is
already compiled and installed). So I would suggest you all to reboot 
before recompiling linuxwacom (I got some strange issue, not doin so).
Comment 17 Federico Fissore 2006-11-22 15:05:12 UTC
_p3 is out. just rename the ebuild file
Comment 18 Harald van Dijk (RETIRED) gentoo-dev 2006-11-29 11:44:00 UTC
(In reply to comment #15)
> afaik, enabling wacom module support (and therefor compiling the bundled
> module, even if not properly working) is mandatory as linuxwacom, during
> compile, checks if you have enabled that. if not, even you have asked it to, it
> will not compile its own module
> 
> sad, but true (afaik)

At least with 0.7.6_p3, the external module gets built just fine if you don't enable the kernel's, so if the check was necessary before, it doesn't seem to be anymore.
Comment 19 Federico Fissore 2006-12-05 06:57:46 UTC
_p4 is out. just rename the ebuild file
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-12-14 11:10:31 UTC
*** Bug 158154 has been marked as a duplicate of this bug. ***
Comment 21 Nico 2006-12-26 08:51:04 UTC
Hi all..
I have a volito 2 wacom tablet, I write to let you know that with the stable version 0.7.4_p3 it wasn't working, while with the 0.7.6_p2 it works properly using the wacom useflag to override the wacom module.
thanks,
Nic
Comment 22 Roger 2006-12-26 20:31:33 UTC
Noticing several version since there has been an updated Gentoo ebuild.  Wow!  How about pushing a new ebuild into portage?

Also, are there any benefits with using the linuxwacom module over a recent kernel release?
Comment 23 crusaderky 2006-12-29 12:10:47 UTC
(In reply to comment #22)
> Also, are there any benefits with using the linuxwacom module over a recent
> kernel release?
well... kinda. the linuxwacom module works, the vanilla kernel module doesn't. :P

@Nico: please try p4. I'm using it with a volito2 without problems.
Comment 24 Nico 2007-01-05 08:56:22 UTC
@Guido:
I apologize for the late answer, I was on holidays. What do you mean with try p4? I'm using now the 0.7.6_p2 which is the latest (I suppose) and it works perfectly, if you're asking me to test something, I'll do it, but please be more clear... thanks, Nico
Comment 25 crusaderky 2007-01-05 09:09:38 UTC
@Nico: sorry, i misread your original post. no need for testing
Comment 26 Federico Fissore 2007-01-07 17:18:47 UTC
(In reply to comment #24)
> p4? I'm using now the 0.7.6_p2 which is the latest (I suppose) and it works
> 

The latest is _p4. See comment #19
Comment 27 Thomas Kear 2007-01-26 20:36:20 UTC
Upstream released 0.7.7-2
Comment 28 Sudrien 2007-02-07 03:55:32 UTC
Created attachment 109400 [details]
60-wacom.rules

based on the fedora core rules - creates /dev/input/wacom - this assumes only one tablet, but I don't know of any cases where two are needed.
Comment 29 Sudrien 2007-02-07 04:23:22 UTC
Created attachment 109401 [details]
linuxwacom-0.7.6_p4-r1.ebuild

adds udev flag for installing 60-wacom.rules
Comment 30 Federico Fissore 2007-02-24 16:49:51 UTC
Comment on attachment 100992 [details]
linuxwacom-0.7.6_p2.ebuild

_p4-r1 with udev rules tested and working fine for me
Comment 31 Stuart Longland (RETIRED) gentoo-dev 2007-03-06 14:39:10 UTC
Actually, I've got some udev rules I nicked from Debian Etch which handle multiple tablets, and work a treat with my Graphire 4 -- even on MIPS.

Quick query: What's the status with the X11 driver herd's support of this package?  If there's a problem with test hardware, then I'm happy to test on your behalf -- as I use my tablet on a _daily_ basis. :-)
Comment 32 Stuart Longland (RETIRED) gentoo-dev 2007-03-07 01:14:30 UTC
Created attachment 112349 [details]
Aforementioned Udev rules nicked from Debian Etch

The attached udev rules create the following symlinks:

stuartl@wander ~ $ ls -l /dev/input
total 0
crw------- 1 root root 13, 64 Mar  7  2007 event0
crw------- 1 root root 13, 65 Mar  7 09:40 event1
crw------- 1 root root 13, 66 Mar  7 09:40 event2
crw------- 1 root root 13, 67 Mar  7 09:40 event3
crw-r--r-- 1 root root 13, 63 Mar  7  2007 mice
crw-r--r-- 1 root root 13, 32 Mar  7 09:40 mouse0
crw-r--r-- 1 root root 13, 33 Mar  7 09:40 mouse1
lrwxrwxrwx 1 root root      6 Mar  7 09:40 tablet-graphire4-4x5 -> event1
lrwxrwxrwx 1 root root      6 Mar  7 09:40 wacom -> event1

I haven't seen this with other Wacom tablets or multiple tablets, but should handle them fine.
Comment 33 Christopher Warrington (c45207) 2007-04-07 03:48:11 UTC
linuxwacom-0.7.6_p4-r1.ebuild (USE flags: -udev -usb -wacom) works just fine for me on a HP tc4200 (tablet PC, serial Wacom interface).
Comment 34 Federico Fissore 2007-07-09 18:44:19 UTC
stable version 0.7.8 is out.

the attached linuxwacom-0.7.6_p4-r1.ebuild suffices for correctly compile and install it
Comment 35 Federico Fissore 2007-07-15 20:11:08 UTC
stable version 0.7.8-1 is out.

see comment #34
Comment 36 Jacek Sieka 2007-07-26 07:29:19 UTC
...and 0.7.8_p2
Comment 37 Andrea Franceschini 2007-07-28 09:19:30 UTC
Is there any chance to have the latest version in Portage? Or maybe there's an overlay I didn't see already?
Comment 38 crusaderky 2007-07-29 11:41:04 UTC
ebuild doesn't work with linux-2.6.22, since the wacom module changed name from USB_WACOM to TABLET_USB_WACOM.
Comment 39 crusaderky 2007-07-29 13:07:20 UTC
The path of the kernel module has changed to 
/lib/modules/${KV}/kernel/drivers/input/tablet/wacom.k
too.
Comment 40 Denys Duchier 2007-08-01 10:59:02 UTC
Created attachment 126591 [details]
ebuild for 0.7.8-2 tested on linux 2.6.22

here is an updated ebuild for linuxwacom 0.7.8-2.  I have tested it on linux gentoo-sources-2.6.22-r2 with a newly acquired wacom bamboo tablet.
Comment 41 R. Bosch 2007-09-11 12:05:31 UTC
Linuxwacom needs pixman.h from libpixman. Could this have something to do with the fact that I'm using Xorg 7.3?
Then it fails on:
./wcmCommon.c: In function 'xf86WcmEvent':
./wcmCommon.c:1099: error: 'pDev' undeclared (first use in this function)
./wcmCommon.c:1099: error: (Each undeclared identifier is reported only once
./wcmCommon.c:1099: error: for each function it appears in.)

looks like Linuxwacom needs to catch up. The New Xorg is new, so no biggie - yet ;-)

Remy
Comment 42 Honza Macháček 2007-09-16 21:13:46 UTC
(In reply to comment #41)
I suspect it's simply a bug in the linuxwacom code. The compilation crashes inside a function definition starting like this:

void xf86WcmEvent(WacomCommonPtr common, unsigned int channel,
        const WacomDeviceState* pState)
{
        WacomDeviceState* pLast;
        WacomDeviceState ds;
        WacomChannelPtr pChannel;
        WacomFilterState* fs;
        int i, suppress = 0;

        pChannel = common->wcmChannel + channel;
        pLast = &pChannel->valid.state;

        DBG(10, common->debugLevel, ErrorF("xf86WcmEvent at channel = %d\n", channel));

        /* Tool on the tablet when driver starts. This sometime causes
         * access errors to the device */
#if defined WCM_XFREE86 || GET_ABI_MAJOR(ABI_XINPUT_VERSION) == 0
        if (!miPointerCurrentScreen())
#else
        if (!miPointerGetScreen(pDev->dev))
#endif


Unless pDev is meant to be some ugly global variable, its appearance there is probably a typo (cut & paste with insufficient editing?). After some searching and experimenting I've managed to compiled the code with the critical line stating:

        if (!miPointerGetScreen(common->wcmDevices->local->dev))

I haven't tested if that actually works, but I've at least checked quickly that I can connect my Graphire 4 and get some interaction, so I'm going to share my solution and wait for extensive testing and/or better solutions from the others.
Comment 43 Honza Macháček 2007-09-16 21:19:29 UTC
Created attachment 131092 [details, diff]
diff from linuxwacom-0.7.8_p2.ebuild to linuxwacom-0.7.8_p3.ebuild

Along with patch version increment adds media-libs/libpixman to dependencies, breaks obsolete (AFAIK) USE flag tcltk to tcl and tk, and applies patch to get rid of undeclared pDev in src/xdrv/wcmCommon.c (line 1099).
Comment 44 Honza Macháček 2007-09-16 21:20:58 UTC
Created attachment 131093 [details, diff]
linuxwacom-0.7.8-pDev.patch for linuxwacom-0.7.8_p3.ebuild
Comment 45 Federico Fissore 2007-09-17 21:22:45 UTC
(In reply to comment #44)
> Created an attachment (id=131093) [edit]
> linuxwacom-0.7.8-pDev.patch for linuxwacom-0.7.8_p3.ebuild
> 

working correctly here!
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2007-10-02 20:57:12 UTC
*** Bug 194506 has been marked as a duplicate of this bug. ***
Comment 47 Andrea Franceschini 2007-10-06 09:37:56 UTC
This is working for me on suspend2-sources-2.6.22-r2.

What else is needed to bring this into portage?
Comment 48 crusaderky 2007-10-07 11:03:36 UTC
posted ebuild for 0.7.8_p3 still has references to "tcltk":
 	tcltk? ( dev-lang/tcl dev-lang/tk )

also, the problem with linux-2.6.22 (see posts #38 and #39) hasn't been solved.
Comment 49 Honza Macháček 2007-10-07 12:00:35 UTC
Created attachment 132812 [details, diff]
linuxwacom-0.7.8_p2-p3.ebuild.patch

Omitted tcltk USE flag reference broken to tcl and tk. Worked for me before, because I have tcl and tk installed.

I'm not sure if tk flag ought not to enforce tcl; I just hope that somebody better acquainted and skillful with ebuilds will check and eventually correct that.

Comments #38 and #39 should have been dealt with before, by Denys Duchier in his ebuild for 0.7.8_p2 -- see comment #40. For me the modified ebuild for 0.7.8_p3 works with gentoo-sources-2.6.22-r6.
Comment 50 crusaderky 2007-10-07 12:41:40 UTC
(In reply to comment #49)
> Comments #38 and #39 should have been dealt with before, by Denys Duchier in
> his ebuild for 0.7.8_p2 -- see comment #40. For me the modified ebuild for
> 0.7.8_p3 works with gentoo-sources-2.6.22-r6.

Oh yeah, you're right. However, I'm afraid that that ebuild won't work anymore with linux-2.6.21 and earlier.

Comment 51 ql882 2007-10-12 01:59:34 UTC
I find that the 0.7.8-p3 version works fine with xorg-7.3 and gentoo-sources 2.6.22-r8, and any program I've used-- except for gimp (2.4.0-rc3). It acts as if the button mappings are screwed up, and it only seems to get worse when I try to change them in the gimp input settings. 
BTW, this same version of gimp worked previously with 0.7.6-p4.
linuxwacom compiled with USE="gtk udev usb wacom -tcl -tk"
Comment 52 crusaderky 2007-10-24 16:03:40 UTC
0.7.8-p3 works fine with my Volito2 tablet, linux-2.6.22-gentoo-r8, xorg-x11-7.2 and gimp-2.4.0 running on amd64.

I've upgraded my HOWTO to reflect the latest changes:
http://forums.gentoo.org/viewtopic-t-346788-start-0-postdays-0-postorder-asc-highlight-.html
Comment 54 antonmx 2007-11-01 07:33:18 UTC
Created attachment 134867 [details]
alternative 0.7.8-3 ebuild

First of all thanks for the nice ebuild. However I had some problems with it and here I attach modiffied version of it. The changes are:

1) it will work with not only CONFIG_TABLET_USB_WACOM option in the kernel .config but also with CONFIG_USB_WACOM in the newer kernels. The same it will choose the appropriate driver path.

2) added USE flag "multitouch". Emerging with USE="-multitouch" will apply my patch (see next attachment) wich removes the multitouch "feature". This feature makes the usage almost impossible on my Lenovo X60t tablet. Accordingly to the forums I am not the only one who has this problem with the same tablet.
Comment 55 antonmx 2007-11-01 07:35:38 UTC
Created attachment 134868 [details, diff]
patch which removes the multitouch feature

patch which removes the multitouch feature. Emerge previosly attached 0.7.8-3 ebuild with USE="-multitouch" to apply this patch.
Comment 56 Jakub Moc (RETIRED) gentoo-dev 2007-11-01 07:38:27 UTC
*** Bug 197699 has been marked as a duplicate of this bug. ***
Comment 57 crusaderky 2007-11-01 13:52:25 UTC
antonmx's ebuild works fine with my Volito2 and linux-2.6.22.
Comment 58 crusaderky 2007-11-01 14:00:37 UTC
However, USE=udev does nothing (it doesn't install the udev rules file).
Comment 59 crusaderky 2007-11-01 14:12:20 UTC
 # equery files linuxwacom | grep etc
/etc
/etc/udev
/etc/udev/rules.d

60-wacom.rules does not get installed.
Comment 60 antonmx 2007-11-05 01:12:22 UTC
(In reply to comment #59)
>  # equery files linuxwacom | grep etc
> /etc
> /etc/udev
> /etc/udev/rules.d
> 
> 60-wacom.rules does not get installed.
> 

You need to download 60-wacom.rules file from this page and put it into the files directory of the linuxwacom ebuild
Comment 61 crusaderky 2007-11-05 03:11:46 UTC
(In reply to comment #60)
> You need to download 60-wacom.rules file from this page and put it into the
> files directory of the linuxwacom ebuild
> 

Then the problem is, that the ebuild doesn't complain at all if the file is missing (while it should crash).
Comment 62 Jakub Moc (RETIRED) gentoo-dev 2007-11-30 21:28:11 UTC
*** Bug 200876 has been marked as a duplicate of this bug. ***
Comment 63 Jakub Moc (RETIRED) gentoo-dev 2007-12-11 21:55:56 UTC
*** Bug 201972 has been marked as a duplicate of this bug. ***
Comment 64 Daniel Weigert 2007-12-16 18:05:49 UTC
Do we have any idea when this new ebuild and version will make it into portage? I'll be happy to test, as my tablet is useless until it does.
Comment 65 Jan Kopecky 2007-12-20 14:23:18 UTC
I have Bamboo Fun Small and driver version 0.7.8_p3 does not support this tablet. Version 0.7.9-4 has support for this tablet. Ebuild for this version would be nice, becouse manual installation described on homepage didn't work for me as I expected.
Comment 66 Robert Buchholz (RETIRED) gentoo-dev 2007-12-30 14:33:54 UTC
udev rules should be installed without a use flag, see bug 158114.

antonmx, is that patch the revert of an upstream commit or did you do these changes yourself?
Comment 67 Mike Auty gentoo-dev 2007-12-30 15:10:11 UTC
Created attachment 139632 [details]
linuxwacom-0.7.9_p4.ebuild

Right, 

Here's the linuxwacom-0.7.9_p4 ebuild I'm using.  It does appear to work fine with my graphire 3 and Xorg-1.4, so it's probably worth people trying out.  It doesn't have the multitouch patch applied, but I'm not certain where that came from and it seems a little odd to completely remove upstream code.

It no longer needs any of the other patches, but does use the debian udev rules, which are now always installed.  It does still feature a USE flag for building the kernel module (called module, much like media-libs/libifp, although there doesn't seem to be a standard name for "build kernel module").  Ideally there would be a better method than manual installation and particularly overwriting the existing kernel module, but this does at least work.  I've got some reading of the linux-mod eclass to do, and if anyone knows of other ebuilds that encounter this problem (fuse springs to mind), let me know and I'll see if we can get something cleaner going.

Lastly, I would have taken this package over a while ago when it came up as maintainer-needed, but several issues have all conspired to come together at once (not least of which is finger problems, making typing/coding much more time consuming).  I therefore won't take over the package, but I'll help out however I can, and if there's still no maintainer in a few months (or more accurately once everything's returned to normal) then I'll take it over...
Comment 68 antonmx 2007-12-30 15:41:10 UTC
(In reply to comment #66)
> udev rules should be installed without a use flag, see bug 158114.
> 
> antonmx, is that patch the revert of an upstream commit or did you do these
> changes yourself?

Just the revert. This feature, untested and annoying in many cases, was included into the main branch. So I removed it. Actually I am thinking of writing a patch which can turn it on/off on the fly. But now on vocation untill mid Feb.
Comment 69 Robert Buchholz (RETIRED) gentoo-dev 2007-12-30 15:59:39 UTC
antonmx, I will be committing this ebuild to the tree without your patch. I heard other complaints about missing functionality with the multitouch feature, but manually reverting is not the way to go for me.

There are two patches available, both not included upstream. Let's handle this at a new bug, ok?
Comment 70 antonmx 2007-12-30 16:41:34 UTC
(In reply to comment #69)
> antonmx, I will be committing this ebuild to the tree without your patch. I
> heard other complaints about missing functionality with the multitouch feature,
> but manually reverting is not the way to go for me.
> 
> There are two patches available, both not included upstream. Let's handle this
> at a new bug, ok?
> 

Hey, that is why I created the USE flag "multitouch": those who miss the functionality can turn it on, those who do not need it - cat turn it off. It is not the manually reverting: I have found that patch which included the feature and found the code where it is located and then REWROTE the code to exlude this and then created the patch. I tald reverting because I used the original patch to understand how it works. But of cause you can commit it as you prefer. I just do not understand why you do not want to give people the choise.
Comment 71 antonmx 2007-12-30 16:57:22 UTC
BTW, here I found the patch which is better than mine (accordingly to the description):
http://sourceforge.net/mailarchive/forum.php?thread_name=200711061311.48946.danny.kukawka%40web.de&forum_name=linuxwacom-discuss
Comment 72 Robert Buchholz (RETIRED) gentoo-dev 2007-12-30 17:31:57 UTC
anton, please open a new bug for this discussion.

I did not mean to dispute your issue, but as you stated yourself, there are better ways to deal with this. It is a bad hack to enable or disable "bugs" at compile time. Also, it is Gentoo's policy to not deviate from upstream as far as we can, so I want to coordinate fixing that bug with them.

What I need for a next step (maybe inclusion of the patch your mentioned), is a new bug where you describe what the real problem with the vanilla upstream is (because I am missing this here).
Comment 73 antonmx 2007-12-30 18:02:42 UTC
(In reply to comment #72)
> anton, please open a new bug for this discussion.
> 
> I did not mean to dispute your issue, but as you stated yourself, there are
> better ways to deal with this. It is a bad hack to enable or disable "bugs" at
> compile time. Also, it is Gentoo's policy to not deviate from upstream as far
> as we can, so I want to coordinate fixing that bug with them.
> 
> What I need for a next step (maybe inclusion of the patch your mentioned), is a
> new bug where you describe what the real problem with the vanilla upstream is
> (because I am missing this here).
> 

OK, Robert, I think you are right. It's better to do like you purpose. I will try to find a moment to post this bug. The only problem is i am pretty lazy and it's difficult to do smth unless i am forced to do, but now my pen works exactly as I expect from it..)) Anyway thanks for you work.

Anton.
Comment 74 Robert Buchholz (RETIRED) gentoo-dev 2007-12-30 20:54:03 UTC
(In reply to comment #73)
> OK, Robert, I think you are right. It's better to do like you purpose. I will
> try to find a moment to post this bug. The only problem is i am pretty lazy and
> it's difficult to do smth unless i am forced to do, but now my pen works
> exactly as I expect from it..)) Anyway thanks for you work.

Only until the ebuild gets bumped in the tree. Just write four lines describing the problem ;-)

Comment 75 Jakub Moc (RETIRED) gentoo-dev 2008-01-27 20:11:17 UTC
*** Bug 207745 has been marked as a duplicate of this bug. ***
Comment 76 Mike Auty gentoo-dev 2008-02-12 22:43:28 UTC
Ok, sorry for the long wait guys, but 0.7.9_p7 is now in the tree.  It's masked for the time being, as it's got a few new features and brings back the module building capability.  It's been working for me for a few weeks without problem (in fact it fixed my jiggle problem), but hasn't been strongly tested on older kernels, or older Xorg versions.  Please let me know how it works out by posting here...  5:)
Comment 77 Federico Fissore 2008-02-24 16:22:43 UTC
Created attachment 144512 [details]
emerge --info

working here (w/ xorg-server-1.4.0.90-r3)
Comment 78 Robert Buchholz (RETIRED) gentoo-dev 2008-02-24 17:51:58 UTC
With the ebuilds in the tree, I think we can close this here now?
Comment 79 Federico Fissore 2008-02-24 20:19:53 UTC
(In reply to comment #78)
> With the ebuilds in the tree, I think we can close this here now?
> 

I would wait for it to be unmasked
Comment 80 Mike Auty gentoo-dev 2008-02-24 20:22:14 UTC
Congrats!  It just got unmasked.  5:)  Please give the servers a couple of hours to synchronize...
Comment 81 Robert Buchholz (RETIRED) gentoo-dev 2008-02-24 20:52:11 UTC
For anyone affected, the multitouch bug is separately tracked as bug 211136.