Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 211136 - x11-drivers/linuxwacom-0.7.8_p3: Multitouch feature of linuxwacom interferes with stylus/eraser use in tablet mode
Summary: x11-drivers/linuxwacom-0.7.8_p3: Multitouch feature of linuxwacom interferes ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mike Auty (RETIRED)
Depends on:
Reported: 2008-02-22 21:14 UTC by John Troxler
Modified: 2008-12-07 08:56 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Troxler 2008-02-22 21:14:35 UTC
The multitouch feature of the linuxwacom driver is interfering so that when I go to use my x61t with my stylus, both the stylus tip, eraser and my hand on the screen create touch events that make it nearly unusable.

The Vista driver has some way of disabling the touch screen when the stylus is being used so that no touch events are transferred to the system.

A previous user in bug #147537 had made a patch available that selectively removed the multitouch code from the linuxwacom driver based on a USE flag. I'd like to have some way to turn the multitouch off until the driver code gets better at recognizing what's a finger touch and what's not a finger touch.

Here's some basic info on my system:
Lenovo X61T with multitouch/multiview lcd screen
gentoo-2.6.23-r8 with tuxonice-2.6.23-r8 kernel sources

Reproducible: Always

Steps to Reproduce:
1. emerge linuxwacom-0.7.8_p3 on a tablet pc
2. write on screen with stylus

Actual Results:  
cursor flies all over the screen between the palm of your hand resting on the screen and the stylus tip
Comment 1 Robert Buchholz (RETIRED) gentoo-dev 2008-02-24 12:32:46 UTC
Rather than making it a compile-time feature I'd make it configurable via xorg.conf, as in:

John, can you try the patches here -- does applying them help?
Comment 2 John Troxler 2008-02-25 13:50:41 UTC
I created a temporary ebuild with the multitouch patch from sf and emerged it, and now it works fine.  The driver now effectively ignores touch events while using the stylus.

Robert, is there an official ebuild in portage that includes this patch?
Comment 3 Mike Auty (RETIRED) gentoo-dev 2008-08-22 14:45:01 UTC
Now that 0.8.0 is in the main tree, can I ask the status of this bug?  Has upstream resolved the issues you were having?
Comment 4 Matthew Kasa (RETIRED) gentoo-dev 2008-12-07 08:56:08 UTC
I'd say yes, you can probably close this, I tried 0.7.8_p3 and experienced the same issue (pressing the stylus results in a second press close to the first one, leaving you with infinitely repeating clicks, extremely disruptive), but now on 0.8.0_p3-r1 things work as expected.