Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 910723 - media-sound/audacity-3.2.5-r1 fails to configure: Failed to find the system package Opus
Summary: media-sound/audacity-3.2.5-r1 fails to configure: Failed to find the system p...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
Keywords: PullRequest
Depends on:
Reported: 2023-07-23 13:45 UTC by ricardompcampos
Modified: 2024-04-16 22:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Attachments (emerge-info.txt,6.30 KB, text/plain)
2023-07-23 13:46 UTC, ricardompcampos
emerge -pqv (emerge-pqv.txt,173 bytes, text/plain)
2023-07-23 13:46 UTC, ricardompcampos
build.log (build.log,9.12 KB, text/x-log)
2023-07-23 13:47 UTC, ricardompcampos
emerge --info audacity (emerge-info-audacity.txt,6.40 KB, text/plain)
2023-07-23 13:48 UTC, ricardompcampos
environment (environment.txt,99.91 KB, text/plain)
2023-07-23 13:48 UTC, ricardompcampos

Note You need to log in before you can comment on or make changes to this bug.
Description ricardompcampos 2023-07-23 13:45:39 UTC
Audacity failing to compile, in the configure step, it says unable to find system package Opus, but no Opus USE flag is being used.

Already tried with "USE=-opus emerge -a audacity" and already tried after adding to make.conf global USE flags and running @world update. Same message.

Reproducible: Always

Steps to Reproduce:
1.Run emerge -av media-sound/audacity
Actual Results:  
Fail to configure for compiling

Expected Results:  
Configure with success then compile.
Comment 1 ricardompcampos 2023-07-23 13:46:19 UTC
Created attachment 866007 [details]
Comment 2 ricardompcampos 2023-07-23 13:46:54 UTC
Created attachment 866008 [details]
emerge -pqv
Comment 3 ricardompcampos 2023-07-23 13:47:19 UTC
Created attachment 866009 [details]
Comment 4 ricardompcampos 2023-07-23 13:48:01 UTC
Created attachment 866010 [details]
emerge --info audacity
Comment 5 ricardompcampos 2023-07-23 13:48:18 UTC
Created attachment 866011 [details]
Comment 6 mehw 2024-04-01 09:06:23 UTC

As a side note, media-sound/audacity-3.2.5-r1 had been dropped already with the merge of PR.
Comment 7 Larry the Git Cow gentoo-dev 2024-04-16 22:57:21 UTC
The bug has been closed via the following commit(s):

commit 72e8c24fcd0beb997a88f7d185a02a212abafe37
Author:     Aliaksei Urbanski <>
AuthorDate: 2024-04-16 19:03:31 +0000
Commit:     Yixun Lan <>
CommitDate: 2024-04-16 22:53:49 +0000

    media-sound/audacity: fix various issues
    The flac USE flag was mistakenly used
    instead of the opus USE flag for configuring.
    Also, Audacity 3.4.2 introduced a brand new
    USE_OPUSFILE option which must be set properly.
    These changes:
      - fix the opus USE flag
      - add proper REQUIRED_USE
      - replace media-sound/mpg123 with media-sound/mpg123-base
      - move dev-libs/rapidjson from RDEPEND to DEPEND
      - fix missing `#include <limits>` for 2.4.2-r4
      - limit media-video/ffmpeg to <5 for 2.4.2-r4
      - add x11-base/xorg-proto to DEPEND
      - add some ASM to BDEPEND
      - add audacity-3.4.2-audiocom-std-string.patch to PATCHES for 3.3.3-r1
      - add audacity-2.4.2-fix-libflac-undefined-references.patch to PATCHES for 2.4.2-r4
      - reset KEYWORDS for 2.4.2-r4 and 3.3.3-r1
    Co-authored-by: Matthew White <>
    Signed-off-by: Aliaksei Urbanski <>
    Signed-off-by: Yixun Lan <>

 media-sound/audacity/audacity-2.4.2-r4.ebuild      | 135 +++++++++++++++++++++
 ...acity-3.3.3.ebuild => audacity-3.3.3-r1.ebuild} |  33 ++---
 ...acity-3.4.2.ebuild => audacity-3.4.2-r1.ebuild} |  24 ++--
 media-sound/audacity/audacity-9999.ebuild          |  24 ++--
 ...audacity-2.4.2-add-missing-include-limits.patch |  10 ++
 ...ty-2.4.2-fix-libflac-undefined-references.patch |  61 ++++++++++
 media-sound/audacity/metadata.xml                  |   4 +-
 7 files changed, 258 insertions(+), 33 deletions(-)