Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 83238 - revdep-rebuild misses to rebuild imlib when having switched from libungif to giflib
Summary: revdep-rebuild misses to rebuild imlib when having switched from libungif to ...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
: 86779 87727 87840 88128 91781 92373 96184 96285 96343 97792 98713 98771 99570 99715 100097 100634 100801 105236 106374 108435 114370 114384 114983 115200 116568 116797 117102 117599 118249 121674 121947 125785 128666 131973 135616 144546 146109 158856 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-24 15:28 UTC by Robert Muchacki (RETIRED)
Modified: 2006-12-22 10:45 UTC (History)
20 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Muchacki (RETIRED) gentoo-dev 2005-02-24 15:28:55 UTC
grep: /usr/lib/libungif.la: No such file or directory
/bin/sed: can't read /usr/lib/libungif.la: No such file or directory
libtool: link: `/usr/lib/libungif.la' is not a valid libtool archive
make[3]: *** [libkdeinit_kuickshow.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdegraphics-3.4.0_beta2/work/kdegraphics-3.3.92/kuickshow/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdegraphics-3.4.0_beta2/work/kdegraphics-3.3.92/kuickshow'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdegraphics-3.4.0_beta2/work/kdegraphics-3.3.92'
make: *** [all] Error 2


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Dan Armak (RETIRED) gentoo-dev 2005-02-25 00:50:01 UTC
kuickshow doesn't use libungif directly; it uses imlib, on which it depends.
The attempt to link against libungif must be coming from imlib's .la files.
Try remerging media-libs/imlib.
Comment 2 Gregorio Guidi (RETIRED) gentoo-dev 2005-03-24 15:26:53 UTC
No reply from reporter.
Comment 3 Gregorio Guidi (RETIRED) gentoo-dev 2005-03-26 08:48:23 UTC
*** Bug 86779 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Herzog 2005-03-26 09:52:05 UTC
re-emerging media-libs/imlib solved it in case of Bug #86779
Comment 5 Gregorio Guidi (RETIRED) gentoo-dev 2005-04-03 14:58:52 UTC
*** Bug 87727 has been marked as a duplicate of this bug. ***
Comment 6 Gregorio Guidi (RETIRED) gentoo-dev 2005-04-03 14:59:43 UTC
*** Bug 87840 has been marked as a duplicate of this bug. ***
Comment 7 Anders Norgaard 2005-04-17 08:11:44 UTC
This still happens on a fresh 2005.0 install.

I followed the quickinstall guide and installed from GRP

> USE="bindist" emerge -k xorg-x11 kde

and immediately after, emerging kde3.4 (not split ebuilds) on top of that

> emerge sync
> ACCEPT_KEYWORDS="~x86" emerge -kb kde


per this post I 

http://forums.gentoo.org/viewtopic-t-282539-highlight-libungif.html

> emerge -k libungif

and 

> ACCEPT_KEYWORDS="~x86" emerge -kb kde

again.

Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-05-07 04:13:51 UTC
*** Bug 91781 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-05-12 06:51:55 UTC
*** Bug 92373 has been marked as a duplicate of this bug. ***
Comment 10 Gregorio Guidi (RETIRED) gentoo-dev 2005-05-12 10:49:11 UTC
*** Bug 88128 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2005-06-15 08:16:55 UTC
*** Bug 96184 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2005-06-16 08:21:09 UTC
*** Bug 96285 has been marked as a duplicate of this bug. ***
Comment 13 Peter Thomassen 2005-06-16 08:26:30 UTC
Reemering imlib-1.9.14-r3 didn't help in my case. 
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2005-06-17 00:27:03 UTC
*** Bug 96343 has been marked as a duplicate of this bug. ***
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2005-07-03 01:39:08 UTC
*** Bug 97792 has been marked as a duplicate of this bug. ***
Comment 16 Gregorio Guidi (RETIRED) gentoo-dev 2005-07-11 23:45:04 UTC
*** Bug 98713 has been marked as a duplicate of this bug. ***
Comment 17 Jakub Moc (RETIRED) gentoo-dev 2005-07-12 06:40:33 UTC
*** Bug 98771 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2005-07-19 13:16:42 UTC
*** Bug 99570 has been marked as a duplicate of this bug. ***
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2005-07-20 12:40:52 UTC
*** Bug 99715 has been marked as a duplicate of this bug. ***
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2005-07-24 02:28:53 UTC
*** Bug 100097 has been marked as a duplicate of this bug. ***
Comment 21 Artur Wegele 2005-07-24 03:06:45 UTC
This bug does not seems to be attached to the right package.  
I did not found it, by searching for kdegraphics  
That is the reason for all duplicated bugs. 
Comment 22 Gregorio Guidi (RETIRED) gentoo-dev 2005-07-28 14:05:13 UTC
*** Bug 100634 has been marked as a duplicate of this bug. ***
Comment 23 Gregorio Guidi (RETIRED) gentoo-dev 2005-07-30 03:36:45 UTC
*** Bug 100801 has been marked as a duplicate of this bug. ***
Comment 24 Carsten Lohrke (RETIRED) gentoo-dev 2005-09-08 05:04:05 UTC
*** Bug 105236 has been marked as a duplicate of this bug. ***
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2005-09-18 16:31:47 UTC
*** Bug 106374 has been marked as a duplicate of this bug. ***
Comment 26 katerina 2005-09-21 11:17:47 UTC
This bug bit me as well.  Re-emerging imlib fixed it.

Comment 27 Jakub Moc (RETIRED) gentoo-dev 2005-12-03 10:31:31 UTC
*** Bug 114370 has been marked as a duplicate of this bug. ***
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2005-12-03 13:09:44 UTC
*** Bug 114384 has been marked as a duplicate of this bug. ***
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2005-12-09 06:42:38 UTC
*** Bug 114983 has been marked as a duplicate of this bug. ***
Comment 30 Andreas Arens 2005-12-10 13:33:18 UTC
I just ran into this when a world update wanted to emerge kdegraphics-3.4.3-r2.
(X86 2005.1)

The imlib hint was almost right, the dependency did hide in
/usr/lib/imlib2/loaders/gif.la (it did pull /usr/lib/libungif.la).

I know the system was changed from ungif to gif keyword in make.conf a while
ago, so this is partially user fault, but probably worth a hint, especially
since it was not found by a revdep-rebuild that was ran after that.

Reemerging imlib2 (note the '2') did fix it.
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2005-12-11 08:22:09 UTC
*** Bug 115200 has been marked as a duplicate of this bug. ***
Comment 32 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-16 16:57:40 UTC
*** Bug 108435 has been marked as a duplicate of this bug. ***
Comment 33 Gregorio Guidi (RETIRED) gentoo-dev 2005-12-24 02:17:33 UTC
*** Bug 116568 has been marked as a duplicate of this bug. ***
Comment 34 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-26 11:52:05 UTC
*** Bug 116797 has been marked as a duplicate of this bug. ***
Comment 35 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-26 11:52:55 UTC
hm
Comment 36 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-26 11:56:12 UTC
According to a thread in the german part of forums.g.o, it looks like that even the revdep-rebuild version in the latest gentoolkit package fails to rebuild imlib for some reason.
Comment 37 Paul Varner (RETIRED) gentoo-dev 2005-12-26 13:48:41 UTC
garath ~ # emerge -pv gentoolkit
[ebuild   R   ] app-portage/gentoolkit-0.2.1_rc4  0 kB [1]

garath ~ # ldd /usr/kde/3.5/bin/kuickshow
<snip>
        libImlib.so.1 => /usr/lib/libImlib.so.1 (0xb6c6a000)
        libungif.so.4 => /usr/lib/libungif.so.4 (0xb6bf5000)
<snip>

garath ~ # ldd /usr/lib/libImlib.so.1
<snip>
        libungif.so.4 => /usr/lib/libungif.so.4 (0xb7ecb000)
<snip>

garath ~ # emerge -auDNv world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] media-libs/libungif (is blocking media-libs/giflib-4.1.4)
[ebuild  N    ] media-libs/giflib-4.1.4  +X -rle 591 kB

Total size of downloads: 591 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        on the same system.

garath ~ # emerge --unmerge media-libs/libungif

garath ~ # emerge -auDNv world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild  N    ] media-libs/giflib-4.1.4  +X -rle 591 kB

Total size of downloads: 591 kB

Do you want me to merge these packages? [Yes/No] yes
<snip>
>>> media-libs/giflib-4.1.4 merged.

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

garath ~ # emerge -v kuickshow
<snip>
/bin/sed: can't read /usr/lib/libungif.la: No such file or directory
libtool: link: `/usr/lib/libungif.la' is not a valid libtool archive
make[3]: *** [libkdeinit_kuickshow.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/kuickshow-3.5.0/work/kuickshow-3.5.0/kuickshow/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kuickshow-3.5.0/work/kuickshow-3.5.0/kuickshow'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kuickshow-3.5.0/work/kuickshow-3.5.0'
make: *** [all] Error 2

garath ~ # revdep-rebuild --ignore --pretend --extra-verbose
Configuring search environment for revdep-rebuild

revdep-rebuild environment:
SEARCH_DIRS="/bin/ /sbin/ /usr/bin/ /usr/sbin/ /lib/ /usr/lib/ /usr/libexec/ /opt/bin/ /usr/i686-pc-linux-gnu/gcc-bin/3.4.4/ /opt/blackdown-jdk-1.4.2.03/bin/ /opt/blackdown-jdk-1.4.2.03/jre/bin/ /usr/kde/3.5/sbin/ /usr/kde/3.5/bin/ /usr/qt/3/bin/ /opt/vmware/workstation/bin/ /opt/bin/ /usr/i686-pc-linux-gnu/gcc-bin/3.4.4/ /opt/blackdown-jdk-1.4.2.03/bin/ /opt/blackdown-jdk-1.4.2.03/jre/bin/ /usr/kde/3.5/bin/ /usr/qt/3/bin/ /usr/games/bin/ /opt/vmware/workstation/bin/ /opt/limewire/ /usr/local/lib/ //usr/lib/opengl/nvidia/lib/ /usr/i686-pc-linux-gnu/lib/ /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/ /usr/lib/ /usr/lib/openmotif-2.2/ /opt/blackdown-jdk-1.4.2.03/jre/lib/i386/ /opt/blackdown-jdk-1.4.2.03/jre/lib/i386/native_threads/ /opt/blackdown-jdk-1.4.2.03/jre/lib/i386/classic/ /opt/blackdown-jdk-1.4.2.03/jre/lib/i386/server/ /usr/kde/3.5/lib/ /usr/qt/3/lib/ /usr/lib/nspr/ /usr/lib/nss/ /usr/games/lib/ /usr/lib/libstdc++-v3/"
SEARCH_DIRS_MASK="/usr/lib/azureus"
LD_LIBRARY_MASK="libodbcinst.so libodbc.so libjava.so libjvm.so"
CALLED_OPTIONS=""
EMERGE_OPTIONS="--pretend"

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/kde/3.5/lib/kde3/kuickshow.so (requires  libungif.so.4)
  broken /usr/kde/3.5/lib/libkdeinit_kuickshow.so (requires  libungif.so.4)
  broken /usr/lib/libImlib.so.1.9.14 (requires  libungif.so.4)
  broken /usr/lib/libimlib-gif.so (requires  libungif.so.4)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot --pretend =media-libs/imlib-1.9.14-r3 =kde-base/kuickshow-3.5.0

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] media-libs/imlib-1.9.14-r3
[ebuild   R   ] kde-base/kuickshow-3.5.0
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.

garath ~ # revdep-rebuild --extra-verbose
<snip>
Build finished correctly. Removing temporary files...
You can re-run revdep-rebuild to verify that all libraries and binaries
are fixed. If some inconsistency remains, it can be orphaned file, deep
dependency, binary package or specially evaluated library.

garath ~ # ldd /usr/kde/3.5/bin/kuickshow
<snip>
        libImlib.so.1 => /usr/lib/libImlib.so.1 (0xb6c90000)
        libgif.so.4 => /usr/lib/libgif.so.4 (0xb6c1b000)
<snip>

garath ~ # ldd /usr/lib/libImlib.so.1
<snip>
        libgif.so.4 => /usr/lib/libgif.so.4 (0xb7f34000)
<snip>

Reopen, if you have a system that can duplicate the problem and are willing to help troubleshoot.
Comment 38 Anthony Staines 2005-12-26 16:36:58 UTC
Essentially the same problem with kdegraphics 3.4.3-r3 - compilation fails looking for libungif.la. Emerging 'imlib' doesn't seem to help. I'm now tryig emerging 'giflib-4.1.4'. I have neither 'gif' nor 'ungif' in my make.conf, although gif turns up in my USE flags.

emerge --info
Portage 2.0.53 (default-linux/x86/2005.0, gcc-3.3.6, glibc-2.3.5-r2, 2.6.13-gentoo-r3 i686)
=================================================================
System uname: 2.6.13-gentoo-r3 i686 Pentium III (Katmai)
Gentoo Base System version 1.6.13
distcc 2.16 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/grass60/etc /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict userpriv usersandbox"
GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo/ http://gentoo.blueyonder.co.uk http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://mirror.uni-c.dk/gentoo/"
LINGUAS="en_GB en fr de es"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X acl alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 cdparanoia cdr crypt cups curl eds emboss encode esd exif expat f77 fam flac foomaticdb fortran gdbm gif glut gmp gnome gpm gstreamer gtk gtk2 idn imagemagick imlib ipv6 java jpeg junit kde lcms ldap libg++ libwww lua mad mhash mikmod mmx mng motif mozilla mozsvg mp3 mpeg mysql ncurses nls ogg oggvorbis opengl oss pam pcre pda pdflib perl png python qt quicktime readline recode samba sdl slang spell sse ssl svga tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev vorbis xine xml xml2 xmms xv xvid zlib linguas_en_GB linguas_en linguas_fr linguas_de linguas_es userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LC_ALL, LDFLAGS, MAKEOPTS
Comment 39 Carsten Lohrke (RETIRED) gentoo-dev 2005-12-26 16:54:08 UTC
(In reply to comment #37)

Thanks for testing Paul. I don't see why it shouldn't work either, but our user base continuous to file bugs. At least this will find an end, now that libungif is gone. Referencing the (german) thread here, just in case.


http://forums.gentoo.org/viewtopic-t-415882.html
Comment 40 Anthony Staines 2005-12-28 16:20:03 UTC
(In reply to comment #38)
> Essentially the same problem with kdegraphics 3.4.3-r3 - compilation fails
> looking for libungif.la. Emerging 'imlib' doesn't seem to help. I'm now tryig
> emerging 'giflib-4.1.4'. I have neither 'gif' nor 'ungif' in my make.conf,
> although gif turns up in my USE flags.
>

'emerge giflib' worked a treat - all is now well.  Thanks to Paul Varner for a very helpful e-mail which I reproduce :-

'Try the following:

If libungif is still installed,
emerge --unmerge libungif

emerge --oneshot giflib (use oneshot so it doesn't get added to world)

If you don't have the latest gentoolkit which is gentoolkit-0.2.1_rc4

echo "=app-portage/gentoolkit-0.2.1_rc4 ~x86" >> /etc/portage/package.keywords

emerge gentoolkit --pretend (make sure that the latest will be installed)
emerge gentoolkit

revdep-rebuild --ignore --pretend

If you agree with the listing

revdep-rebuild

After this your system should be consistent.

Regards,
Paul'

Comment 41 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 09:40:54 UTC
*** Bug 117102 has been marked as a duplicate of this bug. ***
Comment 42 Scott 2005-12-29 10:15:34 UTC
Worked for me (117102).  Thanks!
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2006-01-03 06:48:35 UTC
*** Bug 117599 has been marked as a duplicate of this bug. ***
Comment 44 Jakub Moc (RETIRED) gentoo-dev 2006-01-08 01:25:52 UTC
*** Bug 118249 has been marked as a duplicate of this bug. ***
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2006-02-05 08:56:06 UTC
*** Bug 121674 has been marked as a duplicate of this bug. ***
Comment 46 Jakub Moc (RETIRED) gentoo-dev 2006-02-07 02:27:01 UTC
*** Bug 121947 has been marked as a duplicate of this bug. ***
Comment 47 Jakub Moc (RETIRED) gentoo-dev 2006-03-11 00:21:40 UTC
*** Bug 125785 has been marked as a duplicate of this bug. ***
Comment 48 Jakub Moc (RETIRED) gentoo-dev 2006-04-03 10:36:17 UTC
*** Bug 128666 has been marked as a duplicate of this bug. ***
Comment 49 Diego Elio Pettenò (RETIRED) gentoo-dev 2006-05-01 21:51:23 UTC
*** Bug 131973 has been marked as a duplicate of this bug. ***
Comment 50 Jakub Moc (RETIRED) gentoo-dev 2006-06-05 04:44:14 UTC
*** Bug 135616 has been marked as a duplicate of this bug. ***
Comment 51 Jakub Moc (RETIRED) gentoo-dev 2006-08-20 12:33:39 UTC
*** Bug 144546 has been marked as a duplicate of this bug. ***
Comment 52 Jakub Moc (RETIRED) gentoo-dev 2006-09-03 04:21:40 UTC
*** Bug 146109 has been marked as a duplicate of this bug. ***
Comment 53 Jakub Moc (RETIRED) gentoo-dev 2006-12-22 10:45:20 UTC
*** Bug 158856 has been marked as a duplicate of this bug. ***