Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 831437 (ffmpeg-5.0) - [TRACKER] Breakage with media-video/ffmpeg-5.0 and media-video/ffmpeg-5.1
Summary: [TRACKER] Breakage with media-video/ffmpeg-5.0 and media-video/ffmpeg-5.1
Status: CONFIRMED
Alias: ffmpeg-5.0
Product: Quality Assurance
Classification: Unclassified
Component: Trackers (show other bugs)
Hardware: All Linux
: Normal normal
Assignee: Gentoo Media-video project
URL:
Whiteboard:
Keywords: Tracker
Depends on: 831486 834384 834393 834399 834408 864721 900947 831480 831481 831482 831483 831485 831487 831595 831604 831607 831608 831614 831617 831619 831620 831621 832734 833868 834359 834360 834369 834370 834371 834372 834374 834376 834377 834378 834379 834380 834381 834382 834383 834385 834386 834387 834388 834390 834391 834392 834394 834396 834397 834398 834400 834401 834402 834403 834404 834405 834406 834407 834409 834415 834416 834418 834419 834420 834421 834422 834423 834424 834425 876748 876760 876963 884393 907406 907948 911567
Blocks: metatracker
  Show dependency tree
 
Reported: 2022-01-19 01:22 UTC by James Beddek
Modified: 2023-12-16 11:50 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Beddek 2022-01-19 01:22:44 UTC
Packages that are known to break with ffmpeg >=5.0
Comment 1 Tadej Obrstar 2022-01-19 09:31:55 UTC
dev-qt/qtwebengine-5.15.2_p20211216 with USE flag system-ffmpeg
net-misc/freerdp-{2.4.1-r1,2.5.0} with USE flag ffmpeg
Comment 2 Andreas Sturmlechner gentoo-dev 2022-01-19 09:35:42 UTC
Trackers are not for talking. File bugs for each individual package with complete build.log attached and make it block this tracker.
Comment 3 Iade Gesso 2022-01-30 19:48:28 UTC
media-libs/opencv-4.5.5
media-libs/chromaprint-1.5.1  with USE flag tools
Comment 4 Iade Gesso 2022-01-30 19:49:30 UTC
media-libs/xine-lib-1.2.11
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-02-12 15:18:15 UTC
(In reply to Iade Gesso from comment #3)
> media-libs/opencv-4.5.5
> media-libs/chromaprint-1.5.1  with USE flag tools

You know by now that we need _new_ bugs for such issues.
Comment 6 Larry the Git Cow gentoo-dev 2022-06-26 02:01:34 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ba29faa6160d0209cd99f49b7dfb5f848393c4d7

commit ba29faa6160d0209cd99f49b7dfb5f848393c4d7
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2022-06-26 02:01:12 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2022-06-26 02:01:12 +0000

    profiles: tweak ffmpeg 5 mask
    
    ... to not additionally mask 9999.
    
    Bug: https://bugs.gentoo.org/831437
    Signed-off-by: Sam James <sam@gentoo.org>

 profiles/package.mask | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2023-04-12 07:15:21 UTC
My provisional plan is to unmask ffmpeg-5 after we change the default ruby to ruby31 in a month to avoid too much backtracking/too many conflicts for users.
Comment 8 Larry the Git Cow gentoo-dev 2023-05-29 20:47:57 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2c2e53c6b731ad88f9488e5ab3649b79ce170d85

commit 2c2e53c6b731ad88f9488e5ab3649b79ce170d85
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2023-05-29 20:46:40 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2023-05-29 20:46:40 +0000

    profiles: unmask ffmpeg-5
    
    But shift the mask to ffmpeg-6. Lets us coalesce rebuilds for users who just
    managed to upgrade openssl because of Ruby default changing (e.g. all GNOME
    users).
    
    Bug: https://bugs.gentoo.org/831437
    Bug: https://bugs.gentoo.org/901257
    Signed-off-by: Sam James <sam@gentoo.org>

 profiles/package.mask | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)