Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 789573 - sci-visualization/paraview-5.9.0 fails to compile with gcc-11
Summary: sci-visualization/paraview-5.9.0 fails to compile with gcc-11
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords: PATCH
: 794124 (view as bug list)
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-05-12 06:35 UTC by Agostino Sarubbo
Modified: 2021-06-15 03:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.xz (build.log.xz,58.11 KB, application/x-xz)
2021-05-12 06:35 UTC, Agostino Sarubbo
Details
gcc11.patch (gcc11.patch,661 bytes, patch)
2021-06-04 12:21 UTC, Benjamin Réveillé
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-05-12 06:35:52 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-visualization/paraview-5.9.0 fails to compile with gcc-11.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
Comment 1 Agostino Sarubbo gentoo-dev 2021-05-12 06:35:54 UTC
Created attachment 707241 [details]
build.log.xz

build log and emerge --info (compressed because it exceeds attachment limit, use 'xzless' to read it)
Comment 2 Agostino Sarubbo gentoo-dev 2021-05-12 06:35:56 UTC
Possible context of error(s):

/var/tmp/portage/sci-visualization/paraview-5.9.0/work/ParaView-v5.9.0/VTK/Rendering/Core/vtkColorTransferFunction.cxx:1874:26: error: ‘numeric_limits’ is not a member of ‘std’
Comment 3 Benjamin Réveillé 2021-06-03 20:39:59 UTC
Exact same error in sci-visualization/paraview-5.9.1

/var/tmp/portage/sci-visualization/paraview-5.9.1/work/ParaView-v5.9.1/VTK/Rendering/Core/vtkColorTransferFunction.cxx: Dans la fonction membre « double vtkColorTransferFunction::FindMinimumXDistance() »:
/var/tmp/portage/sci-visualization/paraview-5.9.1/work/ParaView-v5.9.1/VTK/Rendering/Core/vtkColorTransferFunction.cxx:1874:26: erreur: « numeric_limits » n'est pas un membre de « std »
 1874 |   double distance = std::numeric_limits<double>::max();
      |                          ^~~~~~~~~~~~~~
/var/tmp/portage/sci-visualization/paraview-5.9.1/work/ParaView-v5.9.1/VTK/Rendering/Core/vtkColorTransferFunction.cxx:1874:41: erreur: expected primary-expression before « double »
 1874 |   double distance = std::numeric_limits<double>::max();
      |                                         ^~~~~~
Comment 4 Benjamin Réveillé 2021-06-04 12:21:54 UTC
Created attachment 713574 [details, diff]
gcc11.patch

With this patch ebuild emerges fine

Just drop it in /etc/portage/patches/sci-visualization/Paraview-5.9.1/
Comment 5 Sam James archtester gentoo-dev Security 2021-06-13 17:19:06 UTC
(In reply to Benjamin Réveillé from comment #4)
> Created attachment 713574 [details, diff] [details, diff]
> gcc11.patch
> 
> With this patch ebuild emerges fine
> 
> Just drop it in /etc/portage/patches/sci-visualization/Paraview-5.9.1/

Thanks!
Comment 6 Larry the Git Cow gentoo-dev 2021-06-13 17:58:31 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c3dc785bbc6000bc1ad0c48a10f3877404e046da

commit c3dc785bbc6000bc1ad0c48a10f3877404e046da
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-06-13 16:32:01 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-06-13 17:13:52 +0000

    sci-visualization/paraview: fix build for GCC 11
    
    Closes: https://bugs.gentoo.org/789573
    Signed-off-by: Sam James <sam@gentoo.org>

 .../files/paraview-5.9.0-gcc11-include.patch        | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
Comment 7 Sam James archtester gentoo-dev Security 2021-06-15 03:22:30 UTC
*** Bug 794124 has been marked as a duplicate of this bug. ***