Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 794124 - sci-visualization/paraview-5.9.1 - missing includes: error: ‘numeric_limits’ is not a member of ‘std’
Summary: sci-visualization/paraview-5.9.1 - missing includes: error: ‘numeric_limits’ ...
Status: RESOLVED DUPLICATE of bug 789573
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: gcc-11
  Show dependency tree
 
Reported: 2021-06-04 07:08 UTC by Andreas Fink
Modified: 2021-06-15 03:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch adding missing include files (missing_includes.patch,1.02 KB, patch)
2021-06-04 07:08 UTC, Andreas Fink
Details | Diff
build.log (build.log.bz2,39.64 KB, application/x-bzip2)
2021-06-04 07:12 UTC, Andreas Fink
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Fink 2021-06-04 07:08:37 UTC
Created attachment 713559 [details, diff]
patch adding missing include files

paraview-5.9.1 fails to build with g++ (Gentoo 11.1.0 p1) 11.1.0.
A patch is attached, which adds the missing include:
#include <limits>

The patch saved as /etc/portage/patches/sci-visualization/paraview-5.9.1/missing_includes.patch fixes the build issues.

Build log and emerge info added too
Comment 1 Andreas Fink 2021-06-04 07:11:31 UTC
Portage 3.0.19 (python 3.8.10-final-0, default/linux/amd64/17.1, gcc-11.1.0, glibc-2.33, 5.12.8-gentoo x86_64)
=================================================================
System uname: Linux-5.12.8-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2640_v4_@_2.40GHz-with-glibc2.2.5
KiB Mem:     8151164 total,   2898268 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 03 Jun 2021 22:45:01 +0000
Head commit of repository gentoo: 4d090ae52f428f679ac80f0e5cc9db42204a2fb0
sh bash 5.1_p8
ld GNU ld (Gentoo 2.36.1 p3) 2.36.1
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0::gentoo
dev-lang/python:          2.7.18_p10::gentoo, 3.8.10_p1::gentoo, 3.9.5_p1::gentoo, 3.10.0_beta2::gentoo
dev-lang/rust:            1.52.1::gentoo
dev-util/cmake:           3.20.3::gentoo
sys-apps/baselayout:      2.7-r2::gentoo
sys-apps/openrc:          0.43.3::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::gentoo
sys-devel/gcc:            11.1.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: --quiet
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

user_ebuilds
    location: /usr/local/portage
    masters: gentoo

Binary Repositories:

vserverli
    priority: 10
    sync-uri: https://www.vserverli.de/gentoo_packages

Installed sets: @deps, @fdroidserver-deps, @mega-deps, @openvpn, @programming-tools, @rss, @sfshare-pythontools, @wireless-hotspot, @work-laptop
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/dracut/modules.d/60crypt-ssh /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
DISTDIR="/home/portage/distfiles"
EMERGE_DEFAULT_OPTS="--buildpkg --jobs=2 --oneshot --keep-going=y --usepkg --buildpkg-exclude app-emulation/virtualbox-modules --buildpkg-exclude x11-drivers/nvidia-drivers --buildpkg-exclude sys-kernel/gentoo-sources"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j4"
PKGDIR="/home/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/home/portage/tmp"
USE="X acl acpi alsa amd64 berkdb bluray bzip2 cleartype cli corefonts crypt cups dbus dri dvb elogind fam fortran gdbm gif gnome-keyring gtk iconv ipv6 java jpeg jpeg2k kpathsea libglvnd libtirpc lirc mmx mng multilib ncurses nls nptl opengl openmp pam pcre pdf png pulseaudio qt4 qt5 readline seccomp split-usr sse sse2 ssl startup-notification svg tcpd threads tiff truetype type1 unicode v4l vaapi vdpau vulkan xattr xcb xcomposite xinerama zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86 AMDGPU NVPTX" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="intel i965 nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 2 Andreas Fink 2021-06-04 07:12:33 UTC
Created attachment 713562 [details]
build.log
Comment 3 Sam James archtester gentoo-dev Security 2021-06-15 03:22:30 UTC
Patched now, thank you!

*** This bug has been marked as a duplicate of bug 789573 ***