Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 73084 - teamspeak2-server-bin needs to depend on app-emulation/emul-linux-x86-baselibs-1.0 or it crashes on startup
Summary: teamspeak2-server-bin needs to depend on app-emulation/emul-linux-x86-baselib...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Jeremy Huddleston (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-01 15:13 UTC by Rob Ostensen
Modified: 2005-02-15 07:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
updated ebuild (teamspeak2-server-bin-2.0.20.1.ebuild,2.46 KB, text/plain)
2004-12-01 15:16 UTC, Rob Ostensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Ostensen 2004-12-01 15:13:34 UTC
teamspeak2-server-bin requires app-emulation/emul-linux-x86-baselibs-1.0 and not a later version. I'm unsure why later versions cause problems. There is also a bug in teamspeak2-client-bin, the depends haven't been updated in the ebuild as per bug #55893 http://bugs.gentoo.org/show_bug.cgi?id=55893

Reproducible: Always
Steps to Reproduce:
1. with an up-to-date system, emerge teamspeak-server-bin
2. /etc/init.d/teamspeak2-server start
3. failure.

Actual Results:  
teamspeak2 fails to start with error 230 

Expected Results:  
worked 

see also http://bugs.gentoo.org/show_bug.cgi?id=55893
Comment 1 Rob Ostensen 2004-12-01 15:16:23 UTC
Created attachment 45091 [details]
updated ebuild

updated ebuild with corrected dependancy
Comment 2 Christian Parpart (RETIRED) gentoo-dev 2004-12-08 15:50:04 UTC
seems to be already fixed by eradicator on 09-Jul-04.
Comment 3 Rob Ostensen 2004-12-08 21:29:01 UTC
nope. the ebuild still depends on app-emulation/emul-linux-x86-baselibs which has a newer stable version which depends on app-emulation/emul-linux-x86-glibc.  Like I said earlier I'm not sure why this binary only works with version 1.0 of app-emulation/emul-linux-x86-baselibs, but it just won't run the executable at all with the current stable app-emulation/emul-linux-x86-baselibs on amd64, therefore it needs to depend on the specific version of app-emulation/emul-linux-x86-baselibs-1.0
Comment 4 Rob Ostensen 2004-12-08 21:38:58 UTC
see also http://bugs.gentoo.org/show_bug.cgi?id=72030 this is the same issue but bug #72030 doesn't mention the server ebuild. should I move this over there?
Comment 5 Christian Parpart (RETIRED) gentoo-dev 2004-12-09 03:01:17 UTC
Well, yeah, sorry, I obviousely read the .ebuild too fast and oversaw this ;-)
However, I'm not able to test this, I'm not having a amd64 box (unfortunately:(

So, someone else shall test this. eradicator? amd64 team?
Comment 6 Jeremy Huddleston (RETIRED) gentoo-dev 2005-01-11 05:10:43 UTC
fixed in cvs
Comment 7 Waldo 2005-02-07 19:30:34 UTC
So this was fixed a month ago... what happens now to get it moved into stable?  (Because current stable.. isn't.)
Comment 8 Christian Parpart (RETIRED) gentoo-dev 2005-02-09 07:07:20 UTC
> So this was fixed a month ago... what happens now to 
> get it moved into stable?  (Because current stable.. isn't.)

test it; report that it's working, and request to be marked stable.
Comment 9 Francesco Lamonica 2005-02-15 07:56:30 UTC
without downgrading the emul-libs it is sufficient to set the GCONV_PATH env variabiale to /usr/lib32/gconv
export GCONV_PATH=/usr/lib32/gconv