Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55893 - Teamspeak client crashes with Runtime error 230 on amd64 with all 32bit emulation libraries installed
Summary: Teamspeak client crashes with Runtime error 230 on amd64 with all 32bit emula...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: AMD64 Project
Depends on:
Reported: 2004-07-02 08:42 UTC by Michael
Modified: 2005-02-15 07:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

strace of TeamSpeak (team-strace.txt,5.64 KB, text/plain)
2004-07-02 08:43 UTC, Michael

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2004-07-02 08:42:41 UTC
On attempt to run teamspeak, it errors out with Runtime error 230. This app used to work on a previous amd64 install with the 32bit emul libs, and now appears to be hosed. will post strace info

Reproducible: Always
Steps to Reproduce:
1.Emerge teamspeak2-client-bin
2.attempt to run TeamSpeak

Actual Results:  
Runtime error 230

Expected Results:  
Software should have started
Comment 1 Michael 2004-07-02 08:43:59 UTC
Created attachment 34653 [details]
strace of TeamSpeak
Comment 2 Danny van Dyk (RETIRED) gentoo-dev 2004-07-02 12:08:31 UTC
Michael: Please give us the exact version number of the emul-libs you've got installed. Further provide the version numbers of those emul-libs that worked successfully.
Comment 3 Herbie Hopkins (RETIRED) gentoo-dev 2004-07-20 05:23:17 UTC
same error here (Runtime error 230 at 0805D21F) with:
works perfectly with:
Comment 4 Danny van Dyk (RETIRED) gentoo-dev 2004-08-23 15:10:29 UTC
Set dependencies to =app-emulation/emul-linux-{base,x}libs-1.0 for teamspeak-client-bin.
Comment 5 Francesco Lamonica 2005-02-15 07:57:47 UTC
without downgrading the emul-libs it is sufficient to set the GCONV_PATH env variable to /usr/lib32/gconv
export GCONV_PATH=/usr/lib32/gconv