Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 715726 - app-emulation/virtualbox-modules-6.1.4-r1 failed to build with 5.6.0 kernel
Summary: app-emulation/virtualbox-modules-6.1.4-r1 failed to build with 5.6.0 kernel
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: https://www.virtualbox.org/ticket/19312
Whiteboard:
Keywords:
: 716138 716524 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-01 07:58 UTC by Fulgurance
Modified: 2020-04-18 15:42 UTC (History)
20 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge info (file_715726.txt,6.91 KB, text/plain)
2020-04-01 07:58 UTC, Fulgurance
Details
This is the build.log file. (build.log,196.07 KB, text/x-log)
2020-04-01 09:50 UTC, Ognjan Kirilov Iordanov
Details
This patch work for me (kernel-5.6.patch,6.34 KB, patch)
2020-04-01 10:22 UTC, Yuriy
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fulgurance 2020-04-01 07:58:13 UTC
Created attachment 628368 [details]
Emerge info

Hello, yesterday i have updated to the last gentoo-sources, but i try to rebuild modules, i have this problem with virtualbox-modules: http://dpaste.com/3SQV956
Comment 1 Ognjan Kirilov Iordanov 2020-04-01 09:50:18 UTC
Created attachment 628372 [details]
This is the build.log file.

I have the same problem.
Comment 2 Andrea Postiglione 2020-04-01 09:55:20 UTC
https://www.virtualbox.org/ticket/19312

patch for linux 5.6
Comment 3 Yuriy 2020-04-01 10:22:41 UTC
Created attachment 628386 [details, diff]
This patch work for me
Comment 4 Adam Carter 2020-04-01 10:47:19 UTC
(In reply to Yuriy from comment #3)
> Created attachment 628386 [details, diff] [details, diff]
> This patch work for me

This one works for me too. Thanks.
Comment 5 Ivan 2020-04-01 11:26:27 UTC
(In reply to Andrea Postiglione from comment #2)
> https://www.virtualbox.org/ticket/19312
> 
> patch for linux 5.6

Worked for me too. Thanks.
Comment 6 Kajzer 2020-04-02 08:05:31 UTC
Patch is working here as well, thanks.
Comment 7 Sam James archtester gentoo-dev Security 2020-04-07 07:06:49 UTC
*** Bug 716524 has been marked as a duplicate of this bug. ***
Comment 8 Silvio 2020-04-08 21:06:49 UTC
this patch works for me too.
Comment 9 Sam James archtester gentoo-dev Security 2020-04-10 13:26:38 UTC
*** Bug 716138 has been marked as a duplicate of this bug. ***
Comment 11 otherz 2020-04-12 16:04:25 UTC
hi, i have some problem https://hastebin.com/ijufirawoc.makefile

virtualbox-6.1.4-r2
gcc-9.3.0
5.6.3-gentoo
Comment 12 Vasilis Lourdas 2020-04-18 12:40:05 UTC
(In reply to usforos from comment #11)
> hi, i have some problem https://hastebin.com/ijufirawoc.makefile
> 
> virtualbox-6.1.4-r2
> gcc-9.3.0
> 5.6.3-gentoo

Stabilization of 6.1.6 which is compatible with Linux 5.6.x is in progress...
Comment 13 Lars Wendler (Polynomial-C) gentoo-dev 2020-04-18 12:47:02 UTC
(In reply to Vasilis Lourdas from comment #12)
> (In reply to usforos from comment #11)
> > hi, i have some problem https://hastebin.com/ijufirawoc.makefile
> > 
> > virtualbox-6.1.4-r2
> > gcc-9.3.0
> > 5.6.3-gentoo
> 
> Stabilization of 6.1.6 which is compatible with Linux 5.6.x is in progress...

No idea where you got that piece of information from but that's plain wrong. Stabilization of virtualbox-6.1.x series is nothing I plan to do anytime soon.
Comment 14 Larry the Git Cow gentoo-dev 2020-04-18 15:42:09 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=589205766d01dfbffb4b4e95a99aa5dfa19a0389

commit 589205766d01dfbffb4b4e95a99aa5dfa19a0389
Author:     Lars Wendler <polynomial-c@gentoo.org>
AuthorDate: 2020-04-18 14:58:56 +0000
Commit:     Lars Wendler <polynomial-c@gentoo.org>
CommitDate: 2020-04-18 15:42:02 +0000

    virtualbox packages: Security bump to ver 5.2.40, 6.0.20 and 6.1.6
    
    Bug: https://bugs.gentoo.org/717626
    Closes: https://bugs.gentoo.org/715726
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

 app-emulation/virtualbox-additions/Manifest        |   3 +
 .../virtualbox-additions-5.2.40.ebuild             |  33 ++
 .../virtualbox-additions-6.0.20.ebuild             |  34 ++
 .../virtualbox-additions-6.1.6.ebuild              |  34 ++
 app-emulation/virtualbox-bin/Manifest              |  10 +
 .../virtualbox-bin-5.2.40.137108.ebuild            | 287 ++++++++++++
 .../virtualbox-bin-6.0.20.137117.ebuild            | 292 ++++++++++++
 .../virtualbox-bin-6.1.6.137129.ebuild             | 292 ++++++++++++
 app-emulation/virtualbox-extpack-oracle/Manifest   |   3 +
 .../virtualbox-extpack-oracle-5.2.40.137108.ebuild |  42 ++
 .../virtualbox-extpack-oracle-6.0.20.137117.ebuild |  43 ++
 .../virtualbox-extpack-oracle-6.1.6.137129.ebuild  |  43 ++
 app-emulation/virtualbox-guest-additions/Manifest  |   4 +
 .../virtualbox-guest-additions-5.2.40.ebuild       | 229 +++++++++
 .../virtualbox-guest-additions-6.0.20.ebuild       | 216 +++++++++
 .../virtualbox-guest-additions-6.1.6.ebuild        | 215 +++++++++
 app-emulation/virtualbox-modules/Manifest          |   3 +
 .../virtualbox-modules-5.2.40.ebuild               |  59 +++
 .../virtualbox-modules-6.0.20.ebuild               |  55 +++
 .../virtualbox-modules-6.1.6.ebuild                |  55 +++
 app-emulation/virtualbox/Manifest                  |   4 +
 app-emulation/virtualbox/virtualbox-5.2.40.ebuild  | 496 ++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.0.20.ebuild  | 511 +++++++++++++++++++++
 app-emulation/virtualbox/virtualbox-6.1.6.ebuild   | 507 ++++++++++++++++++++
 24 files changed, 3470 insertions(+)