Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716524 - app-emulation/virtualbox-6.1.4-r2: Failed build on kernel 5.6
Summary: app-emulation/virtualbox-6.1.4-r2: Failed build on kernel 5.6
Status: RESOLVED DUPLICATE of bug 715726
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2020-04-07 07:01 UTC by kmyuan2006
Modified: 2020-04-07 07:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
ebulid file (virtualbox-modules-6.1.4-r2.ebuild,1.39 KB, text/plain)
2020-04-07 07:01 UTC, kmyuan2006
Details
patch file (virtualbox-modules-6.1.4-r2.patch,6.79 KB, patch)
2020-04-07 07:03 UTC, kmyuan2006
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kmyuan2006 2020-04-07 07:01:23 UTC
Created attachment 630950 [details]
ebulid file

1.Corresponding to the version of app-emulation/virtualbox-6.1.4-r2
2.According to https://www.virtualbox.org/ticket/19312 time.patch and ioremap_nocache replacement patches are required
Comment 1 kmyuan2006 2020-04-07 07:03:56 UTC
Created attachment 630952 [details, diff]
patch file

No patch compilation error:
/var/tmp/portage/app-emulation/virtualbox-modules-6.1.4-r2/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1465:32: error: implicit declaration of function ‘ioremap_nocache’; did you mean ‘ioremap_cache’? [-Werror=implicit-function-declaration]
 1465 |                              ? ioremap_nocache(pMemLnxToMap->Core.u.Phys.PhysBase + offSub, cbSub)
      |                                ^~~~~~~~~~~~~~~
      |                                ioremap_cache


/var/tmp/portage/app-emulation/virtualbox-modules-6.1.4-r2/work/vboxdrv/include/iprt/time.h:379:13: error: dereferencing pointer to incomplete type ‘struct timeval’
  379 |     pTimeval->tv_sec = (time_t)i64;
      |             ^~
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-04-07 07:06:49 UTC
Thanks for the report. In this instance, it looks like a duplicate. Have a look at the bug I've marked it as a dup of.

*** This bug has been marked as a duplicate of bug 715726 ***
Comment 3 kmyuan2006 2020-04-07 07:39:39 UTC
thanks
Comment 4 kmyuan2006 2020-04-07 07:40:10 UTC
(In reply to Sam James (sam_c) (security padawan) from comment #2)
> Thanks for the report. In this instance, it looks like a duplicate. Have a
> look at the bug I've marked it as a dup of.
> 
> *** This bug has been marked as a duplicate of bug 715726 ***

tanks