Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 716138 - app-emulation/virtualbox-modules-6.1.4-r1 : /.../memobj-r0drv-linux.c: error: implicit declaration of function ioremap_nocache
Summary: app-emulation/virtualbox-modules-6.1.4-r1 : /.../memobj-r0drv-linux.c: error:...
Status: RESOLVED DUPLICATE of bug 715726
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-04 08:42 UTC by Toralf Förster
Modified: 2020-04-10 13:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,14.91 KB, text/plain)
2020-04-04 08:43 UTC, Toralf Förster
Details
app-emulation:virtualbox-modules-6.1.4-r1:20200404-082341.log (app-emulation:virtualbox-modules-6.1.4-r1:20200404-082341.log,81.07 KB, text/plain)
2020-04-04 08:43 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,39.49 KB, text/plain)
2020-04-04 08:43 UTC, Toralf Förster
Details
environment (environment,88.98 KB, text/plain)
2020-04-04 08:43 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,10.66 KB, application/x-bzip)
2020-04-04 08:43 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,5.33 KB, application/x-bzip)
2020-04-04 08:43 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2020-04-04 08:42:53 UTC
/var/tmp/portage/app-emulation/virtualbox-modules-6.1.4-r1/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c: In function rtR0MemObjNativeMapKernel:
/var/tmp/portage/app-emulation/virtualbox-modules-6.1.4-r1/work/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1465:32: error: implicit declaration of function ioremap_nocache; did you mean ioremap_cache? [-Werror=implicit-function-declaration]
 1465 |                              ? ioremap_nocache(pMemLnxToMap->Core.u.Phys.PhysBase + offSub, cbSub)
      |                                ^~~~~~~~~~~~~~~
      |                                ioremap_cache

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_no-multilib_hardened-libressl-20200403-101709

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.0 *
/usr/lib/llvm/10
10.0.0
Available Python interpreters, in order of preference:
  [1]   python3.8
  [2]   python3.7
  [3]   python3.6
  [4]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.42.0 *
The Glorious Glasgow Haskell Compilation System, version 8.0.2

timestamp of HEAD at this tinderbox image:
/var/db/repos/gentoo	Sat 04 Apr 2020 07:37:48 AM UTC
/var/db/repos/libressl	Fri 03 Apr 2020 07:10:10 PM UTC

emerge -qpvO app-emulation/virtualbox-modules
[ebuild  N    ] app-emulation/virtualbox-modules-6.1.4-r1  USE="-pax_kernel"
Comment 1 Toralf Förster gentoo-dev 2020-04-04 08:43:00 UTC
Created attachment 629804 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2020-04-04 08:43:08 UTC
Created attachment 629806 [details]
app-emulation:virtualbox-modules-6.1.4-r1:20200404-082341.log
Comment 3 Toralf Förster gentoo-dev 2020-04-04 08:43:16 UTC
Created attachment 629808 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2020-04-04 08:43:19 UTC
Created attachment 629810 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2020-04-04 08:43:23 UTC
Created attachment 629812 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2020-04-04 08:43:30 UTC
Created attachment 629814 [details]
logs.tbz2
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2020-04-10 13:26:38 UTC
Slightly different build error to bug 715726 but upstream are patching various new kernel issues in the same upstream bug.

*** This bug has been marked as a duplicate of bug 715726 ***
Comment 8 Steven Green 2020-04-10 13:33:20 UTC
I can confirm that the proposed patch in bug #715726 fixed this for me with kernel gentoo-sources-5.6.3