Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 690296 (linux-headers-5.2) - linux-headers-5.2 porting
Summary: linux-headers-5.2 porting
Status: RESOLVED FIXED
Alias: linux-headers-5.2
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: Tracker
Depends on: 689808 690418 690788 692336 692352 692428 692430 692544 692546 692550 701958
Blocks:
  Show dependency tree
 
Reported: 2019-07-20 16:21 UTC by Sergei Trofimovich
Modified: 2020-04-25 11:37 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei Trofimovich gentoo-dev 2019-07-20 16:21:27 UTC
This is a tracker for porting to linux-headers-5.2.
There is a t least one known breakage khown today:

'SIOCGSTAMP' is not defined directly to avoid 32-bit vs. 64-bit timeval struct: https://github.com/torvalds/linux/commit/0768e17073dc527ccd18ed5f96ce85f9985e9115
Comment 1 Larry the Git Cow gentoo-dev 2019-07-20 16:29:26 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d7d7c45f4eaa0464e00343fb5a5cd31eabd437b0

commit d7d7c45f4eaa0464e00343fb5a5cd31eabd437b0
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2019-07-20 16:26:23 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2019-07-20 16:29:18 +0000

    package.mask: mask >=sys-kernel/linux-headers-5.2
    
    Bug: https://bugs.gentoo.org/690296
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 2 Sergei Trofimovich gentoo-dev 2019-07-20 16:50:17 UTC
(In reply to Sergei Trofimovich from comment #0)
> This is a tracker for porting to linux-headers-5.2.
> There is a t least one known breakage khown today:
> 
> 'SIOCGSTAMP' is not defined directly to avoid 32-bit vs. 64-bit timeval
> struct:
> https://github.com/torvalds/linux/commit/
> 0768e17073dc527ccd18ed5f96ce85f9985e9115

Sent https://lkml.org/lkml/2019/7/20/108 to clarify proper inclusion of 'SIOCGSTAMP' from userland.
Comment 3 Maciej S. Szmigiero 2019-07-21 15:29:18 UTC
FYI: app-emulation/qemu-4.0.0-r3 compiles fine with linux-headers-5.2 after
applying this upstream patch (small whitespace adaptation needed):
https://git.qemu.org/?p=qemu.git;a=commit;h=6d5d5dde9adb5acb32e6b8e3dfbf47fff0f308d2
Comment 4 Sergei Trofimovich gentoo-dev 2019-07-21 18:59:42 UTC
(In reply to Maciej S. Szmigiero from comment #3)
> FYI: app-emulation/qemu-4.0.0-r3 compiles fine with linux-headers-5.2 after
> applying this upstream patch (small whitespace adaptation needed):
> https://git.qemu.org/?p=qemu.git;a=commit;
> h=6d5d5dde9adb5acb32e6b8e3dfbf47fff0f308d2

Please file a new bug and set it as blocking this one. That way qemu maintainer can apply it earlier.
Comment 5 Jory A. Pratt gentoo-dev 2019-07-25 03:16:56 UTC
*** Bug 690306 has been marked as a duplicate of this bug. ***
Comment 6 Larry the Git Cow gentoo-dev 2019-08-15 22:52:23 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=df1d77a7378f736f08bf931fcd3c4cfabbb727b0

commit df1d77a7378f736f08bf931fcd3c4cfabbb727b0
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2019-08-15 22:50:38 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2019-08-15 22:52:16 +0000

    profiles/package.mask: unmask >=sys-kernel/linux-headers-5.2
    
    Lift mask on >=sys-kernel/linux-headers-5.2 as all major users
    were worked around upstream and there is no fix in kernel headers
    or glibc yet.
    
    Let's find more users of SIOCGSTAMP.
    
    Bug: https://bugs.gentoo.org/690296
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 profiles/package.mask | 5 -----
 1 file changed, 5 deletions(-)
Comment 7 Sergei Trofimovich gentoo-dev 2019-08-18 08:46:20 UTC
Added example fix for SIOCGSTAMP to https://wiki.gentoo.org/wiki/Project:Toolchain#linux-headers-5.2