Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 689808 - www-client/firefox-68.0 - .../work/firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc:67:27: error: use of undeclared identifier 'SIOCGSTAMP'
Summary: www-client/firefox-68.0 - .../work/firefox-68.0/media/webrtc/trunk/webrtc/rtc...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL: https://bugzilla.mozilla.org/show_bug...
Whiteboard:
Keywords:
: 690306 (view as bug list)
Depends on:
Blocks: linux-headers-5.2
  Show dependency tree
 
Reported: 2019-07-14 02:55 UTC by cyrillic
Modified: 2019-08-15 23:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
firefox-68.0-buildlog.xz (firefox-68.0-buildlog.xz,155.77 KB, application/x-xz)
2019-07-14 02:57 UTC, cyrillic
Details
simple firefox fix (firefox-kernel-52.patch,469 bytes, patch)
2019-07-20 18:14 UTC, Maciej S. Szmigiero
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cyrillic 2019-07-14 02:55:34 UTC
www-client/firefox-68.0 fails to compile work/firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc:67:27: error: use of undeclared identifier 'SIOCGSTAMP' when glibc is compiled with linux-headers-5.2
If glibc is compiled with linux-headers-5.1 then firefox does not have a problem.

Reproducible: Always




# emerge --info
Portage 2.3.69 (python 3.7.3-final-0, default/linux/amd64/17.1/desktop/gnome/systemd, gcc-9.1.0, glibc-2.29-r2, 5.2.0 x86_64)
=================================================================
System uname: Linux-5.2.0-x86_64-AMD_Ryzen_Threadripper_2970WX_24-Core_Processor-with-gentoo-2.6
KiB Mem:    65917792 total,  51690132 free
KiB Swap:          0 total,         0 free
Head commit of repository qt: 2cb06f0b92af822a35ca35debbc2d1d986acae11

Head commit of repository gentoo: 1924f7acd322361a73059d7210ab49c5762764c5

sh bash 5.0_p7
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p7::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.7.3::gentoo
dev-util/cmake:           3.14.5::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.1.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.2::newstuff (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

newstuff
    location: /mnt/repos/newstuff
    masters: gentoo
    priority: -1030
    eclass-overrides: fixes

qt
    location: /mnt/repos/qt
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/proj/qt.git
    masters: gentoo
    priority: -1020
    eclass-overrides: fixes

gnomelive
    location: /mnt/repos/gnomelive
    masters: gentoo
    priority: -1010
    eclass-overrides: fixes

gentoo
    location: /mnt/repos/gentoo
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/gentoo.git
    priority: -1000
    eclass-overrides: fixes

crossdev
    location: /mnt/repos/crossdev
    masters: gentoo
    eclass-overrides: fixes

fixes
    location: /mnt/repos/fixes
    masters: gentoo
    priority: 10
    eclass-overrides: fixes

Installed sets: @clang, @system
ACCEPT_KEYWORDS="* amd64 ~*"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/mnt/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j48"
PKGDIR="/var/tmp/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X a52 aac acl alsa amd64 avahi berkdb bluetooth bluray boost bzip2 cairo caps cdr colord cpudetection cracklib css cups curl custom-cflags cxx dbus drm dts dvd eds egl encode exif expat fbcon ffmpeg flac flickr fontconfig gdbm gif glamor glib gnome gnome-keyring gpm graphite gstreamer gtk gtk3 harfbuzz ibus icu imagemagick introspection ipv6 jpeg kmod kms lcms libass libnotify libsamplerate lzma mp3 nautilus ncurses networkmanager nls nptl nss numa ogg opengl openmp openssl opus orc pam pango pcre pdf png policykit postproc postscript pulseaudio python readline samba speex spell ssl ssp static-analyzer svg systemd tcl theora threads tiff tools tracker truetype udev unicode upnp-av usb user-session utils v4l vala vorbis vpx vulkan wayland webp x264 x265 xcb xmp xscreensaver xv xvmc zeroconf zlib zstd" ABI_X86="64" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" CURL_SSL="nss" ELIBC="glibc" INPUT_DEVICES="libinput wacom" KERNEL="linux" L10N="en" LLVM_TARGETS="AMDGPU BPF X86" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_7" RUBY_TARGETS="ruby26" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="amdgpu intel nouveau radeon radeonsi"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 cyrillic 2019-07-14 02:57:59 UTC
Created attachment 582810 [details]
firefox-68.0-buildlog.xz
Comment 2 Jory A. Pratt gentoo-dev 2019-07-18 01:54:36 UTC
Please show me the contect of /usr/include/sys/ioctl.h
Comment 3 cyrillic 2019-07-18 04:16:51 UTC
I found the problem :
https://github.com/torvalds/linux/commit/0768e17073dc527ccd18ed5f96ce85f9985e9115

app-emulation/qemu also fails for the same reason.
Comment 4 Sergei Trofimovich (RETIRED) gentoo-dev 2019-07-20 16:19:02 UTC
Yeah, I had to tweak linux-atm today thinking it's a one-off: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=408621819a85bf67a73efd33a06ea371c20ea5a2

Looks like it's not. I'll mask linux-headers-5.2 until we sort it out.
Comment 5 Maciej S. Szmigiero 2019-07-20 18:13:58 UTC
It looks like it should be safe to simply include the new header file as it
will auto-detect whether to use SIOCGSTAMP_OLD or SIOCGSTAMP_NEW based on
the size of struct timeval:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0768e17073dc527ccd18ed5f96ce85f9985e9115

I will attach a simple patch that I have used to compile www-client/firefox-68.0.1 with sys-kernel/linux-headers-5.2.
Comment 6 Maciej S. Szmigiero 2019-07-20 18:14:36 UTC
Created attachment 583778 [details, diff]
simple firefox fix
Comment 7 Thomas Deutschmann gentoo-dev Security 2019-08-03 15:37:53 UTC
I'll add upstream patch.
Comment 8 cyrillic 2019-08-06 00:35:25 UTC
I am able to compile firefox-69.0_beta10 without this patch, so it looks like upstream is taking care of things.
Comment 9 Thomas Deutschmann gentoo-dev Security 2019-08-14 23:36:35 UTC
Fix is in 68.0.2.
Comment 10 Arfrever Frehtes Taifersar Arahesis 2019-08-15 23:10:01 UTC
*** Bug 690306 has been marked as a duplicate of this bug. ***