Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 692352 - dev-qt/qtwebengine-5.12.4 fails to build with >=sys-kernel/linux-headers-5.2: error: ‘SIOCGSTAMP’ was not declared in this scope
Summary: dev-qt/qtwebengine-5.12.4 fails to build with >=sys-kernel/linux-headers-5.2:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal with 2 votes (vote)
Assignee: Qt Bug Alias
URL: https://bugreports.qt.io/browse/QTBUG...
Whiteboard:
Keywords:
: 693600 693684 694106 (view as bug list)
Depends on:
Blocks: linux-headers-5.2 qt-5.12.5-stable
  Show dependency tree
 
Reported: 2019-08-17 11:00 UTC by peteru
Modified: 2019-10-29 20:49 UTC (History)
44 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (dev-qt_qtwebengine-5.12.4_build.log,214.32 KB, application/octet-stream)
2019-08-17 13:29 UTC, peteru
Details
Fix missing #define (0001-fix-build-after-y2038-changes-in-glibc.patch,863 bytes, patch)
2019-08-17 17:38 UTC, John Bowler
Details | Diff
#include <linux/sockios.h> to fix missing #define of SIOCGSTAMP in later glibc versions (0001-fix-build-after-y2038-changes-in-glibc.patch,859 bytes, patch)
2019-08-17 20:29 UTC, John Bowler
Details | Diff
emerge info for amd athlon 11 (emerge.inf,5.59 KB, text/plain)
2019-08-24 07:32 UTC, Geoff Madden
Details
point of failure after applyting sockios.h patch (point_of_failure-qtwebengine-5.12.4,2.15 KB, text/plain)
2019-08-24 16:57 UTC, Geoff Madden
Details
User Patch (linux-headers-5.2.patch,417 bytes, patch)
2019-08-26 01:58 UTC, Dane (c1pher) Smith
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description peteru 2019-08-17 11:00:19 UTC
This looks like a compatibility issue with kernel 5.2 as documented here:

https://bugreports.qt.io/browse/QTBUG-76963
Comment 1 peteru 2019-08-17 11:01:57 UTC
FAILED: obj/third_party/webrtc/rtc_base/rtc_base_generic/physicalsocketserver.o 
/usr/bin/x86_64-pc-linux-gnu-g++ -MMD -MF obj/third_party/webrtc/rtc_base/rtc_base_generic/physicalsocketserver.o.d -DWEBRTC_BUILT_IN_SSL_ROOT_CERTIFICATES -DV8_DEPRECATION_WARNINGS -DUSE_UDEV -DUSE_AURA=1 -DUSE_NSS_CERTS=1 -DUSE_OZONE=1 -DNO_TCMALLOC -DFULL_SAFE_BROWSING -DSAFE_BROWSING_CSD -DSAFE_BROWSING_DB_LOCAL -DOFFICIAL_BUILD -DCHROMIUM_BUILD -DFIELDTRIAL_TESTING_ENABLED -DTOOLKIT_QT -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -DWEBRTC_ENABLE_PROTOBUF=1 -DHAVE_SCTP -DENABLE_EXTERNAL_AUTH -DUSE_BUILTIN_SW_CODECS -DHAVE_WEBRTC_VIDEO -DHAVE_WEBRTC_VOICE -DLOGGING_INSIDE_WEBRTC -DWEBRTC_NON_STATIC_TRACE_EVENT_HANDLERS=0 -DGTEST_RELATIVE_PATH -DWEBRTC_CHROMIUM_BUILD -DWEBRTC_POSIX -DWEBRTC_LINUX -DABSL_ALLOCATOR_NOTHROW=1 -DNO_MAIN_THREAD_WRAPPING -I../../3rdparty/chromium/third_party/boringssl/src/include -Igen -I../../3rdparty/chromium -I../../3rdparty/chromium/third_party/webrtc_overrides -I../../3rdparty/chromium/third_party/webrtc -Igen -I../../3rdparty/chromium/third_party/boringssl/src/include -fno-strict-aliasing --param=ssp-buffer-size=4 -fstack-protector -funwind-tables -fPIC -pipe -pthread -m64 -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wno-unused-local-typedefs -Wno-maybe-uninitialized -Wno-deprecated-declarations -fno-delete-null-pointer-checks -Wno-comments -Wno-dangling-else -Wno-packed-not-aligned -Wno-missing-field-initializers -Wno-unused-parameter -O2 -fno-ident -fdata-sections -ffunction-sections -fno-omit-frame-pointer -g0 -fvisibility=hidden -isystem ../../3rdparty/chromium/third_party/abseil-cpp -std=gnu++14 -Wno-narrowing -Wno-attributes -Wno-class-memaccess -Wno-subobject-linkage -fno-exceptions -fno-rtti -fvisibility-inlines-hidden -c ../../3rdparty/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc -o obj/third_party/webrtc/rtc_base/rtc_base_generic/physicalsocketserver.o
../../3rdparty/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc: In function ‘int64_t GetSocketRecvTimestamp(int)’:
../../3rdparty/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc:74:27: error: ‘SIOCGSTAMP’ was not declared in this scope; did you mean ‘SIOCGARP’?
   74 |   int ret = ioctl(socket, SIOCGSTAMP, &tv_ioctl);
      |                           ^~~~~~~~~~
      |                           SIOCGARP
Comment 2 peteru 2019-08-17 11:02:52 UTC
# emerge --info
Portage 2.3.71 (python 3.6.9-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-9.2.0, glibc-2.29-r4, 5.2.8-gentoo x86_64)
=================================================================
System uname: Linux-5.2.8-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_750_@_2.67GHz-with-gentoo-2.6
KiB Mem:    16393988 total,   3134584 free
KiB Swap:   10485728 total,  10484180 free
Timestamp of repository gentoo: Fri, 16 Aug 2019 20:00:01 +0000
Head commit of repository gentoo: b6877f6431b16b4905996a39e9350680cb12c249
sh bash 5.0_p9
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p9::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.30.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.9::gentoo, 3.7.4-r1::gentoo
dev-util/cmake:           3.15.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.18::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32-r1::gentoo
sys-devel/gcc:            9.1.0-r1::gentoo, 9.2.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://gw.urbanec.net/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: yes

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe -funit-at-a-time"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7 -O2 -pipe -funit-at-a-time"
DISTDIR="/home/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j4 --keep-going --with-bdeps y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.exetel.com.au/pub/gentoo http://ftp.swin.edu.au/gentoo http://distfiles.gentoo.org"
LANG="en_AU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en_AU en"
MAKEOPTS="-j4 --load-average=5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tmp"
USE="X a52 aac acl acpi activities alsa amd64 apache2 bash-completion berkdb bluray branding bzip2 cairo cdda cdr clang cli cnd consolekit crypt cscope cups cvs cxx dbus declarative designer dri dts dvb dvd dvdr egl emboss encode enterprise exif fam ffmpeg flac fontconfig gd gdbm gif gimp git glamor google gphoto2 gpm graphviz gstreamer gtk iconv icq icu imap ipod ipv6 jpeg jpeg2k kde kipi kwallet lame lcms libnotify libtirpc lzma mad matroska mmx mmxext mng mp3 mp4 mpeg mplayer msn mtp multilib multitarget musicbrainz mysql mysqli ncurses nfs nls nptl ogg openexr opengl openmp pam pango pch pcre pdf phonon plasma png policykit popcnt ppds pulseaudio pvr python qml qt5 raw rdsektop readline rss samba sasl sdl seccomp semantic-desktop slp smime smtp sndfile spell split-usr sqlite sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg taglib theora threads tiff truetype udev udisks unicode upnp upnp-av upower usb v4l vaapi vdpau vim-syntax vnc vorbis webkit webp widgets wxwidgets x264 x265 xattr xcb xcomposite xine xinerama xml xmp xsl xv xvid yahoo zeroconf zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en-US en-AU en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Jonas Stein gentoo-dev 2019-08-17 12:42:42 UTC
Thank you for the report. Please recompile and 
*attach* the logfiles as described on
https://wiki.gentoo.org/wiki/Attach_the_logs_to_the_bug_ticket
We need to have all information at hand before ticket assignment, so that the maintainer can look after it in one session with minimal number of callbacks.
Please reopen this ticket (Status:unconfirmed) afterwards.
Comment 4 peteru 2019-08-17 13:29:49 UTC
Created attachment 587170 [details]
build.log.gz

Build log showing the failure.
Comment 5 peteru 2019-08-17 13:39:19 UTC
I appreciate that you want to follow the documented bureaucratic process. Full log attached as requested.

However, I think you will find that the relevant excerpt and information I provided in previous comments is sufficient to make progress.

The fault boils down to the need to

 #include <linux/sockios.h>

in

 third_party/webrtc/rtc_base/rtc_base_generic/physicalsocketserver.cc

with kernel 5.2 and newer.

And as always, thanks to all Gentoo developers. You guys and girls make Linux cool. ;-)
Comment 6 John Bowler 2019-08-17 17:38:41 UTC
Created attachment 587218 [details, diff]
Fix missing #define

(In reply to peteru from comment #5)
>  #include <linux/sockios.h>
> 
> in
> 
>  third_party/webrtc/rtc_base/rtc_base_generic/physicalsocketserver.cc

To be precise the directory (with emerge/ebuild) is:

portage/dev-qt/qtwebengine-5.12.4/work/qtwebengine-everywhere-src-5.12.4/src/3rdparty/chromium/third_party/webrtc/rtc_base

And the suggested patch from the Qt link peteru provided is attached.  I have not tested it yet.
Comment 7 John Bowler 2019-08-17 17:58:58 UTC
Comment on attachment 587218 [details, diff]
Fix missing #define

The file name seems to have changed: physicalsocketserver.cc in Gentoo is physical_socket_server.cc in the patch.  Testing with the changed name.
Comment 8 John Bowler 2019-08-17 20:29:21 UTC
Created attachment 587222 [details, diff]
#include <linux/sockios.h> to fix missing #define of SIOCGSTAMP in later glibc versions

See https://bugreports.qt.io/browse/QTBUG-76963 for the original report and https://bugreports.qt.io/browse/QTBUG-76963 for the report of this instance.  The attachment is the patch from the latter up-stream bug with the file name of the file in question adjusted for the Gentoo qtwebengine-5.12.4 build (removing the underscores).

Place the attached file in the (new) directory:

/etc/portage/patches/dev-qt/qtwebengine-5.12.4/

and execute "emerge --oneshot qtwebengine", then wait a while; the build succeeds.
Comment 9 Paul Preney 2019-08-18 06:16:26 UTC
An FYI: qtwebengine 5.12.4 failed to compile on my system (with the same error as the original post) but the last patch worked on my two systems.

I am posting this due to earlier mentions in comments: that I am running Linux kernel 5.1.15 --not v5.2-- and the issue of not being able to build qtwebengine also occurred.
Comment 10 risto.paavola 2019-08-18 07:42:28 UTC
(In reply to John Bowler from comment #8)
> Created attachment 587222 [details, diff] [details, diff]
> #include <linux/sockios.h> to fix missing #define of SIOCGSTAMP in later
> glibc versions
> 
> See https://bugreports.qt.io/browse/QTBUG-76963 for the original report and
> https://bugreports.qt.io/browse/QTBUG-76963 for the report of this instance.
> The attachment is the patch from the latter up-stream bug with the file name
> of the file in question adjusted for the Gentoo qtwebengine-5.12.4 build
> (removing the underscores).
> 
> Place the attached file in the (new) directory:
> 
> /etc/portage/patches/dev-qt/qtwebengine-5.12.4/
> 
> and execute "emerge --oneshot qtwebengine", then wait a while; the build
> succeeds.

I think the patch should point to physicalsocketserver.cc, not physical_socket_server.cc
Comment 11 John Bowler 2019-08-18 15:06:02 UTC
From peteru's original report:

sys-kernel/linux-headers: 5.2::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r4::gentoo

I believe the problem arose as a result of one of those changes, most probably the first.  To test your system:

equery l linux-headers glibc

IIRC linux-headers updates independently of the actual kernel, after all you can have multiple kernels installed but only one linux-headers.
Comment 12 Paul Preney 2019-08-18 16:59:37 UTC
FYI running "equery l linux-headers glibc" on my systems that the patched qtwebengine builds and installs yield:

$ equery l linux-headers glibc
 * Searching for linux-headers ...
[IP-] [  ] sys-kernel/linux-headers-5.2:0

 * Searching for glibc ...
[IP-] [  ] sys-libs/glibc-2.29-r4:2.2

however know "uname -r" yields:

$ uname -r
5.1.15-gentoo
Comment 13 John Bowler 2019-08-18 17:57:07 UTC
>FYI running "equery l linux-headers glibc" on my systems that the patched
>qtwebengine builds and installs yield:
>[IP-] [  ] sys-kernel/linux-headers-5.2:0
>[IP-] [  ] sys-libs/glibc-2.29-r4:2.2
>however know "uname -r" yields:
>5.1.15-gentoo

The latter is the version of the kernel you are running, which depends on the kernel image loaded at system boot via the boot loader.  It won't change until you both have a different version built and installed and select it on reboot.  The equery output refers to the files installed in the root file system and these change on emerge.  linux-headers provides the <linux/...> files and that seems to be where the relevant change was made.

A possible work round, other than the patch (which seems harmless) is to downgrade linux-headers to linux-headers-5.1, either by forcing emerge to do it (emerge =sys-kernel/linux-headers-5.1) or by masking =sys-kernel/linux-headers-5.2 in /etc/portage/package.mask.  I haven't tried either.
Comment 14 Paul Preney 2019-08-19 19:51:39 UTC
Heads-up that this issue is possibly more major...

On my two systems that I applied the patch after rebooting KDE has no sound (the multimedia System Settings module says, "The module Multimedia is not a valid configuration module." Nothing else appears therein.)

So I masked sys-kernel/linux-headers:5.2 to install v5.1, moved the patch out, and I am currently rebuilding qtwebengine (which will take hours) to see if my multimedia comes back (it should as this was the only config item that changed on these systems between reboots). If it doesn't come back then I will try masking qtwebengine 5.12.4 and start reverting to older previously installed packages until things work again.
Comment 15 Paul Preney 2019-08-20 05:44:13 UTC
WRT Comment 14:

Masking sys-kernel/linux-headers-5.2 and then
emerge -1v sys-kernel/linux-header
(or if preferred: emerge -1v =sys-kernel/linux-headers-5.1)

followed by:

  emerge -1v =dev-qt/qtwebengine-5.12.4

works without the patch from this issue.

So, either the patch is used, or, one avoids upgrading linux-headers to v5.2.

---

With respect to my multimedia issues mention in Comment 14, they appear to have been fixed and the problem was not due to qtwebengine so such is not relevant to this issue.
Comment 16 Geoff Madden 2019-08-24 07:30:03 UTC
tried the above patch ,did not take,manually inserted ,repacked file then i get
failure of the nouveau patch,I assume it was because of the differing file size
I had repacked as a tar.xz file as original but the oneliner installed created
a sustatially larger filemwhich I duly inserted in distfiles reran ebuild on 
/usr/portage/dev-qt/qtwebkit/*.5.12.4.  Some help here is needed as i suspect the rest of the patches
will fail as well.
Comment 17 Geoff Madden 2019-08-24 07:32:55 UTC
Created attachment 587888 [details]
emerge info for amd athlon 11
Comment 18 Francesco Turco 2019-08-24 09:38:14 UTC
@Geoff

Try discarding your custom modifications to the distfile and to the ebuild and do the following instead:

# mkdir -p /etc/portage/patches/dev-qt/qtwebengine-5.12.4
# cd /etc/portage/patches/dev-qt/qtwebengine-5.12.4
# wget "https://692352.bugs.gentoo.org/attachment.cgi?id=587222" -O 0001-fix-build-after-y2038-changes-in-glibc.patch
# emerge -1 =dev-qt/qtwebengine-5.12.4
Comment 19 Geoff Madden 2019-08-24 16:57:52 UTC
Created attachment 587962 [details]
point of failure after applyting sockios.h patch
Comment 20 John Bowler 2019-08-25 01:20:42 UTC
>Created attachment 587962 [details]
<point of failure after applyting sockios.h patch

That's not the point of failure because of:

MAKEOPTS="-j5"

see your emerge info.  The real point of failure is some unknown number of lines before the ones you reported, you can either track back up from the ninja message to find the error (I just search for "error", but then I use MAKEOPTS="--jobs" :-), or you can do this:

MAKEOPTS="-j1" emerge --oneshot dev-qt/qtwebengine

Sounds like there is some interaction with the other changes you are making, the easy way out is to mask the 5.2 headers; you are using the 5.1 kernel so don't need them.
Comment 21 Chris Smith 2019-08-25 01:26:19 UTC
Are we going to get a fix in the tree soon?
Comment 22 Dane (c1pher) Smith 2019-08-26 01:57:09 UTC
Ran in to this myself today. I added the following user patch and compilation was successful.

laptop ~ # cat /etc/portage/patches/dev-qt/qtwebengine-5.12.4/linux-headers-5.2.patch 
--- a/src/3rdparty/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
+++ b/src/3rdparty/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
@@ -67,6 +67,7 @@ typedef void* SockOptArg;
 #endif  // WEBRTC_POSIX
 
 #if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
+#include <linux/sockios.h>
 
 int64_t GetSocketRecvTimestamp(int socket) {
   struct timeval tv_ioctl;
Comment 23 Dane (c1pher) Smith 2019-08-26 01:58:38 UTC
Created attachment 588076 [details, diff]
User Patch

Patch that can be downloaded and dropped into: /etc/portage/patches/dev-qt/qtwebengine-5.12.4/linux-headers-5.2.patch
Comment 24 email200202 2019-08-26 08:54:06 UTC
works with @Dane's patch
Comment 25 peteru 2019-08-26 11:41:08 UTC
> works with @Dane's patch

Which is effectively the same patch that John Bowler provided earlier.

The patch from John Bowler works. It should be added to the ebuild and released so that this bug can be closed.
Comment 26 Robert Crawford 2019-08-26 14:52:57 UTC
I applied the linux-headers-5.2 patch described in comment 23.
qtwebengine-5.12.4 now compiles OK. Also, enabled the jumbo-build USE flag, which cut compile time by 2/3. Amazing!

However, the final compile output "severe warnings" posted below seems a bit upsetting. Could this have anything to do with jumbo-build, and/or the linux-headers-5.2 patch, or neither, and is it cause for concern at all?
Any thoughts on this situation? 
details on severe warnings here. https://forums.gentoo.org/viewtopic-t-1101206.html
Comment 27 Michael Cook 2019-08-26 17:00:32 UTC
(In reply to Robert Crawford from comment #26)
> I applied the linux-headers-5.2 patch described in comment 23.
> qtwebengine-5.12.4 now compiles OK. Also, enabled the jumbo-build USE flag,
> which cut compile time by 2/3. Amazing!
> 
> However, the final compile output "severe warnings" posted below seems a bit
> upsetting. Could this have anything to do with jumbo-build, and/or the
> linux-headers-5.2 patch, or neither, and is it cause for concern at all?
> Any thoughts on this situation? 
> details on severe warnings here.
> https://forums.gentoo.org/viewtopic-t-1101206.html

I had these warnings the last time I was able to compile qtwebengine.
Comment 28 peteru 2019-08-26 17:07:32 UTC
Those warnings are unrelated to the patch or USE flags.
Comment 29 Geoff Madden 2019-08-28 10:58:44 UTC
Regarding my point of failure 587962 Iwas led up a path, once I had corrected
my mistakes,I manually reapplied the patch again, and modified the ebuild to the
2nd makeopts changed from 0 to 1 the file is now compiling well into 13000 bracket area 
now, if any one is still having hassles I suggest this extra small change
will be helpful
Comment 30 Larry the Git Cow gentoo-dev 2019-09-01 23:07:39 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0b676d8201b607caa6465c3020fb10b50d27df89

commit 0b676d8201b607caa6465c3020fb10b50d27df89
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-09-01 23:04:38 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-09-01 23:07:24 +0000

    dev-qt/qtwebengine: Fix build with >=linux-headers-5.2
    
    Tested-by: Aaron Bauman <bman@gentoo.org>
    Closes: https://bugs.gentoo.org/692352
    Package-Manager: Portage-2.3.74, Repoman-2.3.17
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 ...webrtc-missing-header-w-linux-headers-5.2.patch | 26 ++++++++++++++++++++++
 dev-qt/qtwebengine/qtwebengine-5.12.4.ebuild       |  2 ++
 2 files changed, 28 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3d1586fade3f0eda87ce1a830961af79d6d28e0c

commit 3d1586fade3f0eda87ce1a830961af79d6d28e0c
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-09-01 23:04:27 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-09-01 23:07:24 +0000

    dev-qt/qtserialbus: Fix build with >=linux-headers-5.2
    
    Bug: https://bugs.gentoo.org/692352
    Package-Manager: Portage-2.3.74, Repoman-2.3.17
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 ...2.4-canbus-missing-header-w-linux-headers.patch | 31 ++++++++++++++++++++++
 dev-qt/qtserialbus/qtserialbus-5.12.4.ebuild       |  4 +++
 2 files changed, 35 insertions(+)
Comment 31 Brian Evans Gentoo Infrastructure gentoo-dev 2019-09-06 13:41:43 UTC
*** Bug 693600 has been marked as a duplicate of this bug. ***
Comment 32 Brian Evans Gentoo Infrastructure gentoo-dev 2019-09-07 14:15:56 UTC
*** Bug 693684 has been marked as a duplicate of this bug. ***
Comment 33 Brian Evans Gentoo Infrastructure gentoo-dev 2019-09-07 15:00:36 UTC
*** Bug 693684 has been marked as a duplicate of this bug. ***
Comment 34 Andreas Sturmlechner gentoo-dev 2019-09-12 09:45:05 UTC
*** Bug 694106 has been marked as a duplicate of this bug. ***
Comment 35 LW 2019-09-29 22:27:20 UTC
Should dev-qt/qtwebengine-5.12.3 somehow enforce a dependency on <=linux-headers-5.1? I upgraded the kernel to 5.3.1 and headers to 5.3 and then qtwebengine-5.12.3 wouldn't build.

An upgrade of all dev-qt packages to 5.12.5 gets past the SIOCGSTAMP issue. Still waiting for qtwebengine's rebuild to complete.
Comment 36 Andreas Sturmlechner gentoo-dev 2019-10-29 20:49:15 UTC
*** Bug 693684 has been marked as a duplicate of this bug. ***