Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684198 - =media-libs/alsa-lib-1.1.8 - no sound in Steam games: ALSA lib .../work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Summary: =media-libs/alsa-lib-1.1.8 - no sound in Steam games: ALSA lib .../work/alsa-...
Status: RESOLVED DUPLICATE of bug 670960
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo ALSA team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-23 16:29 UTC by Adrien DAUGABEL
Modified: 2019-06-30 11:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrien DAUGABEL 2019-04-23 16:29:51 UTC
Hi Team gentoo,

Since 1 month, on sevral games on Steam, no sound. (AudioSurf, L4D2, CS:GO)

I tried sevral things : See forum : https://forums.gentoo.org/viewtopic-t-1094956-start-0-postdays-0-postorder-asc-highlight-.html

The message in console when starting the game : ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.1.8/work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave

I use pulseaudio on my system. 
Without pulseaudio (only ALSA) i have sound in theses games, but i need pulseaudio for others things.

I enabled pulseaudio again, and i tried to  downgrade alsa-lib, alsa-utils and alsa-plugins from 1.1.8 to 1.1.6, now I have sound. 

I think there are a problem between alsa 1.1.8 and pulseaudio.

Please, fix it !

Thanks

Reproducible: Always

Steps to Reproduce:
1. Install Gentoo + pulseaudio + steam from steam overlay and install CS:Go (free)
2. Try the game : no sound
3. downgrade alsa-lib, alsa-utils and alsa-plugins from 1.1.8 to 1.1.6, and reboot
4. Test CS:GO again : OK sound
Actual Results:  
No sound with alsa-lib, alsa-utils and alsa-plugins version 1.1.8
Comment 1 Adrien DAUGABEL 2019-05-26 19:47:55 UTC
Now alsa-plugins-1.1.6 : rebuild failed. I try the symlink
Comment 2 Adrien DAUGABEL 2019-05-27 05:50:07 UTC
OK the workaround works for me :
ln -sv /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf /etc/alsa/conf.d/
Comment 3 Gabriele Svelto 2019-06-26 08:45:33 UTC
I encountered the same problem with moc and the workaround in comment 2 also worked for me. Same package versions installed as the reporter.
Comment 4 Pacho Ramos gentoo-dev 2019-06-30 11:04:45 UTC

*** This bug has been marked as a duplicate of bug 670960 ***