Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 682232 - media-sound/timidity++ with >=media-libs/alsa-lib-1.1.8 - ALSA lib .../work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Summary: media-sound/timidity++ with >=media-libs/alsa-lib-1.1.8 - ALSA lib .../work/a...
Status: RESOLVED DUPLICATE of bug 670960
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 681368
  Show dependency tree
 
Reported: 2019-04-01 17:12 UTC by haarp
Modified: 2019-06-30 11:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info timidity++ (timi,8.03 KB, text/plain)
2019-04-01 17:12 UTC, haarp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haarp 2019-04-01 17:12:32 UTC
Created attachment 571442 [details]
emerge --info timidity++

Hello,

It seems Alsa 1.1.8 threw out some old things. On top of having to remove some entries from my .asoundrc (it is empty for the following bug report!), it broke timidity. With alsa-lib-1.1.8:

> timidity foo.mid
Couldn't open output device
> timidity -Os -iA foo.mid
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.1.8/work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Can't open pcm device 'default'.
Couldn't open ALSA pcm device (`s')

It plays fine on alsa-lib-1.1.6-r1.

Tested with both timidity++-2.14.0-r3 and timidity++-2.15.0.
Comment 1 Uladzimir Bely 2019-04-21 07:19:09 UTC
The similar problem on two machines. Speaker-test fails with alsa-lib-1.1.8:

speaker-test -c2 -t wav

speaker-test 1.1.8

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
ALSA lib /tmp/portage/media-libs/alsa-lib-1.1.8/work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
Playback open error: -16,Device or resource busy


With 1.1.6 version it's OK
Comment 2 Uladzimir Bely 2019-04-21 07:38:45 UTC
P.S. For me the solution was related to missing symlink: https://bugs.gentoo.org/681628
After it had been created the problem with speaker-test went away.
Comment 3 Pacho Ramos gentoo-dev 2019-06-30 11:08:28 UTC

*** This bug has been marked as a duplicate of bug 670960 ***