Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 670960 - media-plugins/alsa-plugins-1.1.7 missing pulseaudio conf in /etc/alsa/conf.d/
Summary: media-plugins/alsa-plugins-1.1.7 missing pulseaudio conf in /etc/alsa/conf.d/
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
: 681628 682232 684198 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-11 20:49 UTC by Manuel Lauss
Modified: 2019-07-16 19:12 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Lauss 2018-11-11 20:49:23 UTC
alsa-plugins-1.1.7 forgets to symlink /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf  in /etc/alsa/conf.d, causing alsa-only applications to cease working (mplayer -ao alsa  for example).  Adding this symlink fixes that.
Comment 1 Manuel Lauss 2018-11-16 20:00:16 UTC
to illustrate:

# mplayer -ao alsa:
[...]
[AO_ALSA] alsa-lib: /tmp-ram/portage/media-libs/alsa-lib-1.1.7/work/alsa-lib-1.1.7/src/pcm/pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'
Could not open/initialize audio device -> no sound.
Audio: no sound 


alsa-lib-1.1.7 changed /usr/share/alsa/alsa.conf to read /etc/alsa/conf.d/
instead of /usr/share/alsa/alsa.conf.d.

alsa-utils-1.1.7 still puts file "51-pulseaudio-probe.conf" there without
making a symlink to it in /etc/alsa/conf.d/.

after "ln -s /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf /etc/alsa/conf.d/51-pulseaudio-probe.conf":

# mplayer -ao alsa audio.mp3
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.6 (00.6) of 193.0 (03:13.0)  0.3% 26% 


This also affects some games on Steam which use alsa instead of pa.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2019-02-12 07:46:31 UTC
Is this still an issue with =media-plugins/alsa-plugins-1.1.8?
Comment 3 Manuel Lauss 2019-02-12 10:03:04 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #2)
> Is this still an issue with =media-plugins/alsa-plugins-1.1.8?

Yes.  Initially, /etc/alsa/ is empty.
After installing alsa-plugins-1.1.8 (with USE="pulseaudio" only), the following 2 files are created:

50-pulseaudio.conf -> /usr/share/alsa/alsa.conf.d/50-pulseaudio.conf
99-pulseaudio-default.conf.example

Native alsa apps still don't work (example mplayer):
[AO_ALSA] alsa-lib: /tmp-ram/portage/media-libs/alsa-lib-1.1.8/work/alsa-lib-1.1.8/src/pcm/pcm_dmix.c:1108:(snd_pcm_dmix_open) unable to open slave
[AO_ALSA] Playback open error: No such file or directory
Failed to initialize audio driver 'alsa'

Doing a "ln -s /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf" in /etc/alsa/  solves all that.
Comment 4 Pacho Ramos gentoo-dev 2019-06-30 11:04:09 UTC
*** Bug 681628 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2019-06-30 11:04:45 UTC
*** Bug 684198 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2019-06-30 11:08:28 UTC
*** Bug 682232 has been marked as a duplicate of this bug. ***
Comment 7 Larry the Git Cow gentoo-dev 2019-06-30 11:23:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=852053b504a01ac36620344245bc9e460f9a8618

commit 852053b504a01ac36620344245bc9e460f9a8618
Author:     Pacho Ramos <pacho@gentoo.org>
AuthorDate: 2019-06-30 11:01:59 +0000
Commit:     Pacho Ramos <pacho@gentoo.org>
CommitDate: 2019-06-30 11:22:49 +0000

    media-plugins/alsa-plugins: Symlink is needed for loading pulse config file
    
    Closes: https://bugs.gentoo.org/670960
    Package-Manager: Portage-2.3.67, Repoman-2.3.14
    Signed-off-by: Pacho Ramos <pacho@gentoo.org>

 .../alsa-plugins/alsa-plugins-1.1.9-r1.ebuild      | 103 +++++++++++++++++++++
 1 file changed, 103 insertions(+)
Comment 8 Kobboi 2019-07-02 22:28:29 UTC
Please also check the bug the above commit introduces: https://bugs.gentoo.org/689184 (or is it a problem with portage?)
Comment 9 haarp 2019-07-16 13:50:05 UTC
Am I going crazy? Commit 852053b504a01ac36620344245bc9e460f9a8618 appears to exist, but doesn't seem to be in the master tree (nor anywhere else for that matter) The latest commit I can see in media-libs/alsa-lib is from May 14. Checked on my updated local mirror, gitweb.gentoo.org and the Github mirror.
Comment 10 haarp 2019-07-16 19:12:14 UTC
(In reply to haarp from comment #9)

Yes, I was crazy ;) I was looking at alsa-lib, not alsa-plugins...

The fix works for me. Thanks, Pacho.