Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 654160 - media-libs/openimageio-1.8.7 : /.../ffmpeginput.cpp:333:72: error: CODEC_CAP_DELAY was not declared in this scope
Summary: media-libs/openimageio-1.8.7 : /.../ffmpeginput.cpp:333:72: error: CODEC_CAP_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 679744 (view as bug list)
Depends on: 686456
Blocks: ffmpeg-4
  Show dependency tree
 
Reported: 2018-04-27 01:32 UTC by Toralf Förster
Modified: 2019-05-28 20:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.22 KB, text/plain)
2018-04-27 01:32 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,44.12 KB, text/plain)
2018-04-27 01:32 UTC, Toralf Förster
Details
environment (environment,157.54 KB, text/plain)
2018-04-27 01:32 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.73 KB, application/x-bzip)
2018-04-27 01:32 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,5.41 KB, application/x-bzip)
2018-04-27 01:32 UTC, Toralf Förster
Details
media-libs:openimageio-1.8.7:20180426-230106.log (media-libs:openimageio-1.8.7:20180426-230106.log,76.79 KB, text/plain)
2018-04-27 01:32 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,38.21 KB, application/x-bzip)
2018-04-27 01:33 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-04-27 01:32:38 UTC
/var/tmp/portage/media-libs/openimageio-1.8.7/work/openimageio-1.8.7/src/ffmpeg.imageio/ffmpeginput.cpp: In member function ‘virtual bool OpenImageIO_v1_8::FFmpegInput::open(const string&, OpenImageIO_v1_8::ImageSpec&)’:
/var/tmp/portage/media-libs/openimageio-1.8.7/work/openimageio-1.8.7/src/ffmpeg.imageio/ffmpeginput.cpp:333:72: error: ‘CODEC_CAP_DELAY’ was not declared in this scope
  m_codec_cap_delay = (bool) (m_codec_context->codec->capabilities & CODEC_CAP_DELAY);
                                                                     ^~~~~~~~~~~~~~~
/var/tmp/portage/media-libs/openimageio-1.8.7/work/openimageio-1.8.7/src/ffmpeg.imageio/ffmpeginput.cpp:333:72: note: suggested alternative: ‘AV_CODEC_CAP_DELAY’

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-ffmpeg4_20180425-205701

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
  [3]   pypy3 (fallback)




emerge -qpv media-libs/openimageio
[ebuild  N    ] media-libs/openimageio-1.8.7  USE="ffmpeg gif opengl python qt5 ssl truetype -colorio -doc -field3d -jpeg2k -libressl -opencv -ptex -raw" CPU_FLAGS_X86="avx sse2 sse3 sse4_1 sse4_2 ssse3 -avx2 -avx512f -f16c" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
Comment 1 Toralf Förster gentoo-dev 2018-04-27 01:32:42 UTC
Created attachment 528604 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-04-27 01:32:45 UTC
Created attachment 528606 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-04-27 01:32:48 UTC
Created attachment 528608 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-04-27 01:32:51 UTC
Created attachment 528610 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-04-27 01:32:54 UTC
Created attachment 528612 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-04-27 01:32:57 UTC
Created attachment 528614 [details]
media-libs:openimageio-1.8.7:20180426-230106.log
Comment 7 Toralf Förster gentoo-dev 2018-04-27 01:33:00 UTC
Created attachment 528616 [details]
temp.tbz2
Comment 8 Larry the Git Cow gentoo-dev 2018-04-27 12:13:30 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=aca6a611eb0cda805b60113ccd0a6f56369ef41a

commit aca6a611eb0cda805b60113ccd0a6f56369ef41a
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2018-04-27 12:12:58 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2018-04-27 12:13:23 +0000

    media-libs/openimageio: backport upstream fix for ffmpeg4
    
    Closes: https://bugs.gentoo.org/654160
    Package-Manager: Portage-2.3.31, Repoman-2.3.9

 .../files/openimageio-1.8.7-ffmpeg4.patch          | 26 ++++++++++++++++++++++
 media-libs/openimageio/openimageio-1.8.7.ebuild    |  4 ++++
 2 files changed, 30 insertions(+)
Comment 9 Jeroen Roovers gentoo-dev 2019-03-08 10:03:12 UTC
*** Bug 679744 has been marked as a duplicate of this bug. ***
Comment 10 Cyp 2019-05-23 11:06:49 UTC
Same issue with the currently-stable media-libs/openimageio-1.7.17 and the recently-stabilised media-video/ffmpeg-4.1.3 (which somehow isn't showing at all on https://packages.gentoo.org/packages/media-video/ffmpeg ).

So I think 1.7.17 should be patched or 1.8.17 stabilised.
Comment 11 Israel G. Lugo 2019-05-28 20:29:49 UTC
(In reply to Cyp from comment #10)
> Same issue with the currently-stable media-libs/openimageio-1.7.17 and the
> recently-stabilised media-video/ffmpeg-4.1.3 (which somehow isn't showing at
> all on https://packages.gentoo.org/packages/media-video/ffmpeg ).
> 
> So I think 1.7.17 should be patched or 1.8.17 stabilised.

I have created bug 686920 to address the new failure, as this bug has not been reopened.