Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 650304 - dev-libs/cloog-0.18.4 with >=dev-libs/isl-0.19: …/libcloog-isl.so: undefined reference to `isl_basic_set_drop_constraint'
Summary: dev-libs/cloog-0.18.4 with >=dev-libs/isl-0.19: …/libcloog-isl.so: undefined ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: EBUILD, PullRequest
: 650286 650298 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-12 17:08 UTC by Toralf Förster
Modified: 2020-10-10 04:58 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.59 KB, text/plain)
2018-03-12 17:08 UTC, Toralf Förster
Details
dev-libs:cloog-0.18.4:20180312-020954.log (dev-libs:cloog-0.18.4:20180312-020954.log,52.82 KB, text/plain)
2018-03-12 17:08 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,123.18 KB, text/plain)
2018-03-12 17:08 UTC, Toralf Förster
Details
environment (environment,89.15 KB, text/plain)
2018-03-12 17:08 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.59 KB, application/x-bzip)
2018-03-12 17:08 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,8.02 KB, application/x-bzip)
2018-03-12 17:08 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,26.38 KB, application/x-bzip)
2018-03-12 17:08 UTC, Toralf Förster
Details
cloog-0.19.0.ebuild (cloog-0.19.0.ebuild,1.40 KB, text/plain)
2018-04-06 16:09 UTC, Alexander
Details
environment (environment,88.96 KB, text/plain)
2018-04-26 21:08 UTC, Roman Gruber
Details
cloog-0.20.0-notexi.patch (cloog-0.20.0-notexi.patch,1.44 KB, patch)
2020-08-06 17:37 UTC, Sven Eusewig
Details | Diff
cloog-0.20.0.ebuild (cloog-0.20.0.ebuild,1.66 KB, text/plain)
2020-08-06 17:42 UTC, Sven Eusewig
Details
dev-libs/cloog-0.18.4 full build log (cloog_build.log,63.98 KB, text/x-log)
2020-08-20 08:52 UTC, Anton Kochkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-03-12 17:08:20 UTC
/bin/sh ./libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Wall -O2 -pipe -march=native  -L/lib -Wl,-O1 -Wl,--as-needed -o cloog source/cloog.o libcloog-isl.la -lgmp
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -O2 -pipe -march=native -Wl,-O1 -Wl,--as-needed -o .libs/cloog source/cloog.o  -L/lib ./.libs/libcloog-isl.so -lgmp
./.libs/libcloog-isl.so: undefined reference to `isl_basic_set_drop_constraint'
./.libs/libcloog-isl.so: undefined reference to `isl_set_drop_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_set_copy_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_basic_map_from_basic_set'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-systemd_libressl_20180309-191749

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby22 (with Rubygems)
  [2]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv dev-libs/cloog
[ebuild  N    ] dev-libs/cloog-0.18.4  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 

!!! The following installed packages are masked:
- x11-base/xorg-server-1.19.99.901-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sebastian Pipping <sping@gentoo.org> (11 Mar 2018)
# Breaks XFCE, 1.19.6 was fine (in that regard). Bug #650228

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 1 Toralf Förster gentoo-dev 2018-03-12 17:08:23 UTC
Created attachment 523606 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-03-12 17:08:26 UTC
Created attachment 523608 [details]
dev-libs:cloog-0.18.4:20180312-020954.log
Comment 3 Toralf Förster gentoo-dev 2018-03-12 17:08:30 UTC
Created attachment 523610 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-03-12 17:08:33 UTC
Created attachment 523612 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-03-12 17:08:36 UTC
Created attachment 523614 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-03-12 17:08:39 UTC
Created attachment 523616 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2018-03-12 17:08:43 UTC
Created attachment 523618 [details]
temp.tbz2
Comment 8 Arfrever Frehtes Taifersar Arahesis 2018-03-13 00:18:02 UTC
*** Bug 650298 has been marked as a duplicate of this bug. ***
Comment 9 Arfrever Frehtes Taifersar Arahesis 2018-03-13 00:18:08 UTC
*** Bug 650286 has been marked as a duplicate of this bug. ***
Comment 10 Arfrever Frehtes Taifersar Arahesis 2018-03-13 00:37:13 UTC
Either development moved to GitHub or there is a fork:
https://github.com/periscop/cloog

And somebody is working on a patch there:
https://github.com/periscop/cloog/pull/38


Anyway dev-libs/cloog is needed only by obsolete versions of 2 packages:
=dev-lang/gnat-gpl-2016*[graphite]
=sys-devel/gcc-4.8*[graphite]
=sys-devel/gcc-4.9*[graphite]
Comment 11 Guilherme Amadio gentoo-dev 2018-03-15 10:07:38 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #10)
> Either development moved to GitHub or there is a fork:
> https://github.com/periscop/cloog
> 
> And somebody is working on a patch there:
> https://github.com/periscop/cloog/pull/38
> 
> 
> Anyway dev-libs/cloog is needed only by obsolete versions of 2 packages:
> =dev-lang/gnat-gpl-2016*[graphite]
> =sys-devel/gcc-4.8*[graphite]
> =sys-devel/gcc-4.9*[graphite]

Actually, I work on code that needs to support these versions of GCC, so I have hit this bug, and suspect other users might too. I'm using GCC 7.3 as system compiler.
Comment 12 Alexander 2018-04-06 16:09:56 UTC
Created attachment 526694 [details]
cloog-0.19.0.ebuild

This ebuild is compile by me without errors.
Yes, it's contain «dirty hack» around `eautoreconf`.

Best regards,
alex
Comment 13 Roman Gruber 2018-04-26 21:07:44 UTC
Still happens on current box. regardless of  [1] x86_64-pc-linux-gnu-7.2.0
Switched to [2] x86_64-pc-linux-gnu-7.3.0 *

My box is build with [1] x86_64-pc-linux-gnu-7.2.0


/bin/sh ./libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -m32 -Wall -march=native -O2 -pipe -fomit-frame-pointer  -L/lib -Wl,-O1 -Wl,--as-needed -o cloog source/cloog.o libcloog-isl.la -lgmp
libtool: link: x86_64-pc-linux-gnu-gcc -m32 -Wall -march=native -O2 -pipe -fomit-frame-pointer -Wl,-O1 -Wl,--as-needed -o .libs/cloog source/cloog.o  -L/lib ./.libs/libcloog-isl.so -lgmp
./.libs/libcloog-isl.so: undefined reference to `isl_basic_set_drop_constraint'
./.libs/libcloog-isl.so: undefined reference to `isl_set_drop_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_set_copy_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_basic_map_from_basic_set'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:767: cloog] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-libs/cloog-0.18.4/work/cloog-0.18.4-abi_x86_32.x86'
make: *** [Makefile:1046: all-recursive] Error 1
 * ERROR: dev-libs/cloog-0.18.4::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-libs/cloog-0.18.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/cloog-0.18.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/cloog-0.18.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/cloog-0.18.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/cloog-0.18.4/work/cloog-0.18.4-abi_x86_32.x86'
 * S: '/var/tmp/portage/dev-libs/cloog-0.18.4/work/cloog-0.18.4'

>>> Failed to emerge dev-libs/cloog-0.18.4, Log file:

>>>  '/var/tmp/portage/dev-libs/cloog-0.18.4/temp/build.log'
Comment 14 Roman Gruber 2018-04-26 21:08:34 UTC
Created attachment 528600 [details]
environment
Comment 15 Arfrever Frehtes Taifersar Arahesis 2018-05-06 02:37:40 UTC
*** Bug 650298 has been marked as a duplicate of this bug. ***
Comment 16 Rafal Kupiec 2018-05-07 12:10:21 UTC
Same here, I hot exact the same problem:


libtool: link: x86_64-pc-linux-gnu-gcc -shared  -fPIC -DPIC  source/.libs/libcloog_isl_la-block.o source/.libs/libcloog_isl_la-clast.o source/.libs/libcloog_isl_la-matrix.o source/.libs/libcloog_isl_la-state.o source/.libs/libcloog_isl_la-input.o source/.libs/libcloog_isl_la-int.o source/.libs/libcloog_isl_la-loop.o source/.libs/libcloog_isl_la-names.o source/.libs/libcloog_isl_la-options.o source/.libs/libcloog_isl_la-pprint.o source/.libs/libcloog_isl_la-program.o source/.libs/libcloog_isl_la-statement.o source/.libs/libcloog_isl_la-stride.o source/.libs/libcloog_isl_la-union_domain.o source/.libs/libcloog_isl_la-util.o source/.libs/libcloog_isl_la-version.o source/isl/.libs/libcloog_isl_la-domain.o source/isl/.libs/libcloog_isl_la-constraints.o source/isl/.libs/libcloog_isl_la-backend.o   -L/lib -lisl -lgmp  -march=corei7 -mtune=corei7 -msse4.1 -msse4.2 -mcx16 -msahf -mpopcnt -O2 -Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--hash-style=both -Wl,--as-needed   -Wl,-soname -Wl,libcloog-isl.so.4 -o .libs/libcloog-isl.so.4.0.0
libtool: link: (cd ".libs" && rm -f "libcloog-isl.so.4" && ln -s "libcloog-isl.so.4.0.0" "libcloog-isl.so.4")
libtool: link: (cd ".libs" && rm -f "libcloog-isl.so" && ln -s "libcloog-isl.so.4.0.0" "libcloog-isl.so")
libtool: link: ( cd ".libs" && rm -f "libcloog-isl.la" && ln -s "../libcloog-isl.la" "libcloog-isl.la" )
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -march=corei7 -mtune=corei7 -msse4.1 -msse4.2 -mcx16 -msahf -mpopcnt -O2 -s -pipe -fomit-frame-pointer -Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,--hash-style=both -Wl,--as-needed -o .libs/cloog source/cloog.o  -L/lib ./.libs/libcloog-isl.so -lgmp
./.libs/libcloog-isl.so: undefined reference to `isl_basic_set_drop_constraint'
./.libs/libcloog-isl.so: undefined reference to `isl_set_drop_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_set_copy_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_basic_map_from_basic_set'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:767: cloog] Error 1
make: *** [Makefile:1046: all-recursive] Error 1
 * ERROR: dev-libs/cloog-0.18.4::gentoo failed (compile phase):
Comment 17 tokiclover 2018-05-12 11:23:05 UTC
The SLOT should be changed because the library API changed. The issue go away for <=dev-libs/isl-0.18, the stmbols are still there. The SLOT should be changed and the dependency as well accordingly to the SLOT change. Until then, masking the newer version of dev-libs/isl is required. Thanks.
Comment 18 Arfrever Frehtes Taifersar Arahesis 2019-07-26 00:45:51 UTC
(In reply to Arfrever Frehtes Taifersar Arahesis from comment #10)
> Either development moved to GitHub or there is a fork:
> https://github.com/periscop/cloog
> 
> And somebody is working on a patch there:
> https://github.com/periscop/cloog/pull/38

cloog version from https://github.com/periscop/cloog contains 2 new releases made in last year:
  0.19.0  (2018-04-04)
  0.20.0  (2018-09-07)

They supposedly contain fix for compatibility with dev-libs/isl-0.19.

Original homepage (https://www.bastoul.net/cloog/ , https://repo.or.cz/w/cloog.git) seems to have been unmaintained after year 2015.

Maybe switching dev-libs/cloog to https://github.com/periscop/cloog would make sense?
Comment 19 ilovekiruna 2019-09-17 09:39:20 UTC
The mentioned patch seems to be completely developed. Maybe this could be applied to fix the bug.
Comment 20 gentoobugs 2019-09-18 18:42:16 UTC
+1, would be nice to get this fixed so that HHVM can be compiled.
Comment 21 Sergei Trofimovich gentoo-dev 2019-09-18 22:24:47 UTC
Would be nice to address the status of the project WRT upsream:
    https://github.com/periscop/cloog/issues/40
Comment 22 Jeroen Roovers (RETIRED) gentoo-dev 2019-11-07 08:49:15 UTC
(In reply to Alexander from comment #12)
> Created attachment 526694 [details]
> cloog-0.19.0.ebuild
Comment 23 Sven Eusewig 2020-08-06 17:37:30 UTC
Created attachment 653404 [details, diff]
cloog-0.20.0-notexi.patch

# texi2dvi -I ./doc --pdf doc/cloog.texi -o doc/cloog.pdf
# TeX neither supports -recorder nor outputs \openout lines in its log file

This fix deactivate tex2dvi - pdf creation.
Comment 24 Sven Eusewig 2020-08-06 17:42:34 UTC
Created attachment 653406 [details]
cloog-0.20.0.ebuild

With this patch https://bugs.gentoo.org/attachment.cgi?id=653404 the cloog-0.20.0 builds with system isl-0.22.1 and gmp-6.2.0-r1.
Comment 25 Anton Kochkov 2020-08-20 08:52:36 UTC
Created attachment 655668 [details]
dev-libs/cloog-0.18.4 full build log

Met this problem recently too on this system (emerge --info output):

Portage 3.0.4 (python 3.6.12-final-0, default/linux/amd64/17.0/no-multilib/hardened, gcc-9.3.0, glibc-2.32, 4.9.24-hardened x86_64)
=================================================================
System uname: Linux-4.9.24-hardened-x86_64-Intel-R-_Core-TM-_i7_CPU_930_@_2.80GHz-with-gentoo-2.7
KiB Mem:     8163492 total,   2404136 free
KiB Swap:   16016792 total,  15854432 free
Timestamp of repository gentoo: Thu, 20 Aug 2020 04:45:01 +0000
Head commit of repository gentoo: 8853e9530c77ebdf13d3594bdee576f048e647d9
sh bash 5.0_p18
ld GNU ld (Gentoo 2.34 p6) 2.34.0
app-shells/bash:          5.0_p18::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.30.3-r1::gentoo
dev-lang/python:          2.7.18-r1::gentoo, 3.6.12::gentoo, 3.7.9::gentoo, 3.8.5::gentoo, 3.9.0_rc1::gentoo
dev-util/cmake:           3.18.1::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7::gentoo
sys-apps/openrc:          0.42.1::gentoo
sys-apps/sandbox:         2.20::gentoo
sys-devel/autoconf:       2.69-r5::gentoo
sys-devel/automake:       1.14.1-r2::gentoo, 1.15.1-r2::gentoo, 1.16.2::gentoo
sys-devel/binutils:       2.34-r2::gentoo
sys-devel/gcc:            6.4.0-r2::gentoo, 7.3.0-r3::gentoo, 8.1.0-r3::gentoo, 8.2.0-r6::gentoo, 9.3.0-r1::gentoo, 10.2.0::gentoo
sys-devel/gcc-config:     2.3.1::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.32::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.us.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

gentoo-xvilka
    location: /var/lib/layman/gentoo-xvilka
    masters: gentoo
    priority: 1

godin
    location: /var/lib/layman/godin
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 bzip2 crypt cvs git gnutls hardened iconv ipv6 libglvnd libtirpc lighttpd mercurial mmx ncurses nls nptl openmp pam pcre perl php pie postgresql python readline sbcl seccomp split-usr sse sse2 sse4 ssl ssp ssse3 subversion unicode xattr xml xmlrpc xsl xtpax zlib" ABI_X86="64" ADA_TARGET="gnat_2018" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2 php7-3" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python2_7 python3_6 python3_7" RUBY_TARGETS="ruby27" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 26 Larry the Git Cow gentoo-dev 2020-10-10 04:58:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1017ea43cf122de0fd78039583b5a197efa40d46

commit 1017ea43cf122de0fd78039583b5a197efa40d46
Author:     Aisha Tammy <gentoo@aisha.cc>
AuthorDate: 2020-10-10 00:37:58 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2020-10-10 04:52:13 +0000

    dev-libs/cloog: drop old broken version
    
    Closes: https://bugs.gentoo.org/595132
    Closes: https://bugs.gentoo.org/650304
    Package-Manager: Portage-3.0.8, Repoman-3.0.1
    Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
    Closes: https://github.com/gentoo/gentoo/pull/17867
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-libs/cloog/Manifest            |  1 -
 dev-libs/cloog/cloog-0.18.4.ebuild | 61 --------------------------------------
 2 files changed, 62 deletions(-)