Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 650286 - dev-libs/cloog-0.18.4 with =dev-libs/isl-0.19 fails to build
Summary: dev-libs/cloog-0.18.4 with =dev-libs/isl-0.19 fails to build
Status: RESOLVED DUPLICATE of bug 650304
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 14:41 UTC by Cyp
Modified: 2018-03-13 00:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyp 2018-03-12 14:41:28 UTC
Related bugs: Bug 595132 – a test failure rather than a build failure.

————————————————————————————————————————————————————————————
/bin/sh ./libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Wall -march=native -O2 -pipe -g  -L/lib -Wl,-O1 -Wl,--as-needed -Wl,-O1 -o cloog source/cloog.o libcloog-isl.la -lgmp
libtool: link: x86_64-pc-linux-gnu-gcc -Wall -march=native -O2 -pipe -g -Wl,-O1 -Wl,--as-needed -Wl,-O1 -o .libs/cloog source/cloog.o  -L/lib ./.libs/libcloog-isl.so -lgmp
./.libs/libcloog-isl.so: undefined reference to `isl_basic_set_drop_constraint'
./.libs/libcloog-isl.so: undefined reference to `isl_set_drop_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_set_copy_basic_set'
./.libs/libcloog-isl.so: undefined reference to `isl_basic_map_from_basic_set'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:767: cloog] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-libs/cloog-0.18.4/work/cloog-0.18.4-abi_x86_64.amd64'
make: *** [Makefile:1046: all-recursive] Error 1
Comment 1 Arfrever Frehtes Taifersar Arahesis 2018-03-13 00:18:08 UTC

*** This bug has been marked as a duplicate of bug 650304 ***