Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 648374 - app-portage/layman-2.4.2 - ImportError: No module named requests
Summary: app-portage/layman-2.4.2 - ImportError: No module named requests
Status: UNCONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-21 10:15 UTC by Martin Mokrejš
Modified: 2018-02-22 14:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,98.72 KB, text/plain)
2018-02-21 22:15 UTC, Martin Mokrejš
Details
emerge.log.xz (emerge.log.xz,875.86 KB, application/octet-stream)
2018-02-21 23:01 UTC, Martin Mokrejš
Details
emerge -e @world --keep-going -pv --tree (emerge_e_world.txt,313.16 KB, text/plain)
2018-02-22 14:12 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2018-02-21 10:15:51 UTC
Hi,
  on a relatively newly installed ~and64 host I get the following:


# layman -S
...
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 234.95K
Total bytes received: 48.04M

sent 234.95K bytes  received 48.04M bytes  510.83K bytes/sec
total size is 224.92M  speedup is 4.66
ERROR:root:OpenPGP verification failed:
gpg: Signature made Wed Feb 21 08:38:19 2018 UTC
gpg:                using RSA key E1D6ABB63BFCFB4BA02FDF1CEC590EEAC9189250
gpg: Can't check signature: No public key

q: Updating ebuild cache in /scratch/usr/portage ... 
q: Finished 37467 entries in 0.109256 seconds
!!! Repository 'x-layman' is missing masters attribute in '/scratch/var/lib/layman/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage' is missing masters attribute in '/scratch/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

 * IMPORTANT: 1 news items need reading for repository 'science'.
 * IMPORTANT: 31 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Action: sync for repo: gentoo, returned code = 1


Traceback (most recent call last):
  File "/usr/lib/python-exec/python2.7/layman", line 30, in <module>
    from   layman.cli            import Main
  File "/usr/lib64/python2.7/site-packages/layman/cli.py", line 29, in <module>
    from layman.api import LaymanAPI
  File "/usr/lib64/python2.7/site-packages/layman/api.py", line 25, in <module>
    from layman.remotedb        import RemoteDB
  File "/usr/lib64/python2.7/site-packages/layman/remotedb.py", line 46, in <module>
    from   sslfetch.connections     import Connector
  File "/usr/lib64/python2.7/site-packages/sslfetch/connections.py", line 40, in <module>
    import requests
ImportError: No module named requests



True, I do not have dev-python/requests installed so layman-2.4.2 should depend on it.


# emerge -pv dev-python/requests
!!! Repository 'x-layman' is missing masters attribute in '/scratch/var/lib/layman/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage' is missing masters attribute in '/scratch/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

        /scratch/var/lib/layman/profiles/repo_name
        /scratch/usr/local/portage/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/openssl-1.0.2n::gentoo  USE="asm gmp sctp sslv3 tls-heartbeat zlib -bindist* -kerberos -rfc3779 -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 0 KiB
[ebuild  N     ] dev-python/cryptography-2.1.4::gentoo  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 432 KiB
[ebuild  N     ] dev-python/pyopenssl-17.5.0::gentoo  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 167 KiB
[ebuild   R    ] dev-python/urllib3-1.22::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5* -pypy -pypy3 -python3_6" 221 KiB
[ebuild  N     ] dev-python/requests-2.18.4::gentoo  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 124 KiB

Total: 5 packages (3 new, 2 reinstalls), Size of downloads: 943 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0=[bindist] required by (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, installed)
                          ^^^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.6_p1-r3:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2n:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.1.4:0/0::gentoo, ebuild scheduled for merge)




# emerge -pv layman
!!! Repository 'x-layman' is missing masters attribute in '/scratch/var/lib/layman/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage' is missing masters attribute in '/scratch/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

        /scratch/var/lib/layman/profiles/repo_name
        /scratch/usr/local/portage/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/openssl-1.0.2n::gentoo  USE="asm gmp sctp sslv3 tls-heartbeat zlib -bindist* -kerberos -rfc3779 -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 0 KiB
[ebuild  N     ] dev-python/cryptography-2.1.4::gentoo  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 432 KiB
[ebuild  N     ] dev-python/pyopenssl-17.5.0::gentoo  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 167 KiB
[ebuild   R    ] dev-python/urllib3-1.22::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5* -pypy -pypy3 -python3_6" 221 KiB
[ebuild  N     ] dev-python/requests-2.18.4::gentoo  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 124 KiB
[ebuild   R    ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_4 python3_5* -pypy -python3_6" 12 KiB
[ebuild   R    ] app-portage/layman-2.4.2::gentoo  USE="git sqlite -bazaar -cvs -darcs -g-sorcery -gpg -mercurial -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5* -pypy -python3_6" 135 KiB

Total: 7 packages (3 new, 4 reinstalls), Size of downloads: 1089 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0=[bindist] required by (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, installed)
                          ^^^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by (net-misc/openssh-7.6_p1-r3:0/0::gentoo, installed)
                                  ^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2n:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.1.4:0/0::gentoo, ebuild scheduled for merge)





# emerge --info
!!! Repository 'x-layman' is missing masters attribute in '/scratch/var/lib/layman/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage' is missing masters attribute in '/scratch/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

        /scratch/var/lib/layman/profiles/repo_name
        /scratch/usr/local/portage/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.


Portage 2.3.22 (python 2.7.14-final-0, default/linux/amd64/17.0, gcc-6.4.0, glibc-2.25-r10, 4.15.4 x86_64)
=================================================================
System uname: Linux-4.15.4-x86_64-Intel-R-_Core-TM-_i7-7820HQ_CPU_@_2.90GHz-with-gentoo-2.4.1
KiB Mem:     8098372 total,   4113868 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Wed, 21 Feb 2018 09:00:01 +0000
Head commit of repository gentoo: d9105e66471f2fa62c50a1caa1b1fb83c587d669
sh bash 4.4_p18
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p18::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.26.9999::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.6-r1::gentoo, 3.5.4-r1::gentoo, 3.6.4::gentoo
dev-util/cmake:           3.10.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.27::gentoo, 2.28-r2::gentoo, 2.29.1-r1::gentoo, 2.30::gentoo
sys-devel/gcc:            4.2.4-r1::gentoo, 4.3.6-r1::gentoo, 4.4.7::gentoo, 4.7.4::gentoo, 4.8.5::gentoo, 4.9.4::gentoo, 5.4.0-r3::gentoo, 6.3.0::gentoo, 6.4.0::gentoo, 7.2.0-r1::gentoo, 7.3.0::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.15::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /scratch/usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 

x-portage
    location: /scratch/usr/local/portage
    masters: gentoo
    priority: 0

x-layman
    location: /scratch/var/lib/layman
    masters: gentoo
    priority: 1

haskell
    location: /var/lib/layman/haskell
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50

vmware
    location: /var/lib/layman/vmware
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 sun-bcla-java-vm Oracle-BCLA-JavaSE IBM-J1.6 skype-eula Nero-EULA-US AdobeFlash-10.3 skype-4.0.0.7-copyright AdobeFlash-11.x OPERA-2014 RAR"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=sandybridge -mtune=native -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/lib64/libreoffice/program/sofficerc /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=sandybridge -mtune=native -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.web4u.cz/ rsync://gentoo.mirror.dkm.cz/gentoo/ ftp://gentoo.mirror.web4u.cz/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en_GB en cs"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/scratch/var/tmp"
USE="X acpi alsa amd64 amr apache apache2 asm avx avx2 berkdb bindist bluetooth boost bzip2 cairo cgi cli coin consolekit cracklib crypt cryptlib cryptsetup cups cxx dbus device-mapper dhcp directfb drm dvd emboss encode fax fbcon ffmpeg flac fontconfig fortran gbm gcrypt gd gdbm geoip gimp glpk gmp gnutls gpm gps gtk hal hpijs hwdb iconv id3tag imaging innodb inotify java javafx javascript jce jpeg jpg js jscript keymap ladspa lapack laptop lcms libnotify lm_sensors mad matroska mmx modemmanager modules multilib ncurses nfs nls nptl nptlonly nscd nss ntfsprogs objc ocr ogg opengl openmp openssl pam parport pcre pcre16 pdf perl php png policykit polkit ppds pppd python qt3support qt4 qt5 readline rendering resolvconf romio scanner sctp seccomp server session slideshow sndfile sqlite sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification suexec svg syslog tcl tcpd threads tiff tk truetype udev unicode usb v4l v4l2 vim-syntax vnc wavpack wifi x11 xattr xcb xml xorg xrandr xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="alias authz_host auth_basic auth_digest cgi cgid deflate dir env filter include info mem_cache mime mime_magic negotiation remoteip setenvif status userdir vhost_alias rewrite usertrack cache file_cache disk_cache charset_lite log_config log_forensic" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="aivdm ashtech earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 navcom ntrip oceanserver oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 tnt tripmate tsip ublox fury geostar nmea0183 nmea2000 passthrough" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en-US en en-GB cs" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4 python3_5" RUBY_TARGETS="ruby21 ruby23 ruby24 ruby25" USERLAND="GNU" VIDEO_CARDS="vesa vmware fbdev intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Martin Mokrejš 2018-02-21 10:31:54 UTC
Actually, dev-python/ssl-fetch should have the dev-python/requests dependency.
Comment 2 Brian Dolbec gentoo-dev 2018-02-21 14:57:28 UTC
Layman depended on ssl-fetch, and ssl-fetch has always had the dev-python/requests pkg dependency.


So, what has been done to clean the requests pkg from your system?
Comment 3 Zac Medico gentoo-dev 2018-02-21 18:03:26 UTC
Please attach /var/log/emerge.log.
Comment 4 Martin Mokrejš 2018-02-21 22:08:58 UTC
Thanks for all your inputs. OK, so I emerged dev-python/requests and also dev-python/urllib3, both were missing.


But, to re-test, I just enumeged both urrlib3 and requests and attempting to re-install layman did *not* bring them into the deps. so something is broken.
Comment 5 Martin Mokrejš 2018-02-21 22:15:02 UTC
Created attachment 520492 [details]
build.log

# emerge --unmerge requests urllib3
#
# FEATURES=noclean emerge layman
...
[attached build.log]
...
#


# emerge -pv --tree layman

Calculating dependencies... done!
[ebuild   R    ] app-portage/layman-2.4.2::gentoo  USE="git sqlite -bazaar -cvs -darcs -g-sorcery -gpg -mercurial -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -python3_6" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

It really does not trigger installation of dev-python/requests and in turn dev-python/urllib3. Weird.
Comment 6 Zac Medico gentoo-dev 2018-02-21 22:28:49 UTC
(In reply to Martin Mokrejš from comment #4)
> But, to re-test, I just enumeged both urrlib3 and requests and attempting to
> re-install layman did *not* bring them into the deps. so something is broken.

You need to use the emerge --deep option.
Comment 7 Brian Dolbec gentoo-dev 2018-02-21 22:43:08 UTC
a couple more things:

1) urllib3 is not needed, requests uses either the std py3 lib or it's own bundled version if needed.

2) ssl-fetch deps on requests, so since ssl-fetch was not unmerged, then layman emerge would need the --deep option like Zac said.

3) We needed to see the emerge log (not the build log) to find out how or why the requests pkg was cleaned out in case there is a bug in portage/emerge that missed that dependency so unmerged it during a deplclean.

The emerge log records all pkgs that are merged or unmerged.

it is located at /var/log/emerge.log
Comment 8 Martin Mokrejš 2018-02-21 22:50:04 UTC
(In reply to Zac Medico from comment #6)
> You need to use the emerge --deep option.

Wow! I (mis)use Gentoo Linux since about 2001 or 2002 and always thought "--deep" is "needed" only for eventual "emerge -uND world" (for real masochists who want to *voluntarily* upgrade even the DEPENDed packages although it is not strictly needed) but in a normal "world" emerge will pick all the necessary deps. So you say that "emerge -uN world" or "emerge layman" is not enough? Uh.
Comment 9 Zac Medico gentoo-dev 2018-02-21 22:58:57 UTC
(In reply to Martin Mokrejš from comment #8)
> (In reply to Zac Medico from comment #6)
> > You need to use the emerge --deep option.
> 
> Wow! I (mis)use Gentoo Linux since about 2001 or 2002 and always thought
> "--deep" is "needed" only for eventual "emerge -uND world" (for real
> masochists who want to *voluntarily* upgrade even the DEPENDed packages
> although it is not strictly needed) but in a normal "world" emerge will pick
> all the necessary deps. So you say that "emerge -uN world" or "emerge
> layman" is not enough? Uh.

If you test it, you should see that --deep pulls in the (indirect) requests dependency. Don't take my word for it. ;-)
Comment 10 Martin Mokrejš 2018-02-21 23:01:25 UTC
Created attachment 520516 [details]
emerge.log.xz

OK, I think a few times I used emerge with --nodeps because the USE=bindist was such a pain, blocking networkmanager due to qtnetwork ... So provided the discussion we had I cannot rule out I twisted emerge. I am sorry if that is the case. I wasn't aware of the downstream consequences (that I would need to use the --deep option to be safe).
Comment 11 Brian Dolbec gentoo-dev 2018-02-21 23:34:40 UTC
You aren't quite getting why --deep was needed in your case.

requests is a dep of ssl-fetch, not layman

ssl-fetch was seen as being installed when you tried emerge layman, so didn't look any further.

the --deep option tells emerge to look at all dependencies including their dependencies, the deps of ssl-fetch in your case.  It would then see that requests was not installed and pull it in to the merge list.

thank you for the emerge.log
Comment 12 Martin Mokrejš 2018-02-21 23:42:58 UTC
Time for sleep here. As always, USE=bindist is a hassle and a bad decision on this host. Some remnants of that still kicking in.


# emerge -pv --tree --deep layman
!!! Repository 'x-layman' is missing masters attribute in '/scratch/var/lib/layman/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
!!! Repository 'x-portage' is missing masters attribute in '/scratch/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
WARNING: One or more repositories have missing repo_name entries:

        /scratch/var/lib/layman/profiles/repo_name
        /scratch/usr/local/portage/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R    ] app-portage/layman-2.4.2::gentoo  USE="git sqlite -bazaar -cvs -darcs -g-sorcery -gpg -mercurial -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -python3_6" 0 KiB
[nomerge       ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -python3_6" 
[ebuild  N     ]  dev-python/requests-2.18.4::gentoo  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 0 KiB
[ebuild  N     ]   dev-python/urllib3-1.22::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy -pypy3 -python3_6" 0 KiB
[nomerge       ] dev-qt/qtnetwork-5.9.3:5/5.9::gentoo  USE="bindist ssl -connman -debug -libproxy -networkmanager {-test}" 
[ebuild   R    ]  dev-libs/openssl-1.0.2n::gentoo  USE="asm bindist* gmp sctp sslv3 tls-heartbeat zlib -kerberos -rfc3779 -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 0 KiB

Total: 4 packages (2 new, 2 reinstalls), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.1.4:0/0::gentoo, installed)
                                                                                                                       
    >=dev-libs/openssl-1.0.1:0/0=[-bindist] required by (net-misc/openssh-7.6_p1-r4:0/0::gentoo, installed)
                                  ^^^^^^^^                                                                                                     
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.6_p1-r4:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     

  (dev-libs/openssl-1.0.2n:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/0=[bindist] required by (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, installed)
                          ^^^^^^^                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-qt/qtnetwork-5.9.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.2n bindist

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.


I will fix that in he morning, later with "emerge --deep -uN world". I thought the "emerge --changed-deps world --keep-going" was the most I could have done today already. I don't see a reason why --deep behavior is not the default. Who want's a broken install? If --deep is mandatory, then it should be a default.
Comment 13 Brian Dolbec gentoo-dev 2018-02-22 00:04:17 UTC
yes, you did unmerge requests many times, emerge --no-deps it...

Also several groups of emerge fails for lots of pkgs...


I would recommend you do an emerge -e @world to get your system fully in sync with all it's deps...  Your system may benefit greatly from it.
Comment 14 Martin Mokrejš 2018-02-22 14:12:59 UTC
Created attachment 520544 [details]
emerge -e @world --keep-going -pv --tree

Well there are not that many issues actually but I need to get over bugs #648504 and #648506 first.

Often I did

emerge -uND world --keep-going --changed-deps=y --backtrack=30000 | grep  '^\[' | grep -v  'virtual/' | awk '{print $4}' | while read p; do emerge -uN1 --keep-going --backtrack=30000 =$p --changed-deps=y =$p; done

so my system is rather OK. Something emerge could have done easier to users. Notoriously every tiny perl, qt version bump causes so much troubles and emerge is just unable to perform at least some of the scheduled work.