Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 62378 - net-misc/nx-x11 does not compile with gcc 3.4
Summary: net-misc/nx-x11 does not compile with gcc 3.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
: 62706 63859 77065 (view as bug list)
Depends on:
Blocks: 63757 76387
  Show dependency tree
 
Reported: 2004-08-31 06:06 UTC by Christian Korff
Modified: 2005-05-23 12:14 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log file of emerge output (emerge-nx-x11.log.bz2,19.33 KB, application/x-bzip2)
2004-08-31 06:09 UTC, Christian Korff
Details
Patch from Fabian Franz (FreeNX-kNX Mailinglist) (patch-nxcomp-types.h,1.57 KB, patch)
2004-09-12 11:51 UTC, Benjamin Podszun (Blafasel @ irc)
Details | Diff
Patch for makefile.in (nxcomp needs -fpermissive) (patch-nxcomp-makefile.in,615 bytes, patch)
2004-09-12 12:29 UTC, Benjamin Podszun (Blafasel @ irc)
Details | Diff
bug-fix and change of the name (nx-x11-1.4.0.nxcomp.types.h.patch,1.60 KB, patch)
2004-09-13 11:36 UTC, Gergan Penkov
Details | Diff
the second patch with standartised name (nx-x11-1.4.0.nxcomp.makefile.in.patch,602 bytes, patch)
2004-09-13 11:38 UTC, Gergan Penkov
Details | Diff
...and the ebuild to apply the two patches (nx-x11-1.4.0-r2.ebuild,2.66 KB, text/plain)
2004-09-13 11:43 UTC, Gergan Penkov
Details
(nx-x11-1.4.0-nxcomp.patch) patch for nxcomp fixing gcc3 compile errors (nx-x11-1.4.0-nxcomp.patch,9.30 KB, patch)
2005-02-05 02:48 UTC, Richard Benjamin Voigt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Korff 2004-08-31 06:06:26 UTC
net-misc/nx-x11 compiles fine with gcc 3.3.4 but fails with gcc 3.4
for more details i attached the log file of the emerge output.
Comment 1 Christian Korff 2004-08-31 06:09:03 UTC
Created attachment 38575 [details]
log file of emerge output
Comment 2 Benjamin Podszun (Blafasel @ irc) 2004-09-12 11:51:44 UTC
Created attachment 39453 [details, diff]
Patch from Fabian Franz (FreeNX-kNX Mailinglist)

Attached this patch on behalf of Fabian Franz.. I didn't play aound with it
yet, though. It "should work".
Comment 3 Benjamin Podszun (Blafasel @ irc) 2004-09-12 12:29:03 UTC
Created attachment 39458 [details, diff]
Patch for makefile.in (nxcomp needs -fpermissive)

Got some help from lauri@freenode.net/#nx
Apply both patches (Makefile.in and Types.h) to build nxcomp
Comment 4 Stuart Herbert (RETIRED) gentoo-dev 2004-09-13 10:26:12 UTC
I'll be adding these patches shortly.  In the meantime, anyone who needs them can get them from here.

Best regards,
Stu
Comment 5 Gergan Penkov 2004-09-13 11:36:42 UTC
Created attachment 39520 [details, diff]
bug-fix and change of the name 

that's the types.h patch plus one line more, which has elluded probably the
developers
Comment 6 Gergan Penkov 2004-09-13 11:38:25 UTC
Created attachment 39521 [details, diff]
the second patch with standartised name
Comment 7 Gergan Penkov 2004-09-13 11:43:47 UTC
Created attachment 39522 [details]
...and the ebuild to apply the two patches

the ebuild, which patches the sources. Ok and one more hint, everything runs,
but one must start the ssh deamon. I don't if this ist the right thing to do
(from security perespective of view), but that was the only thing, which worked
for me, without any further modifications and actions.
Comment 8 Stuart Herbert (RETIRED) gentoo-dev 2004-09-15 11:35:18 UTC
*** Bug 64066 has been marked as a duplicate of this bug. ***
Comment 9 Marius Mauch (RETIRED) gentoo-dev 2004-09-27 00:59:44 UTC
*** Bug 63859 has been marked as a duplicate of this bug. ***
Comment 10 Roie Kerstein 2004-11-28 00:49:17 UTC
Will this patched ebuild be integrated in the portage tree?
Comment 11 SpanKY gentoo-dev 2004-12-06 20:48:30 UTC
*** Bug 62706 has been marked as a duplicate of this bug. ***
Comment 12 Andy Boyko 2005-01-06 15:11:31 UTC
Applying the two patches attached by Gergan Penkov, but using the current ebuild (nx-x11-1.4.0-r3) rather than the ebuild he supplied (which was an update to -r2), appears to compile correctly with gcc 3.4.3. 
Comment 13 Stuart Herbert (RETIRED) gentoo-dev 2005-01-07 14:14:23 UTC
*** Bug 77065 has been marked as a duplicate of this bug. ***
Comment 14 FieldySnuts 2005-01-09 09:22:12 UTC
I'm still having the problem with -r3 and gcc-3.4.1.

Should I try upgrading to gcc-3.4.3-r1 and try again?
Comment 15 Stuart Herbert (RETIRED) gentoo-dev 2005-01-11 16:42:51 UTC
I can't advise you there.  I offer support for the current stable version of gcc.  I'm not in a position to offer support for non-stable versions, especially as gcc-3.3 and gcc-3.4 cannot co-exist on the same Gentoo installation AFAIK.

Best regards,
Stu
Comment 16 Hans-Christian Armingeon 2005-01-12 06:35:42 UTC
@stuart:
> especially as gcc-3.3 and gcc-3.4 cannot co-exist on the same Gentoo installation AFAIK

Why? Why do we have slotting?
Why is there a command gcc-config?

# gcc-config -l
[1] i686-pc-linux-gnu-3.3.4
[2] i686-pc-linux-gnu-3.4.3 *
[3] i686-pc-linux-gnu-3.4.3-hardened
[4] i686-pc-linux-gnu-3.4.3-hardenednopie
[5] i686-pc-linux-gnu-3.4.3-hardenednossp

I hope, that we're getting closer to this bug.

Johnny
Comment 17 Stuart Herbert (RETIRED) gentoo-dev 2005-01-13 13:56:07 UTC
The ABI for C++ software changed between gcc 3.3 and gcc 3.4.  I'm sorry, I just don't have a machine to dedicate to gcc 3.4 at the moment.

Best regards,
Stu
Comment 18 Joe Kowalski 2005-01-23 07:32:49 UTC
Actually, the ebuild for gcc-3.4 has portage install sys-libs/libstdc++-v3, which allows for gcc-3.3 compiled apps to run without abi problems.  There is NO problem with having a system that has both gcc-3.3 and 3.4 on it.
Comment 19 Richard Benjamin Voigt 2005-02-05 02:48:05 UTC
Created attachment 50429 [details, diff]
(nx-x11-1.4.0-nxcomp.patch) patch for nxcomp fixing gcc3 compile errors

(I think all attachments are obsoleted)

nxcomp had really poor ANSI compliance.

I actually removed the entire clear() function that the previous patches were
against, since standards-compliant STL std::vector provides a working
implementation.  (I don't know what the calls to destroy, etc are supposed to
resolve to, I don't see any functions by those names in STL.)

I also updated the header names to #include <iostream> without the .h and added
using namespace std.  Also, a lot of -W parameters were being passed to g++
that aren't valid for c++, so they've been eliminated.

I did ebuild clean unpack, applied this patch against the base, ebuild compile
install package, emerge -k and tested it.  I now can connect to the nxserver
for the first time ever.  (nxfree without nx-x11 causes problems during
connect, reported as timeout on the server side and "Parse error in remote
options string 'NX> '" on the client)  Something is wrong with the
dependencies, because the nxserver was installed previously by emerge --resume
--skipfirst even though nx-x11 hadn't been installed (should I file a new bug
report?).

The files compile under both versions of gcc I have, now with *no* warnings
(installed and tested under 3.4.3)
i686-pc-linux-gnu-3.3.3
i686-pc-linux-gnu-3.4.3

I don't know why the old header files names are being used.  Is this for
compatibility with non-gcc compilers?  Or for gcc2?  If the latter, then this
patch should only be applied to gcc v3 and up.	It is tested and working under
gcc 3.3 and 3.4 both.  This sort of thing should be done by configure, but... 
if someone points me to a package that is a really perfect example of the right
way to use autoconf and automake I'll endeavor to have the header filename
selected by configure.	caveat: I've never used autoconf/automake before.
Comment 20 Joe Kowalski 2005-04-29 12:47:12 UTC
This bug is fixed in the nx-comp-1.4.0-31 package.  net-misc/nx-x11 now properly compiles with gcc-3.4.  Reccomend closing this.
Comment 21 Stuart Herbert (RETIRED) gentoo-dev 2005-05-23 12:14:16 UTC
Closing bug as per Joe's suggestion.

Best regards,
Stu