Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 64066 - nx-x11-1.4.0-r2 fails to build
Summary: nx-x11-1.4.0-r2 fails to build
Status: RESOLVED DUPLICATE of bug 67538
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Stuart Herbert (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: 67538
Blocks: 63757
  Show dependency tree
 
Reported: 2004-09-14 16:53 UTC by Caleb Shay
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Output from ebuild (nx-x11.build.txt,14.44 KB, text/plain)
2004-09-14 16:54 UTC, Caleb Shay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Caleb Shay 2004-09-14 16:53:17 UTC
emerge info:

Portage 2.0.50-r11 (default-x86-2004.2, gcc-3.4.2, glibc-2.3.4.20040808-r0, 2.6.8-gentoo-r3)
=================================================================
System uname: 2.6.8-gentoo-r3 i686 Pentium III (Coppermine)
Gentoo Base System version 1.5.3
distcc 2.17 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distcc sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl apm arts arts-wrapper-suid avi berkdb bitmap-fonts chroot crypt cups encode esd foomaticdb gdbm gif gnome gpm gtk gtk2 imlib innodb java jpeg kde ldap libg++ libwww lzw-tiff mad mikmod mmx motif mpeg mysql nas ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline samba sdl slang slp spell sse ssl svga tcpd tiff truetype unicode x86 xinerama xml xml2 xmms xprint xv zlib"
Comment 1 Caleb Shay 2004-09-14 16:54:01 UTC
Created attachment 39621 [details]
Output from ebuild
Comment 2 Stuart Herbert (RETIRED) gentoo-dev 2004-09-15 11:35:17 UTC

*** This bug has been marked as a duplicate of 62378 ***
Comment 3 Caleb Shay 2004-09-15 13:34:27 UTC
No, it's not a duplicate of that bug.  The errors are entirely different (and using the patches from that bug still leaves me with exactly the same errors).
Comment 4 Stuart Herbert (RETIRED) gentoo-dev 2004-09-15 13:47:46 UTC
Fair enough.  gcc-3.4 is currently masked.  I won't be looking at gcc-3.4 bugs until the package in portage stabilises a bit.

Best regards,
Stu
Comment 5 Caleb Shay 2004-09-15 14:15:50 UTC
I can live with that :)
Comment 6 Thomas Deutsch 2004-11-17 13:13:40 UTC
Same(?) Problem here:

[...]
g++ -c -O3 -I../nx-X11/exports/include -Wno-deprecated
-Wmissing-declarations -Wnested-externs -DIN_ADDR_T=in_addr_t
-DVERSION=\"1.4.0\"  -I/usr/X11R6/include -DPACKAGE_NAME=\"\"
-DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\"
-DPACKAGE_BUGREPORT=\"\" -Wall -Wpointer-arith -Wstrict-prototypes
-Wmissing-prototypes   Loop.cpp
cc1plus: warning: command line option "-Wmissing-declarations" is valid
for C/ObjC but not for C++
cc1plus: warning: command line option "-Wnested-externs" is valid for
C/ObjC but not for C++
cc1plus: warning: command line option "-Wstrict-prototypes" is valid for
C/ObjC but not for C++
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for
C/ObjC but not for C++
In file included from Control.h:24,
                 from Loop.cpp:69:
Types.h: In member function `void T_data::clear()':
Types.h:95: error: `start' undeclared (first use this function)
Types.h:95: error: (Each undeclared identifier is reported only once for
each function it appears in.)
Types.h:95: error: `finish' undeclared (first use this function)
Types.h:95: error: `destroy' undeclared (first use this function)
Types.h:97: error: `deallocate' undeclared (first use this function)
Types.h:99: error: `end_of_storage' undeclared (first use this function)
Types.h: In member function `void T_messages::clear()':
Types.h:129: error: `start' undeclared (first use this function)
Types.h:129: error: `finish' undeclared (first use this function)
Types.h:129: error: `destroy' undeclared (first use this function)
Types.h:131: error: `deallocate' undeclared (first use this function)
Types.h:133: error: `end_of_storage' undeclared (first use this function)
make[4]: *** [Loop.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/nx-x11-1.4.0-r2/work/nxcomp'
make[3]: *** [../../../nxcomp/libXcomp.so] Error 2
make[3]: Leaving directory
`/var/tmp/portage/nx-x11-1.4.0-r2/work/nx-X11/lib/X11'
make[2]: *** [depend] Error 2
make[2]: Leaving directory `/var/tmp/portage/nx-x11-1.4.0-r2/work/nx-X11/lib'
make[1]: *** [depend] Error 2
make[1]: Leaving directory `/var/tmp/portage/nx-x11-1.4.0-r2/work/nx-X11'
make: *** [World] Error 2
Comment 7 Paul Hannah 2004-12-10 08:02:57 UTC
it's actually the build of nxcomp within nx-x11 that fails.  And this is fixed with the changes suggested in #67538.
Comment 8 Stuart Herbert (RETIRED) gentoo-dev 2005-01-02 01:29:40 UTC

*** This bug has been marked as a duplicate of 67538 ***