Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58821 - gentoo.minimal.2004.2.iso does not boot
Summary: gentoo.minimal.2004.2.iso does not boot
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Everything (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo LiveCD Package Maintainers
: 58474 59527 59932 62941 66356 68594 (view as bug list)
Depends on:
Reported: 2004-07-29 13:00 UTC by imagination
Modified: 2005-03-25 11:38 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description imagination 2004-07-29 13:00:18 UTC
On the same machine as used for releases since
Gentoo1.4, the current gentoo.minimal.2004.2.iso
does NOT BOOT. What is different since
Gentoo1.4, 2004.0 and 2004.1?

Reproducible: Always
Steps to Reproduce:
1. Put CD into drive
Comment 1 imagination 2004-07-30 09:46:09 UTC
... but genoo.universal.2004.2.iso does it!
But here ...
    fdisk /dev/hda
... results in "/dev/hda no such device"
Comment 2 Sven Vermeulen (RETIRED) gentoo-dev 2004-07-30 12:25:05 UTC
Same issue here; the minimal CD for x86 (2004.2 release) doesn't boot. Others (2004.1, 2004.0 and 1.4) did (still do).

System: AMD Athlon-XP 1800+, SiS 530-based motherboard; both CD-rom drives (Plextor PlexWriter 8/4/32 and Pioneer DVD) fail on this CD.

ISO doublechecked (md5sum and gpg check) and doubleburned (one on CD-R, one on CD-RW). I have not tried to boot the CD on a different PC though (due to lack of PCs).
Comment 3 Benjamin Krause 2004-07-30 14:10:55 UTC
same here.. does not boot on a teac dv-516e dvd-rom drive.
i am able to boot any other live cd (2004.1 or .0) or windows or whatever.. and the iso will boot on my notebook, but not on my p4-albatron px865.
Comment 4 Timothy Waters 2004-08-03 01:01:57 UTC
Same for me too. I have an Athlon 2000+ system. It looks in the cd for something to boot, but then goes straight to grub on the hdd. 
Comment 5 Chris Mathis 2004-08-04 00:22:05 UTC
the problem with fdisk /dev/hda is filed under another bug, modprobe ide-disk it should work. i am also having the same problem as the rest the 2004.1 works and a universal amd64 2004.2 also works.
Comment 6 Chris Mathis 2004-08-04 00:23:04 UTC
oh and thats the x86 2004.2 that does not boot for me
Comment 7 imagination 2004-08-05 08:26:17 UTC
Could Chris Mathis be a bit more specific on 
"modprobe ide-disk it should work"? "modprobe ide-disk"
is not meant literally, right? 'modprobe ide-*' did not
help. "problem with fdisk /dev/hda is filed under another bug"
-- which one? 
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-05 09:00:41 UTC
*** Bug 59527 has been marked as a duplicate of this bug. ***
Comment 9 Guido Vranken 2004-08-07 16:29:46 UTC
install-x86-minimal-2004.2.iso won't boot on one PC but it does on another. 

Working pc:
  bios: AMIBIOS K7S5A 12/15/2001 S
  cdrom: PHILIPS PCA402CDA

Nonworking pc:
  bios: ASUS MEL-C ACPI BIOS Revision 1008.B
  cdrom: SONY CD-ROM CDU523 1

Placing the Philips CD-ROM drive (from the working PC) in the nonworking PC and trying to boot with it doesn't help.
Comment 10 MAL 2004-08-08 20:50:32 UTC
Again, same here.  2004.1 minimal boots in the machine, 2004.2 minimal doesn't.

The DVD+-RW drive it's booting from is a NEC ND-2510A (very recent), so from this and others comments, I think it's fair to assume this is an issue with some BIOSs.

What disk emulation mode does the LiveCD use?
Comment 11 Rob Duggan 2004-08-09 05:01:56 UTC
I had same issue NEC dual layer dvd-rw drive.
Comment 12 MAL 2004-08-09 22:08:10 UTC
One thing noone's mentioned... what speed did you write the CD at?

I'l try re-writing it at less that 52x (:P) this evening.  It shouldn't make a difference though, and there's a certain lack of acknowledgement from the LiveCD team, but it's worth a try.
Comment 13 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-10 05:36:45 UTC
*** Bug 59932 has been marked as a duplicate of this bug. ***
Comment 14 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-10 05:38:42 UTC
Lack of acknowledgement?  About what?  You have a crappy BIOS?  *grin*

There isn't much I can do to fix this without your hardware to test.  I am working on resolving the tons of bugs that have been submitted to me since 2004.2 was released.... and in case you're wondering, I *am* the LiveCD team, so have a bit of patience.  Also, having to search through the tons of duplicate bug reports doesn't help, as it only slows down the process... *grin*

I'm going to try to figure out what is wrong with the CD, and why it only seems to plague the minimal CD, and I will be reporting back here as time permits.  I ask all of you to have some patience, and try the universal CD, as I have not heard any reports of it having troubles booting.
Comment 15 Rob Duggan 2004-08-10 05:51:04 UTC
One workaround is the smart bootmanager floppy.  It worked for me at least.
1. boot to smart bootmanager floppy
2. choose cdrom as boot option.
This boots the cd in my system where it fails if I go directly to cd first.

If you have a windows box grab sbminst.exe and run it, it will gen the floppy
It gives usage instructions when you run it without any flags, so I won't replicate.

Hope this helps.
Comment 16 Andrew Molloy 2004-08-10 17:49:27 UTC
I can also confirm this.

I have created two 2004.2 minimal livecd's, one using Windows burned at 16X, and one using Linux at 4X, both with identical results.

Box 1: Shuttle SB62G2 with FB62S00H(17-NOV-2003) and with FB62S00L (14-MAY-2004) Phoenix BIOS.  2004.0 boots fine.  2004.2 will not boot in any test case.  I have tried a relatively new 52X CD-RW, old 16X DVD, and very old 4X CDROM.  All fail.  Tried with both sets of BIOS.  CPU is a P4 Prescott (with HT).

Box 2: Tyan S1836 (circa 1999) with a DVD drive. Dual PIII. Boots 2004.2 fine.
Box 3: Compaq laptop (1999) with laptop DVD drive. Pentium II. Boots 2004.2 fine.

I'm confident it's a BIOS problem that 2004.2 is triggering.
Comment 17 MAL 2004-08-10 23:28:44 UTC
Re: #14

Hey, no worries :)
I've got to thank you for the excellent work.

Universal is downloading, I'll report whether it works.
What boot emulation type do the LiveCDs use? (if not none).
Comment 18 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-11 06:44:18 UTC
There's no boot emulation on the LiveCD.
Comment 19 kennet bäckman 2004-08-14 14:03:30 UTC
I supect some BIOS do not support long filenames. I have re-built the minimal iso with iso9660 8.3 support only and with additional rock ridge support. This solved the problem for me.
Comment 20 alex b 2004-08-21 11:56:59 UTC

Number of CPUs	2 (1 Physical)	
CPU#1	APIC ID = 0	
CPU Name	Intel Pentium 4	
Code Name	Northwood	
Specification	Intel(R) Pentium(R) 4 CPU 2.80GHz	
Family / Model / Stepping	F 2 9	
Extended Family / Model	0 0	
Brand ID	9	
Technology	0.13 
Comment 21 alex b 2004-08-21 11:56:59 UTC

Number of CPUs	2 (1 Physical)	
CPU#1	APIC ID = 0	
CPU Name	Intel Pentium 4	
Code Name	Northwood	
Specification	Intel(R) Pentium(R) 4 CPU 2.80GHz	
Family / Model / Stepping	F 2 9	
Extended Family / Model	0 0	
Brand ID	9	
Technology	0.13 µ	
Supported Instructions Sets	MMX, SSE, SSE2	
CPU Clock Speed	2793.7 MHz	
Clock multiplier	x 14.0	
Front Side Bus Frequency	199.5 MHz	
Bus Speed	798.2 MHz	
L1 Data Cache	8 KBytes, 4-way set associative, 64 Bytes line size	
L1 Trace Cache	12 Kµops, 8-way set associative	
L2 Cache	512 KBytes, 8-way set associative, 64 Bytes line size	
L2 Speed	2793.7 MHz (Full)	
L2 Location	On Chip	
L2 Data Prefetch Logic	yes	
L2 Bus Width	256 bits	
CPU#2	APIC ID = 1	
CPU Name	Intel Pentium 4 (logical unit)	
Mainboard and chipset	 	
Motherboard manufacturer	MICRO-STAR INTERNATIONAL CO., LTD	
Motherboard model	MS-6747, 	
BIOS vendor	Phoenix Technologies, LTD	
BIOS revision	6.00 PG	
BIOS release date	07/16/2003	
Chipset	Intel i865P/PE/G/i848P rev. A2	
Southbridge	Intel 82801EB (ICH5) rev. 2	
Sensor chip	Winbond W83627THF	
FSB Select	800 MHz	
Performance Mode	disabled	
AGP Status	enabled, rev. 3.0	
AGP Data Transfert Rate	8x	
AGP Side Band Addressing	supported, enabled	
AGP Aperture Size	128 MBytes	
DRAM Size	512 MBytes	
DRAM Frequency	199.5 MHz	
CAS# Latency	3.0 clocks	
RAS# to CAS#	3 clocks	
RAS# Precharge	3 clocks	
Cycle Time (TRAS)	8 clocks	
# of memory modules	2	
Module 0	Siemens AG DDR-SDRAM PC3200 - 256 MBytes	
Module 1	Siemens AG DDR-SDRAM PC3200 - 256 MBytes	
Windows version	Microsoft Windows XP Workstation Service Pack 1 (Build 2600)
Comment 22 Guillaume Destuynder (RETIRED) gentoo-dev 2004-08-22 05:45:07 UTC
Same problem here. minimal cd doesn't boot.
I've an asus A7N8X-delux revision 2.0, latest bios. drive is a Liteon 811S.
Every ISO boot but this one: older gentoos, windowsxp of course, skyos, freebsd, whatever i tried, just minimal cd of 2004.2 doesn't boot.
Comment 23 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-23 06:06:52 UTC
Can you guys test out the CD at and report here if it boots properly.  It was built from the same build directory as the official 2004.2 release.  The only difference is I have dropped the 2.4 kernel completely, so there is only one kernel on the CD.
Comment 24 Rainer Größlinger (RETIRED) gentoo-dev 2004-08-23 06:58:39 UTC
This image works for me
Comment 25 imagination 2004-08-23 12:00:11 UTC
Yes, the recommended iso of comment #22 DOES boot now.
The sad finding is, that -- as with 2004.2 universal --
'fdisk /dev/hda' responds with
'Unable to open /dev/hda'  
Comment 26 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-23 12:15:16 UTC
What kind of disk/chipset do you have?
Comment 27 imagination 2004-08-24 05:40:53 UTC
 ... to #25
 Seagate Barracuda 120GB S-ATA, Intel 82865G/PE/P
 'fdisk /dev/hda' worked on this target
                  with any previous version since Gentoo 1.4
Comment 28 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-24 05:58:51 UTC
SATA should be using the libsata driver interface.  Your devices are /dev/sda and so on...
Comment 29 imagination 2004-08-24 09:08:33 UTC

'fdisk /dev/sda'
... Disk /dev/sda 65MB ...
    /dev/sda1 * 1 800 ... FAT16
    This is my memory stick.
Plugging out this stick
'fdisk /dev/sda'
... Unable to open /dev/sda

Or must I do something to load libsata?
Comment 30 Chris Gianelloni (RETIRED) gentoo-dev 2004-08-24 10:15:44 UTC
Nothing is needed to load the proper driver.  Can you post the output from dmesg here?  Actually... file a separate bug, since this bug is for the system booting, and we're off that topic now.
Comment 31 Kevin Williams 2004-08-30 11:13:35 UTC
The original minimal-x86-2004.2.iso file did not boot due to "No Operating System found" on the CD, but the revision ISO file proposed by wolf in comment #22 works. 

ISO was burned onto CD with:
OS: Windows XP (SP2).
Software: Nero Burning ROM 6.3.X.

test machine:
CD Drive: Creative Labs 52x CD-ROM.

Comment 32 Daniel Savard 2004-09-02 18:54:55 UTC
I downloaded universal on Aug 27 and it doesn't work on my old laptop. Haven't try on any other machines yet. Minimal didn't work, but I can't remember when I downloaded the iso image.

I am downloading the image from the link on #22. If this image is reported working, why isn't it replace the original image? It would save time to everyone. The universal image also, needs to be fixed.

On my old laptop, I'm not sure I can use the boot manager trick, since I never tested switching the diskette and CD-ROM drives live. So, hope the r1 image will work.
Comment 33 Konstantin V. Yarkov 2004-09-03 03:02:56 UTC
My English is bad, sorry...
Image of comment 22 does boot now.
I use `smp nodhcp noraid` boot parameters for P4HT2.8 CPU system with 1G RAM and SATA 120G HDD.
But my onboard Broadcom 4400 10/100 Ethernet adapter does not work. Network card detect by Kudzu, modules b44 and Mii loaded. 
`#ifconfig eth0` say:
eth0: error fetching interface information: Device not found
Where is truble?
I boot from install-x86-minimal-2004.1.iso and install 2004.2 release. That is right?
Comment 34 roger55 (RETIRED) gentoo-dev 2004-09-05 17:45:27 UTC
*** Bug 62941 has been marked as a duplicate of this bug. ***
Comment 35 David Cassetti 2004-09-11 21:53:01 UTC
I have tried the 2004.2 minimal on five systems. The three Award BIOS systems fail to boot, while the two Phoenix BIOS systems (one of them quite old) boot fine.

The 2004.2-1 minimal from #22 works fine on the Award system I'm installing on. I haven't had the chance to test it on the other two Award systems.
Comment 36 Malte Skoruppa 2004-09-12 07:35:17 UTC
I really don't understand how this bug is still not solved now, over one month after it was originally posted, while people actually figured the problem out (more or less) and managed to build ISOs that DO work (to be read here and in this topic in the forums:

At least, there should be a note on the downloads page, because this problem concerns a huge lot of people, who are wasting cds for nothing... and it would be nice if a developer posted something about this to the forums, because a lot of people there don't look into bugzilla ;-)
Comment 37 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-12 08:03:32 UTC
This bug has *been* solved (see comment #22) the problem is feedback.  I have received almost zero feedback on the new ISO, which means as far as I am concerned, it is still VERY untested.  If you have used the ISO, then PLEASE COMMENT.

I am getting sick of people whining and complaining, then doing nothing to help the problem.  Especially when those same people then run around pointing blame on others.  YOU ARE AS MUCH TO BLAME AS ANYONE FOR NOT HELPING.

Did I make that clear enough?


Now, I am copying the ISO out to the /experimental directory on the Gentoo mirrors and once it has propogated, there will be an announcement on the front page of explaining the reason for the CD.

As for the forums, a lot (most?) of the Gentoo developers never go there.  I for one don't have the time to develop and browse the forums, as the signal to noise ratio is simply too high to waste time there.
Comment 38 Malte Skoruppa 2004-09-13 12:37:11 UTC
Man, don't be so upset. I didn't want to BLAME anyone (in the sense of aggressing someone), this was just meant as a friendly and constructive post.

As far as for the people "whining and complaining, then doing nothing to help the problem", I must tell you I HAVE Gentoo installed, thus, I wouldn't have the tiniest advantage of it if the minimal CD worked. In other words, it actually doesn't make ANY difference for me. I'm just so committed I thought I'd post something about it in the hope that something might happen (which worked, so I'm happy :-), because so many people in the forums keep complaining. I didn't know you couldn't bear a little criticism, I'm sorry.

I must admit I actually didn't notice that there already was a half-way official "fixed cd" for this (to be precise, I noticed that "some guy" named Chris Gianelloni posted a link to a fixed ISO, but I didn't realise you were a dev... because there are many indepent people that actually have made working ISOs, at least in the forums). And neither did almost anybody, which is why you received so little feedback. That was one little post in this huge thread, and moreover most people never look in the bug tracker. So no wonder...

Whatever... I'm thankful that you put it in the mirrors and posted about it in the news. That was more than I was hoping for :-)

And to give you your feedback, I justed tested it and it works, whereas the original minimal 2004.2 doesn't work on my machine (ASUS A7N8X Deluxe, Award BIOS), so, it seems we're on the right way ;-)


Comment 39 Paul Waring 2004-09-16 02:28:07 UTC
With regards to complaining, the main issue(s) I had was that it took so long for a fix to what was a serious issue for a number of people (judging by the forum posts on it) to be annouced on the front page. Also, the description on the front page seems to point the blame at the users for having buggy BIOS's, which seems a bit strange given that I've *never* had this problem before with any other CDs (gentoo or otherwise)...
Comment 40 imagination 2004-09-16 03:22:57 UTC
I feel moved to strongly support the opinions expressed in 
comments #37 and #38, in particular the issue concerning
the side-wipe against buggy BIOS's. One could come to the conclusion
that all Gentoo ISO's except the 2004.2-minimal were better
in that they could handle even 'buggy BIOS's' as Award and (in my case)
Comment 41 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-16 05:01:55 UTC
Nobody is blaming the *user* but rather AWARD/Phoenix, since the only reports we have had of it not working have been from users with these BIOS chips.  What is really strange is users with the same hardware having varying successes.  I had a fix within a few days in this bug, however, I got very little testing or feedback from anyone, so I was not sure that it was fixing the problem, hence the reason for NOT posting it to the front page.  I'm sorry that a bunch of forum users couldn't check bugzilla, since this is the official Gentoo location for any bugs and fixes, njot the forums.  The forums are a forum for user-to-user interaction.  While they can be used for bug fixing, they generally are not browsed by most developers, especially when we do have a proper bug tracking system.

Now, with all that said, this horse has been beaten and is now a decaying mess.  It is done and over with and continuing this conversation is not only pointless, but bordering on the edge of the asinine.
Comment 42 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-17 18:35:07 UTC
*** Bug 58474 has been marked as a duplicate of this bug. ***
Comment 43 Tom K 2004-09-24 16:23:48 UTC
I have an Award BIOS, and this fixed the issue for me.

However the only reason I was dimly aware of it was from visiting the Gentoo IRC channel and noticing the topic referred to problems with booting a 2004.2 livecd.

Given that this seems to be a very common problem, I'd suggest it'd save a lot of CDRs as well as time if there was any easy to find documentation about this.

Such as:

1) A mention on the frontpage of
2) A note in the installation handbook
3) etc

As widespread as this bug seems to be, people should not have to dig around on forums, IRC, or much less bugzilla to find the answer.

Comment 44 Chris Gianelloni (RETIRED) gentoo-dev 2004-09-27 07:01:51 UTC
It *was* on the front page.  In fact, it still is.
Comment 45 Chris Gianelloni (RETIRED) gentoo-dev 2004-10-04 15:16:51 UTC
*** Bug 66356 has been marked as a duplicate of this bug. ***
Comment 46 FieldySnuts 2004-10-13 09:41:23 UTC
The topic of #gentoo pointed me here. I tried the URL in comment #22, but it's not there. I also noticed that it should be on the "front page" ( but don't see anything.

Where can I get the new iso to test?
Comment 47 Chris Gianelloni (RETIRED) gentoo-dev 2004-10-13 10:33:30 UTC
Go to your local Gentoo mirror..

Look in /experimental/x86/livecd/x86
Comment 48 Chris Gianelloni (RETIRED) gentoo-dev 2004-10-24 06:54:44 UTC
*** Bug 68594 has been marked as a duplicate of this bug. ***
Comment 49 Gentoo User 2004-11-03 14:09:56 UTC
The install-x86-2004.2-r1-minimal.iso image worked for me, too.

The non-r1 version worked in computer A, but not computer B.  I tried everything, including moving the CDrom drive from A to B, but I think the motherboard in B didn't like the CD.  Version r1 works in both machines.
Comment 50 Chris Gianelloni (RETIRED) gentoo-dev 2005-03-25 11:24:35 UTC
Moving these so we can remove the "Install CD" component from "Gentoo Linux".

I apologize to everyone for this spam, but according to the bugzilla developers,
this is the only reasonable way to do this.