Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 534702 - dev-util/kdevelop-python-1.7.0 python3 support
Summary: dev-util/kdevelop-python-1.7.0 python3 support
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-04 20:08 UTC by Tetja Rediske
Modified: 2015-07-07 14:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
kdevelop-python-1.7.0 with semantic-analyzer useflags (kdevelop-python-1.7.0.ebuild,1.33 KB, text/plain)
2015-01-04 20:14 UTC, Tetja Rediske
Details
kdevelop-python-1.7.0 with proper PYTHON_SINGLE_TARGET (kdevelop-python-1.7.0.ebuild,1.45 KB, text/plain)
2015-01-04 22:37 UTC, Tetja Rediske
Details
kdevelop-python-1.7.0 with proper PYTHON_SINGLE_TARGET r2 (kdevelop-python-1.7.0.ebuild,1.59 KB, text/plain)
2015-01-07 11:54 UTC, Tetja Rediske
Details
After Feedback from #gentoo-dev-help I removed PYTHON_SINGLE_TARGET (kdevelop-python-1.7.0.ebuild,1.56 KB, text/plain)
2015-01-07 18:35 UTC, Tetja Rediske
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tetja Rediske 2015-01-04 20:08:42 UTC
Like proposed in Bug #522476 I edited the ebuild to contain USE Flags for booth versions of the Semantic Analyzer, sadly they can only selected at build time and use different sources.

Reproducible: Always
Comment 1 Tetja Rediske 2015-01-04 20:14:09 UTC
Created attachment 393162 [details]
kdevelop-python-1.7.0 with semantic-analyzer useflags
Comment 2 Tetja Rediske 2015-01-04 22:37:55 UTC
Created attachment 393174 [details]
kdevelop-python-1.7.0 with proper PYTHON_SINGLE_TARGET

Sorry, the initial ebuild won't work properly.

After a nice hint at python-single-r1 I reworked it and attached the new version.

Since this is my 1st more complex ebuild, please feel open to comment.
Comment 3 Tetja Rediske 2015-01-07 11:54:20 UTC
Created attachment 393398 [details]
kdevelop-python-1.7.0 with proper PYTHON_SINGLE_TARGET r2

Added some cmake Options, since the Buildtime detection of Python kind of does not work on Gentoo.
Comment 4 Tetja Rediske 2015-01-07 18:35:48 UTC
Created attachment 393438 [details]
After Feedback from #gentoo-dev-help I removed PYTHON_SINGLE_TARGET
Comment 5 Johannes Huber gentoo-dev 2015-02-10 22:02:46 UTC
How about to just drop python2 and use python3?
Comment 6 Tetja Rediske 2015-02-10 22:08:22 UTC
(In reply to Johannes Huber from comment #5)
> How about to just drop python2 and use python3?

It won't care, if it is just the Code running as python3. But the sytax analyzer sadly just works on the build python version.

So if you build it for python3, you only get code completion, syntax checks and so on for python3.

It is the same with python2. 

Since python2 is still pretty common, i think it would be good to have a choice.
Comment 7 Tetja Rediske 2015-07-07 14:01:14 UTC
Features was broken by Upstream python and as far as i understand won't be fixed for kde4 Version