Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522476 - dev-util/kdevelop-4.7.0 version bump (and related packages)
Summary: dev-util/kdevelop-4.7.0 version bump (and related packages)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal with 6 votes (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 529106 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-10 04:18 UTC by godlike64
Modified: 2015-01-04 11:10 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kdevplatform-1.7.0.ebuild (kdevplatform-1.7.0.ebuild,1.18 KB, text/plain)
2014-09-10 04:20 UTC, godlike64
Details
kdevelop-4.7.0.ebuild (kdevelop-4.7.0.ebuild,1.40 KB, text/plain)
2014-09-10 04:20 UTC, godlike64
Details
kdevelop-php-1.7.0.ebuild (kdevelop-php-1.7.0.ebuild,883 bytes, text/plain)
2014-09-10 04:21 UTC, godlike64
Details
kdevelop-php-docs-1.7.0.ebuild (kdevelop-php-docs-1.7.0.ebuild,724 bytes, text/plain)
2014-09-10 04:22 UTC, godlike64
Details
kdevelop-python-1.7.0.ebuild (kdevelop-python-1.7.0.ebuild,1011 bytes, text/plain)
2014-09-10 04:22 UTC, godlike64
Details
kdevelop-qmake-1.7.0.ebuild (kdevelop-qmake-1.7.0.ebuild,766 bytes, text/plain)
2014-09-10 04:25 UTC, godlike64
Details
Diff for kdevelop-4.7.0 (kdevplatform-4.7.0-bump.patch,657 bytes, patch)
2014-09-12 16:00 UTC, godlike64
Details | Diff
kdevplatform-1.7.0.diff (kdevplatform-1.7.0.diff,1.74 KB, patch)
2014-12-12 14:21 UTC, Lorenzo Porta (Vindex17)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description godlike64 2014-09-10 04:18:54 UTC
Kdevelop-4.7.0 was released on 8/30/2014. I renamed the related ebuilds in order to fit this release (with a bump in kdevplatform) and also the related kdevelop-* packages. These ebuilds should build fine. Kdevelop opens for me and the Python part works (which is what I use inside kdevelop). I have not done further testing.

Removed the appwizard patch from kdevplatform since it was not compiling.

Reproducible: Always
Comment 1 godlike64 2014-09-10 04:20:00 UTC
Created attachment 384498 [details]
kdevplatform-1.7.0.ebuild
Comment 2 godlike64 2014-09-10 04:20:29 UTC
Created attachment 384500 [details]
kdevelop-4.7.0.ebuild
Comment 3 godlike64 2014-09-10 04:21:56 UTC
Created attachment 384502 [details]
kdevelop-php-1.7.0.ebuild

The original parmake.patch from the portage tree can be applied to this ebuild with no issues in building afterwards.
Comment 4 godlike64 2014-09-10 04:22:35 UTC
Created attachment 384504 [details]
kdevelop-php-docs-1.7.0.ebuild
Comment 5 godlike64 2014-09-10 04:22:57 UTC
Created attachment 384506 [details]
kdevelop-python-1.7.0.ebuild
Comment 6 godlike64 2014-09-10 04:25:13 UTC
Created attachment 384508 [details]
kdevelop-qmake-1.7.0.ebuild
Comment 7 godlike64 2014-09-10 04:25:59 UTC
Just finished uploading the last ebuild and noticed that I hadn't changed the header for each ebuild, so they're still showing the old versions there. If this gets in the tree/kde overlay, please change the headers accordingly.
Comment 8 Johannes Huber gentoo-dev 2014-09-12 15:39:16 UTC
Comment on attachment 384498 [details]
kdevplatform-1.7.0.ebuild

Please attach patches, if there is no change. There is no need to attach the ebuild.
Comment 9 godlike64 2014-09-12 16:00:00 UTC
Created attachment 384628 [details, diff]
Diff for kdevelop-4.7.0

Here's the only change I performed in the ebuilds. Of course, the header should change I believe (this is my first ebuild submission). Other than that, it's a version rename
Comment 10 Paul Zander 2014-10-28 19:03:09 UTC
This bug is now six weeks old, any chance the changes will hit the tree any time soon?

Or is there any other work to be done?
Comment 11 Michael Palimaka (kensington) gentoo-dev 2014-10-30 12:07:44 UTC
Unfortunately, simply nobody has had the time to look at it.

Bumping is not necessary as simple as just copying the ebuild - we need to check the changes since the previous release to ensure there's no dependency changes, new features to handle etc.

If someone's keen to get involved, a good start would be checking for any upstream changes we need to handle (eg. you can see the changes between 4.6 branch and v4.7.0 tag for kde-base/kdevelop at http://quickgit.kde.org/?p=kdevelop.git&a=shortlog&h=a35fa2c7f991a720bc686f49e778b2ff99367932). Then, file a pull request on github (https://github.com/gentoo/kde) based of 4.9999 version (we accumulate small changes between releases in the live ebuild). This also has the benefit of hopefully getting some testing before it hits the tree.
Comment 12 Øystein Senneset Haaland 2014-11-12 21:29:55 UTC
Here is a pull request for some of the ebuilds: https://github.com/gentoo/kde/pull/82

I didn't go through the changes between 4.6 and 4.7 tags though.
Comment 13 Michael Palimaka (kensington) gentoo-dev 2014-11-13 02:33:55 UTC
*** Bug 529106 has been marked as a duplicate of this bug. ***
Comment 14 Paul Zander 2014-12-03 17:46:02 UTC
Skimmed through the CMakeLists.txt, apart from a bump to CMake 2.8.9 or 2.8.12 (we require 2.8.12) nothing really new.

Some packages seem to include stuff for kde 5.

Build went fine.
Comment 15 Lorenzo Porta (Vindex17) 2014-12-10 12:58:33 UTC
The only two new features are Bazaar support and clang plugin (which is mutually exclusive with the cpp one), so, in my point of view, this update should take little effort/time to be made. In addition, as it's said by kdevelop developers' announcement, << KDevelop 4.7.0 comes with a long-term stability guarantee >>
Comment 16 Lorenzo Porta (Vindex17) 2014-12-12 14:21:31 UTC
Created attachment 391500 [details, diff]
kdevplatform-1.7.0.diff
Comment 17 Lorenzo Porta (Vindex17) 2014-12-12 14:41:37 UTC
Comment on attachment 391500 [details, diff]
kdevplatform-1.7.0.diff

>--- kdevplatform-1.6.0-r1.ebuild	2014-07-29 18:53:23.000000000 +0200
>+++ kdevplatform-1.7.0.ebuild	2014-12-12 15:16:29.920381199 +0100
>@@ -1,10 +1,9 @@
> # Copyright 1999-2014 Gentoo Foundation
> # Distributed under the terms of the GNU General Public License v2
>-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.6.0-r1.ebuild,v 1.1 2014/07/29 16:53:23 johu Exp $
>+# $Header: $
> 
> EAPI=5
> 
>-KMNAME="kdevelop"
> KDE_LINGUAS="bs ca ca@valencia da de el es et fi fr gl it kk nb nl pl pt pt_BR
> ru sk sl sv th uk zh_CN zh_TW"
> VIRTUALDBUS_TEST="true"
>@@ -14,7 +13,7 @@ inherit kde4-base
> 
> DESCRIPTION="KDE development support libraries and apps"
> LICENSE="GPL-2 LGPL-2"
>-IUSE="cvs debug reviewboard subversion"
>+IUSE="bazaar +classbrowser cvs +dashboard debug git +konsole reviewboard subversion"
> SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz"
> 
> if [[ $PV == *9999 ]]; then
>@@ -26,8 +25,11 @@ fi
> RESTRICT="test"
> 
> DEPEND="
>-	dev-libs/boost:=
>+	bazaar? ( dev-vcs/bzr )
>+	classbrowser? ( dev-libs/boost )
>+	cvs? ( dev-vcs/cvs )
> 	dev-libs/grantlee
>+	git? ( dev-vcs/git )
> 	reviewboard? ( dev-libs/qjson )
> 	subversion? (
> 		dev-libs/apr
>@@ -37,17 +39,17 @@ DEPEND="
> "
> RDEPEND="${DEPEND}
> 	!<dev-util/kdevelop-${KDEVELOP_VERSION}:4
>-	$(add_kdebase_dep konsole)
>-	cvs? ( dev-vcs/cvs )
>+	konsole? $(add_kdebase_dep konsole)
> "
> 
>-PATCHES=( "${FILESDIR}/${P}-appwizard.patch" )
>-
> src_configure() {
> 	mycmakeargs=(
>+		$(cmake-utils_use_build classbrowser)
> 		$(cmake-utils_use_build cvs)
>+		$(cmake-utils_use_build dashboard)
>+		$(cmake-utils_use_build konsole)
> 		$(cmake-utils_use_find_package reviewboard QJSON)
>-		$(cmake-utils_use_build subversion)
>+		$(cmake-utils_use_find_package subversion SubversionLibrary)
> 	)
> 
> 	kde4-base_src_configure
Comment 18 Michael Palimaka (kensington) gentoo-dev 2014-12-26 13:07:10 UTC
Thanks, all bumped now.
Comment 19 AlexTAI 2015-01-04 10:15:17 UTC
Is there any way to add a use switch for python2/python3 support?
http://download.kde.org/stable/kdevelop/4.7.0/src/ has both of them:
http://download.kde.org/stable/kdevelop/4.7.0/src/kdev-python-1.7.0.tar.xz
http://download.kde.org/stable/kdevelop/4.7.0/src/kdev-python-1.7.0-py3.tar.xz
currently only python2 is supported (2.x and 3.x seems to be mutually exclusive).
Comment 20 Øystein Senneset Haaland 2015-01-04 11:10:42 UTC
(In reply to AlexTAI from comment #19)
> Is there any way to add a use switch for python2/python3 support?
> http://download.kde.org/stable/kdevelop/4.7.0/src/ has both of them:
> http://download.kde.org/stable/kdevelop/4.7.0/src/kdev-python-1.7.0.tar.xz
> http://download.kde.org/stable/kdevelop/4.7.0/src/kdev-python-1.7.0-py3.tar.
> xz
> currently only python2 is supported (2.x and 3.x seems to be mutually
> exclusive).

Maybe file as a new bug?

Seems it can be solved quite easily:

http://devmanual.gentoo.org/ebuild-writing/variables/index.html#src_uri