Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 526808 - dev-python/imaging: please remove dependency on media-libs/lcms:0
Summary: dev-python/imaging: please remove dependency on media-libs/lcms:0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on: 471542 471544 488112 508200 508266 512696 512854 512856 512858 512860 512862 512864
Blocks: lcms-1
  Show dependency tree
 
Reported: 2014-10-25 22:38 UTC by Matthias Maier
Modified: 2014-12-30 18:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Maier gentoo-dev 2014-10-25 22:38:18 UTC
media-libs/lcms:0 is unmaintained, has seen no releases since 2009, and (according to upstream) is affected by unspecified serious security issues. Please 

* either upgrade your package to use media-libs/lcms:2, 
* or hard-disable an optional dependency on media-libs/lcms:0, 
* or mask your package for removal.

Thank you!
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2014-10-26 06:13:00 UTC
imaging is the package taken over by pillow.  imaging is a leftover that will in the end be cleaned.  Just as well that occur and save  this effort
Comment 2 Andreas K. Hüttel gentoo-dev 2014-12-26 20:10:47 UTC
Package will be masked for security reasons on 30/12/2014.
Comment 3 Mike Gilbert gentoo-dev 2014-12-30 18:23:34 UTC
+  30 Dec 2014; Mike Gilbert <floppym@gentoo.org> -imaging-1.1.7-r4.ebuild,
+  imaging-1.1.7-r1.ebuild, imaging-1.1.7-r2.ebuild, imaging-1.1.7-r5.ebuild:
+  Drop lcms support, bug 526808.