Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 508266 - [TRACKER] dev-python/imaging removal
Summary: [TRACKER] dev-python/imaging removal
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: Tracker
Depends on:
Blocks: 526808
  Show dependency tree
 
Reported: 2014-04-20 19:17 UTC by Mike Gilbert
Modified: 2015-11-11 18:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Gilbert gentoo-dev 2014-04-20 19:17:56 UTC
This bug will be used to track any necessary stabilizations or other changes which must occur before dev-python/imaging can be masked/removed from the package tree.
Comment 1 ahudson.news 2014-09-08 10:55:48 UTC
depends on >= media-gfx/comix-4.0.4-r1 stabilization
Comment 2 Maxim Britov 2014-10-03 09:17:53 UTC
net-im/pyicq-t-0.8.1.5 and net-im/pyicq-t-0.8.1.5-r1 depends on >=dev-python/imaging-1.1
Comment 3 Justin Lecher gentoo-dev 2015-11-11 10:07:02 UTC
commit 581ffe810c1c7f40300a1cb969ac824d8de48cfb
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Nov 11 11:00:57 2015 +0100
    
    Drop dev-python/imaging
    
    Package superceeded by dev-python/pillow and vulnerable
    for CVE-2014-{1932,1933}
    
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=507982
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=508266
    
    obsoletes:
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=452468
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=479750
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=536408
    
    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    
    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=581ffe810c1c7f40300a1cb969ac824d8de48cfb
Comment 4 Garry Filakhtov 2015-11-11 18:33:36 UTC
Hi everyone,

python-imaging is already masked, but:
gnome-extra/cinnamon-2.6.13 requires virtual/python-imaging

what should I do?
Comment 5 Justin Lecher gentoo-dev 2015-11-11 18:44:47 UTC
(In reply to Igor Filakhtov from comment #4)
> Hi everyone,
> 
> python-imaging is already masked, but:
> gnome-extra/cinnamon-2.6.13 requires virtual/python-imaging
> 
> what should I do?

Since https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=51387d96d2100653c21c2125766020d77ce0b781 it doesn't do it anymore.
Comment 6 Garry Filakhtov 2015-11-11 18:47:44 UTC
Ah, perfect, thanks!

Portage didn't suggested me to rebuild the cinnamon package. confusing... resolved!