Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 486506 - dev-python/twisted-*-13.0.0-r1 stabilization
Summary: dev-python/twisted-*-13.0.0-r1 stabilization
Status: RESOLVED DUPLICATE of bug 512012
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 511672 513132
Blocks: gnome-3.12-stable
  Show dependency tree
 
Reported: 2013-09-29 19:47 UTC by Hanno Böck
Modified: 2014-07-18 19:36 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Böck gentoo-dev 2013-09-29 19:47:44 UTC
Can we start stabilization of the twisted-ebuilds that use the new python eclasses? (Background is: I'd like to stabilize the python-transports pyicq-t/pymsn-t/pyaim-t updates soon, and they depend on it)
Comment 1 Hanno Böck gentoo-dev 2014-05-16 12:31:42 UTC
Checked via mail with python-team, nobody objects, so archs please go ahead and stabilize:

twisted-conch/twisted-conch-13.0.0-r1
twisted-lore/twisted-lore-13.0.0-r1
twisted-mail/twisted-mail-13.0.0-r1
twisted-names/twisted-names-13.0.0-r1
twisted-news/twisted-news-13.0.0-r1
twisted-pair/twisted-pair-13.0.0-r1
twisted-runner/twisted-runner-13.0.0-r1
twisted-web/twisted-web-13.0.0-r1
twisted-words/twisted-words-13.0.0-r1

Some packages (e.g. twisted-pair) don't have keywords on some archs, you may leave them or decide if you want to keyword it for your arch.
Comment 2 Jeroen Roovers gentoo-dev 2014-05-16 14:13:53 UTC
(In reply to Hanno Boeck from comment #1)

> twisted-conch/twisted-conch-13.0.0-r1
> twisted-lore/twisted-lore-13.0.0-r1
> twisted-mail/twisted-mail-13.0.0-r1
> twisted-names/twisted-names-13.0.0-r1
> twisted-news/twisted-news-13.0.0-r1
> twisted-pair/twisted-pair-13.0.0-r1
> twisted-runner/twisted-runner-13.0.0-r1
> twisted-web/twisted-web-13.0.0-r1
> twisted-words/twisted-words-13.0.0-r1

These are _not_ valid atoms. Can you provide a proper list with added architecture targets, please?
Comment 3 Hanno Böck gentoo-dev 2014-05-16 14:23:44 UTC
Target Keywords based on previous version stabilizations with valid packet atoms:

KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
dev-python/twisted-conch-13.0.0-r1
dev-python/twisted-mail-13.0.0-r1
dev-python/twisted-web-13.0.0-r1
dev-python/twisted-words-13.0.0-r1

KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
dev-python/twisted-lore-13.0.0-r1
dev-python/twisted-names-13.0.0-r1
dev-python/twisted-news-13.0.0-r1
dev-python/twisted-runner-13.0.0-r1

KEYWORDS="amd64 arm x86"
dev-python/twisted-pair-13.0.0-r1
Comment 4 Jeroen Roovers gentoo-dev 2014-05-17 17:00:26 UTC
What about dev-python/twisted-core? Also, dev-python/twisted-names is stable for HPPA so it should have been in your list.
Comment 5 Hanno Böck gentoo-dev 2014-05-17 17:08:05 UTC
Hope I finally got it right now, sorry for the confusion:

KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
dev-python/twisted-core-13.0.0-r3
dev-python/twisted-conch-13.0.0-r1
dev-python/twisted-mail-13.0.0-r1
dev-python/twisted-web-13.0.0-r1
dev-python/twisted-words-13.0.0-r1
dev-python/twisted-names-13.0.0-r1

KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
dev-python/twisted-lore-13.0.0-r1
dev-python/twisted-news-13.0.0-r1
dev-python/twisted-runner-13.0.0-r1

KEYWORDS="amd64 arm x86"
dev-python/twisted-pair-13.0.0-r1
Comment 6 Jeroen Roovers gentoo-dev 2014-05-17 20:00:55 UTC
And now you need >=net-zope/zope-interface-4.0.5 for dev-python/twisted-core-13.0.0-r3 ...
Comment 7 Jeroen Roovers gentoo-dev 2014-06-04 00:27:07 UTC
And a newer soappy and wstools.
Comment 8 Jeroen Roovers gentoo-dev 2014-06-04 00:28:00 UTC
Stable for HPPA.
Comment 9 Tobias Klausmann gentoo-dev 2014-06-23 13:27:06 UTC
dev-python/twisted-core-13.0.0-r3 fails tests on alpha, bug 514674

The rest of the packages seem to be okay, but after the back-and-forth of pyopenssl recently, I'm not touching them until the test failures mentioned above are fixed/dealt with.
Comment 10 Markus Meier gentoo-dev 2014-06-29 18:53:42 UTC
arm stable
Comment 11 Pacho Ramos gentoo-dev 2014-07-18 19:36:50 UTC
Will handle the remaining arches in parent bug as it's preferred by Ago and this can wait for those arches until the rest is done

*** This bug has been marked as a duplicate of bug 512012 ***