Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 484950 - sys-apps/portage-2.2.1: emerge-webrsync does not work for non-exists/empty directory
Summary: sys-apps/portage-2.2.1: emerge-webrsync does not work for non-exists/empty di...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
: 488788 489422 (view as bug list)
Depends on:
Blocks: 240187 484436
  Show dependency tree
 
Reported: 2013-09-15 01:08 UTC by lsching17
Modified: 2013-10-26 15:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lsching17 2013-09-15 01:08:31 UTC
my portage dir is "/custom/tmp/portage/tree" which is non-existant directory, after i updated to sys-apps/portage-2.2.1, emerge-webrsync do not works anymore

Reproducible: Always

Steps to Reproduce:
sudo emerge-webrsync
Password:
!!! Invalid PORTDIR_OVERLAY (not a dir): '/custom/tmp/portage/tree'
!!! Section 'gentoo' in repos.conf has location attribute set to nonexistent directory: '/custom/tmp/portage/tree'
!!! main-repo not set in DEFAULT and PORTDIR is empty.
emerge-webrsync: error: Repository 'gentoo' not found 

if i create the directory manually and retry, "mkdir -p '/custom/tmp/portage/tree'", and retry

$ sudo emerge-webrsync
!!! Section 'gentoo' in repos.conf refers to repository without repository name set in '/custom/tmp/portage/tree/profiles/repo_name'
emerge-webrsync: error: Repository 'gentoo' not found 



/etc/portage/repos.conf/gentoo.conf

[DEFAULT]
main-repo = gentoo

[gentoo]
location = /custom/tmp/portage/tree
sync-type = 
sync-uri = 





emerge --info
Portage 2.2.1 (default/linux/amd64/13.0/no-multilib, gcc-4.6.3, glibc-2.15-r3, 3.10.10-custom_20130905195723 x86_64)
=================================================================
System uname: Linux-3.10.10-custom_20130905195723-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16382696 total,  13168484 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sat, 14 Sep 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.1, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.10 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fuse-linker-plugin -march=native -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fuse-linker-plugin -march=native -ftree-vectorize"
DISTDIR="/custom/tmp/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.aditsu.net"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j16"
PKGDIR="/custom/tmp/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/custom/tmp/portage/tmp"
PORTDIR="/custom/tmp/portage/tree"
PORTDIR_OVERLAY=""
SYNC=""
USE="3dnow 3dnowext X a52 aac acl alsa amd64 avx berkdb bluetooth bzip2 cairo caps cdda cjk cli consolekit cracklib crypt custom-optimization cxx dbus dga dri dts dvd exif flac fortran gdbm gif gnutls gtk iconv icu ipv6 jpeg jpg lcms libnotify lzma lzo mmx mmxext mng modules mp3 mpeg mudflap ncurses nls nptl ogg openal opengl openmp opus pam pango pcre pdf png policykit qt4 readline sasl sdl session smp spell sse sse2 sse3 ssl ssse3 startup-notification svg tcl tcpd threads thunar tiff truetype udev udisks unicode usb vdpau vorbis wifi x264 xattr xft xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel r600 radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Zac Medico gentoo-dev 2013-09-15 11:28:22 UTC
This is fixed in 2.2.5.
Comment 5 Zac Medico gentoo-dev 2013-09-23 21:17:47 UTC
This is fixed in 2.2.7.
Comment 6 Jeroen Roovers gentoo-dev 2013-10-20 23:53:05 UTC
*** Bug 488788 has been marked as a duplicate of this bug. ***
Comment 7 Jeroen Roovers gentoo-dev 2013-10-26 15:02:20 UTC
*** Bug 489422 has been marked as a duplicate of this bug. ***