Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 484060 - media-libs/openal-1.15.1-r1 USE=abi_x86_32 with app-emulation/emul-linux-x86-sdl-20130224 - file collisions in /usr/lib32/*
Summary: media-libs/openal-1.15.1-r1 USE=abi_x86_32 with app-emulation/emul-linux-x86-...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius (RETIRED)
Depends on: 484252
Blocks: 489248 489758
  Show dependency tree
Reported: 2013-09-07 00:54 UTC by eroen
Modified: 2013-12-31 12:06 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

openal-1.15.1-r1.ebuild.patch (openal-1.15.1-r1.ebuild.patch,1.14 KB, patch)
2013-12-26 22:18 UTC, Michael Mair-Keimberger (iamnr3)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description eroen 2013-09-07 00:54:01 UTC
Upgrading to media-libs/openal-1.15.1-r1 with ABI_X86="32 64" gives collisions with app-emulation/emul-linux-x86-sdl-20130224 .

 * Detected file collision(s):
 *      /usr/lib32/
 *      /usr/lib32/pkgconfig/openal.pc
 *      /usr/lib32/
 *      /usr/lib32/
 * Searching all installed packages for file collisions...
 * Press Ctrl-C to Stop
 * app-emulation/emul-linux-x86-sdl-20130224:0::gentoo
 *      /usr/lib32/
 *      /usr/lib32/
 *      /usr/lib32/
 *      /usr/lib32/pkgconfig/openal.pc

$ emerge --info '=media-libs/openal-1.15.1-r1' '=app-emulation/emul-linux-x86-sdl-20130224'
Portage 2.2.1 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.17, 3.10.7-e6-falcon0+ x86_64)
                         System Settings
System uname: Linux-3.10.7-e6-falcon0+-x86_64-Intel-R-_Core-TM-2_Quad_CPU_@_2.40GHz-with-gentoo-2.2
KiB Mem:     4038272 total,   1302744 free
KiB Swap:    8388604 total,   6921908 free
Timestamp of tree: Fri, 06 Sep 2013 23:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r2, 3.2.5-r2, 3.3.2-r2
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.5.4, 4.6.4, 4.7.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo gamerlay eroen
ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs 3 --nospinner --quiet-build --with-bdeps=y --binpkg-respect-use y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="/var/temdist/ /var/distfiles-occam/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/eroen"
USE="X a52 aac aacs accessibility acl adns alsa amd64 ao atm berkdb bluray bs2b bzip2 cairo calendar canberra caps cdda cdio cdparanoia cdr cli corefonts cracklib crypt css cue cups curl cxx dbus dia dirac djvu dmapi dri dts dvd dvdnav dvi ebook eigen exif faac fam fbcondecor ffmpeg fftw fits flac fontconfig fortran fuse g3dvl gcrypt gd gdbm gif gimp git gmp gnutls gold gstreamer hdri highlight iconv icu id3tag idn imagemagick inotify iptc ipv6 jpeg jpeg2k kde kvm lcms lensfun libnotify loop-aes lqr lzma lzo mad man matroska midi mikmod mkv mms mmx mmxext mng mod modplug modules mp3 mp4 mpeg mpeg2 mpeg4 mpeg4pt2 mplayer mtp mudflap multilib musepack ncurses netlink nfs nls nouveau nptl ocr offensive ogg openal opencl openexr opengl opengtl openmp openvg optimization osmesa pam pango pcre pdf png pnm portaudio postscript pulseaudio qalculate qemu qt3support qt4 rar raw rdesktop readline real rtmp samba scanner schroedinger security session smp sndfile socks5 speex spice sse sse2 sse3 ssl ssse3 strong-optimization svg tbb tcpd theora threads tiff timidity tls truetype udev uml unicode usb usbredir v4l v4l2 vdpau virtualbox vnc vorbis wacom wavpack webp wmf x264 xattr xcb xcomposite xetex xfs xft xine xinerama xorg xps xrandr xv xvid xvmc zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" DRACUT_MODULES="biosdevname caps crypt crypt-gpg dmraid lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64 pc qemu" INPUT_DEVICES="evdev keyboard mouse synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver presenter-console presenter-minimizer" LINGUAS="en en_US en_GB nb no nb_NO" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" RUBY_TARGETS="ruby20" SANE_BACKENDS="net plustek pnm" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia vesa" XFCE_PLUGINS="menu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"

                        Package Settings

app-emulation/emul-linux-x86-sdl-20130224 was built with the following:

$ emerge -pqv '=media-libs/openal-1.15.1-r1' '=app-emulation/emul-linux-x86-sdl-20130224'
[ebuild     U ] media-libs/openal-1.15.1-r1 [1.15.1] USE="alsa portaudio sse -alstream (-coreaudio) -debug (-neon) -oss -pulseaudio*" ABI_X86="32%* (64%*) (-x32)" 
[ebuild   R   ] app-emulation/emul-linux-x86-sdl-20130224  USE="development"
Comment 1 Mario Kicherer 2013-09-07 08:30:42 UTC
Same problem here.
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2013-09-08 12:50:27 UTC
huh? reassigning to who last touched these:

  06 Sep 2013; Ian Stakenvicius <> openal-1.15.1-r1.ebuild:
  dropped some unnecessary emul-linux blocker atoms
Comment 3 Pacho Ramos gentoo-dev 2013-09-08 13:03:16 UTC
Ian, you usually need to release a revbump for affected emul set with:
1. An update to the "${FILESDIR}/remove-native" file to drop colliding file.
2. Addition of abi_x86_32 to it to allow the removal of collision for people having that USE flag set.

I would take latest emul-linux-x86-medialibs ebuild as reference
Comment 4 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-09-08 14:33:46 UTC
And then, you still need a blocker against emul-linux-x86-sdl[-abi_x86_32(-)].
Comment 5 Ian Stakenvicius (RETIRED) gentoo-dev 2013-09-08 20:01:00 UTC
Apologies -- i multilib-built this because i thought it -wasnt- part of an emul-* ... i must have missed this during my content checks.  Will fix asap.  in the meantime maybe mask this revbump? i dont have access to the tree right at the moment
Comment 6 Ian Stakenvicius (RETIRED) gentoo-dev 2013-09-08 20:27:02 UTC
Got my tree access ; ebuild is masked until I can finish the conversion by bumping emul-linux-x86-sdl on Monday.  Also dropped the multilib-use dep in media-libs/allegro (which should be the only thing using it).
Comment 7 Alexis Ballier gentoo-dev 2013-09-08 21:34:32 UTC
(In reply to Ian Stakenvicius from comment #6)

please make a proper conversion before unmasking it. it is missing MULTILIB_USEDEP (and conversion) of some of its deps meaning it is broken on any multilib arch but amd64. even on amd64 it is probably broken: for example for ffmpeg, you will build with headers from your native package but the version in emul-libs is ffmpeg-0.10 and will link to that, which version is not ABI compatible with anything in stable or ~arch...
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2013-10-20 09:22:27 UTC
$ quse -D alstream
 local:alstream:media-libs/openal: Build and install the FFmpeg based alstream example utility

That one should go for native ABI only.
Comment 9 Michael Mair-Keimberger (iamnr3) 2013-12-26 22:18:46 UTC
Created attachment 366244 [details, diff]

This is a patch against the latest (masked) openal ebuild in tree. Since pulseaudio is already ported and ffmpeg (alstream) is only needed for native abi we could actually move forward with this bug..

emul-linux-x86-sdl might needs a update too..

I've tested my changes and it worked (even though i run into bug 481670, which hasn't anything todo with multilib)
Comment 10 Alexis Ballier gentoo-dev 2013-12-30 07:47:39 UTC
everything should be in place and unmasked now
Comment 11 Michael Mair-Keimberger (iamnr3) 2013-12-30 13:15:55 UTC
Sorry for piking on that bug again, but actually my changes aren't completely correct :( - sorry for that.
First of all, calling multilib_is_native_abi in src_configure will always return true, which means alstream/Examples would be always active on both archs (if use is enabled)
Secondly, there is a spelling mistake: i've wrote mymakeargs instead of mycmakeargs, which means it's actually always disabled..

However, even though it's disabled at the moment anyway, it wouldn't matter since examples wouldn't be build even if's it's enabled (afaik). I *think* it's because it's looking for following packages which it won't find: (i'm not so familiar with cmake)
--   package 'libavcodec>=53.61.100' not found
--   package 'libavformat>=53.32.100' not found
--   package 'libavutil>=51.35.100' not found

I've tested openal[alstream] with libav-0.8.7, libav-0.8.9 and libav-9.10. While the first too seems to have outdated version's, the last one doesn't work at all because of the bug which i mentioned before.
I'm not sure if it's just an dependency problem (openal might need a newer libav) or if it's a different problem - after all, the stable ebuild seems to be affected aswell.
Though i don't know how it looks on ffmpeg side.

Regarding disabling multilib on non native abi's - i currently have no idea how todo it. I though about adding a additional cmake-multilib_src_configure function and putting the multilib_is_native_abi in there (like with multilib_src_configure from multilib-minimal), however that didn't work.
Comment 12 Alexis Ballier gentoo-dev 2013-12-31 12:06:48 UTC
(In reply to Michael Mair-Keimberger (iamnr3) from comment #11)
> Sorry for piking on that bug again, but actually my changes aren't
> completely correct :( - sorry for that.
> First of all, calling multilib_is_native_abi in src_configure will always
> return true, which means alstream/Examples would be always active on both
> archs (if use is enabled)
> Secondly, there is a spelling mistake: i've wrote mymakeargs instead of
> mycmakeargs, which means it's actually always disabled..

fixed those; the rest is probably a not precise enough dep on virtual/ffmpeg; note that upstream seems to use version checks for libraries provided by ffmpeg and not libav (this can be seen from the .100 suffix)