Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 474800 - =dev-db/mariadb-5.5.40-r1 stabilization
Summary: =dev-db/mariadb-5.5.40-r1 stabilization
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords: STABLEREQ
: 491158 (view as bug list)
Depends on: 429708 473002 474802 474952 481304 486682 512328 512330
Blocks:
  Show dependency tree
 
Reported: 2013-06-26 01:46 UTC by Jorge Manuel B. S. Vicetto
Modified: 2014-10-22 19:21 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-06-26 01:46:06 UTC
As talked with Robin, it's time we get 5.5 marked stable.
Let's use this bug as a tracker for anything that needs to be done to get 5.5 marked stable.
Comment 1 Vasilis Lourdas 2013-08-27 11:07:12 UTC
Hi,

Sorry to interfere, this bug and its dependent are two months old already, is there a progress regarding these?
Comment 2 Joakim Tjernlund 2013-10-04 14:45:59 UTC
I don't see how this bug depends on 474802, should it not be the other
way around?

Seems like 429708 is resolved for most arch's, can we not stable
this bug for those?
Comment 3 Niklas Carlsson 2013-10-07 06:53:53 UTC
Agreed, it would be nice to the switch/stabilization move along, and 474802 looks like it has been ready to go for a month now.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-11-13 19:24:55 UTC
*** Bug 491158 has been marked as a duplicate of this bug. ***
Comment 5 Guillaume Hilt 2013-11-13 19:28:03 UTC
I have an issue with 5.5.32 as it blocks dspam compilation, see bug #491156.
Comment 6 Guillaume Hilt 2013-11-14 07:40:33 UTC
Ok, DSPAM compilation issue is an ebuild issue.
So, are we far from a stable marked mysql 5.5 ebuild ?
Comment 7 Marcin Mirosław 2013-11-14 08:33:07 UTC
Due to bug http://bugs.mysql.com/bug.php?id=69623 I would suggest to not mark as stable version 5.5.32.
Comment 8 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-11-14 13:12:54 UTC
(In reply to Marcin Mirosław from comment #7)
> Due to bug http://bugs.mysql.com/bug.php?id=69623 I would suggest to not
> mark as stable version 5.5.32.

I've added the info about this bug on the 5.5.33 and 5.6.13 bump bug and added it as a blocker for this bug.
Comment 9 Vasilis Lourdas 2014-01-19 09:10:57 UTC
What's the status of stabilizing MariaDB? I looked at many depending bugs and saw that some of them depended on newer versions which now exist either in the official tree or the mysql overlay, can't this bug "refresh" status and see what's now missing?
Comment 10 David Heidelberg (okias) 2014-02-15 01:46:51 UTC
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by virtual/mysql-5.5
# required by dev-perl/DBD-mysql-4.20.0
=dev-db/mariadb-5.5.32 ~amd64
# required by dev-db/mariadb-5.5.32
# required by mariadb (argument)
=virtual/mysql-5.5 ~amd64

really?

5.5.35+dfsg-0+wheezy1 ... DEBIAN (stable)...

Where is exactly problem now? There was times, when Gentoo has cutting edge things, now Gentoo is more conservative than Debian?
Comment 11 Milos Ivanovic 2014-04-26 04:48:11 UTC
I have the same thoughts as David. I cannot understand how Debian's stable repository (used by many production servers in the wild) contains a more recent version of MySQL than Gentoo's equivalent. Could we get an update please? MySQL 5.5 went GA in December 2010.

I understand that a source-based distro has its own set of issues, but if they cannot be fixed in four years then something isn't right.

What is currently blocking MySQL 5.5 from being stabilised (for x86/amd64 at least)? I would like to evaluate the severity of the blocker(s).
Comment 12 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2014-04-26 06:25:20 UTC
I forgot to add a comment here yesterday.

Now that 5.5.37-r1 is in the tree, I'd appreciate if interested users could test it and report any issues they hit. 5.5.37-r1 is currently the candidate for the first version marked stable.
Comment 13 Vasilis Lourdas 2014-04-29 14:54:26 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #12)
> I forgot to add a comment here yesterday.
> 
> Now that 5.5.37-r1 is in the tree, I'd appreciate if interested users could
> test it and report any issues they hit. 5.5.37-r1 is currently the candidate
> for the first version marked stable.

Everything's working nicely here so far. I haven't faced any issues.
Comment 14 Guillaume Hilt 2014-04-29 14:55:23 UTC
Same here, looks good to me.
Comment 15 Brian Evans Gentoo Infrastructure gentoo-dev 2014-05-15 15:18:39 UTC
When we put out a news item about the new stable, we should note that everyone should check the size of their InnoDB file vs the max in my.cnf.

The upgrade will automatically inflate the tablespace but if it reaches max, bug 442346 is hit.
Comment 16 cyberbat 2014-05-18 20:26:17 UTC
(In reply to Brian Evans from comment #15)
> When we put out a news item about the new stable, we should note that
> everyone should check the size of their InnoDB file vs the max in my.cnf.
> 
> The upgrade will automatically inflate the tablespace but if it reaches max,
> bug 442346 is hit.

Is both mariadb and mysql affected? Or only mysql?
Comment 17 Tom 2014-07-21 01:26:10 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #12)
> Now that 5.5.37-r1 is in the tree, I'd appreciate if interested users could
> test it and report any issues they hit. 5.5.37-r1 is currently the candidate
> for the first version marked stable.

I emerged dev-db/mysql-5.5.38 and upgraded without issues on amd64
Comment 18 Mike Limansky 2014-08-01 09:18:20 UTC
I'm also used MariaDB from 5.5.32 to 5.5.37 on production x86 server without any issues. And now using 5.5.38 on the new amd64 LAMP server.
Comment 19 ChaosEngine 2014-08-02 01:08:08 UTC
Stabilization should be also motivated, that for example newer phpmyadmin (version >4.2.25 AFAIR) requires mysql-5.5*
Comment 20 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-05 17:51:53 UTC
Security stable happening in bug 518718
Comment 21 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-07 16:21:40 UTC
Arches, please test and mark stable.

This is the new preferred provider of virtual/mysql which is being stabled in bug 518718.

Target keywords:

=dev-db/mariadb-5.5.39 alpha amd64 arm ia64 ppc ppc64 sparc x86

Deps on certain arches:
@alpha: dev-libs/jemalloc needs completed wrt bug 512330
@ppc,ppc64: dev-util/systemtap needs completed wrt bug 512328

Test instructions :

# Official test instructions:
# USE='-cluster embedded extraengine perl ssl static-libs community' \
# FEATURES='test userpriv -usersandbox' \
# ebuild mariadb-5.5.39.ebuild \
# digest clean package
Comment 22 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-08 13:49:46 UTC
amd64 done
Comment 23 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-08 13:55:07 UTC
Alpha done by klausman

  08 Aug 2014; Tobias Klausmann <klausman@gentoo.org> mariadb-5.5.39.ebuild:
  Stable on alpha, bug 518718
Comment 24 Agostino Sarubbo gentoo-dev 2014-08-08 22:07:04 UTC
x86 stable
Comment 25 Brian Evans Gentoo Infrastructure gentoo-dev 2014-10-16 16:02:02 UTC
Changing target to dev-db/mariadb-5.5.40 due to bug 525504
Comment 26 Brian Evans Gentoo Infrastructure gentoo-dev 2014-10-18 14:55:13 UTC
ia64, ppc, ppc64, sparc done in bug 525504
Comment 27 Markus Meier gentoo-dev 2014-10-22 19:21:21 UTC
arm stable via bug #525504, closing.