Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 481304 - dev-db/mysql-{5.5.35,5.6.15} version bump
Summary: dev-db/mysql-{5.5.35,5.6.15} version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 481986 506686 (view as bug list)
Depends on: 474952
Blocks: 474800
  Show dependency tree
 
Reported: 2013-08-16 13:16 UTC by Tom Wijsman (TomWij) (RETIRED)
Modified: 2014-04-25 00:32 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-08-16 13:16:24 UTC
This package needs a bump to apply the eclass change from the blocker.

New versions appear to be available; so, this can likely be combined...
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2013-08-16 16:33:13 UTC
I posted the 5.5.33 ebuild to the overlay.

Failing test(s): rpl.rpl_deadlock_innodb main.plugin_auth main.mysqladmin main.mysqlhotcopy_archive main.mysqlhotcopy_myisam

rpl.rpl_deadlock_innodb is the same as bug 473002

CURRENT_TEST: main.plugin_auth
/var/tmp/portage/dev-db/mysql-5.5.33/work/mysql-5.5.33_build/client//mysqladmin: connect to server at 'localhost' failed
error: 'SSL connection error: error:00000001:lib(0):func(0):reason(1)'
mysqltest: At line 420: command "$MYSQLADMIN -u root -S $MASTER_MYSOCK -P $MASTER_MYPORT --default-auth=auth_test_plugin $PLUGIN_AUTH_OPT ping" failed

CURRENT_TEST: main.mysqladmin
/var/tmp/portage/dev-db/mysql-5.5.33/work/mysql-5.5.33_build/client//mysqladmin: connect to server at 'localhost' failed
error: 'SSL connection error: error:00000001:lib(0):func(0):reason(1)'
mysqltest: At line 42: command "$MYSQLADMIN -u root -S $MASTER_MYSOCK -P $MASTER_MYPORT --sleep=1 --count=2 ping > $MYSQLTEST_VARDIR/tmp/mysqladmin.tmp" failed

CURRENT_TEST: main.mysqlhotcopy_archive
DBI connect(';host=localhost;mysql_socket=/var/tmp/portage/dev-db/mysql-5.5.33/work/mysql/mysql-test/var-tests/tmp/mysqld.1.sock;mysql_read_default_group=mysqlhotcopy','root',...) failed: SSL connection error: error:00000001:lib(0):func(0):reason(1) at /var/tmp/portage/dev-db/mysql-5.5.33/work/mysql-5.5.33_build/scripts/mysqlhotcopy line 197
mysqltest: In included file "./include/mysqlhotcopy.inc":
included from ./include/mysqlhotcopy.inc at line 47:
At line 46: command "$MYSQLHOTCOPY --quiet -S $MASTER_MYSOCK -u root hotcopy_test hotcopy_save" failed

CURRENT_TEST: main.mysqlhotcopy_myisam
DBI connect(';host=localhost;mysql_socket=/var/tmp/portage/dev-db/mysql-5.5.33/work/mysql/mysql-test/var-tests/tmp/mysqld.1.sock;mysql_read_default_group=mysqlhotcopy','root',...) failed: SSL connection error: error:00000001:lib(0):func(0):reason(1) at /var/tmp/portage/dev-db/mysql-5.5.33/work/mysql-5.5.33_build/scripts/mysqlhotcopy line 197
mysqltest: In included file "./include/mysqlhotcopy.inc":
included from ./include/mysqlhotcopy.inc at line 47:
At line 46: command "$MYSQLHOTCOPY --quiet -S $MASTER_MYSOCK -u root hotcopy_test hotcopy_save" failed
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2013-08-16 19:41:16 UTC
Reran tests after editing /etc/mysql/my.cnf to disable "ssl-ca=/etc/mysql/certs/ca-cert.pem".

Tests passed except for the one in bug 473002.

Seems the tests reference the client and/or mysql section of /etc/mysql/my.cnf and may get varying results on a box with an install.  This observation needs more testing.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2013-08-21 16:14:16 UTC
*** Bug 481986 has been marked as a duplicate of this bug. ***
Comment 4 manwe 2013-09-25 16:43:04 UTC
I don't get it. For 99.9% of software Gentoo's portage is one of the quickest respoding systems compared to other Linux distros. But with MySQL it's somehow different. Version 5.6 was released over 2 years ago but still it's not in the portage. Even better, few days ago second version of 5.7 branch (5.7.2) was releases, and we're still stuck with 5.5.x.
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-11-14 13:11:30 UTC
As we don't have an open bug about this issue and it was fixed on 5.5.33 and 5.6.13, I'm adding it here.

https://bugs.gentoo.org/show_bug.cgi?id=481304
"Since 5.5.32 & 5.6.12, innodb cant start with own multi-file tablespace"
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2014-04-04 14:03:40 UTC
*** Bug 506686 has been marked as a duplicate of this bug. ***
Comment 7 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2014-04-25 00:32:46 UTC
I'm going to close this bug as I'm in the process of pushing mysql-5.5.37 into the tree.
For now, 5.6.17 is in the overlay. We'll push 5.6 into the tree as soon as we agree in how to deal with the virtuals.