Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 462 - package configuration files
Summary: package configuration files
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Ebuild Support (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 461 1887 10801 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-01-31 14:17 UTC by Geert Bevin
Modified: 2005-07-14 06:58 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geert Bevin 2002-01-31 14:17:33 UTC
Packages should not perform configuration with pkg_config anymore, but instead
install a file in /var/config. The file has this format '01packagename.sh'.
Portage could have convenience functions to auto generate the numbers.
Additionally packages can put important informative messages in the same
location but then as '01packagename.txt'. Portage can have options to auto
execute new config scripts and auto show new messages. It however always gives
the status of the /var/config dir.
Comment 1 Geert Bevin 2002-01-31 14:19:45 UTC
*** Bug 461 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Robbins (RETIRED) gentoo-dev 2002-02-21 01:20:36 UTC
I'll add this soon.  We desperately need it.
Comment 3 Daniel Robbins (RETIRED) gentoo-dev 2002-04-21 17:06:14 UTC
*** Bug 1887 has been marked as a duplicate of this bug. ***
Comment 4 Donny Davies (RETIRED) gentoo-dev 2002-04-30 23:59:50 UTC
neat.. i think!  :)

sounds like another huge round of cleanups.  but still.. neat!
Comment 5 Spider (RETIRED) gentoo-dev 2002-05-01 05:26:49 UTC
This sounds good, yes.

While on a similar subject, is there a way to keep a variable assignment between
the different parts of an ebuild?

ie, set a variable in src_install and get it again in pkg_config or in the new set?

this would be good for cases like "check the files installed "there" and perform
an action on them.

Sure, this could be handled by manually checking files and typing down names,
but this makes for a lot of errors by ebuild creators.

Comment 6 Wout Mertens (RETIRED) gentoo-dev 2002-05-12 12:15:32 UTC
For keeping vars: I guess you could do env>${TEMPDIR}/vars and . ${TEMPDIR}/vars in the functions?  
Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2002-12-02 05:09:11 UTC
Are this stil in the pipeline, or something else planned ?
Comment 8 Daniel Robbins (RETIRED) gentoo-dev 2002-12-10 10:22:48 UTC
Still in the pipeline. (At least something like it)
Comment 9 SpanKY gentoo-dev 2003-01-08 14:01:05 UTC
nice suggestion from 10801 ... `emerge --config <pkg>`
Comment 10 SpanKY gentoo-dev 2003-01-08 14:01:08 UTC
*** Bug 10801 has been marked as a duplicate of this bug. ***
Comment 11 Brian Harring gentoo-dev 2004-04-08 19:57:25 UTC
Tiz an enhancement, so marking it as such.
Comment 12 Jason Stubbs (RETIRED) gentoo-dev 2005-05-05 04:43:13 UTC
emerge --config available in 2.0.51.21
Comment 13 Jason Stubbs (RETIRED) gentoo-dev 2005-07-14 05:47:54 UTC
Fixed on or before 2.0.51.22-r1 
Comment 14 Jason Stubbs (RETIRED) gentoo-dev 2005-07-14 06:58:38 UTC
Looking through the batch of bugs, I'm not sure that some of these are 
actually fixed in stable. Others, the requirements have possibly changed after 
the initial fix was committed. 
 
If you think this bug has been closed incorrectly, please reopen or ask that 
it be reopened.