Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 456108 - Mask dev-libs/openssl-1.0.1d
Summary: Mask dev-libs/openssl-1.0.1d
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 455804 455810 455886 455934 455980 455982 455996 456022 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-08 01:02 UTC by Ryan Hill (RETIRED)
Modified: 2013-02-11 16:16 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:02:41 UTC
dirtyepic@caribou ~ $ openssl s_client -host dev.gentoo.org -port 993
[...]
139746525091496:error:1408F06B:SSL routines:SSL3_GET_RECORD:bad decompression:s3_pkt.c:498:


dev-libs/openssl-1.0.1d was built with the following:
USE="gmp (multilib) (sse2) test zlib -bindist -kerberos -rfc3779 -static-libs -vanilla" ABI_X86="64"
CFLAGS="-O2 -march=native -g -pipe -fno-strict-aliasing -Wa,--noexecstack"
CXXFLAGS="-O2 -march=native -g -pipe -fno-strict-aliasing -Wa,--noexecstack"


Portage 2.2.0_alpha161 (default/linux/amd64/13.0/developer, gcc-4.7.2, glibc-2.17, 3.7.4-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-3920XM_CPU_@_2.90GHz-with-gentoo-2.2
KiB Mem:    32598108 total,  23451292 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Fri, 08 Feb 2013 00:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.5.4-r5, 2.6.8-r1, 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -g -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -g -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache clean-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8 V=1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/dirtyepic/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:04:47 UTC
*** Bug 455804 has been marked as a duplicate of this bug. ***
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:05:13 UTC
*** Bug 455934 has been marked as a duplicate of this bug. ***
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:05:44 UTC
*** Bug 455980 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:06:44 UTC
*** Bug 455810 has been marked as a duplicate of this bug. ***
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:07:13 UTC
*** Bug 455982 has been marked as a duplicate of this bug. ***
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:08:36 UTC
*** Bug 455996 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2013-02-08 01:17:24 UTC
+# Ryan Hill <dirtyepic@gentoo.org> (7 Feb 2013)
+# Breaks everything (bug #456108)
+=dev-libs/openssl-1.0.1d
Comment 8 Mike Gilbert gentoo-dev 2013-02-08 02:15:54 UTC
*** Bug 456022 has been marked as a duplicate of this bug. ***
Comment 10 SpanKY gentoo-dev 2013-02-08 06:29:08 UTC
should be all set now in the tree; thanks for the report!

Commit message: Add fix from upstream for 1.0.1c regression
http://sources.gentoo.org/dev-libs/openssl/files/openssl-1.0.1d-s3-packet.patch?rev=1.1
http://sources.gentoo.org/dev-libs/openssl/openssl-1.0.1d-r1.ebuild?rev=1.1
Comment 11 Michael Palimaka (kensington) gentoo-dev 2013-02-08 12:34:12 UTC
*** Bug 455886 has been marked as a duplicate of this bug. ***